E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > BMW CODING success



Reply
 
Thread Tools Search this Thread
      03-17-2011, 10:24 PM   #2333
lopealle
Resident Black Guy
lopealle's Avatar
Zimbabwe
65
Rep
2,245
Posts

 
Drives: Lion
Join Date: May 2009
Location: Federal Way, WA

iTrader: (2)

Garage List
2006 M5  [5.00]
Some please help me with configuring my computer so I can get some coding done? I have a couple of issues: The paths that are suppose to be set for don't exist on my computer. 2 When I click to open the INPA it tells me that im missing file api32.ll
Appreciate 0
      03-17-2011, 10:57 PM   #2334
e90TiAg335i
Captain
e90TiAg335i's Avatar
United_States
12
Rep
993
Posts

 
Drives: 10 e90 335i
Join Date: Mar 2010
Location: jacksonville, FL

iTrader: (7)

Garage List
2010 e90 335i  [0.00]
Quote:
Originally Posted by lopealle View Post
Some please help me with configuring my computer so I can get some coding done? I have a couple of issues: The paths that are suppose to be set for don't exist on my computer. 2 When I click to open the INPA it tells me that im missing file api32.ll
Come down this way Saturday and I'll help you sort everything out!
__________________

JB4, DP, VMR V710, Sonic Tuning S1 coilovers, Hybrid Ovations, Soundsplinter 10" and Zapco DC Ref amps
Appreciate 0
      03-17-2011, 11:19 PM   #2335
lopealle
Resident Black Guy
lopealle's Avatar
Zimbabwe
65
Rep
2,245
Posts

 
Drives: Lion
Join Date: May 2009
Location: Federal Way, WA

iTrader: (2)

Garage List
2006 M5  [5.00]
Ok I think I almost have it...I just need somebody to tell me how to set my com1 port. I have windows 7
Appreciate 0
      03-18-2011, 08:01 AM   #2336
jphughan
Brigadier General
jphughan's Avatar
United_States
39
Rep
3,474
Posts

 
Drives: 2011.75 M3 E92 6MT
Join Date: Mar 2011
Location: Austin, TX

iTrader: (0)

Quote:
Originally Posted by lopealle View Post
Ok I think I almost have it...I just need somebody to tell me how to set my com1 port. I have windows 7
Go into Device Manager, click the Properties for the cable you're using, click Port Settings > Advanced. In there you should be able to change your port to COM1. If something is already using COM1, use the same procedure to move that device to another COM port first.
Appreciate 0
      03-18-2011, 09:14 AM   #2337
lopealle
Resident Black Guy
lopealle's Avatar
Zimbabwe
65
Rep
2,245
Posts

 
Drives: Lion
Join Date: May 2009
Location: Federal Way, WA

iTrader: (2)

Garage List
2006 M5  [5.00]
Ok I finally got the INPA to work but the the optioon to do the karosserie is not on mine when I load it up. I don't know if it makes a difference that I drive a 12/05 E60 (shouldn't matter because it's for the airbag) or not but the option still is there. Also the NCSEXPERT says that

"The version of this file is not compatible with the version of Windows your're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and the contact the software publisher."

Somebody please help a pc noob
Appreciate 0
      03-18-2011, 09:41 AM   #2338
Wissam
Private First Class
Canada
6
Rep
141
Posts

 
Drives: 2007 e90 328I
Join Date: Dec 2006
Location: GTA, Canada

iTrader: (3)

lopealle, see my post below...

Quote:
Originally Posted by Wissam View Post
For those running Windows 7 x64, I used VMWare Player to setup XP mode and everything worked flawlessly...below are links I used for VMWare Player, setup instructions, and cable drivers...

http://www.softpedia.com/get/System/...e-Player.shtml

http://www.howtogeek.com/howto/11060...ons-and-vista/

http://www.ftdichip.com/Drivers/VCP.htm
Quote:
Originally Posted by lopealle View Post
Ok I finally got the INPA to work but the the optioon to do the karosserie is not on mine when I load it up. I don't know if it makes a difference that I drive a 12/05 E60 (shouldn't matter because it's for the airbag) or not but the option still is there. Also the NCSEXPERT says that

"The version of this file is not compatible with the version of Windows your're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and the contact the software publisher."

Somebody please help a pc noob
Appreciate 0
      03-18-2011, 09:43 AM   #2339
Horniekoala
New Member
0
Rep
6
Posts

 
Drives: 325i
Join Date: Feb 2011
Location: Stanton

iTrader: (0)

Quote:
Originally Posted by NiVeDh View Post
Sorry guys but when I tried to post a DIY for this and help people out, my posts were deleted because I was taking business away from a certain vendor.

I and a few others are fairly knowledgeable on doing this so if you sincerely want to learn and don't expect me to spoonfeed information to you, please PM me.

OP: Let me know if you need help. I know how to code all the things you mentioned, and then some.
Hey. I have a 2006 325i, can u tell me which hard ware and software I need to get?
Appreciate 0
      03-18-2011, 10:12 AM   #2340
BlaSTiWi
Not new just quite
United_States
0
Rep
20
Posts

 
Drives: E60 & E92
Join Date: Feb 2008
Location: Omaha, NE

iTrader: (0)

I thought post #1 pretty well explained every single thing very detail, no?

Quote:
Originally Posted by Horniekoala View Post
Hey. I have a 2006 325i, can u tell me which hard ware and software I need to get?
Appreciate 0
      03-18-2011, 10:17 AM   #2341
Pseudo Nim
twinborific
Pseudo Nim's Avatar
55
Rep
4,738
Posts

 
Drives: fast, sometimes slow
Join Date: Nov 2008
Location: i am a citizen of the world

iTrader: (9)

Quote:
Originally Posted by Horniekoala View Post
Hey. I have a 2006 325i, can u tell me which hard ware and software I need to get?
I swear I wish I could ban people like this.

Quote:
Originally Posted by BlaSTiWi View Post
I thought post #1 pretty well explained every single thing very detail, no?
Bro, you really shouldn't reply to that. Like seriously - I know there are 1,000 pages in this thread, but the LEAST people could do is read post NUMBER ONE and then ask :P
__________________
Appreciate 0
      03-18-2011, 10:31 AM   #2342
BlaSTiWi
Not new just quite
United_States
0
Rep
20
Posts

 
Drives: E60 & E92
Join Date: Feb 2008
Location: Omaha, NE

iTrader: (0)

I feel your pain Bro ... to the OP of this tread too & other that contributed.
I was just being sarcastic ... sorry should've been more harsher ...
The fact that he picked up & quoted post #5 just carelessly skipped post #1.

Quote:
Originally Posted by Pseudo Nim View Post
Bro, you really shouldn't reply to that. Like seriously - I know there are 1,000 pages in this thread, but the LEAST people could do is read post NUMBER ONE and then ask :P
Appreciate 0
      03-18-2011, 10:31 AM   #2343
matrix76
Major
matrix76's Avatar
Canada
21
Rep
1,300
Posts

 
Drives: 2011 E90 328i xDrive Ex/Ps
Join Date: Sep 2009
Location: The West Coast, BC

iTrader: (1)

Quote:
Originally Posted by Pseudo Nim View Post
I swear I wish I could ban people like this.
Bro, you really shouldn't reply to that. Like seriously - I know there are 1,000 pages in this thread, but the LEAST people could do is read post NUMBER ONE and then ask :P
+1 , , Yes newbies, take a little time and read through the thread, your questions have been answered serveral times. Seeing a "what cable to I get" post started over and over again is getting a bit much when it has been covered to death.

READ THE THREAD, THEN ASK YOUR QUESTION!
__________________
Brian
Black Sapphire, Black w/Burrwood Trim & Shifter, 162's, Mtec H8 AE's, DS1 HID 6000K


Last edited by matrix76; 03-18-2011 at 06:01 PM.
Appreciate 0
      03-18-2011, 12:21 PM   #2344
DESI4life10
Banned
DESI4life10's Avatar
Canada
47
Rep
3,365
Posts

 
Drives: Coding: Desi4life10@gmail.com
Join Date: Oct 2008
Location: West of Toronto, Canada

iTrader: (18)

Quote:
Originally Posted by Horniekoala View Post
Hey. I have a 2006 325i, can u tell me which hard ware and software I need to get?
READ man READ....

The first page alone will explain everything you need to know. Better yet use the button
Appreciate 0
      03-18-2011, 12:23 PM   #2345
DESI4life10
Banned
DESI4life10's Avatar
Canada
47
Rep
3,365
Posts

 
Drives: Coding: Desi4life10@gmail.com
Join Date: Oct 2008
Location: West of Toronto, Canada

iTrader: (18)

^ LOL...man I guess I was late on that topic..ahaha... saw the noobs post and went all red. Before you know it, I was ready to hit send on my post :-)
Appreciate 0
      03-18-2011, 12:45 PM   #2346
rambalu80
Captain
rambalu80's Avatar
United_States
11
Rep
987
Posts

 
Drives: 2007 BMW 328i
Join Date: Apr 2007
Location: Lake Jackson TX

iTrader: (2)

Garage List
2007 328i  [0.00]
You guys are leaps and bounds ahead with all the coding and here I am still waiting on my INPA cable to arrive from Hong Kong!
__________________
Alpine White/Terra | 6MT | Navi | Premium Package | OEM Chrome Tips | HO C30 Tint | OEM Aluminum Pedals | Rear Fogs Enabled | 17" OEM Style 159 Wheels | Hella Whitelines | USDM Bi-xenons w/ 4300k D1S HID Bulbs

Appreciate 0
      03-18-2011, 01:06 PM   #2347
DESI4life10
Banned
DESI4life10's Avatar
Canada
47
Rep
3,365
Posts

 
Drives: Coding: Desi4life10@gmail.com
Join Date: Oct 2008
Location: West of Toronto, Canada

iTrader: (18)

Quote:
Originally Posted by rambalu80 View Post
You guys are leaps and bounds ahead with all the coding and here I am still waiting on my INPA cable to arrive from Hong Kong!
LOL...3 weeks buddy :-)
Appreciate 0
      03-18-2011, 01:11 PM   #2348
matrix76
Major
matrix76's Avatar
Canada
21
Rep
1,300
Posts

 
Drives: 2011 E90 328i xDrive Ex/Ps
Join Date: Sep 2009
Location: The West Coast, BC

iTrader: (1)

Quote:
Originally Posted by rambalu80 View Post
You guys are leaps and bounds ahead with all the coding and here I am still waiting on my INPA cable to arrive from Hong Kong!
And it is worth the wait, ,
__________________
Brian
Black Sapphire, Black w/Burrwood Trim & Shifter, 162's, Mtec H8 AE's, DS1 HID 6000K

Appreciate 0
      03-18-2011, 01:41 PM   #2349
rambalu80
Captain
rambalu80's Avatar
United_States
11
Rep
987
Posts

 
Drives: 2007 BMW 328i
Join Date: Apr 2007
Location: Lake Jackson TX

iTrader: (2)

Garage List
2007 328i  [0.00]
Quote:
Originally Posted by DESI4life10 View Post
LOL...3 weeks buddy :-)
Well, that sounds like 10 more days to go!

Quote:
Originally Posted by matrix76 View Post
And it is worth the wait, ,
I sure am looking forward to it!
__________________
Alpine White/Terra | 6MT | Navi | Premium Package | OEM Chrome Tips | HO C30 Tint | OEM Aluminum Pedals | Rear Fogs Enabled | 17" OEM Style 159 Wheels | Hella Whitelines | USDM Bi-xenons w/ 4300k D1S HID Bulbs

Appreciate 0
      03-18-2011, 01:58 PM   #2350
Jay0101
New Member
0
Rep
13
Posts

 
Drives: 328i e92
Join Date: Mar 2010
Location: Hamilton

iTrader: (0)

error #135 API-0015: HOST COMMUNICATION ERROR No API calls possible

Hi,

This is the error I keep getting in INPA 5.0.2 using K+ DCAN cable (missing pin8) with e92 328i (08/2006 build) - any ideas?
The driver seems to be working and the cable's light goes on when plugged into the car and computer.

Thanks

J
Appreciate 0
      03-18-2011, 02:16 PM   #2351
jphughan
Brigadier General
jphughan's Avatar
United_States
39
Rep
3,474
Posts

 
Drives: 2011.75 M3 E92 6MT
Join Date: Mar 2011
Location: Austin, TX

iTrader: (0)

Quote:
Originally Posted by Jay0101 View Post
Hi,

This is the error I keep getting in INPA 5.0.2 using K+ DCAN cable (missing pin8) with e92 328i (08/2006 build) - any ideas?
The driver seems to be working and the cable's light goes on when plugged into the car and computer.

Thanks

J
Try these drivers: http://www.e90post.com/forums/showpo...postcount=1014

Actually, I notice you have an 8/2006 build. It's possible that your car is pre-DCAN and actually requires Double K-Line, since DCAN wasn't introduced on the E9x until 3/07. If that's the case, you'll need Pin 8 connected (which will break compatibility with everything from 3/2009) or the adapter from that seller that bridges 7 and 8.

Last edited by jphughan; 03-18-2011 at 03:14 PM.
Appreciate 0
      03-18-2011, 04:02 PM   #2352
Jay0101
New Member
0
Rep
13
Posts

 
Drives: 328i e92
Join Date: Mar 2010
Location: Hamilton

iTrader: (0)

error #135 API-0015: HOST COMMUNICATION ERROR No API calls possible

jphughan;

Appreciate the reply

I think your right, that my car is pre dcan. I did notice that the #8 pin was not there - but what's weird is they provided an adaptor which did have the 8 pin present. Why not the other way around??

Cheers!
Appreciate 0
      03-18-2011, 04:52 PM   #2353
jphughan
Brigadier General
jphughan's Avatar
United_States
39
Rep
3,474
Posts

 
Drives: 2011.75 M3 E92 6MT
Join Date: Mar 2011
Location: Austin, TX

iTrader: (0)

Quote:
Originally Posted by Jay0101 View Post
jphughan;

Appreciate the reply

I think your right, that my car is pre dcan. I did notice that the #8 pin was not there - but what's weird is they provided an adaptor which did have the 8 pin present. Why not the other way around??

Cheers!
Because cars built starting 3/2009 can't be coded if Pin 8 is connected. The reason is that those cars have an Ethernet interface on Pin 8, and if the car senses a signal on that pin it drops the connection that's actually being used to code it. Gotta love BMW recycling pins and breaking stuff!

I guess it's true they could've kept making the cables as they were and then had an adapter that blocked Pin 8, but I suspect that was changed because most people didn't want to pay extra for an adapter to code newer cars.
Appreciate 0
      03-18-2011, 06:22 PM   #2354
orangedawg
First Lieutenant
9
Rep
397
Posts

 
Drives: 328xi
Join Date: Mar 2010
Location: WA

iTrader: (0)

I have an 02/07 328xi and use the K-line cable off ebay. cost was about $30 and it works just fine, fyi. But, I thought the cables for newer cars should work for pre 03/07 cars as well.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:47 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST