E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > BMW CODING success



Reply
 
Thread Tools Search this Thread
      01-17-2011, 05:10 PM   #1035
Noxious_
Banned
Canada
22

 
Drives: 08 E90
Join Date: Feb 2010
Location: Canada


Posts: 315
iTrader: (4)

Quote:
Originally Posted by GenePoole View Post
Are you sure it's not api.dll? That is a 16bit dll that NCSExpert need to talk to the 32 bit ediabas.
It could be. The type is in lower case so I might be reading it wrong. Thanks for the help. How do I solve this problem?
Appreciate 0
      01-17-2011, 07:11 PM   #1036
larry_bml
Private
2

 
larry_bml's Avatar
 
Drives: BMW 320d Steptronic 2007
Join Date: Dec 2009
Location: Romania - Pitesti


Posts: 77
iTrader: (0)

Quote:
Originally Posted by spera23 View Post
Does anyone know how to code the different welcome lights to activate when the car is unlocked?


WELCOME_LIGHTS in the CAPPL module seems to just give me a "welcome lights" option in the iDrive menu that does not change anything nor does it stay activated!
I have the same problem like you, seems no one wants to help us. I just want a FRM or a file from the exact module who makes welcome lights, but .... no luck until now.
Appreciate 0
      01-17-2011, 08:11 PM   #1037
spera23
Second Lieutenant
11

 
Drives: 335i
Join Date: Sep 2009
Location: Toronto


Posts: 207
iTrader: (3)

Hey Larry,

Let me know if you find anything. I will do the same. One way we should be able to figure it out!



Quote:
Originally Posted by larry_bml View Post
I have the same problem like you, seems no one wants to help us. I just want a FRM or a file from the exact module who makes welcome lights, but .... no luck until now.
Appreciate 0
      01-17-2011, 08:56 PM   #1038
spazticrecords
Banned
1

 
Drives: 2010 E90 328 XI
Join Date: Jun 2007
Location: Yorktown Heights, NY.


Posts: 123
iTrader: (0)

Larry

As per our pm conversation, I told you to email me and I will help you with this.

Send me copies of your nrfm and lma modules to *************************
Appreciate 0
      01-18-2011, 12:08 AM   #1039
Mike Benvo
www.bpmsport.com
United_States
130

 
Mike Benvo's Avatar
 
Drives: Harrop SC M3 / E46 M3 / 7Turbo
Join Date: Apr 2008
Location: SoCal


Posts: 4,750
iTrader: (7)

Garage List
2008 BMW M3  [5.00]
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Just FYI

Someone mentioned x64 Win 7 capability...

Edit: You can't run it on a 64bit OS period. But you can run on Windows 7 x86 (32 bit) without any problem.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----

Last edited by Mike Benvo; 01-18-2011 at 11:13 PM.
Appreciate 0
      01-18-2011, 12:11 AM   #1040
Imperator
Major
United_States
45

 
Imperator's Avatar
 
Drives: 2010 E92 335i
Join Date: Mar 2010
Location: Plano, Texas


Posts: 1,128
iTrader: (7)

Quote:
Originally Posted by Mike@Powerchip View Post
Just FYI

Someone mentioned x64 Win 7 capability...

That's what I'm running on - no problems whatsoever.
The software works fine on my laptop running Win 7 x64. Which cable and drivers are you using?
Appreciate 0
      01-18-2011, 02:00 AM   #1041
larry_bml
Private
2

 
larry_bml's Avatar
 
Drives: BMW 320d Steptronic 2007
Join Date: Dec 2009
Location: Romania - Pitesti


Posts: 77
iTrader: (0)

Quote:
Originally Posted by spazticrecords View Post
Larry

As per our pm conversation, I told you to email me and I will help you with this.

Send me copies of your nrfm and lma modules to *************************
I've sent you the files to ************************* , check your inbox here, because is full. If we managed to make them work i will post that you do it, and who wants them work can contact you. I'm waiting back the files to test them.
Appreciate 0
      01-18-2011, 05:34 AM   #1042
Geby-E90
FD3S + 335i + R6
Canada
3

 
Geby-E90's Avatar
 
Drives: 2007 BMW 335i
Join Date: Oct 2010
Location: Kelowna BC


Posts: 188
iTrader: (10)

Anyway to make it so you can just turn your fogs on w/o making the lows come on too? Also whats the steps to make it so your high's and flash to pass can both stay on when you have your stalk pushed for high beams.
__________________
Hardparker
TRACK - 1993 Mazda RX-7 (Montego Blue); Single GT40R - Feed Widebody - Supporting Mods
DAILY - 2007 BMW 335i (Jet Black); Premium & Sport Pkg - PROcede V5 (DIC) - BBS CH's - KW V2 - AMS FMIC - M3 Front/Skirts
Appreciate 0
      01-18-2011, 07:55 AM   #1043
Toshi
Private First Class
Japan
9

 
Drives: ALPINA B4 BiTurbo Coupe (F32)
Join Date: Aug 2010
Location: Tokyo, Japan


Posts: 169
iTrader: (1)

These are the WL codes in my NFRM.

WL_AL
nicht_aktiv
WL_BLK_H
nicht_aktiv
WL_BLK_V
nicht_aktiv
WL_FL
nicht_aktiv
WL_KZL
soft_einschalten
WL_NSL
nicht_aktiv
WL_NSW
nicht_aktiv
WL_POL
nicht_aktiv
WL_SL_1
soft_einschalten
WL_SL_2
soft_einschalten


Give it a try.
The value must be "nicht_aktiv", "soft_einschalten" or "hart_einschalten".


Quote:
Originally Posted by spera23 View Post
Does anyone know how to code the different welcome lights to activate when the car is unlocked?
WELCOME_LIGHTS in the CAPPL module seems to just give me a "welcome lights" option in the iDrive menu that does not change anything nor does it stay activated!
Quote:
Originally Posted by larry_bml View Post
I have the same problem like you, seems no one wants to help us. I just want a FRM or a file from the exact module who makes welcome lights, but .... no luck until now.
Appreciate 0
      01-18-2011, 09:52 AM   #1044
spazticrecords
Banned
1

 
Drives: 2010 E90 328 XI
Join Date: Jun 2007
Location: Yorktown Heights, NY.


Posts: 123
iTrader: (0)

All,

I will be offering remote and onsite coding in New York, Westchester. Please e-mail me if you are interested. This is for people who are not familiar or do not want to learn how to code or are having problems.

*************************
Appreciate 0
      01-18-2011, 10:01 AM   #1045
spera23
Second Lieutenant
11

 
Drives: 335i
Join Date: Sep 2009
Location: Toronto


Posts: 207
iTrader: (3)

Quote:
Originally Posted by Toshi View Post
These are the WL codes in my NFRM.

WL_AL
nicht_aktiv
WL_BLK_H
nicht_aktiv
WL_BLK_V
nicht_aktiv
WL_FL
nicht_aktiv
WL_KZL
soft_einschalten
WL_NSL
nicht_aktiv
WL_NSW
nicht_aktiv
WL_POL
nicht_aktiv
WL_SL_1
soft_einschalten
WL_SL_2
soft_einschalten


Give it a try.
The value must be "nicht_aktiv", "soft_einschalten" or "hart_einschalten".

I noticed changing WL_AL to "soft_einschalten" did get my low beams to come on as welcome lights once. Without making any further changes they no longer come on as welcome lights and after double checking, they are still coded as "soft_einschalten".

Anyone else experience this?
Appreciate 0
      01-18-2011, 10:02 AM   #1046
spazticrecords
Banned
1

 
Drives: 2010 E90 328 XI
Join Date: Jun 2007
Location: Yorktown Heights, NY.


Posts: 123
iTrader: (0)

I think we can confirm that it's not the OS, because I am running on WinXP x32 and above people are running on Win7 x64 without issue. It might be a driver compatibility issue. I am using the black USB cable and I know there was another cable with a silver case housing. Can we confirm what everyone with problems is using?
Appreciate 0
      01-18-2011, 10:15 AM   #1047
Toshi
Private First Class
Japan
9

 
Drives: ALPINA B4 BiTurbo Coupe (F32)
Join Date: Aug 2010
Location: Tokyo, Japan


Posts: 169
iTrader: (1)

I will check again this weekend since my car is now in my local dealer for repair.
I was able to change WL_KZL from "soft_einschalten" to "nicht_aktiv".


Quote:
Originally Posted by spera23 View Post
I noticed changing WL_AL to "soft_einschalten" did get my low beams to come on as welcome lights once. Without making any further changes they no longer come on as welcome lights and after double checking, they are still coded as "soft_einschalten".

Anyone else experience this?
Appreciate 0
      01-18-2011, 12:17 PM   #1048
coolamber
New Member
1

 
Drives: 2007 335i
Join Date: Dec 2010
Location: Henderson, NV


Posts: 11
iTrader: (0)

I purchased this cable from ebay: http://cgi.ebay.ca/NEW-BMW-K-DCAN-D-...-/160527159443

I am having the connection disturbed error no matter what settings I put in the registry for FIFO buffers. I see a few posts back that the silver cabled one is bad, however this one looks a bit different. Should I have gotten the one posted several pages back?

I am trying to code my car for 6FL retrofit. Got everything else working, had to make my own harness, this is the last step.
Appreciate 0
      01-18-2011, 12:50 PM   #1049
1QuikWS6
No 55mph
United_States
111

 
1QuikWS6's Avatar
 
Drives: 09 E92 328iX N51 3-Stage
Join Date: Jul 2009
Location: Blitzburgh, PA


Posts: 4,753
iTrader: (83)

Garage List
I don't know WHY so many people went out and bought the incorrect cable after we dedicated probably 6 pages to the correct cables to buy, posted all the links, and the guy that makes the correct cables even registered so he could come on the forum and explain the quality of his cable. Geez all ya need to do is read people

Just because you bought one on eBay does not mean it is a good cable, or that it has been proven to work.

Plus you paid to much for the one you bought. The correct one had a price of $119 and also an option to 'Make Offer' At the time, we all each offered $85 and he accepted - shipping was free.

It seems that everyone that bought just any old cable off eBay got the clear cable version - and they are having troubles with them.

HERE is the link for the CORRECT eBay cable:

http://cgi.ebay.com/ebaymotors/BMW-I...item255f64e9f4

And finally, what the CORRECT eBay cable looks like





So you see, yours is not the same, and quality of cables are not the same. If you continue to have connection problems it may well be the cable.


Sorry to seem to go off on a rant on ya, but there have been quite a few that ignored, or did not bother to read the thread from the beginning, and made a mistake on cable purchase. Now they are all posting up with problems.

It will be very hard to troubleshoot any problems you are having since you don't have the same cable as the rest and it may be suspect.

So now, once again - THIS example is what people need to buy, from that vendor, and looking same as pics.

No offense, but if it was too difficult for you to buy the correct, proven cable - then actually doing the coding is probably out of your reach...
__________________
2009 328ix E92//SGM//ACS Roof Spoiler//MTech Aero Lip+Trunk Spoiler//M3 Side Skirts//CF Roundels+Grilles//M3 Novillo Interior//Perf Shift Lever+Boot//MPerf DCT Wheel//M3 GT3 eBrake Handle+Boot//ACS Pedals//M3 Mirrors//LCI Tails w/LUX Rev//DTEC V7 AE+MTec 6000K D1S+HPB HID 6000K Fogs//HPB LED Interior//RPI Scoops//CF Euro Airbox+Underhood Hsgs//K&N//BMW PE//MTech Rear Bumper-iS Sport Diffuser//CF Strut Brace//Vishnu OFT//BMW 193M's+Kumho 4X
Appreciate 0
      01-18-2011, 01:09 PM   #1050
spera23
Second Lieutenant
11

 
Drives: 335i
Join Date: Sep 2009
Location: Toronto


Posts: 207
iTrader: (3)

Quote:
Originally Posted by Toshi View Post
I will check again this weekend since my car is now in my local dealer for repair.
I was able to change WL_KZL from "soft_einschalten" to "nicht_aktiv".
WL_KZL - Is that the Liscence Plate Lights?

Could you test the WL_AL on yours and let me know what happens?
Appreciate 0
      01-18-2011, 01:38 PM   #1051
spazticrecords
Banned
1

 
Drives: 2010 E90 328 XI
Join Date: Jun 2007
Location: Yorktown Heights, NY.


Posts: 123
iTrader: (0)

Thank you 1QuikWS6. I agree. We all need to start reading some of the posts. There are only so many who are repeat members who continue to offer support, help and share there knowledge on this whole thing. We need to try and cut down on repeat posts. This is an exciting topic and excited to be able to do.
Appreciate 0
      01-18-2011, 02:11 PM   #1052
coolamber
New Member
1

 
Drives: 2007 335i
Join Date: Dec 2010
Location: Henderson, NV


Posts: 11
iTrader: (0)

Unfortunately I did not see this post or I would have purchased the correct cable from the outset. I was on another forum and was under the impression they were all the same until I saw this post last night and read through everything after I was having issues. My post earlier was simply to verify I had the wrong cable since it did not seem to match either one I saw in earlier threads. The guy I bought it from said it was my fault it was not working and will not let me return it. At least it was relatively inexpensive.
Appreciate 0
      01-18-2011, 04:04 PM   #1053
spazticrecords
Banned
1

 
Drives: 2010 E90 328 XI
Join Date: Jun 2007
Location: Yorktown Heights, NY.


Posts: 123
iTrader: (0)

Who or where did you buy it from. Sounds like a scam artist. E-mail me

************************* and i will try to help.
Appreciate 0
      01-18-2011, 05:36 PM   #1054
larry_bml
Private
2

 
larry_bml's Avatar
 
Drives: BMW 320d Steptronic 2007
Join Date: Dec 2009
Location: Romania - Pitesti


Posts: 77
iTrader: (0)

Quote:
Originally Posted by spazticrecords View Post
Who or where did you buy it from. Sounds like a scam artist. E-mail me

************************* and i will try to help.
I've send you a new email, with all the modules i can access from the car. I don't have an NFRM module, or i didn't see it.
Appreciate 0
      01-18-2011, 05:55 PM   #1055
1QuikWS6
No 55mph
United_States
111

 
1QuikWS6's Avatar
 
Drives: 09 E92 328iX N51 3-Stage
Join Date: Jul 2009
Location: Blitzburgh, PA


Posts: 4,753
iTrader: (83)

Garage List
Quote:
Originally Posted by coolamber View Post
Unfortunately I did not see this post or I would have purchased the correct cable from the outset. I was on another forum and was under the impression they were all the same until I saw this post last night and read through everything after I was having issues. My post earlier was simply to verify I had the wrong cable since it did not seem to match either one I saw in earlier threads. The guy I bought it from said it was my fault it was not working and will not let me return it. At least it was relatively inexpensive.
Well, sorry bout that - I guess my comment wasn't the best 'Welcome to the Forum' post ever made then?

Seems to me that whomever is selling these inferior cables fully knows it & goes by the 'Buyer Beware' code - otherwise he should have no problem with a refund.

What would be nice is if you could find someone local that has the other cable and see if you have same problems, to validate. Barring that, my guess is you will have to get the other cable. Then there are a lot of guys here that can/will help if you run in to a problem.

I'm using the eBay cable, on WinXP, with the specific USB driver from FTDI chip.com without any problems FWIW

So I'll try again - Welcome to the forum!
__________________
2009 328ix E92//SGM//ACS Roof Spoiler//MTech Aero Lip+Trunk Spoiler//M3 Side Skirts//CF Roundels+Grilles//M3 Novillo Interior//Perf Shift Lever+Boot//MPerf DCT Wheel//M3 GT3 eBrake Handle+Boot//ACS Pedals//M3 Mirrors//LCI Tails w/LUX Rev//DTEC V7 AE+MTec 6000K D1S+HPB HID 6000K Fogs//HPB LED Interior//RPI Scoops//CF Euro Airbox+Underhood Hsgs//K&N//BMW PE//MTech Rear Bumper-iS Sport Diffuser//CF Strut Brace//Vishnu OFT//BMW 193M's+Kumho 4X
Appreciate 0
      01-18-2011, 06:08 PM   #1056
coolamber
New Member
1

 
Drives: 2007 335i
Join Date: Dec 2010
Location: Henderson, NV


Posts: 11
iTrader: (0)

No worries, so difficult to convey actual intent or history in a short message

One thing I did notice in an earlier post is the driver for the FTDI unit does not seem to use the serial key in the registry. It instead uses the FTSER2K key instead. However the obdsetup file checks the serial key.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:00 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST