E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Canada > Squeaky noise over bumps?



Reply
 
Thread Tools Search this Thread
      06-06-2011, 09:40 AM   #1
domrep
Captain
 
domrep's Avatar
 
Drives: AW E93 335i
Join Date: Mar 2009
Location: Toronto

Posts: 973
iTrader: (3)

Squeaky noise over bumps?

Any of you guys get a squeaky sound when going over bumps on local roads? At first I thought it was my stock suspension going, but after I switched them I still get it. I think it might be my bushings/bump stop or something of the sort...anybody else have this problem and ever get it resolved?
__________________
2007 AW E93 / Procede V5 / BMS DCI / AR Catted DPs / AR OCC / ER Oil Cooler / AMS FMIC / ER CP + Synapse BOV / Vanguard Exhaust / KW V3 / Wavetrac LSD / 19" BBS LMs
domrep is offline   Canada
0
Reply With Quote
      06-06-2011, 09:56 AM   #2
teamadobo
Captain
 
Drives: 328i Xdrive
Join Date: Nov 2009
Location: Ontario Canada

Posts: 608
iTrader: (3)

Read this thread

http://www.e90post.com/forums/showthread.php?t=472749
teamadobo is offline  
0
Reply With Quote
      06-06-2011, 01:11 PM   #3
domrep
Captain
 
domrep's Avatar
 
Drives: AW E93 335i
Join Date: Mar 2009
Location: Toronto

Posts: 973
iTrader: (3)

Anyone confirm that it's sway bar bushings or have had it replaced? I'm scared they'll screw me on my aftermarket coils. The above thread says they're having a scraping noise, mine is more of a squeak like jumping on an old mattress
__________________
2007 AW E93 / Procede V5 / BMS DCI / AR Catted DPs / AR OCC / ER Oil Cooler / AMS FMIC / ER CP + Synapse BOV / Vanguard Exhaust / KW V3 / Wavetrac LSD / 19" BBS LMs

Last edited by domrep; 06-06-2011 at 01:17 PM.
domrep is offline   Canada
0
Reply With Quote
      06-06-2011, 01:19 PM   #4
teamadobo
Captain
 
Drives: 328i Xdrive
Join Date: Nov 2009
Location: Ontario Canada

Posts: 608
iTrader: (3)

Yes they replaced the swaybar bushing on mine and it fixed the issue. The noise sounds like a mudflap scraping the ground or like you said squeaky mattress springs
teamadobo is offline  
0
Reply With Quote
      06-06-2011, 01:21 PM   #5
domrep
Captain
 
domrep's Avatar
 
Drives: AW E93 335i
Join Date: Mar 2009
Location: Toronto

Posts: 973
iTrader: (3)

are you modded? and did they replace both front and rear?

thanks for the help
__________________
2007 AW E93 / Procede V5 / BMS DCI / AR Catted DPs / AR OCC / ER Oil Cooler / AMS FMIC / ER CP + Synapse BOV / Vanguard Exhaust / KW V3 / Wavetrac LSD / 19" BBS LMs
domrep is offline   Canada
0
Reply With Quote
      06-06-2011, 01:24 PM   #6
MOAB
Major
 
MOAB's Avatar
 
Drives: Porsche & BMW
Join Date: Dec 2006
Location: Toronto

Posts: 1,077
iTrader: (0)

Quote:
Originally Posted by teamadobo View Post
Yes they replaced the swaybar bushing on mine and it fixed the issue. The noise sounds like a mudflap scraping the ground or like you said squeaky mattress springs
agreed. had the same issue (as did many others here) and no issue now that they replaced the bushings.
__________________
March-November - '09 C4S (PDK, Akrapovic)
December-February - '00 323 (only mod - snow tires)
MOAB is offline   Canada
0
Reply With Quote
      06-06-2011, 01:37 PM   #7
teamadobo
Captain
 
Drives: 328i Xdrive
Join Date: Nov 2009
Location: Ontario Canada

Posts: 608
iTrader: (3)

Quote:
Originally Posted by domrep View Post
are you modded? and did they replace both front and rear?

thanks for the help
I'm on stock suspension. The found out only the front swaybar bushing needs replacing
teamadobo is offline  
0
Reply With Quote
      06-06-2011, 02:13 PM   #8
dkha01
Private
 
Drives: e92 328
Join Date: Feb 2011
Location: toronto

Posts: 70
iTrader: (2)

im having the same problem....at first i thought it was the H&R springs that were making the noise.

im out of warranty now so how much would it cost to get fixed
dkha01 is offline  
0
Reply With Quote
      06-06-2011, 02:43 PM   #9
commie
Second Lieutenant
 
Drives: 335i
Join Date: Jun 2008
Location: Toronto

Posts: 203
iTrader: (0)

They replaced my front swaybar bushings, and the noise is gone.
commie is offline  
0
Reply With Quote
      09-19-2011, 07:16 PM   #10
bubbahead
First Lieutenant
 
Drives: 2013 750ix Msport
Join Date: May 2009
Location: GTA

Posts: 358
iTrader: (0)

my car squeeked going over rough roads, small potholes etc. I brought it in, which is still in the shop, and they couldnt figure it out. They replaced my muffler, but that didnt fix the problem...now they are gonna check the breaks...but its on all four wheels..very odd.
bubbahead is offline  
0
Reply With Quote
      09-20-2011, 02:33 AM   #11
mabman
New Member
 
Drives: 2007 BMW 335xi
Join Date: Dec 2010
Location: toronto

Posts: 154
iTrader: (0)

They replaced my front swaybar bushings, and the noise is gone. It was done under the 4 year warranty.
mabman is offline   Canada
0
Reply With Quote
      09-20-2011, 12:02 PM   #12
CHCCubs
Lieutenant Colonel
 
CHCCubs's Avatar
 
Drives: 2013 BMW 328i xDrive Sport
Join Date: Apr 2009
Location: Toronto, ON, Canada

Posts: 1,704
iTrader: (0)

Quote:
Originally Posted by mabman View Post
They replaced my front swaybar bushings, and the noise is gone. It was done under the 4 year warranty.
Same here, had mine done back in February and no noises since.
__________________

2013 BMW 328i xDrive Sport Line
Mineral Grey on Everest Grey
CHCCubs is offline   Latvia
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:44 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST