E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Overvoltage, replaced battery, still overvoltage...



Reply
 
Thread Tools Search this Thread
      07-16-2016, 12:47 PM   #1
DanMZe90
Enlisted Member
2
Rep
44
Posts

Drives: BMW E90 330D SE
Join Date: Jan 2012
Location: Devon

iTrader: (0)

Overvoltage, replaced battery, still overvoltage...

Hi,

I run Carly BMW on my 2005 330D to do diagnostics fairly regularly. For the last few weeks I have been getting an 'overvoltage' error. I have had the car for 4 years and I believe the original battery was in it and due for replacement, even though the voltages were pretty much correct at idle and running.

I purchased a genuine BMW battery from Cotswold BMW with the same output as mine and fitted it today. The Carly app did not recognise it as a different to what was in it already but allowed me to register it as the same kind of battery. I haven't been for a spin in it but have had it idling to a) clear faults and b) re-run the Carly diagnostics a number of times. I am still getting an overvoltage error. Should I see how it is after I've done a few runs to work over the week or is it pretty much now pointing at the voltage regulator or alternator?

If it is the latter where do I get the voltage regulator from? Cotswold BMW don't sell it separately so do I buy that second hand or refurbished? The same goes for the alternator, at 430 it is rather expensive new so is it Ebay or some other place that does refurbs?

Any help much appreciated as always!

Thanks

Dan
Appreciate 0
      07-16-2016, 03:00 PM   #2
Dormermike
Private First Class
7
Rep
104
Posts

Drives: Bmw f10
Join Date: Dec 2015
Location: Uk

iTrader: (0)

Depending on the alternator you've got, you can usually replace the brush pack and or regulator.

What voltage whilst the engine is running?
Appreciate 0
      07-18-2016, 03:28 PM   #3
DanMZe90
Enlisted Member
2
Rep
44
Posts

Drives: BMW E90 330D SE
Join Date: Jan 2012
Location: Devon

iTrader: (0)

Hi, idle it is 12.78 and running it is around the 14.19 - 14.35 mark, max I saw it go to was 14.39. I just cleared the codes again and ran diagnostics and not showing the fault but not sure it happens on the way to work or a longer run. Will check tomorrow evening, hopefully it sorted itself out.....
Appreciate 0
      07-18-2016, 04:48 PM   #4
Dormermike
Private First Class
7
Rep
104
Posts

Drives: Bmw f10
Join Date: Dec 2015
Location: Uk

iTrader: (0)

12.78 is too low at idle
Appreciate 0
      07-18-2016, 05:40 PM   #5
DanMZe90
Enlisted Member
2
Rep
44
Posts

Drives: BMW E90 330D SE
Join Date: Jan 2012
Location: Devon

iTrader: (0)

Thanks, that's what the 'old' battery I took out was registering too. Do you think this points to the regulator/alternator then?

Thanks

Dan
Appreciate 0
      07-18-2016, 05:41 PM   #6
DanMZe90
Enlisted Member
2
Rep
44
Posts

Drives: BMW E90 330D SE
Join Date: Jan 2012
Location: Devon

iTrader: (0)

Sorry, I've been a bit of an idiot. 12.78 is switched off and not idling...doh!
Appreciate 0
      07-27-2016, 04:15 PM   #7
DanMZe90
Enlisted Member
2
Rep
44
Posts

Drives: BMW E90 330D SE
Join Date: Jan 2012
Location: Devon

iTrader: (0)

OK, panic over as overvoltage disappeared and hasn't reared its ugly head again this week so putting it down to bad battery.

Thanks

Dan
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:25 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST