Lux Angel Eyes
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > 335i (N54) Turbos

Thread Tools Search this Thread
      07-27-2016, 11:39 AM   #1

Drives: 2007 E92 335i
Join Date: Apr 2015
Location: UK

iTrader: (0)

335i (N54) Turbos

Good Afternoon All,

I had my turbos replaced 13 months ago with turbos provided by BMW.

The dreaded wastegate rattle is back with a vengeance and the turbos themselves have 24 months warranty.

I have been trying to prove the rattle to my dealership for months who kept saying they were fine, however i managed to prove the rattle due to having a technician come to my car, hear me rev it to 3500 and when the revs drop it hisses and rattles. Disconnect the vacuum hoses and do it again, no rattle.

So we finally established the turbos were at fault. Now here it gets interesting, the technician advised who fitted the turbos, i advised an indy... AHA he replies they fitted them wrong. They need to adjust the turbos before putting them on and as they didn't it's their fault....

I sat and thought about this and said, well the turbos were provided by you and should they not be adjusted correctly out of the box, the fix you refer to is retrospective so if the turbos don't come with instructions to do that how would they have known thus the parts were faulty when they were provided. I advised my car is currently as it comes out of the factory and the turbos even though they are new are faulty by design. Now if you have a fix you should be responsible for rectifying your faulty part as the garage that fit them would not accept liability for you providing them with a faulty turbo.

The technician stuttered and said i should speak to BMW HO.

BMW do have a fix to stop it however they are reluctant to do it as they say it should have been done when they were fitted, which to me seems wrong. They don't have instructions for this when they sell them, then when you say they are faulty they claim you should have done something that you wasn't aware of and as a result its your own fault.

Does anyone else think i am wrong for expecting them to fix the part?
Appreciate 0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:28 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST