E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > *Official* 6FL iPod/USB Thread



Reply
 
Thread Tools Search this Thread
      04-17-2007, 10:57 AM   #397
silverbmwz3
Colonel
23
Rep
2,021
Posts

 
Drives: E90 335d wheelbarrow
Join Date: Mar 2007
Location: Buckinghamshire, UK

iTrader: (0)

Garage List
I never did get a response when I asked:

"To what extent does the E90's voice control allow you to voice control the ipod via this option?"

I.e. can you make it go to the next song / artist etc. via voice control ? Or do you have to spin the idrive controller or what?
__________________
Current: E90 335d (May 2007) | Black/Black | Prof Hifi | Prof Nav | 6FL | Fully Electric Seats | Xenons | Folding Mirrors | PDC
Previous: 325ci Conv. Black/Black with lots of ACS
Previous: z3 3.0 Silver with Black&Red Leather
Appreciate 0
      04-17-2007, 11:03 AM   #398
LEDZEP
Lieutenant General
LEDZEP's Avatar
191
Rep
12,277
Posts

 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

iTrader: (0)

Garage List
Quote:
Originally Posted by silverbmwz3 View Post
I never did get a response when I asked:

"To what extent does the E90's voice control allow you to voice control the ipod via this option?"

I.e. can you make it go to the next song / artist etc. via voice control ? Or do you have to spin the idrive controller or what?
I tried "Entertainment"; "Auxilary" the other day and it took me to the car data screen. I think VC is pretty useless for the iPod, but my testing thus far has been pretty limited.
__________________


I think it is bad luck to be superstitious
Appreciate 0
      04-18-2007, 01:39 AM   #399
funkahdafi
Second Lieutenant
funkahdafi's Avatar
Germany
8
Rep
273
Posts

 
Drives: Z4 (E89) sDrive 35is
Join Date: Oct 2005
Location: Europe, Germany, Mannheim

iTrader: (0)

Send a message via Skype™ to funkahdafi
Any news on shuffling in iDrive equipped cars yet?
Appreciate 0
      04-18-2007, 05:59 AM   #400
LEDZEP
Lieutenant General
LEDZEP's Avatar
191
Rep
12,277
Posts

 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

iTrader: (0)

Garage List
Quote:
Originally Posted by funkahdafi View Post
Any news on shuffling in iDrive equipped cars yet?
Yes, you can shuffle playlists or other lists with the "Random" option. It does not hold that setting after a power-off though (much like iPod itself).
__________________


I think it is bad luck to be superstitious
Appreciate 0
      04-19-2007, 09:50 AM   #401
rocoT
Enlisted Member
Ireland
1
Rep
44
Posts

 
Drives: E90 320d M-Sport
Join Date: Mar 2007
Location: Dublin, Ireland

iTrader: (0)

my 2 cents....6FL doesn't work too well with the iriver H340 mp3 player.

You have to boot the player up, then connect it to the usb port and then the car must do its' indexing etc. The random function only works on the current directory and therefore you must have all of your songs in one directory to get it to work properly.

When the car is switched off, the Iriver still thinks it's actively connected to the car. To shut the Iriver down you must unplug the USB connect, wiat for the player to boot up and then shut it down.

Apart from that, playback is excellent.

I also found a cable in the boot of my car, about 4" long, male USB on one end and female on the other, supposedly to allow connection of a flash drive/USB HD. The upper inside of the armrest also has what looks like a velcro/leather holder for an ipod. Will post a picture soon.

The USB spec document published by BMW doesn't fully endorse every USB HD but I'm going to give mine a go today to see how it works out. It's just a basic 2.5" IBM Travelstar 30GB HD in a USB enabled HD case.

Fingers crossed....
Appreciate 0
      04-19-2007, 11:56 AM   #402
jmonier
Captain
9
Rep
812
Posts

 
Drives: 2007 335i E92, 2002 325i
Join Date: Aug 2006
Location: Torrance, CA

iTrader: (0)

If you just shut off the engine, the USB will remain active. Try hitting the button a second time to shut off radio readiness. Even the iPod will remain active until you exit the car.

The problem with USB hard drives is that there is limited current available at the USB to spin up the drive, so if it's USB powered there might be a problem.
Appreciate 0
      04-19-2007, 12:24 PM   #403
200Duece
Colonel
200Duece's Avatar
26
Rep
2,552
Posts

 
Drives: '73 2002,'12 X5 35d,'12 335 SL
Join Date: Jan 2007
Location: A Whale's Vagina, Ca

iTrader: (5)

I tried to hook up my Sony Mp3 yesterday and wasn't able to get any audio. I had the sound output switched to a "line out" setting and when I connect the usb cable it shows "connecting to PC". After a minute or so I am able to see that a couple of different files are available. I think that they read, " 10f01, 10f02, etc and 20g01, 20g02, etc" . I tried each available selection and no sound.

I do have quite a bit of music stored and I have not waited out the "connecting to PC" screen. This is my next attempt.

Does anyone have reports on non- iPod players?
Appreciate 0
      04-20-2007, 04:22 AM   #404
rocoT
Enlisted Member
Ireland
1
Rep
44
Posts

 
Drives: E90 320d M-Sport
Join Date: Mar 2007
Location: Dublin, Ireland

iTrader: (0)

Quote:
Originally Posted by rocoT View Post
The upper inside of the armrest also has what looks like a velcro/leather holder for an ipod. Will post a picture soon.
Here's the pics folks...


The USB HD didn't work too well. As jmonier said, it seems to suffer from the way it is powered. The drive frequently stops altogether and disappears after you take a call over Bluetooth.

Looks like a USB flash drive is the only way forward for me.
Attached Images
  
Appreciate 0
      04-20-2007, 05:47 AM   #405
LEDZEP
Lieutenant General
LEDZEP's Avatar
191
Rep
12,277
Posts

 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

iTrader: (0)

Garage List
I guess only the Euro market is getting the iPod case? Canada too maybe? Pretty nice... wonder why we don't get it?
__________________


I think it is bad luck to be superstitious
Appreciate 0
      04-20-2007, 07:35 AM   #406
rocoT
Enlisted Member
Ireland
1
Rep
44
Posts

 
Drives: E90 320d M-Sport
Join Date: Mar 2007
Location: Dublin, Ireland

iTrader: (0)

doesn't seem to be detachable but I'm sure it could be retro-fitted.
Appreciate 0
      04-20-2007, 09:48 AM   #407
DLK33
Registered
0
Rep
2
Posts

 
Drives: 2007 335i coupe
Join Date: Apr 2007
Location: NoVa

iTrader: (0)

Problem: iDrive 6FL playback frozen

After picking up the cable last weekend, my iPod has worked perfectly with the 6FL. No problems. As I'm driving to work this morning, I connect the cable, select the playlist and I'm off. A couple of minutes later, there's a stutter in the middle of the song that's playing, audio cuts out and iDrive says that it's loading the audio files. A couple of minutes--nothing. Still says it's loading. I disconnect the cable and reconnect it. Same screen and still loading. I check the iPod--it's continuing to play and has moved on to another song in the playlist, so it doesn't seem that's the problem.

Fifteen minutes later, no change and iDrive still says its loading. I can navigate through the load screen to select "Playlist" or "Now Playing", but pushing the knob does nothing (I can use the scroll bar at the top to navigate among FM/AM/CD/AUX modes). Cannot access any other part or screen for the AUX menu.

After I get to work, I try disconnecting the iPod a few more times, disconnecting the cable from the car, restarting the car, etc. Same screen and no change--still loading (even when the iPod is not connected to the cable).

Not sure anyone has encountered a similar situation or has advice, but any suggestions? I'm going to give it another go later today and see if I can get it working.
Appreciate 0
      04-20-2007, 09:57 AM   #408
LEDZEP
Lieutenant General
LEDZEP's Avatar
191
Rep
12,277
Posts

 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

iTrader: (0)

Garage List
Quote:
Originally Posted by DLK33 View Post
After picking up the cable last weekend, my iPod has worked perfectly with the 6FL. No problems. As I'm driving to work this morning, I connect the cable, select the playlist and I'm off. A couple of minutes later, there's a stutter in the middle of the song that's playing, audio cuts out and iDrive says that it's loading the audio files. A couple of minutes--nothing. Still says it's loading. I disconnect the cable and reconnect it. Same screen and still loading. I check the iPod--it's continuing to play and has moved on to another song in the playlist, so it doesn't seem that's the problem.

Fifteen minutes later, no change and iDrive still says its loading. I can navigate through the load screen to select "Playlist" or "Now Playing", but pushing the knob does nothing (I can use the scroll bar at the top to navigate among FM/AM/CD/AUX modes). Cannot access any other part or screen for the AUX menu.

After I get to work, I try disconnecting the iPod a few more times, disconnecting the cable from the car, restarting the car, etc. Same screen and no change--still loading (even when the iPod is not connected to the cable).

Not sure anyone has encountered a similar situation or has advice, but any suggestions? I'm going to give it another go later today and see if I can get it working.

Rot Roh... that doesn't sound good. I agree, if a day goes by and it is still the same you should make an appointment to have it checked out. Expect some shrugging and head scratching, since 6FL is so new. They may reset your iDrive, or wind up opening a PUMA case.

Please keep us informed!!
__________________


I think it is bad luck to be superstitious
Appreciate 0
      04-20-2007, 10:03 AM   #409
wdogan
Private
United_States
0
Rep
73
Posts

 
Drives: 2007 328xi sedan (as of 4/18)
Join Date: Feb 2007
Location: San Francisco

iTrader: (0)

Just picked up my car on Thursday (woo hoo!). I connected my iPod to the USB and Aux jacks in the armest, and plugged my phone charger into the power outlet in the armrest. But the phone wouldn't charge, was getting no power from the outlet. When I plugged the charger into the ashtray lighter, it worked fine, so the problem is not the charger.

Has anyone else had this problem, or have you been able to use both the USB connector and the armrest power outlet at the same time?
__________________
2007 E90 328xi, 6MT, Sparkling Graphite/Black/Poplar, Sport/Premium/Cold Packages, iDrive/Nav, Xenons, Logic 7, 6FL
Appreciate 0
      04-20-2007, 11:32 AM   #410
LEDZEP
Lieutenant General
LEDZEP's Avatar
191
Rep
12,277
Posts

 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

iTrader: (0)

Garage List
Quote:
Originally Posted by wdogan View Post
Just picked up my car on Thursday (woo hoo!). I connected my iPod to the USB and Aux jacks in the armest, and plugged my phone charger into the power outlet in the armrest. But the phone wouldn't charge, was getting no power from the outlet. When I plugged the charger into the ashtray lighter, it worked fine, so the problem is not the charger.

Has anyone else had this problem, or have you been able to use both the USB connector and the armrest power outlet at the same time?
Interesting. I haven't tried to use the console power supply yet. I wonder if the powered USB makes it an either/or choice. That doesn't really seem right though.

PS - CONGRATS!!
__________________


I think it is bad luck to be superstitious
Appreciate 0
      04-20-2007, 12:25 PM   #411
DLK33
Registered
0
Rep
2
Posts

 
Drives: 2007 335i coupe
Join Date: Apr 2007
Location: NoVa

iTrader: (0)

Quote:
Originally Posted by DLK33 View Post
After picking up the cable last weekend, my iPod has worked perfectly with the 6FL. No problems. As I'm driving to work this morning, I connect the cable, select the playlist and I'm off. A couple of minutes later, there's a stutter in the middle of the song that's playing, audio cuts out and iDrive says that it's loading the audio files. A couple of minutes--nothing. Still says it's loading. I disconnect the cable and reconnect it. Same screen and still loading. I check the iPod--it's continuing to play and has moved on to another song in the playlist, so it doesn't seem that's the problem.

Fifteen minutes later, no change and iDrive still says its loading. I can navigate through the load screen to select "Playlist" or "Now Playing", but pushing the knob does nothing (I can use the scroll bar at the top to navigate among FM/AM/CD/AUX modes). Cannot access any other part or screen for the AUX menu.

After I get to work, I try disconnecting the iPod a few more times, disconnecting the cable from the car, restarting the car, etc. Same screen and no change--still loading (even when the iPod is not connected to the cable).

Not sure anyone has encountered a similar situation or has advice, but any suggestions? I'm going to give it another go later today and see if I can get it working.
UPDATE: Went out at lunch, started up, and got playback immediately. No more frozen screen and I seem to have full functionality back. Didn't do anything else, so not sure whether it just needed to timeout. Crossed fingers that this was a one-time glitch -- 6FL is a hell of an option and I'd hate to have it go down.
Appreciate 0
      04-20-2007, 01:02 PM   #412
LEDZEP
Lieutenant General
LEDZEP's Avatar
191
Rep
12,277
Posts

 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

iTrader: (0)

Garage List
Quote:
Originally Posted by DLK33 View Post
UPDATE: Went out at lunch, started up, and got playback immediately. No more frozen screen and I seem to have full functionality back. Didn't do anything else, so not sure whether it just needed to timeout. Crossed fingers that this was a one-time glitch -- 6FL is a hell of an option and I'd hate to have it go down.
Glad it worked itself out! I wonder if going into full sleep mode cleared the cobwebs?
__________________


I think it is bad luck to be superstitious
Appreciate 0
      04-20-2007, 04:44 PM   #413
Heimes
Registered
Germany
0
Rep
3
Posts

 
Drives: E90 325d
Join Date: Apr 2007
Location: Munich/Germany

iTrader: (0)

Red face First experience with 6fl

Hi,

I picked up my new car today, just can say wow, will have a lot of fun this summer.


To come back to the 6fl. I connected my Ipod Video 60GB to the usb interface. After a couple of minutes, I could see the interpreter names as well as the album names but what i recognized, is, that there are several names in the both lists for 3 or more times. Especially my own compilations are completely fragmented. I also couldn't see any of my playlists.
BTW, I used the standard Ipod cable together with an audio cable. Has someone of you recognized the same behavior? Will this work with the original BMW cable without any problems?

Heimes
Appreciate 0
      04-20-2007, 06:47 PM   #414
LEDZEP
Lieutenant General
LEDZEP's Avatar
191
Rep
12,277
Posts

 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

iTrader: (0)

Garage List
Heimes - Welcome and Congratulations!!

The special cable for iPod makes a world of difference. You may be required to pay extra for it in Germany, but it would be well worth it. With the correct cable, the interface behaves exactly like you iPod, with playlists, artists, albums, etc.
__________________


I think it is bad luck to be superstitious
Appreciate 0
      04-23-2007, 11:28 AM   #415
jhlake
New Member
United_States
0
Rep
8
Posts

 
Drives: 07 335i - Jet Black
Join Date: Mar 2007
Location: St. Louis, MO

iTrader: (0)

My car was a March build and has the iPod holder on the underside of the armrest.

I am waiting for my cable from my dealer. Currently, I'm using the cable that came with my iPod, but I don't have acess to all my playlists or all the music on my iPod. Do these issues get resolved with the special cable?
Appreciate 0
      04-23-2007, 11:41 AM   #416
LEDZEP
Lieutenant General
LEDZEP's Avatar
191
Rep
12,277
Posts

 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

iTrader: (0)

Garage List
Quote:
Originally Posted by jhlake View Post
My car was a March build and has the iPod holder on the underside of the armrest.

I am waiting for my cable from my dealer. Currently, I'm using the cable that came with my iPod, but I don't have acess to all my playlists or all the music on my iPod. Do these issues get resolved with the special cable?
Yes, those issues will all be resolved with the proper cable and you will love it! So you got the iPod holder??

Does BMW use the "eenie, meenie, minie, moe" method of allocating these resources?
__________________


I think it is bad luck to be superstitious
Appreciate 0
      04-23-2007, 12:27 PM   #417
jhlake
New Member
United_States
0
Rep
8
Posts

 
Drives: 07 335i - Jet Black
Join Date: Mar 2007
Location: St. Louis, MO

iTrader: (0)

Thanks. I can't wait to get it.

I think you're right. When I opened the armrest and saw it, my CA said "Wow, I've never seen or heard of that before."
Appreciate 0
      04-23-2007, 12:56 PM   #418
theroyalwe
BMW CA
theroyalwe's Avatar
United_States
4
Rep
304
Posts

 
Drives: MINI, all BMW's
Join Date: Feb 2007
Location: SE PA

iTrader: (0)

yeah who knows what the deal is with the ipod holder. I've delivered two 328xi's with 6fl and neither have that... the 335i sport with 6fl has the ipod holder... so I thought maybe it was only the 335's that get it. and then today I looked at a 328xi manual with no options besides heated seats and 6fl... and it had the ipod holder. weird stuff!
__________________
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:28 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST