E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > *Official* 6FL iPod/USB Thread



Reply
 
Thread Tools Search this Thread
      02-03-2008, 05:24 PM   #991
networkguy
Private First Class
 
networkguy's Avatar
 
Drives: 335D SE Touring
Join Date: Nov 2007
Location: Lincolnshire UK

Posts: 168
iTrader: (0)

Garage List
Where ever you have a situation where a device (in this case the car) reads data from an external source then there is the risk.

So the risk exists from the USB port, a CD, bluetooth or even the computer system at the dealership service centre when your car is on the ramps.

Of course any such thing would need to be written to specifically target a vunerabilty in the software on your car. The odds of this are so low as to be not worth even thinking about.

As for reloading the software, this would be much much easier than say loading windows onto a PC. Remember your car is NOT a computer. It does not have just one CPU with RAM and a hard disk. It is made up of a number of systems that talk to each other at a number of levels.

So could it be done? Yes

Will it be done?

Well IT security is key to what I do for a living and today I would be more than happy to take a USB key from a PC I knew to have a virus on it and plug it into the USB port on my car.
networkguy is offline   United Kingdom
0
Reply With Quote
      02-04-2008, 01:43 PM   #992
E24
DUBYA
 
E24's Avatar
 
Drives: 08 E90 335i & 07 Expedition
Join Date: Oct 2005
Location: 1600 Pennsylvania Avenue

Posts: 346
iTrader: (1)

Sirius Stilletto 2?

Can this unit be connected via the ipod/usb connection?
E24 is offline   United_States
0
Reply With Quote
      02-05-2008, 01:38 AM   #993
adrian1480
Lieutenant
 
adrian1480's Avatar
 
Drives: 2014 435icp
Join Date: Nov 2007
Location: FL

Posts: 407
iTrader: (0)

Send a message via AIM to adrian1480
I have now found that after the update, my 160GB iPod classic charges...but does NOT indicate that its charging. charging symbol never appears.
__________________
Quote:
Originally Posted by Roosevelt
The credit belongs to those who are actually in the arena, who strive valiantly, who know the great enthusiasms, the great devotions, and spend themselves in a worthy cause; who, at the best, know the triumph of high achievement and who, at the worst, if they fail, fail while daring greatly so that their place shall never be with those cold and timid souls who know neither victory nor defeat.
adrian1480 is offline   United_States
0
Reply With Quote
      02-07-2008, 07:48 AM   #994
LEDZEP
Lieutenant General
 
LEDZEP's Avatar
 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

Posts: 12,277
iTrader: (0)

Garage List
Quote:
Originally Posted by networkguy View Post
Where ever you have a situation where a device (in this case the car) reads data from an external source then there is the risk.

So the risk exists from the USB port, a CD, bluetooth or even the computer system at the dealership service centre when your car is on the ramps.

Of course any such thing would need to be written to specifically target a vunerabilty in the software on your car. The odds of this are so low as to be not worth even thinking about.

As for reloading the software, this would be much much easier than say loading windows onto a PC. Remember your car is NOT a computer. It does not have just one CPU with RAM and a hard disk. It is made up of a number of systems that talk to each other at a number of levels.

So could it be done? Yes

Will it be done?

Well IT security is key to what I do for a living and today I would be more than happy to take a USB key from a PC I knew to have a virus on it and plug it into the USB port on my car.
+1 I agree and would have few misgivings about connecting a questionable device. You also have to assume that the system is designed to process input data in any other way than simply directly to the audio system as a sound source - which I would doubt it is.
__________________


I think it is bad luck to be superstitious
LEDZEP is offline  
0
Reply With Quote
      02-07-2008, 10:50 AM   #995
adc
Brigadier General
 
Drives: 2009 E90 M3 ED
Join Date: Sep 2006
Location: MD/DC

Posts: 4,128
iTrader: (6)

Here is the latest chapter in my never-ending 6FL saga...

To recap, my 30GB iPod Photo won't charge, neither will the wife's 80GB Classic.

A few days ago I left the Photo in the car connected via the original iPod dock-USB cable (the white one) - and a few days later, the iPod was charged 50% (from down to zero).

So the original iPod cable does charge it, albeit slowly. But with the BMW cable, nada (either that, or it similarly gets very little juice and perhaps playing it at the same time consumes more current than can go in).

It's getting really really old...


I think out of curiosity I'll update the Classic to the latest firmware and give a go for a few days.
adc is offline  
0
Reply With Quote
      02-07-2008, 11:37 AM   #996
Kb8jumpman
Second Lieutenant
 
Kb8jumpman's Avatar
 
Drives: 08 E92 328i
Join Date: Apr 2007
Location: Brooklyn, NY

Posts: 253
iTrader: (0)

Garage List
2008 328i E92  [0.00]
Send a message via AIM to Kb8jumpman
Quote:
Originally Posted by kitw View Post
Any luck on this?

My 3G iPod just started doing this. It's stuck, and works fine on everything else, just not in my 335i.

What happens is that I can select Aux, and it shows the name of my iPod, but it gets stuck at, "Loading Data from the Audio Device." I can get my iPod to play by manually unplugging the USB port, but I can't control it that way.
I have this same problem, only thing is is that it used to work before and it stopped out since I synced it with the newest Itunes. What can I do?
Its a 08 with 6FL and I have the "new" black Y-cable
__________________
08 E92 328i Crimson red / Coral Red / Aluminum Trim/ 6MT, Navi w/ I-drive, premium, comfort access, 6FL ipod kit. Blacked out vinyl window trim
Ordered: 8/18
Delivered: 10/12
Kb8jumpman is offline   United_States
0
Reply With Quote
      02-08-2008, 07:50 AM   #997
LEDZEP
Lieutenant General
 
LEDZEP's Avatar
 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

Posts: 12,277
iTrader: (0)

Garage List
wow - this thread now has hit 1,000 posts. Pretty amazing for an audio realated thred!
__________________


I think it is bad luck to be superstitious
LEDZEP is offline  
0
Reply With Quote
      02-12-2008, 03:59 PM   #998
cisoid
Enlisted Member
 
Drives: 320d (E46)
Join Date: Feb 2007
Location: Munich

Posts: 30
iTrader: (0)

Quote:
Originally Posted by adrian1480 View Post
I have now found that after the update, my 160GB iPod classic charges...but does NOT indicate that its charging. charging symbol never appears.

I made the same experience. Hoever, even if the iPod does not show the proper charging symbol it still is charged. I checked this with a nearly empty iPod during a long journey. After a couple of hours the iPod was indeed fully charged.
__________________
in love with 335d
cisoid is offline  
0
Reply With Quote
      02-12-2008, 04:02 PM   #999
cisoid
Enlisted Member
 
Drives: 320d (E46)
Join Date: Feb 2007
Location: Munich

Posts: 30
iTrader: (0)

Quote:
Originally Posted by LEDZEP View Post
wow - this thread now has hit 1,000 posts. Pretty amazing for an audio realated thred!
Yes, and close to 70.000 views! Maybe this can convince BMW to come up with some information about 6FL on their own hompage :-}
__________________
in love with 335d
cisoid is offline  
0
Reply With Quote
      02-12-2008, 04:06 PM   #1000
cisoid
Enlisted Member
 
Drives: 320d (E46)
Join Date: Feb 2007
Location: Munich

Posts: 30
iTrader: (0)

Quote:
Originally Posted by Kb8jumpman View Post
I have this same problem, only thing is is that it used to work before and it stopped out since I synced it with the newest Itunes. What can I do?
Its a 08 with 6FL and I have the "new" black Y-cable
3G iPod shouldn't work at all. BMW's compatibility list states that only 4G and later iPods are compatible.

Kb8jumpman: Do you have a 3G iPod? What's a 08?
__________________
in love with 335d
cisoid is offline  
0
Reply With Quote
      02-12-2008, 04:17 PM   #1001
cisoid
Enlisted Member
 
Drives: 320d (E46)
Join Date: Feb 2007
Location: Munich

Posts: 30
iTrader: (0)

Quote:
Originally Posted by adc View Post
Here is the latest chapter in my never-ending 6FL saga...

To recap, my 30GB iPod Photo won't charge, neither will the wife's 80GB Classic.

A few days ago I left the Photo in the car connected via the original iPod dock-USB cable (the white one) - and a few days later, the iPod was charged 50% (from down to zero).

So the original iPod cable does charge it, albeit slowly. But with the BMW cable, nada (either that, or it similarly gets very little juice and perhaps playing it at the same time consumes more current than can go in).

It's getting really really old...


I think out of curiosity I'll update the Classic to the latest firmware and give a go for a few days.

Should not be a problem! All iPod get enough power to charge and simultaneously play music. The BMW cable simply connects the iPod to the USB power supply, i.e., the iPod can draw up to 500mA at 5V.

If it charges with the original (white) Apple cable I the in-car system is OK.

Try again the iPod Classic with the latest firmware. If the iPod still doesn't charge, maybe your BMW cable has a hardware defect. Don't trust the charging symbols at the iPod's display. Check if the battery symbol has grown after a (long) drive.
__________________
in love with 335d
cisoid is offline  
0
Reply With Quote
      02-12-2008, 11:50 PM   #1002
Kb8jumpman
Second Lieutenant
 
Kb8jumpman's Avatar
 
Drives: 08 E92 328i
Join Date: Apr 2007
Location: Brooklyn, NY

Posts: 253
iTrader: (0)

Garage List
2008 328i E92  [0.00]
Send a message via AIM to Kb8jumpman
Quote:
Originally Posted by cisoid View Post
3G iPod shouldn't work at all. BMW's compatibility list states that only 4G and later iPods are compatible.

Kb8jumpman: Do you have a 3G iPod? What's a 08?
I meant my car is a 2008 if that makes a diff, but my ipod used to work fine for a couple months when i first got my car.
__________________
08 E92 328i Crimson red / Coral Red / Aluminum Trim/ 6MT, Navi w/ I-drive, premium, comfort access, 6FL ipod kit. Blacked out vinyl window trim
Ordered: 8/18
Delivered: 10/12
Kb8jumpman is offline   United_States
0
Reply With Quote
      02-18-2008, 01:29 AM   #1003
adrian1480
Lieutenant
 
adrian1480's Avatar
 
Drives: 2014 435icp
Join Date: Nov 2007
Location: FL

Posts: 407
iTrader: (0)

Send a message via AIM to adrian1480
Quote:
Originally Posted by cisoid View Post
I made the same experience. Hoever, even if the iPod does not show the proper charging symbol it still is charged. I checked this with a nearly empty iPod during a long journey. After a couple of hours the iPod was indeed fully charged.
yep, same here. and with the new 1.1.1 firmware update, I don't have to disconnect it in order to make sure it doesn't run itself down overnight!
__________________
Quote:
Originally Posted by Roosevelt
The credit belongs to those who are actually in the arena, who strive valiantly, who know the great enthusiasms, the great devotions, and spend themselves in a worthy cause; who, at the best, know the triumph of high achievement and who, at the worst, if they fail, fail while daring greatly so that their place shall never be with those cold and timid souls who know neither victory nor defeat.
adrian1480 is offline   United_States
0
Reply With Quote
      02-18-2008, 04:37 AM   #1004
nhalliday
Registered
 
Drives: 335d Coupe & 320d Touring
Join Date: Sep 2007
Location: UK

Posts: 1
iTrader: (0)

I just picked up my new E92, and can't seem to get the 6FL working how I guess it should. If I've been playing music on it, then stop the car, I presume it should then resume once I get back in the car again?

What happens on mine is that when I get back in the car, the whole thing has to start from scratch again. So I have to select artist, scroll through the list, etc. This is a real pain, as I make lots of short journeys of 15 minutes or so. I seem to spend the first half of each journey just sorting out the music!

The car is new (I guess December 07 or January 08 build), I've tried both an iPod Video (5G) and an iPod Classic, both with the latest firmware. The cable is the latest (small, rounded) version.

Any ideas?
nhalliday is offline  
0
Reply With Quote
      02-18-2008, 11:09 AM   #1005
jmonier
Captain
 
Drives: 2007 335i E92, 2002 325i
Join Date: Aug 2006
Location: Torrance, CA

Posts: 812
iTrader: (0)

There's certainly something wrong but I have no idea what it might be. Mine (March 2007 build, old Y-cable) has always done the resume perfectly.
jmonier is offline  
0
Reply With Quote
      02-18-2008, 03:17 PM   #1006
ukbmwuk
New Member
 
Drives: 335i
Join Date: Feb 2008
Location: uk

Posts: 6
iTrader: (0)

For those who do not 6fl but who have aux:

I use a Griffin Autopilot which both charges the ipod and allows a connection to the aux through a dock adaptor.

The Autopilot has play/forward button on the top of the charger stick so if the charger is put into the cigarette lighter where the smokers kit is you can press the top of it to stop/start/forward the ipod without touching the ipod. This way the ipod can stay in the centre console.

Main disadvantage is that you have 2 wires running from the smokers kit cigarette lighter is to the centre console. But you dont need to look at the ipod and might be more safe than being tempted to browse songs through the idrive with the 6fl option.
ukbmwuk is offline  
0
Reply With Quote
      02-19-2008, 09:40 AM   #1007
PrimeTime
New Member
 
Drives: 2008 335xi 6 speed manual
Join Date: Jan 2008
Location: Watertown, MA

Posts: 11
iTrader: (0)

Ipod Question

Taking delivery of a new 335xi today - very excited. But after reading this thread, I was wondering if 6FL was worth ordering.

Anyway, I want to make sure I get the right cable for my 30GB Ipod video - the ipod is about 1 and a half years old. What cable part number should I look for at the dealership? What progman should I have (I assume v27 or higher)?

My car is a January 2008 build. The ipod is running latest firmware version 1.2.3. Again a 30GB ipod that was bought new in the fall of 2006.

Any help is most appreciated. I head to the dealership this afternoon and would like to avoid going back this weekend to get a new cable/ software update.

Thanks.
PrimeTime is offline  
0
Reply With Quote
      02-20-2008, 09:32 AM   #1008
PrimeTime
New Member
 
Drives: 2008 335xi 6 speed manual
Join Date: Jan 2008
Location: Watertown, MA

Posts: 11
iTrader: (0)

Is there a separate manual for 6FL?

Thanks! Trying to get up to speed on the new car, but can't find a manual for 6FL specifically. Maybe the radio manual is all you get?

I had a separate manual for the Ipod when I had my old 325xi.
PrimeTime is offline  
0
Reply With Quote
      02-25-2008, 09:10 PM   #1009
poppyljg
New Member
 
Drives: 2006 325i
Join Date: May 2007
Location: woodland hills

Posts: 23
iTrader: (0)

For those that care, I had a problem with getting a 160gb classic, 80 classic, and a 80gb 5g ipod to work w/ my 6fl. They all worked for about a week then stopped.

Anyway, easy solution! I had too many damn playlist on my itunes. When I started using itunes years ago, I put all my albums in individual playlist of there own. I continued doing this until I recently trusted itunes to properly organize my music.

I have over 14,000 songs, so imagine how many albums that is and how many playlist that was.

So I deleted all those playlist and reorganzed all my music and tested out the ipod in the car. BAAAM!!! It works.

So I guess I proved that the 6fl has a playlist limit. Silly me!
poppyljg is offline  
0
Reply With Quote
      02-25-2008, 10:23 PM   #1010
Haasman
Enlisted Member
 
Drives: 07 335i
Join Date: Jul 2007
Location: San Francisco

Posts: 36
iTrader: (1)

Well now that is interesting ..... I also have over 14k songs .... but how many playlists did you have that were choking it?

Haasman
Haasman is offline  
0
Reply With Quote
      02-26-2008, 12:21 AM   #1011
poppyljg
New Member
 
Drives: 2006 325i
Join Date: May 2007
Location: woodland hills

Posts: 23
iTrader: (0)

I never paid attention to how many playlist I actually had, but I made every single album that I ripped or downloaded into a playlist. I will guess that I had somewhere close to 500 playlist.
poppyljg is offline  
0
Reply With Quote
      02-26-2008, 11:28 AM   #1012
adc
Brigadier General
 
Drives: 2009 E90 M3 ED
Join Date: Sep 2006
Location: MD/DC

Posts: 4,128
iTrader: (6)

Quote:
Originally Posted by poppyljg View Post
For those that care, I had a problem with getting a 160gb classic, 80 classic, and a 80gb 5g ipod to work w/ my 6fl. They all worked for about a week then stopped.

Anyway, easy solution! I had too many damn playlist on my itunes. When I started using itunes years ago, I put all my albums in individual playlist of there own. I continued doing this until I recently trusted itunes to properly organize my music.

I have over 14,000 songs, so imagine how many albums that is and how many playlist that was.

So I deleted all those playlist and reorganzed all my music and tested out the ipod in the car. BAAAM!!! It works.

So I guess I proved that the 6fl has a playlist limit. Silly me!
I don't mean to take anything away from your effort, but I think your problem is still there.

Here is what I think happens. You had the same problem as me, i.e. iPod won't charge. So after you charge it the first time, it works for about 1 week, more or less depending on usage, temperature etc. After the battery is depleted it stops working.

So you take it to your computer, plug it in, and reorganize it drastically. While this happens, it gets charged from the computer's USB connection.

You take it back to the car and bam, it works. I would be very curious if it's still going to work in one week, or two at the most.

Would you please keep us posted?
adc is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:46 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST