E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > *Official* 6FL iPod/USB Thread



Reply
 
Thread Tools Search this Thread
      08-24-2009, 01:05 PM   #1167
Captain Oblivious
My car is for sale
Captain Oblivious's Avatar
United_States
3
Rep
239
Posts

 
Drives: slowly for max fuel economy
Join Date: Jan 2007
Location: Cary, NC

iTrader: (0)

I'm sorry if this is a noob question, but I've tried to look through this thread to find the answer.

I've had my 08 E90 with 6FL for less than a week and haven't had any updates done to it. When I scroll through the artist list on my 80gig iPod video, the names change to numbers, but I can still scroll through them.

I just want to confirm that this is the 'fast scroll.' Thanks.
__________________
2008 E90 335i: Alpine White | Terra | Burl | Sport | Premium | Nav | iPod | Heated Seats - Sold
2004 E46 325ci: | Titanium Silver | Gray | Burl | Sport | 5sp - Sold
Appreciate 0
      08-25-2009, 04:23 PM   #1168
arabbmw
Lieutenant
5
Rep
551
Posts

 
Drives: 335i coupe
Join Date: Nov 2007
Location: G hills

iTrader: (2)

hopefully someone can answer this for me, but sometimes my music will cut in and out or
sound half way on, or it will only play on the right side of the car when my ipod is
connected through the usb/aux of the 6fl system. Ill then have to pull and play with the cable till it goes back to normal.

Is the problem the car, the cable, or the ipod? (ive tried 2 different ipods and same thing)

Just wanted to ask before i go buy a new cable
Appreciate 0
      08-25-2009, 05:06 PM   #1169
jpsimon
Team Zissou
jpsimon's Avatar
United_States
164
Rep
9,017
Posts

 
Drives: 2015 STi
Join Date: Dec 2006
Location: CT

iTrader: (6)

sounds like the cable isn't plugged in all the way, or came a little loose
__________________
2015 STi / 335xi (solid)
www.datazap.me - fast, free, interactive data log viewing

Appreciate 0
      08-25-2009, 05:13 PM   #1170
Tag
Colonel
Tag's Avatar
United_States
113
Rep
2,626
Posts

 
Drives: bimmer
Join Date: Jan 2007
Location: CHICAGO

iTrader: (2)

Quote:
Originally Posted by Captain Oblivious View Post
I'm sorry if this is a noob question, but I've tried to look through this thread to find the answer.

I've had my 08 E90 with 6FL for less than a week and haven't had any updates done to it. When I scroll through the artist list on my 80gig iPod video, the names change to numbers, but I can still scroll through them.

I just want to confirm that this is the 'fast scroll.' Thanks.
That's by design. Once you stop scrolling you should see the names again.
Appreciate 0
      08-25-2009, 05:43 PM   #1171
arabbmw
Lieutenant
5
Rep
551
Posts

 
Drives: 335i coupe
Join Date: Nov 2007
Location: G hills

iTrader: (2)

Quote:
Originally Posted by jpsimon View Post
sounds like the cable isn't plugged in all the way, or came a little loose
you think buying a new cable would be a good place to start? and also, are the ebay alternatives just as good, or do i really have to shove out 50 bucks to bmw?
Appreciate 0
      08-25-2009, 05:54 PM   #1172
zerodb
Private
0
Rep
57
Posts

 
Drives: 2008 E92 335i
Join Date: Aug 2009
Location: Santa Barbara, CA

iTrader: (1)

Could be a bad cable, could be a loose contact in the jack, or could be dust/lint in the jack.

Also, I just got a cable from ebay and it doesn't work right (charges and plays music but no control through the BMW stereo, have to use the ipod manually) - your experience may vary.
Appreciate 0
      08-25-2009, 07:10 PM   #1173
Captain Oblivious
My car is for sale
Captain Oblivious's Avatar
United_States
3
Rep
239
Posts

 
Drives: slowly for max fuel economy
Join Date: Jan 2007
Location: Cary, NC

iTrader: (0)

Quote:
Originally Posted by tag824 View Post
That's by design. Once you stop scrolling you should see the names again.
Right. But is this what people call the 'fast scroll?'
__________________
2008 E90 335i: Alpine White | Terra | Burl | Sport | Premium | Nav | iPod | Heated Seats - Sold
2004 E46 325ci: | Titanium Silver | Gray | Burl | Sport | 5sp - Sold
Appreciate 0
      08-26-2009, 07:39 PM   #1174
arabbmw
Lieutenant
5
Rep
551
Posts

 
Drives: 335i coupe
Join Date: Nov 2007
Location: G hills

iTrader: (2)

Quote:
Originally Posted by zerodb View Post
Could be a bad cable, could be a loose contact in the jack, or could be dust/lint in the jack.

Also, I just got a cable from ebay and it doesn't work right (charges and plays music but no control through the BMW stereo, have to use the ipod manually) - your experience may vary.
which cable did you buy?

Im gonna try an ebay alternative, just wanna make sure i try a different one.
Appreciate 0
      08-26-2009, 08:13 PM   #1175
Tag
Colonel
Tag's Avatar
United_States
113
Rep
2,626
Posts

 
Drives: bimmer
Join Date: Jan 2007
Location: CHICAGO

iTrader: (2)

Quote:
Originally Posted by Captain Oblivious View Post
Right. But is this what people call the 'fast scroll?'
Yes, it is. It use to be extremely slow because it had to display all the names when scrolling. They then changed the interface to show the number instead of name to speed scrolling up until you stop and then the names show. IMO the 6FL is a very disappointing interface to the iPod.
Appreciate 0
      09-04-2009, 09:18 PM   #1176
drivecar
Private
1
Rep
63
Posts

 
Drives: bmw
Join Date: May 2009
Location: us

iTrader: (0)

Quote:
Originally Posted by hifidawg09 View Post
I am using the ycable with a Nano 4th gen ipod 6FL option.
Everything works great.I can control the player and use playlists etc and the battery charges. My only problem is that if I leave it plugged in with the car OFF the battery gets drained in a few hours. I have no idea why this is happening. I understand that the power to the y cable will cut out 20-30 min after the key is out and the car is locked. I have no idea why the darn thing will not go into standby mode after the power is cut. Something is preventing it from going to sleep. Is anyone else having this issue? Maybe its only on the 4th gen Nano. I have firmware 1.04 btw and the BMW has all the latest programming as well. Sucks to have to disconnect the Nano every time or else the battery is going to crap out very soon!
It is a design flaw. The same thing happens if you leave a plain USB flash stick plugged in. May cars' battery died overnight not because the USB stick was drawing enough power to drain the battery, but because the car didn't go to sleep and the car's other internal systems kept drawing power through the night.
I have a USB stick with a LED light that flashes when it's active and it doesn't stop flashing even after the car is turned off.
BMW needs to fix this flaw. It's a hassle to unplug USB every time you park and this isn't a problem on non-BMW vehicles with USB.
It shouldn't be that difficult to set the USB port to power off either instantly with the ignition or better yet after 10 or 15 minutes of the engine being off.
Appreciate 0
      09-16-2009, 01:34 PM   #1177
m635csi
Enlisted Member
0
Rep
40
Posts

 
Drives: 2006 330i
Join Date: Sep 2006
Location: Cal.

iTrader: (0)

Quote:
Originally Posted by drivecar View Post
It is a design flaw. The same thing happens if you leave a plain USB flash stick plugged in. May cars' battery died overnight not because the USB stick was drawing enough power to drain the battery, but because the car didn't go to sleep and the car's other internal systems kept drawing power through the night.
I have a USB stick with a LED light that flashes when it's active and it doesn't stop flashing even after the car is turned off.
BMW needs to fix this flaw. It's a hassle to unplug USB every time you park and this isn't a problem on non-BMW vehicles with USB.
It shouldn't be that difficult to set the USB port to power off either instantly with the ignition or better yet after 10 or 15 minutes of the engine being off.
any fix for this yet?
Appreciate 0
      10-11-2009, 12:59 PM   #1178
Xsapper
Private
Xsapper's Avatar
United Kingdom
1
Rep
72
Posts

 
Drives: M135i
Join Date: Feb 2009
Location: Monmouth, UK

iTrader: (0)

Garage List
2014 M135i  [0.00]
6FL & Ipod connection problems

I have this option in my E90 and tend to leave my ipod connected to the car all the time. The problem is that the car will not pick up the Ipod first thing in the morning. I can try everything but nothing will show. Is my Ipod in deep sleep mode?
Has anyone got a similar issue?
Appreciate 0
      10-11-2009, 05:10 PM   #1179
zerodb
Private
0
Rep
57
Posts

 
Drives: 2008 E92 335i
Join Date: Aug 2009
Location: Santa Barbara, CA

iTrader: (1)

Quote:
Originally Posted by Xsapper View Post
I have this option in my E90 and tend to leave my ipod connected to the car all the time. The problem is that the car will not pick up the Ipod first thing in the morning. I can try everything but nothing will show. Is my Ipod in deep sleep mode?
Has anyone got a similar issue?
will your iPod turn on if it's NOT plugged into the car?

The battery on my 4g iPod video is pretty shot and it behaves this way, the battery is so dead it won't wake up until the car has charged it up for awhile.
Appreciate 0
      10-11-2009, 05:39 PM   #1180
HazChem
Private First Class
United_States
1
Rep
156
Posts

 
Drives: '08 E92 335i
Join Date: Jun 2009
Location: SA, TX

iTrader: (4)

Garage List
2008 335i Coupe  [0.00]
I only have issues with it if I haven't driven it after more than 3 days. When that happens, I have to wait about a minute before it begins playing. At that point, I have to set the playlist that I want to listen to.
Appreciate 0
      10-14-2009, 08:15 AM   #1181
fernande-bmw
Second Lieutenant
United_States
11
Rep
277
Posts

 
Drives: 2010 335i E90 M-Sport
Join Date: Sep 2009
Location: Milwaukee, WI

iTrader: (0)

Question iPod with 6FL option without iDrive?

I read the 50+ pages in this thread, but I haven't found a specific answer to my questions.

I am getting a 2010 335i sedan with the 6FL option (iPod/USB integration) without iDrive. So, I will just control the iPod with the radio buttons.

First, I am trying to find the list of compatible devices with this option, where compatible means the ability to sync _and_ charge the device. I am specifically interested in compatibility with the following iPod models:
  • iPod video 5.5 gen
  • iPod touch 3rd gen

Second, is there a place where I can get the manual for the 6FL option? I want to know about the level of control provided, e.g., playlists, search, shuffle, skip, play, etc.

Finally, I read recently that the audio from the provided Y cable is horrible even though it is coming from the iPod's line out. Can anyone confirm that? If that's the case, what's the value of this option and what alternative is there to get the best quality audio from the iPod?

Thanks!
Appreciate 0
      10-15-2009, 11:59 AM   #1182
danniexi
Colonel
danniexi's Avatar
South Korea
30
Rep
2,091
Posts

 
Drives: 2008 AW E92 335xi
Join Date: May 2008
Location: NJ

iTrader: (14)

6fl has been frustrating me.

A few months back, my 6fl crapped out on me. I have the cable, it played fine on my car, and i had the songs on my idrive with no issues.

One day, my ipod was connected (charging), but nothing was loading to my idrive. A message shows up saying "loading data..." but nothing ever happens.

I took it to the dealer, the replaced the part, and told me that they connected another ipod and it was working fine. I got the car back yesterday and tried connecting my ipod again and it didn't work. The same issue happens again... "loading data..." message shows up and simply freezes there.

I tried both on my first gen ipod touch and iphone 3g.
Appreciate 0
      11-16-2009, 08:02 AM   #1183
yromulus
Registered
0
Rep
3
Posts

 
Drives: 2009 E92 M-Sport Space Grey
Join Date: Nov 2009
Location: Bucks, UK

iTrader: (0)

Just for info:

I have a UK 2009 E92 with the 6FL option.

Being a cheapskate I tried getting a cable off the internet and it didn't work - the IPhone 3GS never appeared on the iDrive. So I swallowed my pride and bought the official BMW lead (a bit of a rip-off IMHO). According to the parts man at the garage they've only ever had one type of cable and he told me up front it would NOT charge the 3GS. He was right. It plays fine but runs down if you do anything silly like listen to the IPhone and take calls on a drive longer than an hour or so...

So, I went back onto the internet and bought one of these:

http://cgi.ebay.com/ws/eBayISAPI.dll...m=270445089743

This now allows the IPhone to charge so I'm happy. Although heaven knows why some people get theirs charging without any help and some don't. Seems bizarre.
Appreciate 0
      11-21-2009, 08:35 PM   #1184
CrunchTime
Private
0
Rep
67
Posts

 
Drives: 335xi e90 / 535xi F10
Join Date: May 2009
Location: Markham, Canada

iTrader: (5)

I just took delivery of my 09 335i today and was given a Y-cable with part #61-12-0-440-796. But it does not charge my iphone 3GS. My wife's iphone 2G charges fine. I also have a Scoche Passport adapter which works for charing the 3GS on my last car, but does not work on the BMW. I spent an hour reading this thread. Could not find a definite answer. For some people with Y-cable of the same part #, their iphone 3G/3GS charge fine. Some people seem have be out of luck like me. Please help... Thanks!
Appreciate 0
      12-10-2009, 10:15 PM   #1185
zivyn
First Lieutenant
4
Rep
342
Posts

 
Drives: for enjoyment
Join Date: Nov 2009
Location: West coast transplant

iTrader: (12)

Quote:
Originally Posted by drivecar View Post
It is a design flaw. The same thing happens if you leave a plain USB flash stick plugged in. May cars' battery died overnight not because the USB stick was drawing enough power to drain the battery, but because the car didn't go to sleep and the car's other internal systems kept drawing power through the night.
I have a USB stick with a LED light that flashes when it's active and it doesn't stop flashing even after the car is turned off.
BMW needs to fix this flaw. It's a hassle to unplug USB every time you park and this isn't a problem on non-BMW vehicles with USB.
It shouldn't be that difficult to set the USB port to power off either instantly with the ignition or better yet after 10 or 15 minutes of the engine being off.
Sorry for the long quote, but figured context was important. Anyone found a fix for this yet? Software or otherwise, whatever works really.

I emailed BMW tech support via the website and after two days of back and forth over basic info they sent a blanket email that basically stated "all our technical info with with the dealer, please contact your local service department for technical questions." which was pretty disappointing. I was kinda hoping some simple firmware update could be put out, doesn't seem like an unreasonable request.

Didn't find anything (not that I expected to) when looking for a USB cable with power toggle on google.

I know the above poster said the plugged in flash drive killed his battery. Has anyone else had this happen? I feel like an iPod shouldn't draw enough to kill a battery over a day or two, but if it prevents other parts of the car from going to sleep who knows.
Appreciate 0
      12-13-2009, 04:32 PM   #1186
listerone
First Lieutenant
United_States
3
Rep
327
Posts

 
Drives: 2014 BMW 328d
Join Date: Jul 2009
Location: Connecticut

iTrader: (0)

Quote:
Originally Posted by drivecar View Post
May cars' battery died overnight not because the USB stick was drawing enough power to drain the battery, but because the car didn't go to sleep and the car's other internal systems kept drawing power through the night.I have a USB stick with a LED light that flashes when it's active and it doesn't stop flashing even after the car is turned off.
What year and model do you drive? Thanks to this thread I've just discovered the "USB drive connected via 6FL" thing and was looking forward to having a 16MB chip permenently connected in the center armrest.
__________________
Currently: 2014 328d / Mineral Grey Metallic / Nav
Formerly: 2011 MB E350 Bluetec / Nav / Distronic
Formerly: 2009 335d / Monaco Blue / Beige Dakota Leather / iDrive / Nav / Xenon / Sirius / HD Radio
Appreciate 0
      12-13-2009, 10:51 PM   #1187
Ron1n
Speed Demon
Ron1n's Avatar
United_States
59
Rep
3,248
Posts

 
Drives: '10 335d E90
Join Date: Oct 2009
Location: The 858

iTrader: (4)

Garage List
2010 335d  [5.00]
Just FYI. Picked up my car yesterday and hooked up my iPhone (3GS). I got the "This accessory was not designed for this phone" thing, clicked No (so that I didn't put the phone in Airplane mode), and it charges and plays through fine. Don't like the shortness of the cable, though..quite a pita if I need to see something on my phone, because I then need to open up my armrest and uncomfortably angle to see what's on the phone.

Quote:
Originally Posted by arabbmw View Post
hopefully someone can answer this for me, but sometimes my music will cut in and out or
sound half way on, or it will only play on the right side of the car when my ipod is
connected through the usb/aux of the 6fl system. Ill then have to pull and play with the cable till it goes back to normal.

Is the problem the car, the cable, or the ipod? (ive tried 2 different ipods and same thing)

Just wanted to ask before i go buy a new cable
It's the Aux cable...jiggle it around until full sound comes back...that's been my experience, anyway.

Quote:
Originally Posted by listerone View Post
What year and model do you drive? Thanks to this thread I've just discovered the "USB drive connected via 6FL" thing and was looking forward to having a 16MB chip permenently connected in the center armrest.
Problem with that is that now you've got no place to charge your phone (unless in the '09s, you still have an actual ashtray).
__________________
Appreciate 0
      02-16-2010, 10:29 PM   #1188
mimiandi
Private First Class
2
Rep
168
Posts

 
Drives: 2009 323i
Join Date: Sep 2009
Location: Vancouver

iTrader: (0)

Garage List
2009 323i  [0.00]
6FL retrofit

Guys,

Going through usb retrofit pdf, i see mention of 620, voice control, 640 phone prep, 644 mobile phone with bluetooth, and 609 navi but no mention of car with 639 which is complete phone setup (Telematics ; Cellular phone preparation; Wireless connection Bluetooth; Cellular phone Bluetooth; Online information system ).

I want to figure out what is it that i need to purchase .... usb retrofit cable and something more?

Would appreciate it if someone can shed some light... i have 2009 323i.

thx
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:22 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST