E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > auto transmission hard down shift



Reply
 
Thread Tools Search this Thread
      01-23-2011, 01:53 PM   #1
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

auto transmission hard down shift

bmw has tried to fix my transmission and its under warranty, it was shifting hard going up from gears 1-3 and then when i stopped completely the car would jolt from 2nd to 1st. i took it in and they said they fixed the problem. (they just reset the car)
I drove my car off the lot and for the next week it was all fine. but now my car is starting to do the same thinks again. and its slowly getting worse.

any idea what it could be? the car is going back to the dealer tomorrow.
and what happens if they cant fix it?
chaosticbry is offline  
0
Reply With Quote
      01-23-2011, 07:53 PM   #2
suong
New Member
 
suong's Avatar
 
Drives: 325xi
Join Date: May 2009
Location: canada

Posts: 11
iTrader: (0)

I have the same problem ( its like some one bump you from behind)
from what i've heard there's a transmission software update for it...
suong is offline  
0
Reply With Quote
      01-23-2011, 08:46 PM   #3
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
It's the torque converter engaging/disengaging....it's still there with the new software update but it did improve. You can have Nuetral idle control (NIC) coded out but it will increase gas mileage.
fdriller9 is offline   United_States
0
Reply With Quote
      01-25-2011, 02:18 PM   #4
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

update: ok so the dealer took another look at the car, and they found nothing, they went on a test drive with me and they pointed out the problem before i even had a chance to point it out, he said it was deffinently not normal. any way they sent an email to bmw na and they opend a case. they r now in the process of trying to fid out whats wrong. bmw told them to disengaging then re-engaging the torque converter and report.
chaosticbry is offline  
0
Reply With Quote
      01-25-2011, 02:22 PM   #5
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

Quote:
Originally Posted by suong View Post
I have the same problem ( its like some one bump you from behind)
from what i've heard there's a transmission software update for it...
yep thats what it is, somtimes more noticavble then others but it happens at every stop. and i have the latest software
chaosticbry is offline  
0
Reply With Quote
      02-05-2011, 03:34 PM   #6
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

update again: im sick of BMW! ok so last week, my car was at the dealer for the second time in 2 weeks 4 the same problem and they called me saying they need to keep my car and said they had a loaner car waiting 4 me, i get dropped of at the dearer from a friend and wait about 15-20 min then they say im 2 young 4 a loner and if i need a ride home... i tell them i live 2 far (30min away) and they ask if i can get a ride home... i tell them i have no way 2 get home, so they say ok we will give u an enterprise rental... because im under 21 they need to call and double check i have insurance because reading my insurance card that shows my policy is not enough. but wait because i have insurance through a government agency (civil service employees) they r closed after 5pm. so now about 35min later they don't know what to do and they want to go home because there are almost closed . they tell me there going to give me my car back tonight, and i will have to bring it back ASAP in the morning. i agree. the next day i drop my car off at 9:30am they give me a enterprise rental i call back around 4 to see where my car is at, and they tell me its done.
when i get there they said they fixed the problem, and tell me to pay the $50 deductible, i refuse because this is the same problem they said they fixed last week and i was told i would not have 2 pay it. and go talk 2 my adviser. long story short he says i don't have 2 pay it, i get my car and its fine for a week, now the PROBLEM IS BACK!!! i really dont think they fixed it, they just covered it up and hoped i wouldn't notice. im tired of going back and forth to the dealer, its a waits of time and money!

i made another appointment for Tuesday, that's the soonest they had

what should i do? im tired of this
chaosticbry is offline  
0
Reply With Quote
      02-05-2011, 04:49 PM   #7
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

please
chaosticbry is offline  
0
Reply With Quote
      02-05-2011, 05:05 PM   #8
Verbatim
Colonel
 
Verbatim's Avatar
 
Drives: 2008 335i
Join Date: Sep 2010
Location: at the repair shop

Posts: 2,555
iTrader: (0)

Garage List
2008 BMW 335i  [5.00]
You have a nice dealership. I wouldn't be complaining. The fact that they pointed out the problem and admitted it before you pointed it out goes to show that they care.
Its a known fact that <21 year olds don't get rental cars period.
Next time you go, take your parents or a friend, or manage a ride home. I know it sounds like crap, but you don't have a choice. I have the same problem as you, maybe have your parents take the car in instead.
__________________

2008 BMW 335i Sedan | Sparkling Graphite | Sport | Premium | Navigation | Comfort Access | Logic7
Golf Tee | M3 Spoiler | LED Angel Eyes | 5000k Fogs | Resonator Delete | Black Kidney Grills | Black Finisher Rods | 35%/18% Tint |12mm/20mm (F/R) Spacers | Black Lines


Verbatim is offline   United_States
0
Reply With Quote
      02-05-2011, 05:27 PM   #9
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

i do have a nice dealership there are 2 other dealership about 15 min closer but i chose to go to this one because they do provide great service! im sorry if i came off as complaining about my dealer. i didn't try. they treat me very well for being under 21. im just tired of having to keep going back to the dealer for a repair they cant seem to fix. i know its not there fault they told me the car looks fine, and no problems is showing up on the computer but they said there is clearly something wrong. im just trying to get an idea of what i should expect from bmw na or somthing along those lines.. and would my car be considered a lemon if they cant fix it on the third try?
chaosticbry is offline  
0
Reply With Quote
      02-05-2011, 05:47 PM   #10
hipnotic
Major General
 
hipnotic's Avatar
 
Drives: e92 335i
Join Date: Oct 2007
Location: So. Cal

Posts: 6,557
iTrader: (6)

Garage List
2008 335i coupe  [3.50]
my car does the same
hipnotic is offline   United_States
0
Reply With Quote
      02-05-2011, 05:54 PM   #11
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

Quote:
Originally Posted by josh06lau View Post
my car does the same
doesn't it bug u? i hate sudden jolts when im slowing down to a stop
chaosticbry is offline  
0
Reply With Quote
      02-05-2011, 06:06 PM   #12
Dvdman
Captain
 
Dvdman's Avatar
 
Drives: 2008 BMW 335 XI
Join Date: Aug 2009
Location: Chicago, IL

Posts: 905
iTrader: (2)

Keep bringing it back....
Dvdman is offline  
0
Reply With Quote
      02-05-2011, 06:32 PM   #13
Zulu Saffa
New Member
 
Zulu Saffa's Avatar
 
Drives: 2007 E92 335i
Join Date: Feb 2011
Location: Orange County

Posts: 17
iTrader: (1)

Depending on when you bought it and what year it is, you might be able to use the "lemon" law.
Zulu Saffa is offline  
0
Reply With Quote
      02-05-2011, 07:59 PM   #14
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by Zulu Saffa View Post
Depending on when you bought it and what year it is, you might be able to use the "lemon" law.
I doubt that....it's a feature of the car to do this.

It was poorly implemented but that doesn't make it a lemon.
fdriller9 is offline   United_States
0
Reply With Quote
      02-06-2011, 01:01 AM   #15
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

Quote:
Originally Posted by ********* View Post
I doubt that....it's a feature of the car to do this.

It was poorly implemented but that doesn't make it a lemon.
then why does the master mechanic even say that it shouldn't do that/ its not normal.
chaosticbry is offline  
0
Reply With Quote
      02-06-2011, 01:07 AM   #16
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Im saying the NIC is a feature of the car. Not the jolt you experience when it disengages/engages.

My car jolts sometimes too but it's not that bad...it's really only when the car isnt warmed up.

I have the newest software on my car.
fdriller9 is offline   United_States
0
Reply With Quote
      02-11-2011, 04:26 PM   #17
chaosticbry
Private
 
Drives: 325i
Join Date: Sep 2010
Location: the IE

Posts: 63
iTrader: (0)

ok, so my dealer was told by bmw to replace my transmission, good thing my cars still under warranty.
chaosticbry is offline  
0
Reply With Quote
      03-02-2011, 03:04 PM   #18
WangTa
First Lieutenant
 
WangTa's Avatar
 
Drives: '08 SSII E90 M3
Join Date: Feb 2008
Location: Maryland

Posts: 308
iTrader: (0)

Send a message via AIM to WangTa Send a message via MSN to WangTa
Quote:
Originally Posted by ********* View Post
Im saying the NIC is a feature of the car. Not the jolt you experience when it disengages/engages.

My car jolts sometimes too but it's not that bad...it's really only when the car isnt warmed up.

I have the newest software on my car.
This is a newb question, but how do you check what version of the software you have installed?
WangTa is offline   United_States
0
Reply With Quote
      03-02-2011, 07:09 PM   #19
sk8board511
Captain
 
sk8board511's Avatar
 
Drives: 07 E90-Bikes on bikes on bikes
Join Date: Feb 2010
Location: Charlotte NC

Posts: 686
iTrader: (0)

Quote:
Originally Posted by WangTa View Post
This is a newb question, but how do you check what version of the software you have installed?
it written on the dipstick....sorry i had to
__________________
KING"ish" OF Changed for collins
sk8board511 is offline   United_States
0
Reply With Quote
      04-22-2012, 10:54 AM   #20
zigsman
Private
 
Drives: 2006 330i E90
Join Date: Jan 2012
Location: Arizona

Posts: 78
iTrader: (0)

I have the fix

I know it's a bit late on this post, but I believe I have the fix. I was having the same issue with my auto tranny...it almost felt like I was getting rear-ended as I was coming to a stop...that is how hard it jolted. I replaced the mechatronics seal adapter in the transmission 3 weeks ago and have not experienced this issue since. Don't confuse this with the "sleeve", the mechatronics seal adapter is located at the top of the valve body and sits between it and the body of the transmission. You will need to drop the pan/filter and remove the mechatronics to get to it. It is a very simple task...just do your tranny service with this along with the sealing sleeve as well. The mechatronics adapter is about $10 and the sealing sleeve is about $17 (it is known to leak).

Here is a great website for transmission parts:
http://www.thectsc.com/

Here are the links for the parts for this fix:

Mechatronics Seal Adapter
http://www.thectsc.com/index.php?p=p...d=44&parent=45

Follow this task to replace the adapter:
http://www.zftranspart.com/images/custom/mecha.pdf

Sealing Sleeve
http://www.thectsc.com/index.php?p=p...id=3&parent=10

Sleeve Replacement Task:
http://www.thectsc.com/images/pdf/6_...eplacement.pdf




UPDATE!!

After a few months of driving I have found the "bump" came back! So, just replacing the parts I listed above did NOT fix the problem. I did finally get it fixed though. I ended up replacing all of the solenoids in the mechatronics which has fixed the problem permanently. Here is a link to the kit:

http://www.thectsc.com/index.php?p=p...d=36&parent=52

Right now it is on sale for $455 dollars. The kit comes with instructions...it is really simple. Once you have the mechatronics removed, you separate the plastic piece from the body and the release a retaining plate. The solenoids then just pop in and out easily. Make sure you get the correct kit for your transmission, the link above is for the 6H19/26/32 M-Shift. You may have to pull your mechatronics out first to visually verify which model you have.

PM me if you have any questions.

Last edited by zigsman; 12-05-2012 at 04:26 PM.
zigsman is offline  
0
Reply With Quote
      05-31-2012, 10:02 PM   #21
Helmsdini
New Member
 
Drives: 2008 328i sport
Join Date: Sep 2011
Location: Richmond, IN

Posts: 25
iTrader: (0)

Quote:
Originally Posted by zigsman View Post
I know it's a bit late on this post, but I believe I have the fix. I was having the same issue with my auto tranny...it almost felt like I was getting rear-ended as I was coming to a stop...that is how hard it jolted. I replaced the mechatronics seal adapter in the transmission 3 weeks ago and have not experienced this issue since. Don't confuse this with the "sleeve", the mechatronics seal adapter is located at the top of the valve body and sits between it and the body of the transmission. You will need to drop the pan/filter and remove the mechatronics to get to it. It is a very simple task...just do your tranny service with this along with the sealing sleeve as well. The mechatronics adapter is about $10 and the sealing sleeve is about $17 (it is known to leak).

Here is a great website for transmission parts:
http://www.thectsc.com/

Here are the links for the parts for this fix:

Mechatronics Seal Adapter
http://www.thectsc.com/index.php?p=p...d=44&parent=45

Follow this task to replace the adapter:
http://www.zftranspart.com/images/custom/mecha.pdf

Sealing Sleeve
http://www.thectsc.com/index.php?p=p...id=3&parent=10

Sleeve Replacement Task:
http://www.thectsc.com/images/pdf/6_...eplacement.pdf


PM me if you have any questions.
Very informative... Has this solved your problems, or have they returned? I had a horrible up shift develop that would sporadically cause a hard jerk up shifting, and sometimes a clunk at nearly a dead stop. I had my DME updated last week and the up shifts are now perfect, but when downshifting at about 30 mph I get a noticable jerk now and the car seems to slow aggressively, as if it has downshifted too early. I don't remember having this issue until the DME "learned" the shift points after the update. I tried to reset the shift memory but it didn't work... Next step might be to try this seal if it did the trick for you.
Helmsdini is offline  
0
Reply With Quote
      05-31-2012, 11:18 PM   #22
Want
Panty
 
Want's Avatar
 
Drives: A Monaco Blue
Join Date: Aug 2010
Location: Vancouver

Posts: 355
iTrader: (0)

im in the same boat, 328i, automatic, 07. my car developed a rough upshift from 2-3, i mean really rough. I don't experience the jerk when i stop though.

when i took it in my dealership was useless, they checked everything, reprogrammed the car and changed the ATF. and then they were puzzled, the foreman basically said "well maybe they all do it". in the end i got annoyed at them and thought maybe i can live with it.

1.5years later and the problem has become extremely irritating, so I took it into a different dealership. they were immediately helpful but they had to jump through the hoops, check everything, update to 2012 version, etc. After they were done the foreman took it for test drive and acknowledged that the problem is still there. So now my SA tells me they're trying to get BMW to approve a new transmission or something along those lines.

I just have one problem, when i first took my car in it was under full warranty, now it only has CPO and certain things arent covered (programming one of them) - but there is no way im paying bmw 1cent because of the incompetence of the previous dealership.

Its safe to say this is the last AT i buy.
__________________
mbmbmbmbmbmbmb
Want is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:44 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST