E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY Powered seat retrofit (WIP)



Comment
 
Tutorial Tools Search this Tutorial
woodpecka's Avatar
woodpecka
01-24-2011
This topic was a WIP research about how to do the electric seats retrofit. We discovered there are so many car configurations that it's impossible to do 1 guide for all. So, we prefer to share our notes and you must do your own research to validate your car and seats FROM -> TO configs.
...
  #44  
By woodpecka on 02-06-2011, 04:51 PM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
Great news!

Few questions:
So you didn't need to code your car to get the memory function!?

Why did you kept your old airbag?

For the K_CAN issue, maybe the car is not sending any power if the module is not responding. (By the K_CAN if you have a memory module) Great to know.

How have you wired the driver seat to the IDrive controller? (wiring path)
Reply With Quote
  #45  
By dasammy on 02-06-2011, 05:23 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
No ... I didnt code my car yet and memory is working. BUT it isnt working with the key ... just with the buttons on the side of the seat.
After coding this is possible I think ... there should also be a menu in the display after that (for cars with navi).

I kept the airbags, because I bought the seats without airbags.

Yes ... that was my thought too .. but side-bolsters and lumbar were working! So power came from the car.
I think the seat module is checking connections if more pins, than just the power supply are connected. If it cant find everything needed (e.g. the K_CAN) it gives no power to the actuators. If just the Power is connected to the seat module it wont check it ... maybe its like a function to check the module and actuators in the factory ...


I connected the green wire to the green wire and the green/yellow one to the green/yellow ... its no big deal
Reply With Quote
  #46  
By woodpecka on 02-06-2011, 05:35 PM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
Are you planning doing your own coding? I have an idea but not sure about how to do it.

My question about the wiring path is to see where/how the wiring is joining the center console.
Reply With Quote
  #47  
By dasammy on 02-06-2011, 05:51 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
No, I dont know how to do the coding ...

I linked the cable under the "carpet" where the original harness comes out and put it up to the middle console in direction to the gear shift.
Then to the controller
Reply With Quote
  #48  
By woodpecka on 02-06-2011, 07:46 PM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
There is a lot information about coding here: http://www.e90post.com/forums/showthread.php?t=451145

When my seats will be installed, I will look at the VO parameters to see how I can activate it.
Reply With Quote
  #49  
By AoshichanX on 02-08-2011, 11:53 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Congrats DSammy on your retrofit!! =]


I made a FAQ for coding, it should help you get started =]
Reply With Quote
  #50  
By woodpecka on 02-08-2011, 10:14 PM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
Quote:
Originally Posted by AoshichanX View Post
Congrats DSammy on your retrofit!! =]


I made a FAQ for coding, it should help you get started =]
We will have to test different VO parameter.

After a quick search, I jave found these 2 values that could activate the memory:

DOORLOCKING _ SEATMEMORY or SITZMEMORY _ FAHRER

Thanks for your FAQ
Reply With Quote
  #51  
By dasammy on 02-09-2011, 02:35 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Here are the new plans

One Remark: My seat-heating-modules were powered by Pin9 ... thats a bit strange, because its nowhere in the WDS. Just FYI

First one is drivers side
Second one passenger side

Thx AoshichanX for your FAQ, but I think thats a little bit too risky for me (or isnt it??). I will let it do someone whos expert in coding. You are not planning to travel to Germany within the next few days ?
Attached Images
  
Last edited by dasammy; 02-09-2011 at 02:46 AM.
Reply With Quote
  #52  
By woodpecka on 02-09-2011, 10:04 AM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
Good work!

I hope you enjoy your new seats.
Reply With Quote
  #53  
By AoshichanX on 02-09-2011, 01:48 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by dasammy View Post
Here are the new plans

One Remark: My seat-heating-modules were powered by Pin9 ... thats a bit strange, because its nowhere in the WDS. Just FYI

First one is drivers side
Second one passenger side
Wow those diagrams are PURE GOLD!!! I'm gonna have to check my harness again. Thanks SO much =]


If I don't have Pin 7, you think I can just take out pin 6 and put it in pin 7?
Reply With Quote
  #54  
By dasammy on 02-09-2011, 04:27 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Hi AoshichanX!

Thanks for the flowers ... you're welcome

Is Pin7 missing in the connector of the seats, or the car?
I see no sense in switching Pins this way. What are you trying to achieve?

Would be nice if you could give me a bit more information.

woodpecka:

Yes, I really do ... they are so much better than the old ones
Hope you will be successfull too!

greetings!
Reply With Quote
  #55  
By dasammy on 02-12-2011, 07:34 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Hey woodpecka,

any news?

greetings!
Reply With Quote
  #56  
By woodpecka on 02-12-2011, 10:31 AM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
Tomorrow is the day!

My plan is to connect it on the radio.
Reply With Quote
  #57  
By dasammy on 02-12-2011, 02:49 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Okay! So, good luck!

Maybe you take some pictures?!
I also think that connecting it on the radio would be the best solution in your case.

Greetings!
Reply With Quote
  #58  
By woodpecka on 02-13-2011, 03:11 PM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
My passenger seat is installed and work well, exepting an airbag light. I don't know if the seat is wrong ir if it's normal.

Did you had this issue? (Have you start the car with only 1 sport seat?)
Reply With Quote
  #59  
By dasammy on 02-13-2011, 06:01 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Ok ... so congratulations to your part success

Have you waited about 10min. after disconnecting the barterie before disconnecting the connector?
The airbag error ocures sometimes if you dont wait long enough!
Greetings!
Reply With Quote
  #60  
By woodpecka on 02-13-2011, 10:28 PM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
I have disconnected the battery first but maybe haven't wait enough longer. Maybe it's cause by the seat disconnected too early. I will try to reset the error code.
The strange thing is that I get a seat belt alarm too with no tone. If I or the passenger disconnect his seat belt, I get the error tone after 30 sec. It's maybe related to the same issue.

[edit] I did a search and found that these warnings are often coming together.



I ordered the wrong connector so I haven't been able to connect the K_CAN. When I connect the battery, I can use the seat motors for around 15min but after the driver seat positions stop working. It looks like the issue you had and it could explain why you have been able to test the seats.
-Can you give me the right connector for the K_CAN wires?
(Is it: Socket terminal MQS 0.2-0.35 MM˛/SN 61131383776 ?)
Last edited by woodpecka; 02-13-2011 at 11:17 PM.
Reply With Quote
  #61  
By dasammy on 02-14-2011, 06:59 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Yes that could be possible.
Another reason could be, that the airbags (or the car) have to be recoded. I think I read something like this in a German Forum.

I also think that the airbag error and the seat belt error belong together.

Hmm ... thats a bit strange. Have you connected your seats to Terminal 30 or Terminal 30G?
Sorry, but I cant tell you the part number of the connectors. I used red mini-connectors from a local hardware store.
they looked like this one:

http://www.mindfactory.de/images/pro...0__7796001.jpg

they are for small diameters

greetings!
Reply With Quote
  #62  
By woodpecka on 02-14-2011, 07:48 AM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
Both seat get the power, as the driver seat lumber/side bolsters are working and the passenger seat if fully working (including the child airbag-off detection).

I will try to remove the warning first and see if it come back.

For the connector, I want to know which female socket you used in pin #2 / #3 of plug x275.
Last edited by woodpecka; 02-18-2011 at 11:42 PM.
Reply With Quote
  #63  
By dasammy on 02-14-2011, 08:00 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Oh ... Okay I didn't know what you wanted to say

I didnt use a female socket. I grabed Pin #2 / #3 directly from the seats harness and soldered new wires to the wires of #2 / #3 on both sides. After that, I soldered the wires from each side together and connected them with the mini connector to the iDrive controller. I hope you understood my explanations

greetings
Reply With Quote
  #64  
By woodpecka on 02-19-2011, 02:58 PM
Member reviews
Difficulty [ 1 = Difficult ]
80%80%80%
4
Cost [ 1 = Expensive ]
60%60%60%
3
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 53%
I have connected the driver seat on the K_CAN and all works fine! (positions, heating, lumbar, bolster and memory)

I still need the CAN cable to remove the airbag warning.

To connect the K_CAN, I confirm the connector:
Socket terminal MQS 0.2-0.35 MM˛/SN 61131383776
(I had some difficulties to connect them because my wiring was too big for the holes)
Reply With Quote
  #65  
By dasammy on 02-19-2011, 03:28 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
congratulations woodpecka!!

Reply With Quote
Comment

Bookmarks

Tutorial Tools Search this Tutorial
Search this Tutorial:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:19 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST