E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Canada > Why BMW sucks!



Reply
 
Thread Tools Search this Thread
      01-30-2011, 08:43 PM   #23
Nash335
First Lieutenant
 
Nash335's Avatar
 
Drives: 2010 BMW 335i MSport
Join Date: Apr 2010
Location: Toronto

Posts: 360
iTrader: (0)

contact better business bureau if your really ticked. First id say to contact with senior management see if they have a solution for you. Good Luck - I've always have problems with bmw of sauga
__________________
Nash335 - 2010 335i e92 MSport 19" Style 225 BMW Performance Black Grills H&R Spacers Michelin PSS KW V2 Afe DCI + Scoops AR Design DP Active FMIC Active Custom CP Active BOV BMS OCC Spec Stage 3+ Aquamist HPS4 + Howerton 2 Cobb Custom PTF Tune 500 HP Club!
Nash335 is offline   Canada
0
Reply With Quote
      01-31-2011, 06:29 AM   #24
shagkie
Captain
 
shagkie's Avatar
 
Drives: a....V8
Join Date: Dec 2008
Location: GTA, Canada

Posts: 628
iTrader: (0)

Holy shit, how come this sound just like what I went through couple years back. Was this dealer Town and Country? The difference was that my 330ci had all it's electronics shutdown and I brought it in and they didn't know what was going on then they try this and try that and they claimed that it was my aftermarket CD changer that "might" have cause the problem. They can't explain exactly what the problem was. They charged me $400.

Quote:
Originally Posted by PHR View Post
so, i took my car into the dealership due to a noise coming from the engine. The noise sounded like a rattle, which came when the engine was at about 1200rpm.
The dealer kept my car for 3 days, and than called me and said that they were going to replace my turbos, and that the noise was coming from them. So, since my car is all under wanrtey, i said ok.

Tuesday night, i picked up my car, after the turbos had been replaced, drove home, and the noise was gone, car was running smooth, i was happy.

next morning(wednesday)... i start my car, let it warm up, for a good 15 minutes, and than took off, and about 15 minutes of driving later, check engine light pops up on the dash, and the Idrive has a message... it has a picture with a car on the hoist and it was red, and beside it it sais "Electronic Falut: Don't drive vehicle, please stop carefully. Contact nearest BMW dealer" and when i called them they told me they did not know what was worng, and that if i could, to bring it in. and once i took it in, after a hour of waiting, while they scanned my car, they told me they still don't know whats wrong, and that they would call me when they find out, so they got me a courtesy vehicle, and i was on my way.

Yesterday (thrusday) they call me to tell me that they "think" the problem is coming from the aftermarket subwoofer/amplifier i had installed, and that i should have it removed so they can rescan the car. i asked the service advisor to ask the mechanic if their was any way they could rescan the car, without me goign through the inconveince of coming back and forth and getting it all removed, and the service advisor told me that they would ask the mechanic and call me back, so i waited all day to receive no call.

This monring(friday) i called BMW again, and they told me they removed my system(with no authorization from me) and that they still are not sure if thats what was causing the problem...and ontop of that.. i have to pay $500 for the work they have performed (which i never asked them to perform).

the car is a 2009 335i coupe 6 speed

and so far its had 5 HPFP replacements
a full turbo kit replacement
and now a problem they dont know of

anybody have any ideas what could be the problem?
shagkie is offline  
0
Reply With Quote
      01-31-2011, 12:17 PM   #25
mathu.bala
First Lieutenant
 
mathu.bala's Avatar
 
Drives: 2009 323i/6mt
Join Date: Aug 2009
Location: Kirkland, WA

Posts: 330
iTrader: (0)

Garage List
2009 LCI 323i  [0.00]
Quote:
Originally Posted by Leaker

Youre an idiot.
Not as much as you are. If you are willing to give away $500 for removal of amp without permission by all means do it.
__________________
2009 323i Titanium Silver Metallic: Premium Pkg(Heated SW, Bluetooth, Sunroof), USB
MFD Scoop,SWS-8,JL M6450
mathu.bala is offline   Canada
0
Reply With Quote
      01-31-2011, 12:44 PM   #26
matrix76
Major
 
matrix76's Avatar
 
Drives: 2011 E90 328i xDrive Ex/Ps
Join Date: Sep 2009
Location: The West Coast, BC

Posts: 1,300
iTrader: (1)

Quote:
Originally Posted by mathu.bala View Post
that is fd up...dealers are assholes in general especially the BMW ones.

Quote:
Originally Posted by Leaker View Post
Youre an idiot.
+1, An absolute idiot for sure.

Quote:
Originally Posted by mathu.bala View Post
Not as much as you are. If you are willing to give away $500 for removal of amp without permission by all means do it.

, , and he only gets worse, gives new meaning to "Hoof In Mouth Disease" ,


PHR , Sorry to hear about your problem, hope it gets resolved soon, keep us updated.
__________________
Brian
Black Sapphire, Black w/Burrwood Trim & Shifter, 162's, Mtec H8 AE's, DS1 HID 6000K


Last edited by matrix76; 02-01-2011 at 12:38 AM.
matrix76 is offline   Canada
0
Reply With Quote
      01-31-2011, 01:10 PM   #27
335BBS
Brigadier General
 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

Posts: 3,607
iTrader: (0)

Quote:
Originally Posted by Leaker View Post
Lemon law might apply here. I'd push them.

Youre an idiot.

Exactly. It may well be that your after market audio guy screwed up.
Quote:
Originally Posted by mathu.bala View Post
Not as much as you are. If you are willing to give away $500 for removal of amp without permission by all means do it.
If you read what I was responding to you will see that he calls all Dealers assholes...especially BMW dealers. Thats a moronic uneducated statement.
335BBS is offline   Canada
0
Reply With Quote
      01-31-2011, 03:05 PM   #28
clairvoyant
Major
 
clairvoyant's Avatar
 
Drives: Bavarian Manure Wagon (BMW)
Join Date: Oct 2007
Location: 4519′20″N, 7550′0″W

Posts: 1,033
iTrader: (5)

Garage List
2007 335i  [2.62]
Lightbulb

Generally speaking, I stay away from dealers belong to Quinn Automotive Group.
clairvoyant is offline   No_Country
0
Reply With Quote
      01-31-2011, 03:25 PM   #29
matrix76
Major
 
matrix76's Avatar
 
Drives: 2011 E90 328i xDrive Ex/Ps
Join Date: Sep 2009
Location: The West Coast, BC

Posts: 1,300
iTrader: (1)

Quote:
Originally Posted by Leaker View Post
If you read what I was responding to you will see that he calls all Dealers assholes...especially BMW dealers. Thats a moronic uneducated statement.
Wow, +1 again, 2 for "Leaker" and 0 for "mathu.bala"

, , ,
__________________
Brian
Black Sapphire, Black w/Burrwood Trim & Shifter, 162's, Mtec H8 AE's, DS1 HID 6000K

matrix76 is offline   Canada
0
Reply With Quote
      01-31-2011, 03:34 PM   #30
PHR
phr
 
Drives: F32 435I M Retired:335I M
Join Date: Dec 2009
Location: Toronto

Posts: 333
iTrader: (4)

guys this thread was merrily for the purpose of me spasing out on BMW Mississauga and my bad experience,

I apologize for any misunderstanding i mite have caused, yes, BMWs are amazing, the dealers not so much.

so, this argument we seem to be having, can be done elsewhere, not here please

as for my situation, their are no updates yet, the car is still sitting at the dealership, and they tell me the problem is still not 100% resolved

thanks for everyones help
PHR is offline  
0
Reply With Quote
      01-31-2011, 04:01 PM   #31
adrean8j
Brigadier General
 
adrean8j's Avatar
 
Drives: SGM 135I
Join Date: Jun 2008
Location: Everywhere and Nowhere

Posts: 4,071
iTrader: (1)

Garage List
2008 135i  [5.00]
Send a message via Yahoo to adrean8j
Well if the car worked fine before the turbo replacement WITH the aftermarket subs/amp...then it should work fine afterward..they really do not have anything to do with each other right? Turbos and aftermarket subs/amps????
__________________
Quote:
Originally Posted by ptack View Post
SGM was God's color and has been recalled to heaven.
adrean8j is offline   No_Country
0
Reply With Quote
      01-31-2011, 04:59 PM   #32
NiceAndSlow
Viet Cong
 
NiceAndSlow's Avatar
 
Drives: Black Metalic 335i
Join Date: Jul 2008
Location: Toronto

Posts: 255
iTrader: (0)

Garage List
2007 C2  [0.00]
2001 Boxster  [0.00]
2006 VW Touareg v6  [0.00]
2007 BMW 335i  [0.00]
hmm... bmw does suck but going on a bmw forum to post this may get you killed lol.. just complain to BMW Canada and move on to another car ..
NiceAndSlow is offline  
0
Reply With Quote
      01-31-2011, 11:10 PM   #33
Thussy
First Lieutenant
 
Thussy's Avatar
 
Drives: E92 N54
Join Date: Jan 2011
Location: Southern Ontario

Posts: 309
iTrader: (0)

Garage List
2008 BMW 335i  [5.00]
Thumbs down

Quote:
Originally Posted by clairvoyant View Post
Generally speaking, I stay away from dealers belong to Quinn Automotive Group.
This isn't a Quinn Group dealer - those are Toronto, Parkview, and Waterloo...
Thussy is offline   Canada
0
Reply With Quote
      02-01-2011, 08:31 AM   #34
335BBS
Brigadier General
 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

Posts: 3,607
iTrader: (0)

Quote:
Originally Posted by NiceAndSlow View Post
hmm... bmw does suck but going on a bmw forum to post this may get you killed lol.. just complain to BMW Canada and move on to another car ..
Unfortunately thats just about all people do here...complain. Most other forums arent like this.
335BBS is offline   Canada
0
Reply With Quote
      02-01-2011, 08:34 AM   #35
335BBS
Brigadier General
 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

Posts: 3,607
iTrader: (0)

Quote:
Originally Posted by PHR View Post
guys this thread was merrily for the purpose of me spasing out on BMW Mississauga and my bad experience,

I apologize for any misunderstanding i mite have caused, yes, BMWs are amazing, the dealers not so much.

so, this argument we seem to be having, can be done elsewhere, not here please

as for my situation, their are no updates yet, the car is still sitting at the dealership, and they tell me the problem is still not 100% resolved

thanks for everyones help
The problem is that you are calling ALL dealers terrible when, in reality, you (1person) are having a problem with one dealer. That make s them all shi&?
335BBS is offline   Canada
0
Reply With Quote
      02-01-2011, 11:53 AM   #36
mathu.bala
First Lieutenant
 
mathu.bala's Avatar
 
Drives: 2009 323i/6mt
Join Date: Aug 2009
Location: Kirkland, WA

Posts: 330
iTrader: (0)

Garage List
2009 LCI 323i  [0.00]
Quote:
Originally Posted by NiceAndSlow View Post
hmm... bmw does suck but going on a bmw forum to post this may get you killed lol.. just complain to BMW Canada and move on to another car ..
I agree. Some of the members think BMW should be worshiped no matter what kind of shit thrown at them. lol
__________________
2009 323i Titanium Silver Metallic: Premium Pkg(Heated SW, Bluetooth, Sunroof), USB
MFD Scoop,SWS-8,JL M6450
mathu.bala is offline   Canada
0
Reply With Quote
      02-01-2011, 11:54 AM   #37
PHR
phr
 
Drives: F32 435I M Retired:335I M
Join Date: Dec 2009
Location: Toronto

Posts: 333
iTrader: (4)

Quote:
Originally Posted by Leaker View Post
The problem is that you are calling ALL dealers terrible when, in reality, you (1person) are having a problem with one dealer. That make s them all shi&?
Do you follow me around as i drop my cars off at the dealer?
Mississauga is the closest to me, so when the car tells me "DO NOT DRIVE" iam going to contact the nearest dealership

not all dealerships have charged me for work i had not authorized, but mostly all dealers in the GTA have given me a hard time
PHR is offline  
0
Reply With Quote
      02-01-2011, 11:58 AM   #38
Kid Eh
Grand Theft Votto
 
Kid Eh's Avatar
 
Drives: 2013 335is
Join Date: Sep 2006
Location: Toronto

Posts: 1,288
iTrader: (1)

Garage List
2013 BMW 335is  [3.50]
Quote:
Originally Posted by PHR View Post
Do you follow me around as i drop my cars off at the dealer?
Mississauga is the closest to me, so when the car tells me "DO NOT DRIVE" iam going to contact the nearest dealership

not all dealerships have charged me for work i had not authorized, but mostly all dealers in the GTA have given me a hard time
I'm on my third Bimmer and never had a problem with the vehicles, dealerships or people at them. Just sayin'. *need to find some wood to knock on*
__________________
'86 Fiero GT - Black l Aluminum l Nav l Premium l Cold l DCT l Comfort Access l Audio l

"I used to be conceited. Now I'm perfect"
Kid Eh is offline   Canada
0
Reply With Quote
      02-01-2011, 12:16 PM   #39
PHR
phr
 
Drives: F32 435I M Retired:335I M
Join Date: Dec 2009
Location: Toronto

Posts: 333
iTrader: (4)

Quote:
Originally Posted by Kid Eh View Post
I'm on my third Bimmer and never had a problem with the vehicles, dealerships or people at them. Just sayin'. *need to find some wood to knock on*
lol i agree,
alot of my buddies have the same car, 335i, and they havnt gotten a single problem, car runs like new

don't seem to understand why mine seems to be like this...
PHR is offline  
0
Reply With Quote
      02-01-2011, 01:54 PM   #40
335BBS
Brigadier General
 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

Posts: 3,607
iTrader: (0)

Quote:
Originally Posted by PHR View Post
Do you follow me around as i drop my cars off at the dealer?
Mississauga is the closest to me, so when the car tells me "DO NOT DRIVE" iam going to contact the nearest dealership

not all dealerships have charged me for work i had not authorized, but mostly all dealers in the GTA have given me a hard time
Maybe if you stayed with one and developed a relationship things would be different. If you had been to the same place 6 times and had this problem i bet the situation would be much different. I'm not saying that is right but thats reality. WTF would you go to so many different dealerships? Oh yea....they are all shi*.
335BBS is offline   Canada
0
Reply With Quote
      02-01-2011, 03:15 PM   #41
MOAB
Major
 
MOAB's Avatar
 
Drives: Porsche & BMW
Join Date: Dec 2006
Location: Toronto

Posts: 1,077
iTrader: (0)

Quote:
Originally Posted by PHR View Post
lol i agree,
alot of my buddies have the same car, 335i, and they havnt gotten a single problem, car runs like new

don't seem to understand why mine seems to be like this...
just curious, how old are you?
__________________
March-November - '09 C4S (PDK, Akrapovic)
December-February - '00 323 (only mod - snow tires)
MOAB is offline   Canada
0
Reply With Quote
      02-01-2011, 04:15 PM   #42
nvez
Major
 
nvez's Avatar
 
Drives: an M3..... in a while.
Join Date: Sep 2008
Location: Montreal, QC

Posts: 1,150
iTrader: (0)

http://www.e-laws.gov.on.ca/html/sta...30_e.htm#s57s1

don't pay the $500.
nvez is offline  
0
Reply With Quote
      02-01-2011, 05:42 PM   #43
PHR
phr
 
Drives: F32 435I M Retired:335I M
Join Date: Dec 2009
Location: Toronto

Posts: 333
iTrader: (4)

Quote:
Originally Posted by MOAB View Post
just curious, how old are you?
19
PHR is offline  
0
Reply With Quote
      02-01-2011, 05:48 PM   #44
PHR
phr
 
Drives: F32 435I M Retired:335I M
Join Date: Dec 2009
Location: Toronto

Posts: 333
iTrader: (4)

Quote:
Originally Posted by Leaker View Post
Maybe if you stayed with one and developed a relationship things would be different. If you had been to the same place 6 times and had this problem i bet the situation would be much different. I'm not saying that is right but thats reality. WTF would you go to so many different dealerships? Oh yea....they are all shi*.
actually the people over at bmw mississauga know me verry well,
the reason i go to other dealers is because my dad sends his to toronto, and mom and brother find it more convenient at budds, as work is a huge factor for all 3 of them, as for me, i have given em all a try, because first few times i had a problem with sauga.

and for a car thats 1.5 yrs old, its actually gone in more than 6 times, more like this is my 10th visit to the service department.
PHR is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
335i, bmw, service, turbo, warranty

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:02 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST