E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY - Replacing Camshaft VANOS Solenoid



Reply
 
Thread Tools Search this Thread
      07-01-2011, 12:44 AM   #23
firechicken99
Major
15
Rep
1,035
Posts

Drives: Black '07 335i
Join Date: Mar 2011
Location: United States

iTrader: (0)

Quote:
Originally Posted by Samuel L Jackson View Post
Thanks for the DIY. Had this issue with my car yesterday. It only has 40k miles on it and was idling really rough, took it to the dealer and they replaced it. Even though it was under warranty, I was curious and asked how much it cost. SA said probably around $2000 to fix.......can you believe that??????
are you kidding me?? 220 in parts and a half hour of labor??!!! WOW
Appreciate 0
      07-04-2011, 08:17 AM   #24
ENINTY
Banned
76
Rep
3,415
Posts

Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Quote:
Originally Posted by Samuel L Jackson View Post
Thanks for the DIY. Had this issue with my car yesterday. It only has 40k miles on it and was idling really rough, took it to the dealer and they replaced it. Even though it was under warranty, I was curious and asked how much it cost. SA said probably around $2000 to fix.......can you believe that??????
I doubt the SA new what he/she was talking about. $2K would be a cam replacement.
Appreciate 0
      07-05-2011, 02:38 AM   #25
Samuel L Jackson
Private First Class
Samuel L Jackson's Avatar
United_States
3
Rep
174
Posts

Drives: 328i Coupe
Join Date: Aug 2008
Location: LA County

iTrader: (0)

Quote:
Originally Posted by ENINTY View Post
I doubt the SA new what he/she was talking about. $2K would be a cam replacement.
You would be surprised, this particular dealer is just a plain rip off compared to other BMW dealers. They charge 2-3 times the rate of other dealers in the region. For example, they wanted $1200 for a transmission fluid/filter change while the dealer I regularly go to quoted $550. I only went to this dealer because I was stuck on the road and this was the closest one.
Appreciate 0
      07-10-2011, 07:16 PM   #26
firechicken99
Major
15
Rep
1,035
Posts

Drives: Black '07 335i
Join Date: Mar 2011
Location: United States

iTrader: (0)

I threw an intake vanos code last week and felt at 69K, my mods, and what ive heard about the solenoids it would be good practice to replace both. (especially since they are relatively inexpensive compared (210 total) compared to other things ive had to replace...

This work is EASY. It was even more convenient I was putting my Procede back in so the cowl had to come off anyways.

DEFINITELY good practice to replace one at a time, I did the bottom first, then top. Barely any oil dripped out.

NOTE: I have an 07 335i N54 and it was definitely NOT necessary to remove the snorkel. PLENTY of room to get the bolts/parts out with an 8mm long socket and a 3/8 wrench, and my hands are not small!
Appreciate 0
      07-11-2011, 12:01 PM   #27
Vmax222
New Member
0
Rep
12
Posts

Drives: E90 325i
Join Date: Jul 2006
Location: Germany

iTrader: (0)

did i see the fault codes in the secret hidden BC menu (hidden menu 14)?
Or have i go to the dealer.

My dealer found an 2A82 in the past, but i want to check now by myself if this error happened again.
Appreciate 0
      07-14-2011, 06:58 AM   #28
ENINTY
Banned
76
Rep
3,415
Posts

Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Quote:
Originally Posted by firechicken99 View Post
I threw an intake vanos code last week and felt at 69K, my mods, and what ive heard about the solenoids it would be good practice to replace both. (especially since they are relatively inexpensive compared (210 total) compared to other things ive had to replace...

This work is EASY. It was even more convenient I was putting my Procede back in so the cowl had to come off anyways.

DEFINITELY good practice to replace one at a time, I did the bottom first, then top. Barely any oil dripped out.

NOTE: I have an 07 335i N54 and it was definitely NOT necessary to remove the snorkel. PLENTY of room to get the bolts/parts out with an 8mm long socket and a 3/8 wrench, and my hands are not small!
Just to catch up on this, I really think it is better to just remove them, clean them with electronics cleaner and shop air, then reinstall them in the opposite locations. I really can't see these parts being subject to wear to the point where they become defective; I think they just get dirty. I cleaned and swapped mine over 5,000 miles ago and have not had the codes reocurr. If it doesn't work, then go get the new parts and replace. The work is so easy it's worth trying the cleaning procedure first before spending the $210 for new parts. My car has 149K on it by the way. Just my 2 cents.
Appreciate 0
      07-14-2011, 08:17 AM   #29
firechicken99
Major
15
Rep
1,035
Posts

Drives: Black '07 335i
Join Date: Mar 2011
Location: United States

iTrader: (0)

Its definite worth a Shot. It's a little late.for.me to go that route but my car is running great so Im satisfied with the results
Appreciate 0
      07-14-2011, 06:36 PM   #30
hoopvillian
Private First Class
hoopvillian's Avatar
11
Rep
176
Posts

Drives: 335i
Join Date: Apr 2010
Location: Dago

iTrader: (0)

Any point in doing a preemptive cleaning on these? Or do you guys think this is something you can wait and see if it throws a code.
Appreciate 0
      07-14-2011, 06:59 PM   #31
firechicken99
Major
15
Rep
1,035
Posts

Drives: Black '07 335i
Join Date: Mar 2011
Location: United States

iTrader: (0)

While I agree with entity and it makes sense, into more do so successfully I think its kind of up in the air. For you I personally think if it ain't broke don't fix it. But Idk
Appreciate 0
      07-16-2011, 03:55 PM   #32
robbie211
Captain
United_States
12
Rep
812
Posts

Drives: E90 335i, E36 M3
Join Date: Mar 2006
Location: OC

iTrader: (16)

Garage List
2007 335i  [3.38]
Thanks for putting this together I just changed my exhaust solenoid that went bad. Took me 30 minutes after reading through the thread.
Appreciate 0
      08-09-2011, 04:29 PM   #33
ovaltine224
swagger jacker
ovaltine224's Avatar
5
Rep
65
Posts

Drives: 328xi
Join Date: Aug 2011
Location: United States

iTrader: (0)

very useful and well written DIY...job takes almost 10mins
Appreciate 0
      08-28-2011, 08:07 PM   #34
DAKH1
New Member
0
Rep
20
Posts

Drives: 07 e90 335i
Join Date: Dec 2008
Location: AZ

iTrader: (1)

Thanks for the write up! Had been throwing some vanos codes along with some hesitation when accelerating hard. Hardest part of the removal was the bolts holding the solenoid in place, had to work around the two hoses and my hand kept hitting the radiator fan shroud. I was afraid I would lose the bolt so it is a good idea to have a rag underneath to catch if the bolt is dropped. I also used csc electronics cleaner with the a can of compressed air to clean instead of replacing the part. So far so good on the acceleration, no limp mode, codes, or hesitation.
Appreciate 0
      08-30-2011, 05:45 PM   #35
335i 07
Private
10
Rep
97
Posts

Drives: 07 335i
Join Date: Dec 2010
Location: Mississippi

iTrader: (0)

Quote:
Originally Posted by 335i 07 View Post
Great to hear the faults were eliminated with this fix. My solenoids will be here Friday. I hope it doesn't turn out to be the ledger. Thats gonna cost me $600 with parts and a N54 timing kit. I will repost after install with results. Wish me luck
I changed both the intake and exhaust solenoids and the code hasn't repeated for 2 months.
__________________
2007 335i
Mods: JB4, BMS DCI Intake, HPF FMIC, Forged DVs, ceramic Tint, Black Emblems, 93 Octane
Appreciate 0
      09-03-2011, 03:51 PM   #36
etichi
Slow,fast,slow, then you die.
etichi's Avatar
United_States
4
Rep
243
Posts

Drives: 335i 07,AA short shifter, COBB
Join Date: May 2010
Location: Orlando

iTrader: (1)

I am getting 2A82 every once in a while. Under WOT the car seems to hiccup around 3700 rpms. Is this a symptom of the solenoid going bad?
Appreciate 0
      09-08-2011, 11:09 PM   #37
ENINTY
Banned
76
Rep
3,415
Posts

Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

So just to update everyone, it's been over 9,000 miles since I cleaned and swapped the positions of mine had have not had one reoccurance of the problem.
Appreciate 0
      09-09-2011, 12:13 AM   #38
firechicken99
Major
15
Rep
1,035
Posts

Drives: Black '07 335i
Join Date: Mar 2011
Location: United States

iTrader: (0)

Good to know!
Appreciate 0
      10-12-2011, 03:20 AM   #39
yokono_unit
Private
1
Rep
92
Posts

Drives: F30 335i
Join Date: Jun 2011
Location: Long Beach, CA

iTrader: (0)

Was throwing a 2A87 code. Im running JB4 tune and everytime I would go WOT and then let off it would go into limp mode, half engine. Followed this DIY cleaned both solenoids with carb cleaner and compressed air, also cleaned the contacts with contact cleaner. Needless to say the problem is gone. I have been trying to replicate the issue to no avail. Looks like it took care of my problem...
Appreciate 0
      10-14-2011, 07:44 PM   #40
GRLPWR
Lieutenant
GRLPWR's Avatar
United_States
8
Rep
487
Posts

Drives: '07 335i
Join Date: Aug 2010
Location: Durham, NC

iTrader: (0)

Garage List
2007 335i  [0.00]
It's so easy, even a female can do it!!! lol I cleaned and swapped them around. Will have to wait until tomorrow's long-distance drive to see if it's gonna cure my codes.Thank you so much for this DIY!
Appreciate 0
      11-02-2011, 11:28 PM   #41
axi005
Arthur
United_States
2
Rep
23
Posts

Drives: 07 335i e90 Montego
Join Date: Sep 2011
Location: Lewisburg Pa

iTrader: (0)

Quote:
Originally Posted by orionredwing View Post
My symptoms were mild. Every once in awhile, under WOT, this code would throw, causing the half engine light / limp mode to come up. For me, it only occurred occasionally under WOT like after 10-20 mins of continuous redlines (aka on the track). For more serious cases, some people have reported it triggers everytime they go WOT.

Basically, you're accelerating hard, it triggers, and you go into limp mode until you reset your car. Nothing else happens. Sometimes, it would cause misfires, and your car would shudder until you pull over and reset.
what do you mean exactly by reset, my friends car does this and im trying to help him out. thanks
Appreciate 0
      11-02-2011, 11:40 PM   #42
firechicken99
Major
15
Rep
1,035
Posts

Drives: Black '07 335i
Join Date: Mar 2011
Location: United States

iTrader: (0)

O
Quote:
Originally Posted by axi005 View Post
what do you mean exactly by reset, my friends car does this and im trying to help him out. thanks
Aka turn the car off and turn it back on...
Appreciate 0
      11-04-2011, 04:14 PM   #43
axi005
Arthur
United_States
2
Rep
23
Posts

Drives: 07 335i e90 Montego
Join Date: Sep 2011
Location: Lewisburg Pa

iTrader: (0)

Thanks i appreciate the reply "my bad for the noob question"
Appreciate 0
      11-10-2011, 09:08 PM   #44
BAL278
Major
BAL278's Avatar
20
Rep
1,005
Posts

Drives: E92 335xi JB
Join Date: Jun 2011
Location: North NJ

iTrader: (3)

Thanks for this DIY.. Came in handy
__________________

2008 335xi Jet Black//Coral Red
VTT Stage 1+// Procede V5//VRSF DPs//AMS FMIC//KW V1//M3 Sways & Sub Bushings// Alpina AT flash
Apex EC-7//Michelin PSS//Dinan CAI
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:32 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST