E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > misfire goes away with restart engine



Reply
 
Thread Tools Search this Thread
      02-18-2016, 10:40 PM   #1
jc2078
Private
3
Rep
51
Posts

Drives: 335i
Join Date: Jan 2015
Location: United States

iTrader: (0)

misfire goes away with restart engine

Hi guys

I have a misfire with SES light that comes on. The misfire only happens on cold starts. The car starts shaking, does not accelerate, and throws an SES. However when I pull over and turn off the car and turn it back on, the misfire is gone instantly (and so is the SES). This has happened 3 times now. I already changed the spark plugs, no fix

so i'm down to coils or injectors. Seems electrical but not sure coils do this?

09 n54 335i 40k miles

Thanks

Last edited by jc2078; 02-18-2016 at 10:45 PM.
Appreciate 0
      02-18-2016, 11:47 PM   #2
alexg212
Second Lieutenant
25
Rep
238
Posts

Drives: 335is Coupe/Mustang Gt
Join Date: Oct 2013
Location: DFW

iTrader: (0)

If x amount of misfires in y amount of time, that car will throw an SES and turn off that cylinder. Restarting and it going away is normal. But there should be misfire codes stored letting you know what cylinder the issues are on.
Appreciate 2
      02-19-2016, 01:02 AM   #3
Lshaw
Lieutenant Colonel
Lshaw's Avatar
United_States
73
Rep
1,702
Posts

Drives: 09 335i 6mt
Join Date: Oct 2007
Location: NYC / Bay Area/ Park City/ Pittsburgh

iTrader: (21)

First thing is first, read the stickies on this subsection. Also usually a Google search will bring up every thing you need to know about the codes/symptoms and more.

Since you changed your plugs, usually the next culprit are the coils. But since you misfire on cold starts only, sounds like a leaky injector. Pull the codes check which cyl., check that plug for fouling.
__________________
07 335xi- (2007-2010)
08 Legacy Spec B Fully Built (08-)
09 335i (2010-)
15 X5 xdrive 35i (2015-)
Appreciate 1
      02-19-2016, 01:36 AM   #4
ferocity02
Major
United_States
129
Rep
1,369
Posts

Drives: 2007 E90 335i Pre-LCI
Join Date: May 2014
Location: USA

iTrader: (7)

What codes are you getting? Check the code and see which cylinder it is, then swap that cylinder's coil with another cylinder. Wait until it happens again, then check the code and see if the code switched cylinders. If the code follows the coil then it's the coil. If not then it's probably the injector.
__________________
2007 E90 335i Pre-LCI
Appreciate 0
      02-19-2016, 01:28 PM   #5
joeinsd
Second Lieutenant
26
Rep
242
Posts

Drives: 2010 e92 335i M Sport
Join Date: Apr 2015
Location: San Diego

iTrader: (2)

Had the same issue last year. Dealer replaced (under CPO) coils, plugs, then injectors (in that order, 3 visits) and it was fine after.
Appreciate 0
      02-19-2016, 01:36 PM   #6
ritzzzzzwik
First Lieutenant
ritzzzzzwik's Avatar
27
Rep
318
Posts

Drives: 2007 335i MT
Join Date: Oct 2014
Location: NOVA

iTrader: (0)

I'm sorry but no one would be able to help w/o codes. If you dont have the means to read codes, then take it to the dealer. Codes will be stored in the ECU. I assume at 40K you still have factory warranty.
Appreciate 1
      02-19-2016, 02:57 PM   #7
jc2078
Private
3
Rep
51
Posts

Drives: 335i
Join Date: Jan 2015
Location: United States

iTrader: (0)

Here are the codes. It's 3 cylinders so not sure what to do. Out of warranty since it's an 2009
Attached Images
 
Appreciate 0
      02-19-2016, 03:01 PM   #8
jc2078
Private
3
Rep
51
Posts

Drives: 335i
Join Date: Jan 2015
Location: United States

iTrader: (0)

Plugs are all clean when I changed them last week. One was a bit darker but not much
Appreciate 0
      02-19-2016, 03:08 PM   #9
tc535i
Lieutenant Colonel
138
Rep
1,882
Posts

Drives: 2007 335i, 2001 330i, 1995 M3
Join Date: Sep 2013
Location: West Los Angeles

iTrader: (1)

Might be the o2 for bank 1 since they're all misfiring
Appreciate 0
      02-19-2016, 03:12 PM   #10
ferocity02
Major
United_States
129
Rep
1,369
Posts

Drives: 2007 E90 335i Pre-LCI
Join Date: May 2014
Location: USA

iTrader: (7)

Swap cylinders 1-3 coils to 4-6 and see if the codes follow. If they do, replace all 3 of those coils.
__________________
2007 E90 335i Pre-LCI
Appreciate 0
      02-19-2016, 09:10 PM   #11
muncie21
Private First Class
38
Rep
187
Posts

Drives: 335ix
Join Date: Sep 2015
Location: PA

iTrader: (0)

Mosfets
Appreciate 0
      02-20-2016, 12:55 PM   #12
limitdown
Private First Class
limitdown's Avatar
29
Rep
142
Posts

Drives: 2007 335i E93
Join Date: Jul 2015
Location: Location

iTrader: (0)

It might be the precat O2 sensor for bank1 since that entire bank is misfiring
Appreciate 0
      02-20-2016, 01:29 PM   #13
tc535i
Lieutenant Colonel
138
Rep
1,882
Posts

Drives: 2007 335i, 2001 330i, 1995 M3
Join Date: Sep 2013
Location: West Los Angeles

iTrader: (1)

Quote:
Originally Posted by muncie21 View Post
Mosfets
If swapping o2 doesn't help, this is the next likely culprit
Appreciate 0
      02-20-2016, 05:10 PM   #14
=C=
Private First Class
New Zealand
14
Rep
146
Posts

Drives: 2007 BMW 335i M-Sports E90
Join Date: Jul 2012
Location: Auckland, New Zealand

iTrader: (0)

I started getting misfires when i WOT in 3rd gear. Coils and spark plugs already replaced. I guess injector is next?

Cobb ap tune

Last edited by =C=; 02-20-2016 at 05:27 PM.
Appreciate 0
      02-20-2016, 07:37 PM   #15
jc2078
Private
3
Rep
51
Posts

Drives: 335i
Join Date: Jan 2015
Location: United States

iTrader: (0)

Well I cleared the misfires changed packs 1-3 4-6. Now I have this. Can't drive the car the throttle just goes up and down 1-2k rpm
Attached Images
 
Appreciate 0
      02-20-2016, 07:44 PM   #16
jc2078
Private
3
Rep
51
Posts

Drives: 335i
Join Date: Jan 2015
Location: United States

iTrader: (0)

It was due to adapt reset figured it out
Appreciate 0
      02-20-2016, 07:45 PM   #17
mojobmw_e90
Captain
71
Rep
742
Posts

Drives: 07 BMW 335i
Join Date: Oct 2014
Location: Chicago IL

iTrader: (1)

Quote:
Originally Posted by jc2078 View Post
Well I cleared the misfires changed packs 1-3 4-6. Now I have this. Can't drive the car the throttle just goes up and down 1-2k rpm
Sounds like u reset the throttle adoptions as well. Let the car learn those before driving. Let it idle for a few mins and drive slowely around
Appreciate 0
      02-24-2016, 05:22 PM   #18
muncie21
Private First Class
38
Rep
187
Posts

Drives: 335ix
Join Date: Sep 2015
Location: PA

iTrader: (0)

Did swapping the coils fix the problem?
Appreciate 0
      02-24-2016, 05:32 PM   #19
ferocity02
Major
United_States
129
Rep
1,369
Posts

Drives: 2007 E90 335i Pre-LCI
Join Date: May 2014
Location: USA

iTrader: (7)

After resetting adaptations you need to clear codes and/or let it sit for a bit otherwise you'll get the surging idle issue.
__________________
2007 E90 335i Pre-LCI
Appreciate 0
      02-29-2016, 10:49 PM   #20
jc2078
Private
3
Rep
51
Posts

Drives: 335i
Join Date: Jan 2015
Location: United States

iTrader: (0)

It hasn't thrown a SES code again so I can't tell what is causing the misfire so I'll just have to wait
Appreciate 0
      03-22-2016, 08:54 AM   #21
jc2078
Private
3
Rep
51
Posts

Drives: 335i
Join Date: Jan 2015
Location: United States

iTrader: (0)

Codes came back (cylinder 1-3 misfire) same as above. Any chance this is the low fuel pressure sensor since I have code 29f3 too? I have had that code for a year tho
Appreciate 0
      03-22-2016, 09:05 AM   #22
BRD1234
Second Lieutenant
BRD1234's Avatar
United_States
5
Rep
279
Posts

Drives: E92 335i Coupe
Join Date: Apr 2013
Location: Miami, Fl

iTrader: (0)

I have the 293F Code as well.
It's most likely the low fuel pressure sensor.
I have ordered the part and will let you know if this solves my problem, my symptoms are exactly like yours.
__________________
335i Coupe 6MT Montego Blue
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:58 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST