E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Idling too low and causing vibrations through the car



Reply
 
Thread Tools Search this Thread
      02-13-2011, 04:21 PM   #1
Goodneighbor
Enlisted Member
 
Drives: 06 Z4, 07 328i
Join Date: Dec 2010
Location: NC

Posts: 33
iTrader: (0)

Idling too low and causing vibrations through the car

Ok so I have been driven crazy with the rough vibrations that I get when I come to a stop at stop lights. I have noticed that the rough vibrations that I can feel through the steering wheel and seat only happen when the car starts to idle around 600rpms. Is this normal for my car to idle at 600 b/c it feels like the car is about to fall apart like it has 300,000 miles on it? Would it be possible to raise the idling to 750rpms which would alleviate all of the vibrations? Thanks for your help.
Goodneighbor is offline  
0
Reply With Quote
      02-13-2011, 08:05 PM   #2
e90pilot
Freight Dawg
 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

Posts: 2,095
iTrader: (3)

Yes, the N52 normally idles at around 600. If you want a few more RPM, turn the AC on. That bumps the idle speed up 150-200 rpm.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
e90pilot is offline   United_States
0
Reply With Quote
      02-13-2011, 08:21 PM   #3
Express
Major General
 
Express's Avatar
 
Drives: 06 330i
Join Date: Dec 2008
Location: The Promise Land

Posts: 8,701
iTrader: (17)

Garage List
2006 BMW 330i  [4.15]
check out your motor mounts. one bad one can cause such vibration.

other problems include poor compression in one of your cylinders, but that is unlikely.
Express is offline   Israel
0
Reply With Quote
      02-13-2011, 09:31 PM   #4
Goodneighbor
Enlisted Member
 
Drives: 06 Z4, 07 328i
Join Date: Dec 2010
Location: NC

Posts: 33
iTrader: (0)

I have taken it into two different shops and they have told me everything is running fine. I had them check the motor mounts and such and they said they are in good condition and were not loose. Is there a way to adjust the idle at all? I don't feel like driving an hour to the dealer for them to tell me they can't do that.
Goodneighbor is offline  
0
Reply With Quote
      02-13-2011, 09:36 PM   #5
mike-y
just another bmw douche bag
 
Drives: 1.9L of fury
Join Date: Nov 2008
Location: Los Angeles, CA

Posts: 3,396
iTrader: (4)

when was the last time you changed your air filter, or cleaned your MAF?
mike-y is offline   United_States
0
Reply With Quote
      02-13-2011, 11:20 PM   #6
KDynastyE90
Enlisted Member
 
Drives: Silver Metallic E90 330i
Join Date: Jan 2009
Location: New Jersey

Posts: 37
iTrader: (1)

I have the same issue with my 330i. It only happens during a cold start though and goes away after about 10mins of driving. When the RPM drops down to 600rpm at a stop, it's a loud vibration that sounds like it's coming from behind the steering wheel. I went to the dealer last week and they checked all the panels in that area, the exhaust, and motor mounts and everything was ok. They said they compared it to another 330i and "it was a normal idle sound." I guess i'll deal with it now that I at least know everything checked out ok.
KDynastyE90 is offline  
0
Reply With Quote
      02-14-2011, 07:06 PM   #7
acontisr330i
Private
 
acontisr330i's Avatar
 
Drives: 2006 330i blk/blk
Join Date: Feb 2009
Location: South Jersey

Posts: 61
iTrader: (0)

I'm having the same problem only whens its cold.It started after i had the car serviced. When I come to a stop the idle drops down to 600 i hear a vibration or grouling noise till the car is warm. Dealership said theres nothing wrong.
acontisr330i is offline   United_States
0
Reply With Quote
      02-17-2011, 08:53 AM   #8
Broder
New Member
 
Drives: BMW 330i 06/07 M-Sport
Join Date: Feb 2011
Location: Brazil

Posts: 12
iTrader: (0)

Same problem here. 2006/2007 330i EU-Spec with 66.000km (41k miles). Though some of my symptoms seem to be different. Hereīs what happens:

When I have the A/C turned off (engine idling @ 600rpm on stops), I usually get a annoying vibration that you can feel mainly through the seats. It happens always, independent of the engine being hot or cold. Solution? Turn the A/C on, idle RPM increases and the vibration ceases.

Now the odd thing, when I turn the A/C on Iīm sometimes able to hear a metallic noise coming from the engine bay and you can feel a little vibration from the interior of the car, although itīs a DIFFERENT vibration from the one that happens when you have the A/C turned off, the metallic vibration that happens with A/C on is much less pronounced and definitely better to live with then when the A/C is off (thatīs why I always run with the A/C on, even when itīs not necessary). This metallic noise/vibration seems to be worse on hot days (or when the engine is hot) and less pronounced on cold days, so sometimes you wonīt feel it at all while at other times it will bother me quite a lot. However, this metallic noise/vibration is also discrete, the engine itself tends to be noisier then that sound (thatīs why, even from the outside, people usually canīt hear it), people that ride with me usually canīt hear it or feel it even when itīs there, I can hear it because I drive the car on a daily basis and have to live with it, so Iīm naturally more sensible to my carīs noises and rattles then other people, this also means itīs hard to diagnose the problem in a BMW dealership.

Once, arriving home in a silent night, the sound was actually pronounced enough that I was able to hear it out of my car. I found it the easiest way to listen to it is to crouch and hear it placing my ear next to one of the front wheels (sounds louder on the driverīs side), itīs easier then trying to listen it from top of the engine bay (since engine noise is very loud from the top part), this metallic sound is definitely caused by two elements that are "touching" each other when they shouldnīt, although I canīt pinpoint exactly where it comes from. My first natural hint was that I probably had one or more engine mounts busted, and it was probably causing the engineīs downpipe or something alike to be in contact with something else, causing that metallic noise/vibration.

Well, the technician at BMW told me my engine mounts are fine, thereīs nothing wrong. And pinpointing the metallic noise/vibration seems rather hard at BMW, specially since, for some reason, my car is always very well behaved at the dealership. Turning the A/C off seems to eliminate the metallic noise/vibration, but starts with another kind of vibration thatīs apparently caused by N52īs excessively low idle RPM, and I thought "perhaps both of these vibrations are related, and fixing the 600rpm no-A/C vibration will probably also fix the metallic A/C vibration together", so I turned off the A/C and showed my carīs vibration to BMWīs technician. He agreed that the vibration seemed "wrong" and they checked the car for problems.

The next day they called me telling me the problem was the engine alternator. I thought "wtf, the alternator?". I said "there must be something wrong, the alternator canīt be doing this, it makes no sense", the technician then told me "yes, itīs weird I know, but your alternator seems to have internal loosen parts, that causes the excessive vibration when the A/C is off, once you turn the A/C on, the vibration ceases since the load caused by the A/C causes the alternator to work tighter".

Ok, since my carīs on extended warranty they changed the alternator for me. That was some weeks ago, did it solve? Not really, though some things did get better. For instance, whenever my car was idling with A/C on, sometimes the RPM would have a sudden drop (A/C compressor being activated perhaps?) for a few seconds, then go back to normal range. Since Iīve changed the alternator, I have noticed no drops or oscillations whatsoever during idle RPM. Idling with no A/C seems to be better also, but itīs still uncomfortable, and with A/C on I can still feel the metallic noise/vibration... gonna have to take the car back to the dealership when I have the time...
Broder is offline  
0
Reply With Quote
      01-28-2012, 04:04 PM   #9
E92Alpine328i
Euro.Techniks-EAST
 
E92Alpine328i's Avatar
 
Drives: 2008 328i coupe
Join Date: Jan 2007
Location: Newark, NJ

Posts: 1,379
iTrader: (1)

Send a message via AIM to E92Alpine328i
i had this problem today. came out of nowhere when i stopped at a light i heard a slight flat line squeak coming from the engine bay and the car was idling very low and felt like it wanted to shut off but didnt. when i shut off the car and turned it back on it never came back. what could it be???
E92Alpine328i is offline   United_States
0
Reply With Quote
      01-28-2012, 10:56 PM   #10
Donny Rino
Private First Class
 
Drives: 2006 330i
Join Date: Sep 2011
Location: westchester ny

Posts: 132
iTrader: (0)

So funny I have a 30k mile 330 with the same issue . At 600 rpm there is a rattle at 700 its gone.
Donny Rino is offline  
0
Reply With Quote
      04-03-2012, 12:24 PM   #11
Machines
Registered
 
Drives: 2007 BMW 328i
Join Date: Apr 2012
Location: Minneapolis

Posts: 1
iTrader: (0)

Not to revive a thread that is too old, but this is happening to me too. Just got it back from routine service and a replaced valve cover gasket. Vibrations all through the car when idling at a stoplight. Things are rattling, can feel the vibration in the seat. Seems to go in waves when it happens. Idling at about 600 rpm. Still under CPO (2007 328i), so I might take it back in and see what they say.
Machines is offline  
0
Reply With Quote
      04-05-2012, 12:40 AM   #12
TehKhy
New Member
 
TehKhy's Avatar
 
Drives: 2007 e90 328i Sport
Join Date: Jan 2012
Location: Vancouver

Posts: 29
iTrader: (0)

I was having a similar issue but mine was idling around 550, even with AC on. I ran a bottle of good injector cleaner through and it cleaned up the idle. Was back to normal range with no issues. Might be worthwhile to try a cheap fix.
__________________
Khy.
2007 328i E90 6MT. Sport package, premium audio... so far.
TehKhy is offline   Canada
0
Reply With Quote
      04-05-2012, 10:32 AM   #13
Onefreakinuserid
New Member
 
Drives: 2008 e90 328i
Join Date: Apr 2012
Location: Wesley Chapel florida

Posts: 5
iTrader: (0)

Same problem bout 6 months ago. Took it to reeves and they set my idle to " max idle speed". I normally idle at about 700 or a little over now even with AC off. Problem was fixed.
Onefreakinuserid is offline  
0
Reply With Quote
      04-06-2012, 11:41 AM   #14
Capo335i
Lieutenant Colonel
 
Capo335i's Avatar
 
Drives: 335xi
Join Date: Nov 2009
Location: Middletown,Ny

Posts: 1,922
iTrader: (17)

same issue here except mine isnt as violent as yours it seems. i just have s ilght rattle sound coming but touch the gas peddle even the slightest and it clears it up
__________________
e92 335xi fully loaded aw/cr,kw v1, jb4 g5iso, RB Turbos, bms flash, alpina flash, walboro gls392, cpe fmic, custom catback,catless dp's, er charpipe, hks ssqv bov, bms dci, Bms backend,walboro 255, bmw perf. strut, 19'' volk te 37, m3 sides, mtec rear, Titanium stud+lug, Csl Trunk+Lci tails, ss brake lines, m3 sway +bushings
Capo335i is offline  
0
Reply With Quote
      07-21-2012, 04:50 PM   #15
E92Alpine328i
Euro.Techniks-EAST
 
E92Alpine328i's Avatar
 
Drives: 2008 328i coupe
Join Date: Jan 2007
Location: Newark, NJ

Posts: 1,379
iTrader: (1)

Send a message via AIM to E92Alpine328i
so after months of the problem not returning i go to change my oil and after im done i drive half a mile and that same issue comes back. flat line whistle and engine tremor that only stops when im driving and when i come to a stop light it comes back. if i shut off the car everything is fine for another a few blocks then it returns. im going to have the injectors checked or cleaned see if that could be the issue here.
E92Alpine328i is offline   United_States
0
Reply With Quote
      07-21-2012, 04:55 PM   #16
E92Alpine328i
Euro.Techniks-EAST
 
E92Alpine328i's Avatar
 
Drives: 2008 328i coupe
Join Date: Jan 2007
Location: Newark, NJ

Posts: 1,379
iTrader: (1)

Send a message via AIM to E92Alpine328i
Quote:
Originally Posted by TehKhy View Post
I was having a similar issue but mine was idling around 550, even with AC on. I ran a bottle of good injector cleaner through and it cleaned up the idle. Was back to normal range with no issues. Might be worthwhile to try a cheap fix.
did this problem ever come back? which injector cleaner did you use and how much was the fix?
E92Alpine328i is offline   United_States
0
Reply With Quote
      07-22-2012, 05:10 PM   #17
index1489
Lieutenant Colonel
 
index1489's Avatar
 
Drives: Out of warranty BMW
Join Date: Sep 2008
Location: Chino, CA

Posts: 1,991
iTrader: (7)

Redline Fuel Injector cleaner is the best imo.
__________________
Gotta pay to play.
index1489 is offline   United_States
0
Reply With Quote
      07-27-2012, 02:50 PM   #18
33beto
Second Lieutenant
 
33beto's Avatar
 
Drives: R.I.P. 08 E90 328i/GM 6L45E
Join Date: May 2011
Location: New Jersey

Posts: 278
iTrader: (0)

I had the dealer raise the idle 100 RPM's (A/C off) and 50 RPM's (A/C on)
perfect now.

Lou.
__________________

R.I.P 10/14/12
33beto is offline   United_States
0
Reply With Quote
      10-24-2012, 07:39 PM   #19
mlifxs
Diamond Geezer
 
mlifxs's Avatar
 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

Posts: 1,616
iTrader: (0)

Garage List
I have this "problem" too though I'm not too concerned. At a stop light, in P or D, will get a low level vibration, but it's not overwhelming. Put it in N, it goes away.
mlifxs is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:28 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST