E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Headlight wasn't leveling - Fixed!



Reply
 
Thread Tools Search this Thread
      03-05-2012, 07:38 PM   #45
BKV122
Major
 
BKV122's Avatar
 
Drives: E90
Join Date: Feb 2009
Location: NY

Posts: 1,088
iTrader: (1)

Garage List
2006 330xi  [4.75]
Could be the actual motor in the housing or one of the leveling sensors.
__________________

Monaco Blue 330xi - Terra Interior/6-MT/Sport/Premium/Cold/CSL's/M3 Spoiler Lip/Black Kidney's
BKV122 is offline   United_States
0
Reply With Quote
      03-06-2012, 12:00 AM   #46
grahamn214
Captain
 
Drives: BMW 328xi
Join Date: Oct 2011
Location: Edmonton, Canada

Posts: 43
iTrader: (0)

Garage List
2008 328Xi  [0.00]
I seem to have the opposite problem. My lights auto adjust up and down at car start up but I find that they don't swivel left and right around corners. Maybe I don't have that option, but i thought that if you have the Xenons then you automatically have the automatic cornering ability. I also have the A on the light control round thing on the dashboard. Any ideas anyone???

Quote:
Originally Posted by timmahh View Post
- Sorry this is such a long post; just want to make sure it was detailed! -

The night I bought my car I got on the freeway and realized the driver headlight was lighting up the sky, I manually adjusted it down but it would shake on every bump and during initial startup it wouldn't adjust up/down [self check]. Left to right movement is fine on turns, but again, no height adjustment.

Car went to the dealer on Wednesday for a few things including the headlight, when I picked it up they said everything was fine. I explained the situation but they assured me they saw no fault codes, so it was operating as it should. I explained again that it isn't leveling itself, however adaptive movement is fine, and the tech told me they don't do that - only left to right movement.

I said fine and took the car back, I know people on here mentioned some arm/bracket connected to the lower control arm that attached to the headlight.. FYI there isn't one.

There is a small arm on the left and right front suspension that connects to a servo/data input kinda box.. this is what sends the info to the headlight servo, there's no physical connection to the headlight. There should also be two in the back that monitor load weight to adjust headlights so they aren't blinding anyone.

I decided to try and figure out what the hell was wrong with my light, I didn't want the dealer to spend hours looking at things and say they couldn't find anything.

So here's what I found:

1) The adjustment screws are independent of the Left-Right and Up-Down movement. Use those to aim properly, it shouldn't affect the automatic movement.

2) I took the bumper off and then took the headlight out, there are two servos in the headlight that control movement. The servo attached to the Up-Down movement was popped out of place.

This explains why it wouldn't level, and why the dealer says everything was fine -- because as far as the electronics go it's all fine.. That's also what irritates me, I explained to the tech if something was physically disconnected but the electronics were fine, the computer wouldn't know.. but again, they just assured me it was working as intended.


Hopefully this helps anyone who may be having an issue!

Picture 1: You can see the ball is close but not in the socket


Picture 2: This is end that should be in the socket


Picture 3: This is the socket side of the headlight



To fix it I unplugged the servo motor, it comes out just like a bulb, small turn counter clock wise to remove it. I adjusted the height manually until it was at the end of the screw [visible from inside], figured that might move it further out a little and help with getting it popped back in.

To pop the ball back in you'll want to kinda put the servo in at an angle so the ball end is sitting on the top of socket, then use a flathead to pop it back into the socket all the way. Push the servo back in the rest of way, tighten and reconnect all wires, then fire the lights up to make sure it works. If so, put your baby back together and you're all set!
grahamn214 is offline   Canada
0
Reply With Quote
      03-06-2012, 12:47 AM   #47
JimVR4
Second Lieutenant
 
JimVR4's Avatar
 
Drives: 09 328i M-Sport 6MT
Join Date: Nov 2011
Location: San Jose, CA

Posts: 289
iTrader: (0)

Quote:
Originally Posted by grahamn214
I seem to have the opposite problem. My lights auto adjust up and down at car start up but I find that they don't swivel left and right around corners. Maybe I don't have that option, but i thought that if you have the Xenons then you automatically have the automatic cornering ability. I also have the A on the light control round thing on the dashboard. Any ideas anyone???

Quote:
Originally Posted by timmahh View Post
- Sorry this is such a long post; just want to make sure it was detailed! -

The night I bought my car I got on the freeway and realized the driver headlight was lighting up the sky, I manually adjusted it down but it would shake on every bump and during initial startup it wouldn't adjust up/down [self check]. Left to right movement is fine on turns, but again, no height adjustment.

Car went to the dealer on Wednesday for a few things including the headlight, when I picked it up they said everything was fine. I explained the situation but they assured me they saw no fault codes, so it was operating as it should. I explained again that it isn't leveling itself, however adaptive movement is fine, and the tech told me they don't do that - only left to right movement.

I said fine and took the car back, I know people on here mentioned some arm/bracket connected to the lower control arm that attached to the headlight.. FYI there isn't one.

There is a small arm on the left and right front suspension that connects to a servo/data input kinda box.. this is what sends the info to the headlight servo, there's no physical connection to the headlight. There should also be two in the back that monitor load weight to adjust headlights so they aren't blinding anyone.

I decided to try and figure out what the hell was wrong with my light, I didn't want the dealer to spend hours looking at things and say they couldn't find anything.

So here's what I found:

1) The adjustment screws are independent of the Left-Right and Up-Down movement. Use those to aim properly, it shouldn't affect the automatic movement.

2) I took the bumper off and then took the headlight out, there are two servos in the headlight that control movement. The servo attached to the Up-Down movement was popped out of place.

This explains why it wouldn't level, and why the dealer says everything was fine -- because as far as the electronics go it's all fine.. That's also what irritates me, I explained to the tech if something was physically disconnected but the electronics were fine, the computer wouldn't know.. but again, they just assured me it was working as intended.


Hopefully this helps anyone who may be having an issue!

Picture 1: You can see the ball is close but not in the socket


Picture 2: This is end that should be in the socket


Picture 3: This is the socket side of the headlight



To fix it I unplugged the servo motor, it comes out just like a bulb, small turn counter clock wise to remove it. I adjusted the height manually until it was at the end of the screw [visible from inside], figured that might move it further out a little and help with getting it popped back in.

To pop the ball back in you'll want to kinda put the servo in at an angle so the ball end is sitting on the top of socket, then use a flathead to pop it back into the socket all the way. Push the servo back in the rest of way, tighten and reconnect all wires, then fire the lights up to make sure it works. If so, put your baby back together and you're all set!
You say your switch has the A. Are you switching it all the way to that setting?
__________________
2009 E90 328i ///M-Sport / Blue Water Metallic / Oyster/Black Dakota / PP / 6MT / 194M / Comfort / iPod+USB w/ProClip charging dash mount / $494 /
1995 3000GT Spyder VR4
JimVR4 is offline   United_States
0
Reply With Quote
      03-06-2012, 02:28 AM   #48
keriindhauz
Registered
 
Drives: 2011 Acura MDX Technology
Join Date: Feb 2012
Location: New York

Posts: 3
iTrader: (0)

if you're still under warranty you have to bring this to service and get it fixed. it think it's the best thing to do now.
__________________
keriindhauz is offline  
0
Reply With Quote
      03-06-2012, 04:46 AM   #49
jvsxn
Lieutenant Colonel
 
jvsxn's Avatar
 
Drives: e-ninety
Join Date: Jul 2011
Location: San Jose, CA

Posts: 1,717
iTrader: (8)

Send a message via AIM to jvsxn
I think I might be experiencing this as well.. Thanks in advance if that's the case!
__________________
Hiatus
jvsxn is offline   United_States
0
Reply With Quote
      03-09-2012, 12:16 PM   #50
markk132
Enlisted Member
 
Drives: '07 335xi
Join Date: Mar 2010
Location: North Jersey

Posts: 36
iTrader: (0)

my passenger side headlight is pointed to the floor and when i turn the car on, it seems to be demented when it auto levels. it kind of moves in the opposite direction than the driver side headlight which moves up then down. the passenger one kind of moves down then up but very slightly, its odd. plus the adjustment screw doesn't work. regardless, gonna try to remove the bumper and headlight and tomorrow and i'm guessing this is probably the issue. but i don't have many tools. can i remove the headlight and bumper with just a phillips screw driver and flat head screw driver?? does anybody know what tools are needed for the removal of bumper and headlight? i saw the DIYs and printed them (many thanks to the people who wrote those up) but they didn't mention what tools are needed. Thanks in advance for any help.
markk132 is offline   United_States
0
Reply With Quote
      03-09-2012, 03:59 PM   #51
BKV122
Major
 
BKV122's Avatar
 
Drives: E90
Join Date: Feb 2009
Location: NY

Posts: 1,088
iTrader: (1)

Garage List
2006 330xi  [4.75]
Quote:
Originally Posted by markk132 View Post
my passenger side headlight is pointed to the floor and when i turn the car on, it seems to be demented when it auto levels. it kind of moves in the opposite direction than the driver side headlight which moves up then down. the passenger one kind of moves down then up but very slightly, its odd. plus the adjustment screw doesn't work. regardless, gonna try to remove the bumper and headlight and tomorrow and i'm guessing this is probably the issue. but i don't have many tools. can i remove the headlight and bumper with just a phillips screw driver and flat head screw driver?? does anybody know what tools are needed for the removal of bumper and headlight? i saw the DIYs and printed them (many thanks to the people who wrote those up) but they didn't mention what tools are needed. Thanks in advance for any help.
Your going to need a metric wrench and possibly socket set to get everything off. A standard set would work as well but wont fit snug on the bolt heads. The tools needed should be in the DIY's you found.
__________________

Monaco Blue 330xi - Terra Interior/6-MT/Sport/Premium/Cold/CSL's/M3 Spoiler Lip/Black Kidney's
BKV122 is offline   United_States
0
Reply With Quote
      03-09-2012, 05:08 PM   #52
markk132
Enlisted Member
 
Drives: '07 335xi
Join Date: Mar 2010
Location: North Jersey

Posts: 36
iTrader: (0)

Quote:
Originally Posted by BKV122 View Post
Your going to need a metric wrench and possibly socket set to get everything off. A standard set would work as well but wont fit snug on the bolt heads. The tools needed should be in the DIY's you found.
would a set like this be good?

http://www.homedepot.com/h_d1/N-5yc1...keyword=metric wrench&storeId=10051

sorry i'm SOOOOOOO bad when it comes to tools and their names and everything. would i need anything else besides a set like this. what exactly is a socket set? please don't yell at me
markk132 is offline   United_States
0
Reply With Quote
      08-07-2012, 06:13 PM   #53
Ilanoraa
New Member
 
Drives: 2008 335XI
Join Date: Dec 2011
Location: Sterling Hts. Mi.

Posts: 13
iTrader: (0)

Quote:
Originally Posted by BKV122 View Post
Hmm, I'll have to try this since my driver side isn't leveling and is pointing to far down. There are no error icons and the adaptive mode works (turns left and right while driving around turns) Ive been reading about the sensors on the control arms which I've checked yesterday and all look fine. Now i'll have to give this procedure a shot and see what i can find.

Timmah: Were your inner DRL not leveling also? Because mine are'nt along with my xenons? does this Servo control both the DRL and xenon?

They possibly got disconnected because of hitting potholes, which most likey why auto leveling isn't working.
Yup i was looking under my car today and seen the arm hanging down almost dragging on the ground. I did not know what it was so I took it up to the shop and he said it was a arm to my headlap and reconnected it. Also I am going to say it happened when I went over some deep potholes, heard something pop, thought it was suspension damage, must of been the arm popping out.
Ilanoraa is offline   United_States
0
Reply With Quote
      08-07-2012, 06:17 PM   #54
Ilanoraa
New Member
 
Drives: 2008 335XI
Join Date: Dec 2011
Location: Sterling Hts. Mi.

Posts: 13
iTrader: (0)

Quote:
Originally Posted by 83k View Post
i'm having the same problem for my passenger headlight.
http://imageshack.us/photo/my-images/811/photo1muc.jpg/
^ bulb popped out of the socket.

Is there anyway to fix this problem without removing the bumper and the whole headlight?
Has to be the shop fixed it in less than 10 min or did a half a@@ job.
Ilanoraa is offline   United_States
0
Reply With Quote
      08-27-2012, 09:24 AM   #55
Nitro8472
New Member
 
Drives: 2010 330i
Join Date: Aug 2012
Location: Egypt

Posts: 6
iTrader: (0)

Let me make sure I understand correctly; The front sensors are for adaptive lights while the rears are for auto leveling?!

And may I ask where are the adjustment screws?! Are they on the headlights themselves?!

Also where exactly is that yellow ball, I'm still not familiar enough with the car to tell from the close-up picture!
Nitro8472 is offline   Egypt
0
Reply With Quote
      08-27-2012, 11:12 AM   #56
BKV122
Major
 
BKV122's Avatar
 
Drives: E90
Join Date: Feb 2009
Location: NY

Posts: 1,088
iTrader: (1)

Garage List
2006 330xi  [4.75]
The adjustment screws are found on the headlight housing, i believe the up and down screw is on top of the housing, while the left to right screw is on the back of the housing and not accessible if the headlight housing is still attached to the car.
THe yellow ball is in the headlight housing its self you need to remove the headlight and the back cover to look inside. Post #43 has the back of the housing off, the ball is attached to that silver round thing farthest to the left
http://www.e90post.com/forums/showpo...9&postcount=43
__________________

Monaco Blue 330xi - Terra Interior/6-MT/Sport/Premium/Cold/CSL's/M3 Spoiler Lip/Black Kidney's
BKV122 is offline   United_States
0
Reply With Quote
      09-01-2012, 01:55 AM   #57
XYR03
Lieutenant Colonel
 
Drives: M3
Join Date: Sep 2007
Location: Richmod, VA

Posts: 1,659
iTrader: (6)

My headlights are currently point way to low and it seems like it all happened after I put on the coils on my car. I havn't had a chance to check the arms that connects to the contorl arms but I'm sure one of them is off. I remember putting the driver side back on but I wasn't aware of the passanger side also having one since there were 4 people working on the car. Lets hope its a simple as reconnecting the small arms.
__________________
XYR03 is offline  
0
Reply With Quote
      10-14-2012, 07:19 PM   #58
vapore0n
Lieutenant
 
Drives: 2010 335i
Join Date: Jul 2011
Location: MA

Posts: 413
iTrader: (0)

Quote:
Originally Posted by Bmwe90sg View Post
i have the same problem only pointing way to low on passenger side. however i have normal LCI Xenons NO ADAPTIVE. does this still work for me?
Did you try adjusting using the adjustment screws first?
vapore0n is offline  
0
Reply With Quote
      10-14-2012, 10:10 PM   #59
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

Posts: 18,275
iTrader: (5)

Send a message via Yahoo to cn555ic
Happens because of major bump or pothole causing the joint to pop out..
__________________
917-939-4980 CODING E and F Series New York Area

cn555ic is offline   United_States
0
Reply With Quote
      10-18-2012, 05:12 PM   #60
timmahh
ghey
 
timmahh's Avatar
 
Drives: Viertürigen Fahrzeugs
Join Date: Oct 2010
Location: Southern California

Posts: 1,111
iTrader: (0)

^ Sounds like you need a new housing.. maybe check ebay for some scrap headlights that you can get parts out of.. but meh, the odds don't look great.
__________________

The females confuse me.
timmahh is offline   United_States
0
Reply With Quote
      11-14-2012, 04:59 PM   #61
Yzandrl
newbie.
 
Yzandrl's Avatar
 
Drives: Alpine Weiss 330i
Join Date: Sep 2006
Location: Stuttgart

Posts: 56
iTrader: (0)

Adaptive Headlight issue

I had an issue with left headlight (dealer broke the cover tab and water got in). They fixed it by putting a new cover on correctly a few days later but a few months later the light stopped working and wouldn't light up. Took it back and then I had a new SMC(adaptive headlight control module), a new control Xenon bulb ignition unit(ballast), and D1S bulb(plus igniter).

It auto levels at start up but the light won't turn left-right for the adaptive feature. However the right works fine. I don't see any incorrect coding when we pulled it from the FRM module. Also, shouldn't it be an all or nothing issue when it comes to having it in the VO and coding?

There are no codes and the dealer now wants to replace the whole headlight assembly. They think it is a motor. I don't know how it was damaged for sure as I remember it working before it went out but is it possible it has popped out and this is a physical issue? The dealer broke a cover, bulb, and wire that they replaced. Perhaps they ham-handed this as well and I could fix it with a little bit of epoxy and fiddling.
How could I diagnose? I look at diagrams and they all show the vertical aim stepper motor, but nothing shows a horizonal aim stepper motor. Also, I see when the car is off it appears the light is off center compared to the right one. It aims a little to the side away from the center.

Any ideas?
Yzandrl is offline   Germany
0
Reply With Quote
      05-18-2013, 08:18 PM   #62
avol3xo
Lieutenant
 
avol3xo's Avatar
 
Drives: 2011 E92 335i
Join Date: Jul 2012
Location: Montgomery, AL

Posts: 519
iTrader: (0)

Garage List
2011 BMW 335i  [0.00]
I have this problem after lowering spring installation, where are the actual leveling sensors? and is there anything that could have been disconnected around the suspension? When I turn on the car the lights go through the low high routine then immediately shine straight down and stay there, they still go left and right.
__________________
2011 BMW 335i E92 Vermillion Red, 6MT
avol3xo is online now  
0
Reply With Quote
      05-18-2013, 08:24 PM   #63
Das_Stig
I don't drink water. Fish fuck in it.
 
Das_Stig's Avatar
 
Drives: e90 335xi
Join Date: Nov 2012
Location: Some say he naturally faces magnetic north, and that all of his legs are hydraulic...

Posts: 839
iTrader: (1)

this happened to me before, luckily i was under warranty and they replaced the headlight for a brand new one. even though they were beetchy about it. good to know about this if it happens again, thanks for the info!
__________________

oem blacklines, m3 rep front. waiting for install oem m3 sides... coming soon. csl trunk mtech rear and more.
Das_Stig is offline  
0
Reply With Quote
      06-04-2013, 10:56 PM   #64
timmahh
ghey
 
timmahh's Avatar
 
Drives: Viertürigen Fahrzeugs
Join Date: Oct 2010
Location: Southern California

Posts: 1,111
iTrader: (0)

Quote:
Originally Posted by avol3xo View Post
I have this problem after lowering spring installation, where are the actual leveling sensors? and is there anything that could have been disconnected around the suspension? When I turn on the car the lights go through the low high routine then immediately shine straight down and stay there, they still go left and right.
The L-R component is connected to the driver side front suspension

The Up/Down is located on the rear suspension, I think on the right side. Determines how much the back of the car is raised/lowered due to weight/load and adjusts lights up/down accordingly.
__________________

The females confuse me.
timmahh is offline   United_States
0
Reply With Quote
      06-05-2013, 04:39 PM   #65
avol3xo
Lieutenant
 
avol3xo's Avatar
 
Drives: 2011 E92 335i
Join Date: Jul 2012
Location: Montgomery, AL

Posts: 519
iTrader: (0)

Garage List
2011 BMW 335i  [0.00]
Quote:
Originally Posted by timmahh View Post
The L-R component is connected to the driver side front suspension

The Up/Down is located on the rear suspension, I think on the right side. Determines how much the back of the car is raised/lowered due to weight/load and adjusts lights up/down accordingly.
Thanks man, I ended up jacking the car up to see if anything was out of place and I immediately noticed the leveling arm wasn't connected so I fixed it. Thanks for the reply
__________________
2011 BMW 335i E92 Vermillion Red, 6MT
avol3xo is online now  
0
Reply With Quote
      07-09-2013, 06:45 PM   #66
EverybodyWildOu
Private First Class
 
Drives: 2007 335i
Join Date: Mar 2012
Location: NJ

Posts: 163
iTrader: (0)

Hey Timmahh thanks for the write up. Worked like a charm! Hey and do you still have your G35? (assuming you're the one from G35driver)
EverybodyWildOu is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:04 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST