E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > BIMMERPOST Universal Forums > General BMW News and Cars Discussion > New Owner....with Questions.



Reply
 
Thread Tools Search this Thread
      05-17-2011, 11:39 AM   #1
SOURBIMMA
GRINDIN.....
United_States
0
Rep
2
Posts

 
Drives: WHITE 2000 328i
Join Date: May 2011
Location: BRONX,NEW YORK

iTrader: (0)

Exclamation New Owner....with Questions.

Wassup to everyone,i was given a 2000 bmw 328i as a gift from my father.
This is my first bmw and i love it,the handling is sick.Its nice to join the bmw world.I got a few questions thou...when i got the car the heated seats
didnt work,i was ok with that.Then all of a sudden this morning the buttons on my steering wheel dosent wrk.They were working fine last night now nothing?hope it isnt electrical,its crazy cause when i try to use my signals
the lights blink outside but not inside.could be a fuse?anyway thanx for any info you could provide.Btw im a newbie to bmw's i dont really know nothing about them so i decided to join this forum to learn everything i can.thanx
again.......
Appreciate 0
      05-17-2011, 12:28 PM   #2
SOURBIMMA
GRINDIN.....
United_States
0
Rep
2
Posts

 
Drives: WHITE 2000 328i
Join Date: May 2011
Location: BRONX,NEW YORK

iTrader: (0)

WOW,i guess this forum isnt newbie friendly...
Appreciate 0
      05-17-2011, 03:32 PM   #3
Mark
Administrator
Mark's Avatar
United_States
1889
Rep
4,012
Posts

 
Drives: 1M
Join Date: Mar 2005
Location: USA

iTrader: (1)

Garage List
Well first i'll say with that kinda attitude, you probably wont get too many responses....

Second, this forum isn't specifically geared towards the 2000 328i, so another reason not to get too many takers.

As for your question, its difficult to diagnose electrical issues over the forum, but i've owned that car and a problem like that sounds like something electrical for sure. I know i've had my turn signal fuses go out, but when theyve gone out for me the outside bulb wouldnt keep working. If the bulb goes out, then the blinker will go real fast. Sounds like you have something inbetween, maybee a fuse, maybee faulty wiring.

The best way to find out and get it all fixed is honestly to just goto the dealer. They will plug the car into the computer and have some answers instantly.
__________________
I'll take one please. BMW M3.
Appreciate 0
      05-17-2011, 09:09 PM   #4
pmeloche
Lieutenant Colonel
pmeloche's Avatar
Canada
17
Rep
1,612
Posts

 
Drives: 2013 F25 X3 xDrive35i
Join Date: Feb 2008
Location: Montréal, Canada

iTrader: (0)

Welcome to the BMW world and to this forum in particular. Visit the OT section, it's often hilarious. The general section is going down IMO but it's only my opinion.
__________________

Patrice
2013 F25 X3 xDrive35i Vermillion Red
Appreciate 0
      05-18-2011, 12:07 AM   #5
JayKay335i
Banned
Egypt
77
Rep
5,047
Posts

 
Drives: ///M323 DCT
Join Date: Apr 2009
Location: North Dakota; its best DUHHHHHH

iTrader: (1)

a) wrong forum
b) could you make that paragraph, if you can call it that, any more difficult to read?
c) go get your car fixed
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:16 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST