E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Disturbing Airbag Warning Lamp



Reply
 
Thread Tools Search this Thread
      09-23-2006, 11:54 AM   #1
worlina
Chief
 
worlina's Avatar
 
Drives: 2006 325i TiAg
Join Date: Apr 2005
Location: San Diego, CA

Posts: 47
iTrader: (0)

Disturbing Airbag Warning Lamp

Could you guys tell me which of the TSB's, are the following images referring to? This happens when I have a passenger in the front seat. It's starting to annoy please
(a) 720906 Airbag warning lamp, FC93EB or
(b) 721005 Airbag warning lamp, FC93B4 and/or 93A8
Attached Images
   
worlina is offline   United_States
0
Reply With Quote
      09-24-2006, 05:46 PM   #2
nyc3r
Colonel
 
nyc3r's Avatar
 
Drives: E90
Join Date: Jun 2006
Location: USA

Posts: 2,589
iTrader: (24)

I've seen this once and it was because the passenger wasn't wearing seatbelt.
nyc3r is offline   United_States
0
Reply With Quote
      09-25-2006, 12:50 AM   #3
worlina
Chief
 
worlina's Avatar
 
Drives: 2006 325i TiAg
Join Date: Apr 2005
Location: San Diego, CA

Posts: 47
iTrader: (0)

Quote:
Originally Posted by nyc3r
I've seen this once and it was because the passenger wasn't wearing seatbelt.
For me, the seat belt warning light now comes on even if the passenger had put on the seat belt.

Last edited by worlina; 11-08-2006 at 12:04 AM.
worlina is offline   United_States
0
Reply With Quote
      09-25-2006, 01:12 AM   #4
yamazaho
Wang D.D.S.
 
yamazaho's Avatar
 
Drives: 08' E70 X5, 12' E92 335is
Join Date: Jul 2006
Location: Houston, TX

Posts: 6,937
iTrader: (11)

Garage List
2006 325i  [3.88]
Send a message via MSN to yamazaho
Hey man, you seem to have the EXACT problem as mine... My airbag signal goes off as long as the passanger seat is occupied, and a lotta time it goes off even there's no one on that seat. Both the airbag signal AND the seat belt signal come on when you start the engine, and after driving for like 2 minutes, the airbag signal goes off but the seat belt signal stays on. So if this sounds like your problem, have your car sent to the dealer man. My dealer checked it and told me that it's because the seat mat sensor (or something like that) has gone bad and they need to order the part straight from Germany. It's gonna take them two weeks before they get it..... It's annoying man, I sure love to get rid of that problem. So hopefully you will be able to solve yours ASAP....
yamazaho is offline   Taiwan
0
Reply With Quote
      09-25-2006, 04:02 PM   #5
worlina
Chief
 
worlina's Avatar
 
Drives: 2006 325i TiAg
Join Date: Apr 2005
Location: San Diego, CA

Posts: 47
iTrader: (0)

Thanks for the scoop. I thought it was just mine. We'll see how the dealer here in Spain will treat my US spec 325 when I go in for service. I hope that this is included in the warranty and registering somewhere in the car's memory. I appreciate the help.
worlina is offline   United_States
0
Reply With Quote
      09-26-2006, 12:51 PM   #6
matt20043.0
Private First Class
 
matt20043.0's Avatar
 
Drives: BMW 2006 325i
Join Date: Jul 2006
Location: Modesto, Ca

Posts: 188
iTrader: (0)

Quote:
Originally Posted by yamazaho
Hey man, you seem to have the EXACT problem as mine... My airbag signal goes off as long as the passanger seat is occupied, and a lotta time it goes off even there's no one on that seat. Both the airbag signal AND the seat belt signal come on when you start the engine, and after driving for like 2 minutes, the airbag signal goes off but the seat belt signal stays on. So if this sounds like your problem, have your car sent to the dealer man. My dealer checked it and told me that it's because the seat mat sensor (or something like that) has gone bad and they need to order the part straight from Germany. It's gonna take them two weeks before they get it..... It's annoying man, I sure love to get rid of that problem. So hopefully you will be able to solve yours ASAP....
Exactly what was wrong with mine. Had to wait 2 weeks for part from Germany. Now works perfect.
__________________
2006 325i SG Metallic Premium/Sport
3M Clear Bra, Chrome Tips, Black Line Tail Lights, Flat Black Grille
matt20043.0 is offline   United_States
0
Reply With Quote
      11-07-2006, 08:00 AM   #7
nyc3r
Colonel
 
nyc3r's Avatar
 
Drives: E90
Join Date: Jun 2006
Location: USA

Posts: 2,589
iTrader: (24)

guess that's the fix then... mine is now giving off warning if anyone sits in my front passenger seat... will be taking it in this week. I hope i don't have to wait two weeks for the part.
nyc3r is offline   United_States
0
Reply With Quote
      11-07-2006, 06:19 PM   #8
JIMD1709
Captain
 
JIMD1709's Avatar
 
Drives: 2007 328 Coupe Alpine White
Join Date: Aug 2005
Location: Saint Petersburg, Florida

Posts: 748
iTrader: (8)

Mine was fixed two months ago. No issues since.
JIMD1709 is offline  
0
Reply With Quote
      11-07-2006, 06:20 PM   #9
nyc3r
Colonel
 
nyc3r's Avatar
 
Drives: E90
Join Date: Jun 2006
Location: USA

Posts: 2,589
iTrader: (24)

were they able to fix it the same day or did you have to bring the car back to them once they ordered/received the part.
nyc3r is offline   United_States
0
Reply With Quote
      11-07-2006, 08:16 PM   #10
///Matt
United States Marine
 
///Matt's Avatar
 
Drives: 2007 Dodge Ram 1500
Join Date: Jul 2006
Location: Los Angeles

Posts: 2,749
iTrader: (8)

Garage List
2006 330i  [0.00]
Send a message via AIM to ///Matt
Sounds like a bad seat mat sensor (senses if there's a person in the pass seat, and what weight class they are in).

It's going to take a few days for them to fix this, because they PROBABLY won't have the part in stock. It's a whole new seat cushion, not including the leather/leatherette.

Matt
///Matt is offline   United_States
0
Reply With Quote
      11-07-2006, 09:54 PM   #11
Driv3r
Colonel
 
Driv3r's Avatar
 
Drives: 2006 E46 M3 ZCP
Join Date: May 2005
Location: Miami Beach, FL

Posts: 2,358
iTrader: (8)

Garage List
2006 325i  [0.00]
Quote:
Originally Posted by ///Matt
Sounds like a bad seat mat sensor (senses if there's a person in the pass seat, and what weight class they are in).

It's going to take a few days for them to fix this, because they PROBABLY won't have the part in stock. It's a whole new seat cushion, not including the leather/leatherette.

Matt
Yea, i have that problem and it turns out to be a bad batch of seat mat sensors, but what i was told is that not only do they have to install it but program the new sensor and do a "retrofit"....this service place USUALLY knows what they are talking about and are a great bunch of guys but can you confirm this "retrofit"?
__________________
2006 E46 M3 ZCP 6SPD-Interlagos Blue - 6SPD - SSK - AA Headers -AA Tune - Navigation w/ Splashscreen Mod - 3M Crystalline Series 60 - Carbon Splitters - Swissvax Treated - Bridgestone
2012 Yamaha FZ8 - Matte Black/Grey - Michelin Pilot Pure 2CT - Vortex Rear Sets - Yoshimura R-77D & Fender Delete - Spectro Race Oil - GP Reverse Shifting
Driv3r is offline   United_States
0
Reply With Quote
      11-07-2006, 11:26 PM   #12
zzinco79
Major
 
zzinco79's Avatar
 
Drives: 2006 BMW 325i
Join Date: Nov 2005
Location: Rochester, NY

Posts: 1,412
iTrader: (8)

Send a message via MSN to zzinco79
Quote:
Originally Posted by ///Matt
Sounds like a bad seat mat sensor (senses if there's a person in the pass seat, and what weight class they are in).

It's going to take a few days for them to fix this, because they PROBABLY won't have the part in stock. It's a whole new seat cushion, not including the leather/leatherette.

Matt

Under warrenty?
__________________


2006 BSM 325i / ZPP / ZSP / Adaptive Xenon / BLK leather interior / Steptronic

Eisenmann racing / K&N Ram charger / M5 rep. wheels / D1S 6000k / Brex white ring / OEM style rear trunk spoiler / M steering / OEM strut bar / Blk line tail light

Future Mod

Hamann lip spolier / Mtech rear bumper
zzinco79 is offline  
0
Reply With Quote
      11-08-2006, 12:01 AM   #13
worlina
Chief
 
worlina's Avatar
 
Drives: 2006 325i TiAg
Join Date: Apr 2005
Location: San Diego, CA

Posts: 47
iTrader: (0)

You guys that are having similar problem, is your E90 a pre-September 2005 build?
worlina is offline   United_States
0
Reply With Quote
      11-08-2006, 04:28 AM   #14
///Matt
United States Marine
 
///Matt's Avatar
 
Drives: 2007 Dodge Ram 1500
Join Date: Jul 2006
Location: Los Angeles

Posts: 2,749
iTrader: (8)

Garage List
2006 330i  [0.00]
Send a message via AIM to ///Matt
Yes, under warranty.

I don't beleive it needs programming/retrofit, but it DOES need to be activated via computer.
///Matt is offline   United_States
0
Reply With Quote
      11-08-2006, 07:13 AM   #15
nyc3r
Colonel
 
nyc3r's Avatar
 
Drives: E90
Join Date: Jun 2006
Location: USA

Posts: 2,589
iTrader: (24)

under warranty, mine is a july 06 build.
nyc3r is offline   United_States
0
Reply With Quote
      11-08-2006, 08:54 AM   #16
JIMD1709
Captain
 
JIMD1709's Avatar
 
Drives: 2007 328 Coupe Alpine White
Join Date: Aug 2005
Location: Saint Petersburg, Florida

Posts: 748
iTrader: (8)

It is under warranty of course. On mine they replaced the whole bottom seat leather and all. I guess it's all one part. I noticed it right away, because it was new and very "dry". I had conditioned all the other leather, so it jumped right out at me.
JIMD1709 is offline  
0
Reply With Quote
      11-08-2006, 11:06 AM   #17
mds82
Major General
 
mds82's Avatar
 
Drives: 2006 325xi
Join Date: Aug 2005
Location: South Central Connecticut

Posts: 5,837
iTrader: (40)

Garage List
Send a message via AIM to mds82 Send a message via Yahoo to mds82
Same Problem with mine lately!!! september build on my 325xi.
__________________

19" Breyton Race GTS Matt Grey, Eisenmann 4x70 Exhaust with SR Pipes. Vorsteiner Hood, Bilstein Shocks, CFEverywhere, mtec rear,
Carbon Fiber Headlights
mds82 is offline  
0
Reply With Quote
      02-08-2007, 01:07 AM   #18
ctgazer
Major General
 
ctgazer's Avatar
 
Drives: a dilapidated ride
Join Date: Feb 2006
Location: canada eh!

Posts: 7,952
iTrader: (10)

Garage List
2006 e90  [0.00]
Send a message via MSN to ctgazer
yah, so i guess i have the same problem...just noticed it tonight...kinda didnt pay attention but guess i did see the light near the sun-roof light up everytime i put a bag on there...it says "passenger airbag off" when someone sits in it...isnt it supposed to be on opposed to it being lit when no one is in it? gotta make an appointment tomorrow now...sucky:mad: i hate being without my car
__________________
ctgazer is offline   Canada
0
Reply With Quote
      02-08-2007, 01:22 AM   #19
klinkerklu
Respect my Authoritay
 
klinkerklu's Avatar
 
Drives: 330xi ED
Join Date: Nov 2006
Location: SF Bay

Posts: 223
iTrader: (0)

Garage List
2006 330xi ED  [0.00]
Ours was fixed last month. (may '06 build)The car was in 2 days only. I didn't realize they had to replace the whole cushion tho until I sat in it and realized how much firmer the bottom was! Jeez they break down fast!
__________________
330xi | 6-speed | Sparkling Graphite | Sport Package | iPod Adapter| BlackLines| F1 Pinnacle 35%
klinkerklu is offline   United_States
0
Reply With Quote
      02-08-2007, 03:42 AM   #20
thissnsooosucks
noob saibot
 
thissnsooosucks's Avatar
 
Drives: E90 jet black
Join Date: Oct 2005
Location: Pasadena & Arcadia

Posts: 295
iTrader: (4)

Garage List
2006 325i  [0.00]
i guess a good chunk of us have/had this problem. i've just kinda forgotten about it b/c it doesn't happen all the time.
__________________
thissnsooosucks is offline  
0
Reply With Quote
      02-08-2007, 07:44 AM   #21
nyc3r
Colonel
 
nyc3r's Avatar
 
Drives: E90
Join Date: Jun 2006
Location: USA

Posts: 2,589
iTrader: (24)

bring it to the dealer and they'll replace the passenger side seat sensor and you're all good to go.
nyc3r is offline   United_States
0
Reply With Quote
      02-08-2007, 11:56 AM   #22
ctgazer
Major General
 
ctgazer's Avatar
 
Drives: a dilapidated ride
Join Date: Feb 2006
Location: canada eh!

Posts: 7,952
iTrader: (10)

Garage List
2006 e90  [0.00]
Send a message via MSN to ctgazer
yah i got an appointment for next tuesday...they'll look at ti and give me a loaner....man i hope i got my car for valentines day
__________________
ctgazer is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:09 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST