E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > lost power steering??



Reply
 
Thread Tools Search this Thread
      02-13-2012, 09:08 AM   #1
poloace
Second Lieutenant
6
Rep
225
Posts

 
Drives: 09 335xi coupe
Join Date: Jan 2009
Location: upstate, ny

iTrader: (0)

lost power steering??

was driving home in the snow yesterday... thought I accumulated a little snow in the wheels (which melted overnight) - and this am... still no power steering.... car is still
under warranty- but, anyone ever have this happen? thanks all.
Appreciate 0
      02-13-2012, 09:32 AM   #2
enrita
Major General
enrita's Avatar
Sweden
94
Rep
7,331
Posts

 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

yeah could be the belt. check engine bay , battery will go down very fast as well if its the belt.
happened twice to me.
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
Appreciate 0
      02-13-2012, 10:56 AM   #3
poloace
Second Lieutenant
6
Rep
225
Posts

 
Drives: 09 335xi coupe
Join Date: Jan 2009
Location: upstate, ny

iTrader: (0)

wondering if it's the pump...? I don't even hear it making the normal sound it does.
Appreciate 0
      02-14-2012, 01:39 AM   #4
Railgun
Major
Railgun's Avatar
United Kingdom
16
Rep
1,374
Posts

 
Drives: FD, CBR600RR, R56 JCW
Join Date: Mar 2007
Location: London

iTrader: (2)

Send a message via ICQ to Railgun Send a message via AIM to Railgun Send a message via MSN to Railgun Send a message via Yahoo to Railgun Send a message via Skype™ to Railgun
If it was the belt, you'd have many bells and whistles going off. My belt shredded as I was about 200 ft from home and it definitely let me know.

You'll know if it's a belt. Its possible it could be pump related. Either way, call the dealer if it's under warranty.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:48 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST