E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Rough Idle, stumbling rpms



Reply
 
Thread Tools Search this Thread
      03-10-2012, 10:11 AM   #133
BMR335
New Member
 
Drives: 2007 335i e92
Join Date: Jan 2011
Location: Philadelphia, PA

Posts: 13
iTrader: (0)

I have had this exact same issue, both with and without my COBB AP installed, for the past 8k miles. I am a 2/07 build, auto transmission, with 35k miles. I use bottles of Techron from time to time and it does seem to decrease the frequency for awhile, but invariably the stumbling comes back.
I was picking Jason@Cobb's brain about this, and he suggested getting the injectors cleaned at the dealership with their specially designed crushed-walnut-shell blaster...
I see that a few on here have tried this, but without full resolution for those who have posted. Has it resolved the issue for anyone?

Last edited by BMR335; 03-10-2012 at 10:23 AM. Reason: misread prior posts
BMR335 is offline   United_States
0
Reply With Quote
      03-10-2012, 11:30 AM   #134
gdawg20001
Private
 
gdawg20001's Avatar
 
Drives: Black Sapphire Metallic 335i
Join Date: May 2011
Location: Orlando FL

Posts: 74
iTrader: (2)

Glad I've come across this thread but amazed at how many people have this issue with no resolution.

I too replaced plugs about 2k miles ago and have also been experiencing these hiccups and stumbles ever since.

Car has been running a procede for approx. the last 30k miles and the newest V5 for the last 5k. No issues at all until changing plugs.

Subscribed and interested to see if anyone finds a solution.

Although, it doesn't seem to fix the issue, I know I'm due for a cleaning... What's the walnut shell blasting seem to run most people?
__________________
_____________________________
gdawg20001 is offline  
0
Reply With Quote
      03-10-2012, 12:37 PM   #135
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,463
iTrader: (1)

Garage List
2008 335xi  [0.00]
Both of my walnut shell blastings were great for performance, but didn't help the blip, and were done underwarranty. Shouldn't cost more than a few hundred bucks, but I'm not sure.

I'm on 6 new inectors and plugs right now and my last valve cleaning was pretty recent,and I have still have it.
AWD Addict is offline  
0
Reply With Quote
      03-20-2012, 08:57 PM   #136
DriM3
Private
 
DriM3's Avatar
 
Drives: 2008 335i
Join Date: May 2011
Location: CT

Posts: 69
iTrader: (0)

jesus christ this is awful!!....mine too just started acting funny today. its the second warm week we've had this season and while out on a drive it just randomly started vibrating.

Im in shock that there seems to be no answer on how to fix this
DriM3 is offline  
0
Reply With Quote
      03-21-2012, 09:22 AM   #137
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,199
iTrader: (11)

Mine to now, Had MY HPFP replaced yesterday, (Still have long starts??) but I have replaced plugs, coils and my build date is a 11/01/06 335i. Before my fuel pump was replaced I had misfires on cyl 2 & 5. I am still getting that hesitation/hiccup/jolt at idle. sucks is the only word to discribe it. How much would injectors cost out of pocket? probally $400.00-$500.00 a piece I am guessing.
robc1976 is offline  
0
Reply With Quote
      03-21-2012, 09:29 AM   #138
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,318
iTrader: (0)

Quote:
Originally Posted by robc1976 View Post
Mine to now, Had MY HPFP replaced yesterday, (Still have long starts??) but I have replaced plugs, coils and my build date is a 11/01/06 335i. Before my fuel pump was replaced I had misfires on cyl 2 & 5. I am still getting that hesitation/hiccup/jolt at idle. sucks is the only word to discribe it. How much would injectors cost out of pocket? probally $400.00-$500.00 a piece I am guessing.
http://www.ebay.com/sch/i.html?_from...585261+&_fvi=1
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      03-21-2012, 09:41 AM   #139
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,463
iTrader: (1)

Garage List
2008 335xi  [0.00]
dead linky ^
AWD Addict is offline  
0
Reply With Quote
      03-21-2012, 09:43 AM   #140
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,199
iTrader: (11)

Quote:
Originally Posted by enrita View Post
Thanks!!
robc1976 is offline  
0
Reply With Quote
      03-21-2012, 09:43 AM   #141
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,199
iTrader: (11)

Quote:
Originally Posted by AWD Addict View Post
dead linky ^
Didn't work on phone but worked on PC.
robc1976 is offline  
0
Reply With Quote
      03-21-2012, 09:47 AM   #142
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,199
iTrader: (11)

Here also: (Brand new)...not a bad price! this for a 2007 though.

http://www.trademotion.com/parts/200...onent=INJECTOR
robc1976 is offline  
0
Reply With Quote
      03-21-2012, 09:48 AM   #143
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,463
iTrader: (1)

Garage List
2008 335xi  [0.00]
Jesus. $600 for a full set of injectors.

*gag
AWD Addict is offline  
0
Reply With Quote
      03-21-2012, 10:19 AM   #144
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,199
iTrader: (11)

Quote:
Originally Posted by AWD Addict View Post
Jesus. $600 for a full set of injectors.

*gag
BMW Quoted me $497.00 per injector!!!!

Total of $2,982 (installed maybe??) F-that!! for that price I will deal with the studder LOL!!
robc1976 is offline  
0
Reply With Quote
      03-21-2012, 10:30 AM   #145
Syndicategt
Brigadier General
 
Syndicategt's Avatar
 
Drives: 335i
Join Date: Sep 2009
Location: Nor Cal

Posts: 3,732
iTrader: (11)

Quote:
Originally Posted by robc1976 View Post
BMW Quoted me $497.00 per injector!!!!

Total of $2,982 (installed maybe??) F-that!! for that price I will deal with the studder LOL!!
Are you sure that didn't include plugs,coils, and install? Either way, it's a rip off as install and coding are super easy.
__________________
2008 BMW 335i e90 - Sold - Rob Beck Turbos / PROcede V5 / Aquamist HFS-4 / AR Downpipes / AE Exhaust / ER Comp FMIC / ER CP / TiAL BOV / Custom Intake / RPI Scoops / Quaife LSD / Swift-Koni Coilovers / DSS HS / Morr VS8.2 Sig Black / Michelin PSS / P3 Boost Guage / M3 body / M3 steering wheel / Adam's Rotors / Hawk HPS / SS lines /
Syndicategt is offline   United_States
0
Reply With Quote
      03-21-2012, 10:36 AM   #146
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,463
iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by robc1976 View Post
BMW Quoted me $497.00 per injector!!!!

Total of $2,982 (installed maybe??) F-that!! for that price I will deal with the studder LOL!!
Thieves!

Won't fix the studder anyhow. I'm on all new injectors and plugs. We've ruled those out as the culprit. There's a definite relation to the ECU adaptations I think. WHenever my car is re-flashed, it's good for a couple days, then it slowly comes back.
AWD Addict is offline  
0
Reply With Quote
      03-21-2012, 10:53 AM   #147
marv85
Colonel
 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

Posts: 2,558
iTrader: (4)

Quote:
Originally Posted by robc1976 View Post
BMW Quoted me $497.00 per injector!!!!

Total of $2,982 (installed maybe??) F-that!! for that price I will deal with the studder LOL!!
buy the injectors from ECStuning or Tischer, follow Vasillalov's DIY and you're good to go for ~800$
__________________
'10 E92 335i , COBB
marv85 is offline   United_States
0
Reply With Quote
      03-23-2012, 01:43 AM   #148
prelude2perfect
First Lieutenant
 
Drives: 2007 335i Sedan
Join Date: Apr 2010
Location: Tacoma

Posts: 344
iTrader: (6)

Same issue here. No codes so BMW said they can't fix anything under warranty without a code. Spark plugs were replaced by myself a while ago but, I don't remember if that is when it started running rough or not. I was definitely thinking injectors or hpfp but, I'm clueless now. Maybe I should reset the adaptions? I dunno

Wish someone would figure this out. If I was throwing a misfire code at least I could focus on the problem but, with no codes I have to check everything. I'll be checking coils next but, they have been replaced in the past under warranty. Injectors and HPFP have been replaced long before the problem started. Maybe it was the new plugs that caused it. I'm at 68k miles FYI
__________________

'07 6MT Sports Package l RB Turbos l JB4 G5 l AA IC, CP, BOV l Modified Injen DCI l M2 Dual 3" Exhaust l Raceland DP's l Addicted to Meth
prelude2perfect is offline  
0
Reply With Quote
      03-23-2012, 01:55 AM   #149
PR3CI5N
need4speed
 
PR3CI5N's Avatar
 
Drives: 2010 E90 M 335i
Join Date: Jun 2010
Location: West Coast

Posts: 1,155
iTrader: (15)

Sounds more like the LPFP since this is occurring at idle. Doubt it's the HPFP but you're spark plugs could be due for a replacing as well.
__________________
N54
PR3CI5N is offline   United_States
0
Reply With Quote
      03-23-2012, 07:19 AM   #150
Mangler
First Lieutenant
 
Mangler's Avatar
 
Drives: 08' 335i, ZHP 330i
Join Date: Nov 2008
Location: Southeast

Posts: 334
iTrader: (0)

Garage List
88 .  [0.00]
2008 BMW 335i  [0.00]
Interesting. I am taking my car back in today for a full original order to be installed on my ecu so they can then reflash all the possible new updates to try to get rid of this stumbling issue. They have already replaced all the coils/plugs/injectors at the same time with no change. They did find some iffy vacuum hoses that were replaced also. No change. It feels like a lean misfire but no codes.

T
Mangler is offline  
0
Reply With Quote
      03-23-2012, 07:46 AM   #151
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,463
iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by PR3CI5N View Post
Sounds more like the LPFP since this is occurring at idle. Doubt it's the HPFP but you're spark plugs could be due for a replacing as well.
It's not the HPFP, and it's not plugs. Almost everyone in this thread with the problems has newplugs. In fact, it appears the condition tends to arise immediately after new plugs have been added.

The LPFP is interesting.
AWD Addict is offline  
0
Reply With Quote
      03-23-2012, 09:11 AM   #152
Tzu
Major
 
Drives: 335i
Join Date: Jun 2010
Location: Toronto

Posts: 1,438
iTrader: (1)

My idle stumbles have gotten considerably worse after new plugs. Previously, it would only raise RPMs after every 5th or so drive. Now it does it on every startup or after a short drive. Injectors are coded correctly.

I'm going to try cleaning the coil where it contacts the plug head, and I'm beginning to think 17ft.lbs is too much to torque these. Just a theory though. Correct me if I'm wrong, but wasnt there an idle adaptation value in INPA somewhere? I havnt found it yet because my version is still in German.
Tzu is offline   Canada
0
Reply With Quote
      03-23-2012, 09:17 AM   #153
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,199
iTrader: (11)

Quote:
Originally Posted by Tzu View Post
My idle stumbles have gotten considerably worse after new plugs. Previously, it would only raise RPMs after every 5th or so drive. Now it does it on every startup or after a short drive. Injectors are coded correctly.

I'm going to try cleaning the coil where it contacts the plug head, and I'm beginning to think 17ft.lbs is too much to torque these. Just a theory though. Correct me if I'm wrong, but wasnt there an idle adaptation value in INPA somewhere? I havnt found it yet because my version is still in German.
Makes sense, I did the throttle reset and unplugged my battery for 1 hr and the stumble is gone? This could just be the 1X it didn't do it though. I am still getting long starts after my HPFP was installed so it is going back today.
robc1976 is offline  
0
Reply With Quote
      03-23-2012, 11:35 AM   #154
Tzu
Major
 
Drives: 335i
Join Date: Jun 2010
Location: Toronto

Posts: 1,438
iTrader: (1)

I've done an adaptation reset as of two weeks ago chasing down something else. No change in idle sputters. I'll try again soon.

Last edited by Tzu; 03-23-2012 at 11:42 AM.
Tzu is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:29 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST