E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > Service reset DIY



Reply
 
Thread Tools Search this Thread
      01-20-2009, 11:48 AM   #67
kevbhoy
Private First Class
kevbhoy's Avatar
Scotland
6
Rep
105
Posts

Drives: '06 325i SE Coupe
Join Date: May 2005
Location: Aberdeen, Scotland

iTrader: (0)

Send a message via MSN to kevbhoy
Quote:
Originally Posted by bmwbazza View Post
Hi kevbhoy

The garage you used should in all fairness have replaced the sensor at the same time as the pads, and then when resetting the service it would have functioned correctly.

I work at a motor factors in north london and supply to the trade garages in my area and i can honestly say that if they can get away with i.e replacing the sensors for instance (THEY WILL DO).

I would go back and get them to change the sensor and then all will be good.

Regards
Barry
Thanks Barry

Car is booked back in on Thursday. They are saying that it may be a faulty sensor so they are buying in another to try out!
__________________
Current - '06 325i SE Coupe
Previous - '08 330d M Sport
Previous - '05 320i SE
Appreciate 0
      01-21-2009, 03:58 PM   #68
Duhst
That Go
Duhst's Avatar
United_States
81
Rep
7,415
Posts

Drives: AW e90
Join Date: Dec 2008
Location: Vegas?

iTrader: (1)

Garage List
2007 328i  [0.00]
Send a message via AIM to Duhst
worked perfect for me!!

is it possible to get rid of the like error? got new LED license plate light and now its throwing a error....

thanks!
Appreciate 0
      01-21-2009, 05:47 PM   #69
voltron1011
Colonel
voltron1011's Avatar
54
Rep
2,912
Posts

Drives: 2011 135i, FJR-1300
Join Date: Apr 2005
Location: Wiesbaden

iTrader: (2)

Quote:
Originally Posted by Duhst View Post
worked perfect for me!!

is it possible to get rid of the like error? got new LED license plate light and now its throwing a error....

thanks!

I think you need to get a diode to fix that error.
__________________
'06 E90 325i (Delivered May '05) 6-spd manual, Nav, Xenons, 18' 162's, sport-suspension, 15mm RE spacers,
NURBURGRING:
http://www.e90post.com/forums/album.php?albumid=3270
Appreciate 0
      01-23-2009, 12:32 PM   #70
kevbhoy
Private First Class
kevbhoy's Avatar
Scotland
6
Rep
105
Posts

Drives: '06 325i SE Coupe
Join Date: May 2005
Location: Aberdeen, Scotland

iTrader: (0)

Send a message via MSN to kevbhoy
So, outcome of re-visit to garage...

They have managed to get the mileage in the service info reset which is good. However, I still have the red car on the lift, the handbrake light still remains on and I still have the exclamation mark in the triangle next to the odometer.

So, I called the BMW dealer and spoke to the service dept. They think it could be a diagnostics problem (I didn't mention another garage changing my brake pads lol) so it is booked in with them a week on Monday to have a look.

Hopefully it will be a simple reset. Unfortunately, the car is no longer covered under warranty so fingers crossed I don't get a huge bill!!!

__________________
Current - '06 325i SE Coupe
Previous - '08 330d M Sport
Previous - '05 320i SE
Appreciate 0
      03-09-2009, 02:11 PM   #71
dane12
New Member
0
Rep
7
Posts

Drives: BMW 320i
Join Date: Dec 2008
Location: Danmark

iTrader: (0)

Services reset problem

I have switch the spark plugs, with some news, and follow the complete description as written on the website, and it is true that it was reset to 100000km. But my problem is that it will not count down. What have I done wrong.

Last edited by dane12; 04-28-2009 at 05:00 AM.
Appreciate 0
      03-09-2009, 02:55 PM   #72
E90330iS
Major General
Germany
82
Rep
6,325
Posts

Drives: E90 330i
Join Date: Jan 2006
Location: Arcadia, California

iTrader: (56)

Garage List
2006 330i  [0.00]
Send a message via AIM to E90330iS Send a message via MSN to E90330iS Send a message via Skype™ to E90330iS
great great thread! lets keep perfect this with more experiences!
__________________
1. E90 325i/328i/330i Eisenmann Race Exhaust 2 x 76mm (Used for 30000 miles) $680 OBO
2. E90 M3 Jet Black Front Bumper $120 OBO
3. E90 M3 Style CF Trunk Spoiler $80 OBO
Appreciate 0
      03-10-2009, 09:41 PM   #73
CyberGypsy
Lieutenant
CyberGypsy's Avatar
United_States
7
Rep
443
Posts

Drives: 2006 325i
Join Date: Oct 2008
Location: Key West

iTrader: (0)

Just did my microfilter, did it on first try!

Thanks!
Appreciate 0
      03-13-2009, 12:06 PM   #74
cbad335
Lieutenant Colonel
cbad335's Avatar
United_States
35
Rep
1,735
Posts

Drives: '09 E92 335i
Join Date: Jan 2008
Location: Cardiff-by-the-Sea, CA

iTrader: (17)

Garage List
Worked--thank you. But for me, I had to start the engine. Pushing the start button without starting the car did not work. Plus, after entering the service mode, the first choice that came up was the actual one that needed to be reset, ie microfilter. Anyway, saved me the hassles of a trip to the dealer.
__________________

| 6MT | ZSP | ZPP |
Appreciate 0
      03-15-2009, 05:23 PM   #75
RynoDyno312
Private
0
Rep
86
Posts

Drives: 2007 AW 335i Stepronic
Join Date: Feb 2009
Location: Santa Barbara/Orange County, CA

iTrader: (0)

What happens if you accidentally reset a service interval? I was trying to reset my mpg, mph, etc. and I ended up resetting the service interval instead. I don't know what it was before I reset it--do I just have to pay for an oil change soon just to be safe?

Guess I should have looked it up in the manual, LOL.
__________________
Alpine White/Black E90 335i ZSP Stepronic; DCI/JB+
Appreciate 0
      03-16-2009, 11:21 AM   #76
RynoDyno312
Private
0
Rep
86
Posts

Drives: 2007 AW 335i Stepronic
Join Date: Feb 2009
Location: Santa Barbara/Orange County, CA

iTrader: (0)

Any suggestions?
__________________
Alpine White/Black E90 335i ZSP Stepronic; DCI/JB+
Appreciate 0
      03-16-2009, 12:05 PM   #77
voltron1011
Colonel
voltron1011's Avatar
54
Rep
2,912
Posts

Drives: 2011 135i, FJR-1300
Join Date: Apr 2005
Location: Wiesbaden

iTrader: (2)

So, which service interval did you end up resetting? The oil change one?
Do you happen to remember how many miles you had until your next oil change? How many miles on the car now? Are you still under the free service?
Unfortunately, it sounds like you may have hosed yourself out of a free oil change. The dealerships go directly by whatever the interval meter says. So, if you reset it back to 15,000 miles for your next oil change, but you know you need an oil change in 5,000 miles, you may be out of luck.
__________________
'06 E90 325i (Delivered May '05) 6-spd manual, Nav, Xenons, 18' 162's, sport-suspension, 15mm RE spacers,
NURBURGRING:
http://www.e90post.com/forums/album.php?albumid=3270
Appreciate 0
      03-16-2009, 04:58 PM   #78
RynoDyno312
Private
0
Rep
86
Posts

Drives: 2007 AW 335i Stepronic
Join Date: Feb 2009
Location: Santa Barbara/Orange County, CA

iTrader: (0)

Quote:
Originally Posted by voltron1011 View Post
So, which service interval did you end up resetting? The oil change one?
Do you happen to remember how many miles you had until your next oil change? How many miles on the car now? Are you still under the free service?
Unfortunately, it sounds like you may have hosed yourself out of a free oil change. The dealerships go directly by whatever the interval meter says. So, if you reset it back to 15,000 miles for your next oil change, but you know you need an oil change in 5,000 miles, you may be out of luck.
I'm still under 50k so I have the free maintenance. I think I'll just call the dealer since I had it in for service a couple weeks ago and see if they can let me know when to bring it in.

I'm pretty sure it was for the oil change as I think it was around 7k and then went to 14k.
__________________
Alpine White/Black E90 335i ZSP Stepronic; DCI/JB+
Appreciate 0
      03-17-2009, 01:18 PM   #79
RynoDyno312
Private
0
Rep
86
Posts

Drives: 2007 AW 335i Stepronic
Join Date: Feb 2009
Location: Santa Barbara/Orange County, CA

iTrader: (0)

So it indicates I need a service in 7000mi, but the Oil Service indicator reads 14000mi. I guess I'll try and get my oil changed when I go in in 7k.
__________________
Alpine White/Black E90 335i ZSP Stepronic; DCI/JB+
Appreciate 0
      03-23-2009, 07:12 AM   #80
stevez
Registered
0
Rep
1
Posts

Drives: E90 320i SE
Join Date: Mar 2009
Location: South Wales

iTrader: (0)

My MOT is due and don't want to get it done at a dealer. Can I just reset the 'car worthiness' part of the service menu without it affecting anything else, like next service etc.
Appreciate 0
      03-23-2009, 07:15 AM   #81
biscuits
Dimmer than a dim thing
United Kingdom
21
Rep
1,278
Posts

Drives: C63 AMG Coupe
Join Date: Oct 2008
Location: UK

iTrader: (0)

Garage List
Quote:
Originally Posted by stevez View Post
My MOT is due and don't want to get it done at a dealer. Can I just reset the 'car worthiness' part of the service menu without it affecting anything else, like next service etc.
Yes, the dealer forgot to reset our 130i, so in November the light came on. Just scroll through the service menus looking for a car on a ramp with SS, then you can set the date it's due.
Appreciate 0
      03-23-2009, 01:57 PM   #82
voltron1011
Colonel
voltron1011's Avatar
54
Rep
2,912
Posts

Drives: 2011 135i, FJR-1300
Join Date: Apr 2005
Location: Wiesbaden

iTrader: (2)

I just did this to my '06 325i and it worked flawlessly!!
__________________
'06 E90 325i (Delivered May '05) 6-spd manual, Nav, Xenons, 18' 162's, sport-suspension, 15mm RE spacers,
NURBURGRING:
http://www.e90post.com/forums/album.php?albumid=3270
Appreciate 0
      04-03-2009, 03:51 AM   #83
raceing86
Private First Class
raceing86's Avatar
United_States
10
Rep
160
Posts

Drives: '13 335i Sport Melb. Red
Join Date: Apr 2009
Location: Savannah, GA

iTrader: (0)

Garage List
2013 BMW 335i  [5.00]
When I did this to my car to reset the "Inspection" reminder, I noticed that a yellow ABS image came on in the center screen before the service menu popped up.... Just wondering what the ABS thing was all about...

B.T.W. - The reset guides on the first page worked flawlessly for me...
Appreciate 0
      04-09-2009, 09:19 AM   #84
hybris
Private
hybris's Avatar
Norway
2
Rep
68
Posts

Drives: Bmw 320d E90 M-sport
Join Date: Oct 2008
Location: Oslo, Norway

iTrader: (0)

Garage List
2007 320d  [0.00]
Used this tutorial to reset my brake fluid warning after replacing brake fluid - worked exactly like described. Thanks

A small note - it seemed like I had to have my drivers door closed for this to work, as long as the door was open when I pushed start, I just got a huge exclamation mark instead of the regular service info(which you get when you start the engine)
__________________
Thorbjorn
07 BMW E90 320d M-sport
Appreciate 0
      04-13-2009, 01:00 PM   #85
ocomas
New Member
0
Rep
5
Posts

Drives: 435i Convertible
Join Date: Oct 2007
Location: Weston, FL

iTrader: (0)

Does this work for the oil change service too?
Appreciate 0
      04-13-2009, 11:43 PM   #86
voltron1011
Colonel
voltron1011's Avatar
54
Rep
2,912
Posts

Drives: 2011 135i, FJR-1300
Join Date: Apr 2005
Location: Wiesbaden

iTrader: (2)

Quote:
Originally Posted by ocomas View Post
Does this work for the oil change service too?
Yes
__________________
'06 E90 325i (Delivered May '05) 6-spd manual, Nav, Xenons, 18' 162's, sport-suspension, 15mm RE spacers,
NURBURGRING:
http://www.e90post.com/forums/album.php?albumid=3270
Appreciate 0
      04-16-2009, 01:21 PM   #87
ziplex
New Member
0
Rep
14
Posts

Drives: E91 330d
Join Date: Feb 2009
Location: Bristol

iTrader: (0)

I tried this on the 'vehicle check' to see if it will work on mine, wish I hadn't now as it's gone to something like the year 2014 till next one due!!........and I can't get it to reset, god why do I tinker with things? it's due in soon for a 'vehicle check', (unless I can find out whether it's statutorty or not), and i'm going to look a right plonker unless I can think of an excuse or somebody to blame. It works just as described but no matter what I try it won't change now.....advice please?! (car is an E91)

Last edited by ziplex; 04-16-2009 at 02:07 PM.
Appreciate 0
      04-23-2009, 06:20 AM   #88
dane12
New Member
0
Rep
7
Posts

Drives: BMW 320i
Join Date: Dec 2008
Location: Danmark

iTrader: (0)

resseting problems

Hello averybody
i have a problem regarding my BMW 320, year 2006.
i have change the brakes and the sparkling plugs by following the desciption for resseting the counter, that worked perfect.
but the counter do not count after i have resseting it, wherer i follwed the description i have found "Service reset DIY Published by mikem
03-13-2007"
can anybody tell me the reason for this and, howe i can solved the problem so the counter start counting again.
hope for quick respons
Best regards
dane12
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:06 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST