E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > possibly bad battery??



Reply
 
Thread Tools Search this Thread
      04-06-2011, 12:23 AM   #1
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

possibly bad battery??

So I recently found out the when i unlocked the car with remote, the taillights didn't come on anymore and then I got a battery warning from cluster, but it was gone the next time i got into my car. so does this mean i need to replace my battery? and do the taillights have anything to do with the battery? thanks in advance!!!!
Appreciate 0
      04-06-2011, 12:25 AM   #2
bsamoul
Major General
bsamoul's Avatar
No_Country
78
Rep
7,426
Posts

 
Drives: E90 325i
Join Date: Feb 2007
Location: Walnut Creek, California

iTrader: (2)

Send a message via AIM to bsamoul
Any problems starting the car?
__________________
-Brian
2X 2006 BMW 325i [Electric Red & Mystic Blue] | ZPP | V1 | Rear Fogs | M3 Lip Spoiler | EAS RemoteKey | BMS Powerbox | Projector90 Headlights w/ LED AE | LED plate lights | OEM Blacklines
http://www.tech-shine.com
Appreciate 0
      04-06-2011, 12:30 AM   #3
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

no problem starting the car yet
__________________
FBO Cobb S2+ | HPA SA coilover | M3 suspension bits | UUC SSK | Orion V2 | Advan RS 18"
Appreciate 0
      04-06-2011, 12:30 AM   #4
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

Quote:
Originally Posted by bsamoul View Post
Any problems starting the car?
no problem whatsoever....
__________________
FBO Cobb S2+ | HPA SA coilover | M3 suspension bits | UUC SSK | Orion V2 | Advan RS 18"
Appreciate 0
      04-06-2011, 02:51 AM   #5
hugus311
Titanium silver + Sport + Premium
hugus311's Avatar
United_States
7
Rep
632
Posts

 
Drives: 2006 330i (E90)
Join Date: Nov 2009
Location: west covina 626

iTrader: (6)

battery on way out, car shuts down systems that are non critical to compensate.
Appreciate 0
      04-06-2011, 07:52 AM   #6
ajsalida
Lieutenant Colonel
ajsalida's Avatar
20
Rep
1,737
Posts

 
Drives: 95 M3, 02 R1150GSA, 09 335xi
Join Date: Aug 2010
Location: SW USA

iTrader: (2)

could be software related

I had this problem all winter, but no problems starting. Drove me crazy. I'd get the trip odo and clock zero'd out too, plus various features would shut off (auto door unlock, trunk open, etc.). Took it in to the dealer for the HPFP and this issue. Turns out there is a TSB on battery charging system software, they tested my battery and nothing was wrong. Reprogrammed the car for the false battery warning issue and it has not done it since. Since they also reprogrammed for the HPFP not clear if it was part of that or not.

If your car is relatively new and has few miles I'd look into this. Either way make sure it is actually the battery. Had I replaced the battery on my own (this is not trivial BTW, req reprog.) I'd still not have fixed the problem plus spent $$ for nothing.

My car is a 2009 e92 xi w/23k miles.

The work order says after doing batt tests and finding no fault "found bulletin relating calling for vehicle to be reprogrammed". No TSB #.
Appreciate 0
      04-06-2011, 08:05 AM   #7
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

Quote:
Originally Posted by ajsalida View Post
I had this problem all winter, but no problems starting. Drove me crazy. I'd get the trip odo and clock zero'd out too, plus various features would shut off (auto door unlock, trunk open, etc.). Took it in to the dealer for the HPFP and this issue. Turns out there is a TSB on battery charging system software, they tested my battery and nothing was wrong. Reprogrammed the car for the false battery warning issue and it has not done it since. Since they also reprogrammed for the HPFP not clear if it was part of that or not.

If your car is relatively new and has few miles I'd look into this. Either way make sure it is actually the battery. Had I replaced the battery on my own (this is not trivial BTW, req reprog.) I'd still not have fixed the problem plus spent $$ for nothing.

My car is a 2009 e92 xi w/23k miles.

The work order says after doing batt tests and finding no fault "found bulletin relating calling for vehicle to be reprogrammed". No TSB #.
my car is a 07, does CPO cover any of these problems?
__________________
FBO Cobb S2+ | HPA SA coilover | M3 suspension bits | UUC SSK | Orion V2 | Advan RS 18"
Appreciate 0
      04-06-2011, 11:56 AM   #8
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

so is that true that CPO does not cover electrical stuff like taillights?
__________________
FBO Cobb S2+ | HPA SA coilover | M3 suspension bits | UUC SSK | Orion V2 | Advan RS 18"
Appreciate 0
      04-06-2011, 12:33 PM   #9
ajsalida
Lieutenant Colonel
ajsalida's Avatar
20
Rep
1,737
Posts

 
Drives: 95 M3, 02 R1150GSA, 09 335xi
Join Date: Aug 2010
Location: SW USA

iTrader: (2)

I doubt CPO covers a bad battery on an 07 but would not hurt to ask. First you need to find out what is wrong though. Depending on what that is there may or may not be a free fix.

Others have pointed out that the electronics will shut off various things like flashing light on unlock etc. if the system senses a low battery. My point was it does this is in some cases erroneously, even when the battery is not bad, due to bad software that thinks the battery is bad. There is a TSB on it but first the battery must be checked out.

New battery + req. new battery reprogram from a dealer can cost as much as $500, which is insane IMHO. There are cheaper alterntives. I do not know if there would be a $ charge if the battery is good, software is bad, but car is out of warranty & a CPO.
Appreciate 0
      04-06-2011, 12:43 PM   #10
slavke
Private First Class
slavke's Avatar
3
Rep
165
Posts

 
Drives: E90 330i sport & prem
Join Date: Apr 2010
Location: Ottawa

iTrader: (0)

had a battery replaced recently. Certain things stopped working on the car such as rear defroster, rest button for heating. My car is CPO and battery was not covered. They charged me $50 to test the battery and altenator under load and battery failed hense it got replaced.
Appreciate 0
      04-06-2011, 12:48 PM   #11
Verbatim
Colonel
Verbatim's Avatar
United_States
37
Rep
2,555
Posts

 
Drives: 2008 335i
Join Date: Sep 2010
Location: at the repair shop

iTrader: (0)

Garage List
2008 BMW 335i  [5.00]
I'm guessing your headlights are not in the auto position and your keyfob battery is low.
__________________

2008 BMW 335i Sedan | Sparkling Graphite | Sport | Premium | Navigation | Comfort Access | Logic7
Golf Tee | M3 Spoiler | LED Angel Eyes | 5000k Fogs | Resonator Delete | Black Kidney Grills | Black Finisher Rods | 35%/18% Tint |12mm/20mm (F/R) Spacers | Black Lines


Appreciate 0
      04-06-2011, 01:38 PM   #12
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

Quote:
Originally Posted by davidkneiber View Post
I'm guessing your headlights are not in the auto position and your keyfob battery is low.
My headlights are fine and they are in auto position, it is just my taillights come on every time i unlock the car and now it just won't do it anymore
Appreciate 0
      04-06-2011, 01:39 PM   #13
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

Quote:
Originally Posted by slavke View Post
had a battery replaced recently. Certain things stopped working on the car such as rear defroster, rest button for heating. My car is CPO and battery was not covered. They charged me $50 to test the battery and altenator under load and battery failed hense it got replaced.
so how much they charge you for the battery? i heard that it is going to be something insane,like 500 bucks?
Appreciate 0
      04-06-2011, 01:40 PM   #14
fdriller9
Banned
United_States
103
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
If you drive short distances constantly you won't maintain your battery correctly. Our cars only charge the battery above 1500rpms.

If you drive short distances constantly, get an agm retrofitted. It can deep cycle better than a traditional lead acid.

Make see you have it PROGRAMMED AND REGISTERED. They are 2 DIFFERENT processes.

Get a tender and keep it on it for a week. Check the voltage across the terminals before and after putting the car on a tender....it should be around 12.6v.

If it's below 12v (after putting it on a tender) you need a new battery.
Appreciate 0
      04-06-2011, 01:40 PM   #15
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

Quote:
Originally Posted by ajsalida View Post
I doubt CPO covers a bad battery on an 07 but would not hurt to ask. First you need to find out what is wrong though. Depending on what that is there may or may not be a free fix.

Others have pointed out that the electronics will shut off various things like flashing light on unlock etc. if the system senses a low battery. My point was it does this is in some cases erroneously, even when the battery is not bad, due to bad software that thinks the battery is bad. There is a TSB on it but first the battery must be checked out.

New battery + req. new battery reprogram from a dealer can cost as much as $500, which is insane IMHO. There are cheaper alterntives. I do not know if there would be a $ charge if the battery is good, software is bad, but car is out of warranty & a CPO.
Thanks for the info, I will take it to the dealer to see what is wrong this weekend
Appreciate 0
      04-06-2011, 01:43 PM   #16
HermanL
First Lieutenant
HermanL's Avatar
12
Rep
363
Posts

 
Drives: e92 6mt 335i
Join Date: Feb 2011
Location: Columbia MO

iTrader: (3)

Quote:
Originally Posted by ********* View Post
If you drive short distances constantly you won't maintain your battery correctly. Our cars only charge the battery above 1500rpms.

If you drive short distances constantly, get an agm retrofitted. It can deep cycle better than a traditional lead acid.

Make see you have it PROGRAMMED AND REGISTERED. They are 2 DIFFERENT processes.

Get a tender and keep it on it for a week. Check the voltage across the terminals before and after putting the car on a tender....it should be around 12.6v.

If it's below 12v (after putting it on a tender) you need a new battery.
yeah, i have been driving short distance recently, and thanks for the info, that is something i definitely need to look into
Appreciate 0
      01-28-2013, 07:53 PM   #17
GoRomeo
Colonel
GoRomeo's Avatar
26
Rep
2,371
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Thanks for the info here guys. Now I know why my rear defroster and rest heat functions stopped working. I ve had the low battery indicator in yellow for over a year now. No problems starting car which is a good thing. Oh well, I rather have power to start than using these features. My radio also shuts off about 2 min after I turn off engine. I guess the system is trying to save power. Cheers!
Appreciate 0
      01-28-2013, 08:02 PM   #18
snowman81
Second Lieutenant
United_States
3
Rep
279
Posts

 
Drives: 2008 335i
Join Date: Sep 2010
Location: VA Beach

iTrader: (0)

Garage List
2008 BMW 335i  [0.00]
I've been trying to track down why my radio shuts off by itself and then comes back on while I'm driving. I've charged the battery and had it tested. It checked out good. Maybe it's the software thing. Has anyone found the TSB number? I don't want my dealer playing dumb when I go there.
__________________
Appreciate 0
      01-28-2013, 08:03 PM   #19
sankohuy
Second Lieutenant
sankohuy's Avatar
4
Rep
255
Posts

 
Drives: E92 335i
Join Date: Oct 2012
Location: norcal

iTrader: (0)

I think the battery is running low. My car is currently having the same hick-ups as yours. Angel lights and tail lights will not lid when unlocked. Cannot listen to music without having the engine running, otherwise it would shut off with a low battery warning light on. Also, my "REST" button no longer works, because of inefficient power. I will be having the battery change this weekend. Mine is a 2007 model with factory battery. Btw, warranty does not cover wear and tear parts, sadly, battery is considered wear and tear...
__________________
Appreciate 0
      01-28-2013, 08:09 PM   #20
Blindside_137
Major General
Blindside_137's Avatar
United_States
70
Rep
5,892
Posts

 
Drives: '09 E93 Space Gray 328
Join Date: Jun 2010
Location: Raleigh, NC // Blacksburg, VA

iTrader: (1)

My 09 is doing the same as well. Unlock doesn't light up welcome lights anymore. No problems starting the car but occasionally I do get the battery symbol on dash.

Clock is also running 5 minutes fast now. Not sure if that is related.
__________________
M3 Edition Grilles|Painted Reflectors|Matte Black Vinyl Window Trim|CF Performance Spoiler|35% Tint|19" Satin Black Avant Garde M359|Lux H8 V3
OEM Aero Lip|M3 Side Skirts|LCI Tails|M-tech Rear|Duke Dynamics CF Performance|Cyba 4.0 Black Chrome
Appreciate 0
      01-28-2013, 08:22 PM   #21
GoRomeo
Colonel
GoRomeo's Avatar
26
Rep
2,371
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
guys seems like all share the same symptoms. Most likely we all need a new battery. Iv seen members here got their walmart for like 120 dlls? Anyone?
Appreciate 0
      01-28-2013, 08:43 PM   #22
mr_milo
Captain
mr_milo's Avatar
United_States
8
Rep
670
Posts

 
Drives: 2011 E93 328i
Join Date: Jan 2011
Location: SF Bay Area, CA

iTrader: (1)

Been having the same problems with my battery. It's a 2011, not even 2 years old yet and already to the shop once about it. They charged it and simply told me to keep it locked even when I have it in my garage.

Now I read about this "short trip" issue and am worried. So what is considered a "short" trip? I drive about 20 minutes each way to / from work. It's about 8 miles of mostly city driving but a small stretch (~1 mile) of freeway too. Is this considered a short trip?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:22 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST