E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Confirming defective MAF sensor



Reply
 
Thread Tools Search this Thread
      10-09-2014, 10:11 AM   #1
BMW..
Lieutenant
10
Rep
596
Posts

 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

iTrader: (0)

Hey guys. Please check my recent threads for information about the car problems from the past. I recently rescan the codes and not only did I get bank one and 2 mixture codes but also now I get the mass airflow sensor code. Does this confirm that the sensor is defective? This is my second sensor but it was bought used. I am using a K and N air filter but the problem has always been persistent after removing my afe intake and after that going to KN filter from oem . Would buying a third but brand new sensor resolve my problems? My guess is that the second you censor I bought was also damaged. Would Going back to the stock filter and just replacing the maf sensor altogether resolve it? I just want to make sure before I throw a few bills that are brand-new and pricey sensor. Thanks
__________________
Mystic Blue E90
Phoenix Yellow E46
Appreciate 0
      10-09-2014, 11:06 AM   #2
Phil325i
Major
Phil325i's Avatar
United Kingdom
14
Rep
1,194
Posts

 
Drives: E92 325i MSport Coupe
Join Date: Apr 2012
Location: UK South East

iTrader: (0)

Garage List
Have you tried cleaning the sensor? Aerosol contact cleaner is ideal.
__________________
E92 pre-LCI 325i - Ohlins R&T; H&R spacers; M3 strut brace; Meyle HD droplinks; BMS clutch stop; BMS CDV; RE g/box mounts; Saikoumichi OCC; K&N; Cyba scoops; BMW Perf Exhaust; M3 rear spoiler; M3 white dash LEDs; LED Angels; BMW Perf black grille; CSL reps; SSDD carbon diffuser; Monster Wrap black roof
Appreciate 0
      10-09-2014, 11:07 AM   #3
BMW..
Lieutenant
10
Rep
596
Posts

 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

iTrader: (0)

Quote:
Originally Posted by Phil325i
Have you tried cleaning the sensor? Aerosol contact cleaner is ideal.
Yeah I've cleaned it religiously a multitude of times using the crc MAF cleaner
__________________
Mystic Blue E90
Phoenix Yellow E46
Appreciate 0
      10-09-2014, 11:13 AM   #4
Jamesv
Private
0
Rep
61
Posts

 
Drives: 2007 328i arktis metallic
Join Date: Mar 2014
Location: Stockton ca

iTrader: (0)

Quote:
Originally Posted by BMW..
Quote:
Originally Posted by Phil325i
Have you tried cleaning the sensor? Aerosol contact cleaner is ideal.
Yeah I've cleaned it religiously a multitude of times using the crc MAF cleaner
But have u cleaned it, then threw in the k&n filter, or re-oiled the filter? If it has too much, it will coat the MAF with oil, and it will give a mis-read. Try to clean again, without oiling filter?
Appreciate 0
      10-09-2014, 03:18 PM   #5
BMW..
Lieutenant
10
Rep
596
Posts

 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

iTrader: (0)

Quote:
Originally Posted by Jamesv
Quote:
Originally Posted by BMW..
Quote:
Originally Posted by Phil325i
Have you tried cleaning the sensor? Aerosol contact cleaner is ideal.
Yeah I've cleaned it religiously a multitude of times using the crc MAF cleaner
But have u cleaned it, then threw in the k&n filter, or re-oiled the filter? If it has too much, it will coat the MAF with oil, and it will give a mis-read. Try to clean again, without oiling filter?
I've never reoiled it. I never had problems until I put an intake but I took it off, went oem setup and still had problems. Bought a used sensor and problems came back after a while. After that I cleaned it and no issues. Got a KN and now it's happening again but more noticeable hesitation and what not
__________________
Mystic Blue E90
Phoenix Yellow E46
Appreciate 0
      10-10-2014, 09:19 PM   #6
BMW..
Lieutenant
10
Rep
596
Posts

 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

iTrader: (0)

Bump. Can someone please just chime in on whether or not the sensor is confirmed bad if I get bank 1 and 2 codes along with maf sensor code. Persistent after cleaning. I want to get this solved ASAP
__________________
Mystic Blue E90
Phoenix Yellow E46
Appreciate 0
      10-13-2014, 01:23 PM   #7
BMW..
Lieutenant
10
Rep
596
Posts

 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

iTrader: (0)

144 views and only 2 responses. This isn't rocket science I would really appreciate it if someone can just chime in on this
__________________
Mystic Blue E90
Phoenix Yellow E46
Appreciate 0
      10-13-2014, 03:22 PM   #8
thomas88162
Lieutenant
10
Rep
439
Posts

 
Drives: E92 328i
Join Date: Jun 2013
Location: Clinton, IN

iTrader: (0)

Those codes and symptoms could come from a vacuum leak. There is not much confirmation information to go on. Oiled filters are generally not recommended for our MAF's, they do cause fouling.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:04 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST