E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Sqeal at steering full lock



Reply
 
Thread Tools Search this Thread
      08-24-2012, 04:05 PM   #23
EQUANT
First Lieutenant
4
Rep
310
Posts

 
Drives: 320d
Join Date: Dec 2009
Location: Bucharest

iTrader: (0)

Hissing noise is normal on hydraulic PS. Some cars have electronic PS, and those do not make any noise at full lock. My noise is a squeal, not a hiss (although the hiss is also present, which is normal)

My steering is exactly the same as it was the first day i bought the car - same noise, no worse, no better, although the dealer "fixed" it twice under warranty, thank you very much.
Sometimes, usually when very hot outside, it doesn't do the noise at all. I'm quite sure it's the belt slipping on the PS pulley when PS pump is under load (full lock or turning or very adherent surface)

F it
__________________
BMW 320 dA LCI, BMW PPK - 197HP, 2010, sapphire black, steptronic
Appreciate 0
      01-11-2013, 12:38 PM   #24
flyinglow330
New Member
0
Rep
8
Posts

 
Drives: 2006 330i E90
Join Date: Apr 2011
Location: Virginia

iTrader: (0)

Equant,
I'm having the exact same problem as you described, I have a 330I / 2006 I have been the only owner, I know the in's and out's of the car, from all the noises to the individual smell. I started doing most of the work on it myself after the warranty expired and then had a bad experience with a mechanic. So a few months back I started to get this nasty squealing sound any time I would lock the steering wheel to the left. It's almost like the sound of belts slipping. Then I soon as I let go, the sounds seems to fade off. It's not the normal sound a PS pump makes, it's actually frightening. I started trying to diagnose the problem, but it seems to be coming from underneath the engine and rather not the pulleys, the belt tentioner, or belts themselves. I have yet to find the source. But just want to let you know that you are not the only one experiencing this problem, and I know that its not just the "normal" noise that the SP makes. Please let me know if you have found the solution to this problem, if I can't find it soon, I will have to take it in to the dealer.....
Appreciate 0
      01-11-2013, 01:00 PM   #25
EQUANT
First Lieutenant
4
Rep
310
Posts

 
Drives: 320d
Join Date: Dec 2009
Location: Bucharest

iTrader: (0)

Hi mate.

No, haven't figured it out since. The car has been in the dealer not once, but twice; they replaced all belts, pulleys and vibration damper, and the sound returned.

I'm kind of used to it now, although sometimes you cannot hear it at all (also, if you rev the engine just a bit before locking the steering it will not do the noise), it's still annoying when you do.

I saw a video online when someone applied some soap to the outer edges of the belt to cure a squeal. I will try to do that and see what happens, but it's too cold now to work on the car.
__________________
BMW 320 dA LCI, BMW PPK - 197HP, 2010, sapphire black, steptronic
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:06 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST