E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > E93 interior sensors



Reply
 
Thread Tools Search this Thread
      06-05-2013, 09:43 AM   #1
moreno1
Captain
moreno1's Avatar
Canada
12
Rep
612
Posts

Drives: BMW 335i E93
Join Date: May 2009
Location: Montreal

iTrader: (13)

E93 interior sensors

Hi,

I'm looking for some comments from anyone who has retrofitted the alarm with the 4 interior sensors in the E93. Here is my situation:

I retrofitted the EOM alarm in my e93 last december and everything was working fine. Then in Feb I retrofitted the car with CIC and Combox. The cic was codded perfectly and the alarm and everything else was working fine (lock/unlock beep, panik alarm, clown nose blinking, etc). Last week i decided to purchase 4 interior sensors part number: 65756950525 so i can leave my roof open when i do a quick stop or something, however, when i installed them they don't work. if i lock the doors and put my hand inside nothing happens. i even jumped inside the car and nothing happened . I unplugged the negative battery terminal, left it off for 15 mins and replug, but still nothing . Last night I even removed +k302 from VO and fa write CAS and NFRM. Then I re-added +k302, fa write CAS and NFRM. Then used expert profile to code to default CANS and FZD. I also changed funk_innenraumshutz...line from Nicht to Aktiv in CANS module to activate the interior sensor. Left the car sleeping all night and tried this morning and nothing

So my question to you all: would you know what i'm missing, or what I did wrong? I'm out of ideas now! Why isn't the sensors working?

Any inputs would be appreciated,

Cheers,
__________________
2009 335i E93 /// BSM /// Sport /// Premium /// Codings : bmwmtlcode@hotmail.com /// 19" M pack 225 wheels /// M6 wheels winter set /// 35% Tint /// Gloss Black Grills /// PE Exhaust /// Lux H8 V3 /// Interior LEDs /// JB4-DCI /// Combox & CIC Retrofit /// M3 side skirts /// M3 front bumper ///

Last edited by moreno1; 06-05-2013 at 09:54 AM.
Appreciate 0
      06-09-2013, 09:38 PM   #2
moreno1
Captain
moreno1's Avatar
Canada
12
Rep
612
Posts

Drives: BMW 335i E93
Join Date: May 2009
Location: Montreal

iTrader: (13)

Ok I figured it out...after reading a bunch of post and threads all over the net i found one that mentioned the option $5GA should not be present in the FA list when retrofitting the alarm . After checking my FA I indeed still had $5GA so after trying everything I could think of , I decided to give it a try. So I removed $5GA and $302 that I recently added after +K302 wasn't working. Then I re-added again +K302...FA write CAS, NFRM. Coded to default CIC, KOMBI, NFRM, CAS, FZD, JBBF and CANS. Then to finish up I compared all of them with my original trace files in order to recode all custom codings I previously had. While I was comparing all trc files I noticed that in the CANS file the interior motion sensor "FUNK_INNENRAUMSCHUTZ" was already Aktiv however when I was trying before I removed the $5GA not matter how much I coded CANS to default it always came up as nicht_aktiv, so I figured I was on the right track . I also noticed the following lines/values:
Before removing $5GA:
VALUE_MUW_HL
wert_03
wert_05
VALUE_MUW_HR
wert_05
VALUE_MUW_VL
wert_05
VALUE_MUW_VR
wert_05
After removing $5GA:
VALUE_MUW_HL
wert_04
VALUE_MUW_HR
wert_04
VALUE_MUW_VL
wert_04
VALUE_MUW_VR
wert_04
As per NCSDUmmy theses four lines seems to be the settings for the interior motion sensors...not sure why the settings are different before and after but I can attest that the sensors are now working . I locked the doors with the widow down, inserted my arm inside the car and the siren started buzzing. I then tried with the roof open and same result, siren buzzing. I can now leave my roof open whenever I make a pit stop for a pack of Five gum
__________________
2009 335i E93 /// BSM /// Sport /// Premium /// Codings : bmwmtlcode@hotmail.com /// 19" M pack 225 wheels /// M6 wheels winter set /// 35% Tint /// Gloss Black Grills /// PE Exhaust /// Lux H8 V3 /// Interior LEDs /// JB4-DCI /// Combox & CIC Retrofit /// M3 side skirts /// M3 front bumper ///
Appreciate 0
      06-10-2013, 08:19 AM   #3
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
333
Rep
18,360
Posts


Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (6)

Send a message via Yahoo to cn555ic
Awesome!
Appreciate 0
      06-10-2013, 12:51 PM   #4
MiamiTuning
Banned
1
Rep
113
Posts

Drives: 2015 F80 M3
Join Date: Nov 2012
Location: Miami

iTrader: (0)

Great info, thanks for sharing.
Appreciate 0
      06-10-2013, 12:55 PM   #5
WRichieX
Major
WRichieX's Avatar
United_States
19
Rep
1,005
Posts

Drives: 07 335i e93 6MT
Join Date: May 2013
Location: Chicago

iTrader: (0)

Garage List
This is great! I've read that the e93's don't have motion because of sensitivity to wind and things flying around when top is down. Any problems you've come across from that? I definitely want the motion sensors for the same reasons as you. Do you have a DIY? or can point me in the right track?
__________________

07 BMW 335i E93 6MT (Praying neighborhood doesn't get flooded...again)
04 Infiniti G35 Coupe 6MT (Flooded)
08 Audi TT 2.0T DSG (Flooded)
03 Subaru WRX 5MT (Flooded)
Appreciate 0
      06-10-2013, 01:55 PM   #6
joshuaacook
XXXXXXXXXXX
United_States
0
Rep
15
Posts

Drives: 2009 328i
Join Date: Mar 2012
Location: Hickory, NC

iTrader: (0)

Garage List
2012 BMW X5  [0.00]
That's awesome. I wonder if this would work with my e90. I retrofitted the alarm on mine, before coding the motion worked automatically as well as the tilt sensor. When I coded my car, everything worked except the motion. I've checked every module and all of them are what they're supposed to be. Even the motion is set to aktiv however, it doesn't work anymore. I read in the PDF that a modified VO would have to be sent from BMW technical... Any ideas?
Appreciate 0
      06-12-2013, 10:50 PM   #7
moreno1
Captain
moreno1's Avatar
Canada
12
Rep
612
Posts

Drives: BMW 335i E93
Join Date: May 2009
Location: Montreal

iTrader: (13)

Quote:
Originally Posted by WRichieX View Post
This is great! I've read that the e93's don't have motion because of sensitivity to wind and things flying around when top is down. Any problems you've come across from that? I definitely want the motion sensors for the same reasons as you. Do you have a DIY? or can point me in the right track?
Hey WRichieX since I installed the sensors, I have been leaving my top open and even parked it under trees and did not have any issues. I would say go for it bro just get them, you going to love them..I know I do

Quote:
Originally Posted by joshuaacook View Post
That's awesome. I wonder if this would work with my e90. I retrofitted the alarm on mine, before coding the motion worked automatically as well as the tilt sensor. When I coded my car, everything worked except the motion. I've checked every module and all of them are what they're supposed to be. Even the motion is set to aktiv however, it doesn't work anymore. I read in the PDF that a modified VO would have to be sent from BMW technical... Any ideas?
joshuaacook, while searching for my issue with my sensors I have read in other sites people with your problem. To be honest I don't remember if they got it fix. I think you can try what I posted, but I have a feeling that your DWA/DWAI trace file will be a little different than my CANS trace file. When you try PM if you have question and off course post any findings
__________________
2009 335i E93 /// BSM /// Sport /// Premium /// Codings : bmwmtlcode@hotmail.com /// 19" M pack 225 wheels /// M6 wheels winter set /// 35% Tint /// Gloss Black Grills /// PE Exhaust /// Lux H8 V3 /// Interior LEDs /// JB4-DCI /// Combox & CIC Retrofit /// M3 side skirts /// M3 front bumper ///
Appreciate 0
      06-12-2013, 11:28 PM   #8
WRichieX
Major
WRichieX's Avatar
United_States
19
Rep
1,005
Posts

Drives: 07 335i e93 6MT
Join Date: May 2013
Location: Chicago

iTrader: (0)

Garage List
Quote:
Originally Posted by moreno1 View Post
Hey WRichieX since I installed the sensors, I have been leaving my top open and even parked it under trees and did not have any issues. I would say go for it bro just get them, you going to love them..I know I do

Where did you place the sensors? Is there a diy specific to e93? Any help would be great. Thanks.
__________________

07 BMW 335i E93 6MT (Praying neighborhood doesn't get flooded...again)
04 Infiniti G35 Coupe 6MT (Flooded)
08 Audi TT 2.0T DSG (Flooded)
03 Subaru WRX 5MT (Flooded)
Appreciate 0
      06-13-2013, 01:02 PM   #9
moreno1
Captain
moreno1's Avatar
Canada
12
Rep
612
Posts

Drives: BMW 335i E93
Join Date: May 2009
Location: Montreal

iTrader: (13)

Quote:
Originally Posted by WRichieX View Post
Where did you place the sensors? Is there a diy specific to e93? Any help would be great. Thanks.
Hey,
The sensors they go inside the 2 front door panels and inside the two rear side panels. Check out the following PDF (start from page 6)
http://www.bavauto.com/Assets/inst_pages/ins402.pdf

Once installed you then have to go through the whole coding sequence.

Cheers,
__________________
2009 335i E93 /// BSM /// Sport /// Premium /// Codings : bmwmtlcode@hotmail.com /// 19" M pack 225 wheels /// M6 wheels winter set /// 35% Tint /// Gloss Black Grills /// PE Exhaust /// Lux H8 V3 /// Interior LEDs /// JB4-DCI /// Combox & CIC Retrofit /// M3 side skirts /// M3 front bumper ///
Appreciate 0
      06-20-2013, 06:26 PM   #10
joshuaacook
XXXXXXXXXXX
United_States
0
Rep
15
Posts

Drives: 2009 328i
Join Date: Mar 2012
Location: Hickory, NC

iTrader: (0)

Garage List
2012 BMW X5  [0.00]
Quote:
Originally Posted by moreno1 View Post


joshuaacook, while searching for my issue with my sensors I have read in other sites people with your problem. To be honest I don't remember if they got it fix. I think you can try what I posted, but I have a feeling that your DWA/DWAI trace file will be a little different than my CANS trace file. When you try PM if you have question and off course post any findings
I did try removing the $5GA... recoded and, same problem. I also tried removing $302 and adding +K302 instead and resulted in the same issue . Sad day man. I haven't read anywhere that someone had a fix to the issue! Maybe I will let the stealer obtain the "modified VO" and fix it for me... or do without. I would like the motion to work considering the da** thing is already in there though...
Appreciate 0
      11-30-2013, 12:05 PM   #11
thetooth
Registered
0
Rep
2
Posts

Drives: e93 M3
Join Date: Nov 2013
Location: United States

iTrader: (0)

Thanks so much for this... I will be doing the retrofit over the next week. My interior sensors came first do I got those installed.... no alarm yet.
Appreciate 0
      12-02-2013, 10:34 PM   #12
thetooth
Registered
0
Rep
2
Posts

Drives: e93 M3
Join Date: Nov 2013
Location: United States

iTrader: (0)

Jackpot

Thanks to all! I have a working alarm as well as interior sensors. The only thing I could not find was how to change the volume... not a big deal. I have an M3 E93 and do not have DWA modules... looks like most of the changes I made were in the CANS module.
Appreciate 0
      02-27-2015, 02:45 PM   #13
josehon
Enlisted Member
1
Rep
33
Posts

Drives: 2008 Apline White 328i E93 6MT
Join Date: Feb 2015
Location: Canada

iTrader: (0)

Pre-wire?

I have a 2008 E93 and it is pre-wire. And I am thinking to install the interior sensors. I have ordered the OEM alarm and it is now on its way.

However, I have read some other thread staying that the pre-wired exist only for the OEM hood switch and siren, but not the interior sensors? Are your car pre-wired for interior sensors?

Thanks
Appreciate 0
      02-27-2015, 05:15 PM   #14
Isaiah5411
Lieutenant Colonel
Isaiah5411's Avatar
United_States
82
Rep
1,640
Posts

Drives: 2008 Montego Blue 328i E93
Join Date: Oct 2006
Location: Modagascar

iTrader: (0)

Quote:
Originally Posted by josehon View Post
I have a 2008 E93 and it is pre-wire. And I am thinking to install the interior sensors. I have ordered the OEM alarm and it is now on its way.

However, I have read some other thread staying that the pre-wired exist only for the OEM hood switch and siren, but not the interior sensors? Are your car pre-wired for interior sensors?

Thanks
Yes, yours should be pre-wired for the motion sensors just as it was for the hood switch and siren. The motion sensors are optional, as you know, but the wiring should be there as shown in the BMW E93 alarm installation guide.

I just installed the OEM alarm in my E93 and am waiting on the (used) motion sensors from Germany...will be here next week. I have had my door panels off a bunch of times while doing interior mods and am certain that I saw the pre-wiring for the sensors and wondered what that connection was for.
__________________
2008 Montego 328i / 3.0 manifold / AA / Eurobox / PE / Alufelgen CS7 / Macht Schnell / Michelin PSS / XPel
"O thou afflicted, tossed with tempest, and not comforted, behold, I will lay thy stones with fair colours, and lay thy foundations with sapphires." (Isaiah 54:11)
Appreciate 0
      02-27-2015, 06:52 PM   #15
MarcoE93
Private First Class
1
Rep
147
Posts

Drives: AW coral red E93
Join Date: Jul 2011
Location: Toronto

iTrader: (1)

I've been looking to do this mod myself but could never find much info. How would I know if mine is prewired for the retrofit? Also what sensors would I have to purchase to complete everything. How much would this run me?
Appreciate 0
      02-27-2015, 07:09 PM   #16
mathematics
Captain
mathematics's Avatar
United_States
44
Rep
995
Posts

Drives: 08 328i e93 alpine white
Join Date: May 2009
Location: Queens, NY

iTrader: (0)

that's a lot of work lol. all i did was add the DEI proximity sensor to my alarm/remote start =)
__________________
iPhone 6 Plus (iTunes library/iTunes radio/Waze, etc) to Airport Express via AirPlay. Toslink out of Airport Express to Helix P-Six DSP. PHD AF 1.C tweeters, PHD FB 4.1 midranges. Jehnert Door Cards and mid-bass'.
Appreciate 0
      02-27-2015, 10:20 PM   #17
josehon
Enlisted Member
1
Rep
33
Posts

Drives: 2008 Apline White 328i E93 6MT
Join Date: Feb 2015
Location: Canada

iTrader: (0)

Thanks. I am going to order them. Can wait for Spring to come, winter is too long here in Toronto.
Appreciate 0
      02-27-2015, 10:57 PM   #18
josehon
Enlisted Member
1
Rep
33
Posts

Drives: 2008 Apline White 328i E93 6MT
Join Date: Feb 2015
Location: Canada

iTrader: (0)

You can do a VIN search on bmwarchive.org, if your vehicle order contains 5GA (S5GAA). It is pre-wired.
Appreciate 0
      02-27-2015, 11:11 PM   #19
MarcoE93
Private First Class
1
Rep
147
Posts

Drives: AW coral red E93
Join Date: Jul 2011
Location: Toronto

iTrader: (1)

Thanks. I'll have to take a look at that once car comes out of storage. Do I have to order the sensors from dealer or is there another option?
Appreciate 0
      02-28-2015, 10:21 AM   #20
Isaiah5411
Lieutenant Colonel
Isaiah5411's Avatar
United_States
82
Rep
1,640
Posts

Drives: 2008 Montego Blue 328i E93
Join Date: Oct 2006
Location: Modagascar

iTrader: (0)

Quote:
Originally Posted by MarcoE93 View Post
Thanks. I'll have to take a look at that once car comes out of storage. Do I have to order the sensors from dealer or is there another option?
Check out EBay or BMW parts websites for used ones.

(Be sure to go to RealOEM.com for the correct part number. My car was made before 12/07 so the part number was 65756950525. But after that, the part number is listed as 65776989713. The latter part number is also for the sensors in the Z4.)
__________________
2008 Montego 328i / 3.0 manifold / AA / Eurobox / PE / Alufelgen CS7 / Macht Schnell / Michelin PSS / XPel
"O thou afflicted, tossed with tempest, and not comforted, behold, I will lay thy stones with fair colours, and lay thy foundations with sapphires." (Isaiah 54:11)
Appreciate 0
      03-04-2015, 01:01 PM   #21
josehon
Enlisted Member
1
Rep
33
Posts

Drives: 2008 Apline White 328i E93 6MT
Join Date: Feb 2015
Location: Canada

iTrader: (0)

Where can you find the screws to hold the interior sensors? There 4 in total according to the installation instruction. Can I get them from the local BMW dealer?
Appreciate 0
      03-04-2015, 01:46 PM   #22
Isaiah5411
Lieutenant Colonel
Isaiah5411's Avatar
United_States
82
Rep
1,640
Posts

Drives: 2008 Montego Blue 328i E93
Join Date: Oct 2006
Location: Modagascar

iTrader: (0)

Quote:
Originally Posted by josehon View Post
Where can you find the screws to hold the interior sensors? There 4 in total according to the installation instruction. Can I get them from the local BMW dealer?
Get from dealer. Here is the part # from RealOEM.com:
http://www.realoem.com/bmw/showparts...65&hg=65&fg=60

02 Threaded bolt (2 per sensor) part #51417122657 $1.11ea

Just called dealer (because I need them, too!....thanks for the reminder) and they want $40+ for a pack of 10. Whoa! Hard to believe we can't find some at Lowe's for much less that would work.

I just checked on GetBMWParts.com (see below) and it says "PARTS: Part included with lower quarter trim. " in the description, so...the screws may already be there. Gonna try to take a door panel off this afternoon and see if they are there and, if not, see if I can match the size from Lowes or PepBoys.

https://www.getbmwparts.com/parts/20...agramCallOut=8
__________________
2008 Montego 328i / 3.0 manifold / AA / Eurobox / PE / Alufelgen CS7 / Macht Schnell / Michelin PSS / XPel
"O thou afflicted, tossed with tempest, and not comforted, behold, I will lay thy stones with fair colours, and lay thy foundations with sapphires." (Isaiah 54:11)

Last edited by Isaiah5411; 03-04-2015 at 02:32 PM.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:48 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST