E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Idrive continuously freezing



Reply
 
Thread Tools Search this Thread
      06-19-2011, 09:14 PM   #1
tj9
Private
Australia
2

 
tj9's Avatar
 
Drives: E90 LeMans Blue
Join Date: Feb 2010
Location: Perth, WA


Posts: 69
iTrader: (1)

Unhappy Idrive continuously freezing

Hi Guys,

Having a major problem with my idrive ('07 E90) its the business idrive.

Originally i though it was a CD skipping so i changed to the radio and that started skipping, so i tried to change back to the main menu i realised the system was actually freezing.

The freezing of the idrive has the characteristics of a cd skipping, it can do it 3 times in 10 secs or just freeze for 10 secs then work fine for 1 min then freeze up again and continuously do this.

In addition my bluetooth no longer works now and i cant check the box to allow bluetooth communications.

Anybody had similar issues to this or know what the source of the problem is?

Thanks
Appreciate 0
      09-10-2011, 06:35 PM   #2
Frosty
Lieutenant Colonel
27

 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ


Posts: 1,909
iTrader: (0)

bump
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 185,000+miles (Nov-25-2014)
.................................................. ......................
Appreciate 0
      09-10-2011, 06:40 PM   #3
Canon8mm60D
Photographer for Hire
United_States
0

 
Canon8mm60D's Avatar
 
Drives: Range Rover Sport
Join Date: Sep 2011
Location: Long Island


Posts: 46
iTrader: (0)

i had the same issue........
Appreciate 0
      09-10-2011, 06:42 PM   #4
Mallard
4 pot warrior
No_Country
14

 
Mallard's Avatar
 
Drives: E90 318I
Join Date: Apr 2009
Location: DENMARK


Posts: 1,307
iTrader: (1)

Garage List
2006 e90  [5.00]
software update may help, then again , may crash the most ring, which will cost you a new MASK unit..
__________________

Been there, done that, wanna do it again
Appreciate 0
      09-17-2011, 01:00 AM   #5
Frosty
Lieutenant Colonel
27

 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ


Posts: 1,909
iTrader: (0)

bump
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 185,000+miles (Nov-25-2014)
.................................................. ......................
Appreciate 0
      09-29-2011, 02:50 PM   #6
chaFT328i
Private First Class
United_States
3

 
chaFT328i's Avatar
 
Drives: e90 07 328i
Join Date: Sep 2011
Location: SoCal 626


Posts: 198
iTrader: (2)

Had this problem last year. I took it to the dealer and they said I just needed a software update.


Sadly for me, the real problem was that my i-Drive fried and had to replace the whole unit.
Appreciate 0
      09-30-2011, 12:37 PM   #7
davidkotok
First Lieutenant
3

 
Drives: e92 335i
Join Date: Jun 2010
Location: ny/dc


Posts: 375
iTrader: (3)

try rebooting the navi! i had a similar problem and twice i have rebooted it due to freezing and general slowness...

i believe you push both eject buttons at the same time
then push and release the mute button on the volume knob and that should reset it

hope it helps
Appreciate 0
      10-08-2011, 08:03 AM   #8
peepayy_91
Lieutenant
United_States
5

 
Drives: '07 e92 335i
Join Date: Aug 2011
Location: Tucson,AZ


Posts: 527
iTrader: (2)

Garage List
2007 BMW 335i  [0.00]
Quote:
Originally Posted by davidkotok View Post
try rebooting the navi! i had a similar problem and twice i have rebooted it due to freezing and general slowness...

i believe you push both eject buttons at the same time
then push and release the mute button on the volume knob and that should reset it

hope it helps


i've rebooted it multiple times about 85% of the time it just stays in a blank screen mode. then when it finally resets itll work everything else but there will be no music from the radio or from the aux cord. anyone know any fixes besides getting the whole system swapped which is probably an arm and a leg
__________________


" Yeah man, the chargepipe alone gives me about +50tq to the wheels"
Appreciate 0
      11-13-2011, 01:17 AM   #9
davidkotok
First Lieutenant
3

 
Drives: e92 335i
Join Date: Jun 2010
Location: ny/dc


Posts: 375
iTrader: (3)

figure out which version you are running of your dme and get the dealer to update everything which would include an update of idrive software i believe
Appreciate 0
      11-13-2011, 01:24 AM   #10
davidkotok
First Lieutenant
3

 
Drives: e92 335i
Join Date: Jun 2010
Location: ny/dc


Posts: 375
iTrader: (3)

http://www.bmw.com/com/en/owners/nav...re_update.html

some sort of usb update
Appreciate 0
      12-08-2011, 10:42 AM   #11
davidlao0
Registered
0

 
Drives: E90
Join Date: Dec 2011
Location: Australia


Posts: 1
iTrader: (0)

Hi, im experiencing the same problems, since two days ago it got worse, the system started to freeze on me constantly after i plugged in my iPod through AUX (though i dont think it matters). My navigations functions are working properly but the audio from CD and radio and sound from the system is freezing... Really need help... what should I do? mine is a E90 320i with professional navigation system. THANKS!
Appreciate 0
      12-08-2011, 03:26 PM   #12
just4kickz
boku no namae ha...
United_States
132

 
Drives: 2006 BS 330i
Join Date: Feb 2006
Location: S. Bay Area, CA + Newark, NJ + ChiCity + True Blue


Posts: 11,038
iTrader: (11)

Garage List
2006 E90 330i  [0.00]
Quote:
Originally Posted by davidlao0 View Post
Hi, im experiencing the same problems, since two days ago it got worse, the system started to freeze on me constantly after i plugged in my iPod through AUX (though i dont think it matters). My navigations functions are working properly but the audio from CD and radio and sound from the system is freezing... Really need help... what should I do? mine is a E90 320i with professional navigation system. THANKS!
just send it to the dealership. first thing they'll do is try to reprogram it... then after that, if it doesn't work... they'll replace the unit...
__________________
looking for a PreLCI Black Sapphire e90 front bumper without license plate holes

"Akimbo shotguns. Broken wrists anyone? And don't give me that 'it's just a game' bull****. Where the **** are my akimbo interventions then?! One scope on each eye mother****er!!"
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:16 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST