E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > E92 Stereo/Tearing sound.



Reply
 
Thread Tools Search this Thread
      11-17-2010, 09:13 AM   #1
$hah$
Private First Class
$hah$'s Avatar
United_States
1
Rep
105
Posts

 
Drives: '13 E92 335i
Join Date: Nov 2010
Location: Los Angeles

iTrader: (0)

Garage List
2013 E92  [0.00]
2010 BMW E92  [4.50]
Thumbs down E92 Stereo/Tearing sound.

When I turn up the radio, I hear a loud shreaking, torn sound out of the speakers. I heard this is due to the self- amplified cheap headunit and under amplification in the 2010 models. Has anyone heard of recalls or solutions to the problem, besides replacing everything.

There have been some posts in the past regarding this problem, but I was wondering if anyone found the solution to the problem.

Thanks.
Appreciate 0
      11-17-2010, 09:59 AM   #2
FVM3
Major General
FVM3's Avatar
115
Rep
5,739
Posts

 
Drives: e92 m3, f30 328i
Join Date: Sep 2010
Location: Los Angeles

iTrader: (2)

The fastest way is replace the speakers
Appreciate 0
      11-17-2010, 10:02 AM   #3
tofu-
Banned
43
Rep
2,858
Posts

 
Drives: 335i Jet Black/Coral Red
Join Date: Mar 2010
Location: nyc

iTrader: (4)

I have this problem in my 08 with logic 7. Might just be a loose connection. Been to lazy to diagnose it.
Appreciate 0
      11-17-2010, 12:12 PM   #4
$hah$
Private First Class
$hah$'s Avatar
United_States
1
Rep
105
Posts

 
Drives: '13 E92 335i
Join Date: Nov 2010
Location: Los Angeles

iTrader: (0)

Garage List
2013 E92  [0.00]
2010 BMW E92  [4.50]
Speakers

Shouldn't BMW replace this speakers for me? This is a brand new car and through the research I did, people have replaced the speakers, headunits and the problem still remains. I don't want to resort to spending money on upgrading anything when it comes to the headunit and speakers, but didn't know if any of you have found a solution to this problem through BMW?
Appreciate 0
      11-17-2010, 12:19 PM   #5
ctuna
Brigadier General
45
Rep
4,334
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

You need to go to the Audio Board in e90post

http://www.e90post.com/forums/forumdisplay.php?f=27
plenty of solutions here but you need to spend some bucks

http://www.e90post.com/forums/showth...mp+2010&page=2

http://www.e90post.com/forums/showthread.php?t=365866

If its really broke in the first 50k they should fix it.
Appreciate 0
      11-17-2010, 12:19 PM   #6
e92hobear
Lieutenant
e92hobear's Avatar
United_States
13
Rep
437
Posts

 
Drives: Dacia Sandero
Join Date: Jul 2010
Location: SoCal

iTrader: (2)

call your SA
__________________
2010 e92 mojave metallic
Appreciate 0
      07-06-2011, 06:00 AM   #7
$hah$
Private First Class
$hah$'s Avatar
United_States
1
Rep
105
Posts

 
Drives: '13 E92 335i
Join Date: Nov 2010
Location: Los Angeles

iTrader: (0)

Garage List
2013 E92  [0.00]
2010 BMW E92  [4.50]
Still NO fix- need advice

So I have gone to my local dealer and complained about the radio plenty of times. I took print outs & proof how others are having the speakers pop in their 10 E92's. The service dept apparently test drove it, kept it for 2 days and then said they couldn't diagnose anything b/c they did not hear a pop or crackling sound. 2 days later, windows down on the highway and turned up the music and again -->heard loud pop and tears with the frequency. I am certain that the problem is the under powered self amplified head unit the 10's came with. In addition to going over 50 /60 miles an hour with the wind resistance and radio turned up.

Any advice on what to do besides playing the back and forth game with the service dept? Avoiding spending any kind of $ on this cheap radio to begin w/ but really want the popping sound to go away. What if I bought a amp and self amplified the speakers and radio through an additional amp?

Anyone else out there going through this?
Appreciate 0
      07-06-2011, 06:27 AM   #8
B-737
Captain
B-737's Avatar
United_States
17
Rep
823
Posts

 
Drives: Carrera C2 993
Join Date: Sep 2010
Location: Jersey Shore

iTrader: (6)

Garage List
2011 328 xi  [3.63]
95 Carrera C2 993  [0.00]
theres nothing wrong with your car other than the garbage audio system BMW installed at the factory.

http://www.e90post.com/forums/showthread.php?t=451762

unleash a professional on your car by dumping $1000-$2000 into it, and it'll sound just like, or better, than the $800 upgrade that those of us didnt get because we, like you, assumed the car would have a good radio. it does not.

btw, i love my new system.
__________________
Appreciate 0
Reply

Bookmarks

Tags
e92 stereo

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:39 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST