E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Codes 29F5, 29F4



Reply
 
Thread Tools Search this Thread
      07-07-2011, 07:30 PM   #1
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

Codes 29F5, 29F4

I get fault codes 29F5, 29F4 every 500km after I delete them.
My car currently has 6,104km on it.
I've cleared it multiple times but they come back.
After resetting the adaptation values they came back after 180km.
I've Cleared all codes. Turned the battery off for 15min. And check all the connection but everything seems to be good.
I haven't yet pulled the O2 sensors out yet.

What available actual values should I be looking for in the BT tool to torubleshoot the problem. What voltage or other values should i be looking for to see which O2 Sensor it is or even worse which Catalytic converter it is.

Codes 29F5, 29F4 with Service Engine Soon light on.
No Warranty, I bought it on Auction it was hit in the back quarter panel.
It's a brand new car.
Thanks,
Appreciate 0
      07-08-2011, 05:55 AM   #2
micano
Private
micano's Avatar
United_States
1
Rep
53
Posts

 
Drives: 330 JB, 6MT,ZPP, ZSP, Nav, AA
Join Date: Dec 2009
Location: CT, USA

iTrader: (0)

29F4/F5

Bentley's 3-series Service manual for 06-09 shows the
29F4 (P0420) - Catalyst System Effeciency Below Threshold (Bank 1)
29F5 (P0430) - Catalyst System Effeciency Below Threshold (Bank 2)

Not sure if they are the same for your '11.

Good Luck.
Appreciate 0
      07-08-2011, 07:19 AM   #3
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

Does it say what the threshold values should be?
Appreciate 0
      07-08-2011, 08:37 AM   #4
micano
Private
micano's Avatar
United_States
1
Rep
53
Posts

 
Drives: 330 JB, 6MT,ZPP, ZSP, Nav, AA
Join Date: Dec 2009
Location: CT, USA

iTrader: (0)

Nope, no values.
Appreciate 0
      07-08-2011, 08:44 AM   #5
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

Are these codes usually because of bad catalytic converters or bad O2 sensors.
The car wasn't driven for 6 months before i bought it.
Can new catalytic converters go bad so quickly?

Last edited by cezary; 07-08-2011 at 09:16 AM.
Appreciate 0
      07-08-2011, 09:46 AM   #6
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

I guess the first thing I should to is get an emissions test done.
Appreciate 0
      07-08-2011, 09:55 AM   #7
mithiral67
That guy
mithiral67's Avatar
68
Rep
5,724
Posts

 
Drives: 2015 Cayman GTS
Join Date: Jun 2008
Location: Chicago Burbs

iTrader: (4)

Garage List
I get those codes now after going catless dps. Not sure if that helps.
Appreciate 0
      07-08-2011, 10:23 AM   #8
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

Do you get the Service Engine Soon light?

Last edited by cezary; 07-08-2011 at 10:31 AM.
Appreciate 0
      07-08-2011, 10:49 AM   #9
mbj898
Second Lieutenant
mbj898's Avatar
United_States
3
Rep
297
Posts

 
Drives: 2006 325xi
Join Date: Jun 2008
Location: Rochester, NY

iTrader: (1)

Send a message via AIM to mbj898
If i remember correctly bank 1 is the front 3 cylinders and bank 2 is the rear 3 so this would imply that both something is not working correctly in both exhaust pipes/both cats/both O2 sensors.

Check the rear O2 sensors for both pipes as these are the ones that measure emissions.

mithiral67 will always have these codes because he has no cats...

Does the vehicle have a completely stock exhaust system?

And what do you mean when you say brand new cats? As in the car is brand new, or it has had cats replaced?
__________________
-2006 325xi - DD - 75 shot nitrous

Appreciate 0
      07-08-2011, 11:03 AM   #10
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

It has a completely stock exhaust.
They were never replaced.

I check the Actual Values for
"Voltage lambda probe front catalyst 1" 1.98 V
"Voltage lambda probe front catalyst 2" 2.00 V

"Voltage lambda probe rear catalyst 1" 0.74 V
"Voltage lambda probe rear catalyst 2" 0.73 V
Attached Images
 

Last edited by cezary; 07-08-2011 at 12:01 PM.
Appreciate 0
      07-08-2011, 01:30 PM   #11
joots
Private
0
Rep
58
Posts

 
Drives: e90 328xi
Join Date: Nov 2010
Location: ks

iTrader: (0)

Quote:
Originally Posted by cezary View Post
I get fault codes 29F5, 29F4 every 500km after I delete them.
My car currently has 6,104km on it.
I've cleared it multiple times but they come back.
After resetting the adaptation values they came back after 180km.
I've Cleared all codes. Turned the battery off for 15min. And check all the connection but everything seems to be good.
I haven't yet pulled the O2 sensors out yet.

What available actual values should I be looking for in the BT tool to torubleshoot the problem. What voltage or other values should i be looking for to see which O2 Sensor it is or even worse which Catalytic converter it is.

Codes 29F5, 29F4 with Service Engine Soon light on.
No Warranty, I bought it on Auction it was hit in the back quarter panel.
It's a brand new car.
Thanks,
No warranty? Its essentially still new?
Appreciate 0
      07-08-2011, 02:11 PM   #12
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

I don't know how BMW warranty works but I am the second owner and the car was bought from insurance auction so I am assuming that there is no warranty.
6,000 km seems almost new to me.

That's why it hard for me to believe that the cats are bad.

I know i can fix this problem myself with some help from the users on this forum.
Appreciate 0
      08-15-2011, 09:27 AM   #13
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

I changed the post-cat O2 Sensors.

I reset the light. Drove 120km. Stopped filled the tank then drove another 5km then the light turned on.

Could this error be caused the Activated carbon filter which filters the gas tank vent. It's the oldest part of the car. I installed a used on because the original was damaged when I bought the car.

The error doesn't suggest that it has anything to do with it.
Appreciate 0
      08-15-2011, 09:34 AM   #14
MaximusJ
Colonel
MaximusJ's Avatar
Canada
37
Rep
2,122
Posts

 
Drives: 325i 2006
Join Date: Jul 2010
Location: Quebec, Canada

iTrader: (19)

Garage List
'06 E90  [3.72]
I would check with BMW first just to be sure its still under warranty and ask the dealer to work on it.

Insurance auction or not, i'm pretty sure its still covered.
Appreciate 0
      08-15-2011, 10:40 AM   #15
cezary
New Member
1
Rep
9
Posts

 
Drives: BMW 2011 328xi
Join Date: Mar 2011
Location: Mississauga

iTrader: (0)

Its a Rebuilt Title.
Appreciate 0
      08-16-2011, 06:46 AM   #16
2006330iFTW
Private First Class
1
Rep
142
Posts

 
Drives: 2006 330i
Join Date: Apr 2009
Location: New York

iTrader: (1)

Garage List
2006 330i  [0.00]
PM me your VIN and i'll tell you if it has warranty or not. I know a Service advisor through family he'll be able to tell me for sure if you want.
Appreciate 0
      08-16-2011, 01:03 PM   #17
e90pilot
Freight Dawg
e90pilot's Avatar
United_States
42
Rep
2,110
Posts

 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

iTrader: (3)

Maybe the cats are clogged? Floor it a few times to get clean then out. If a bunch of black smoke flys out of the exhaust then you have some carbon buildup in the exhaust.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
Appreciate 0
      09-12-2011, 09:04 AM   #18
Gunzaro
First Lieutenant
Cyprus
5
Rep
308
Posts

 
Drives: Speed Racer
Join Date: Jan 2011
Location: In transit

iTrader: (0)

I get these codes on my e89 N54 Z4 35i. Codes 29F4 29F5.

I have not seen a warning light on the dash/idrive and when I check the idrive it says no faults. Car drives fantastic.

I believe it could be caused by BAD FUEL since both cats give the fault code.

BTW my car is brand new - only 3500km done - so chance for BOTH cats to have gone bad at the exact same time is very slim.
Appreciate 0
      07-13-2012, 06:01 PM   #19
SpeedDemon7
Private
SpeedDemon7's Avatar
3
Rep
90
Posts

 
Drives: 335i E90
Join Date: Mar 2012
Location: United States

iTrader: (0)

I get the same codes on my e89 35i z4,

I think it might be the E85 mix I am running.
__________________
11' Z4 35i Procede REV 3 SOLD
2007 e90 335i 6MT:Procede REV 3: Raceland 2.5": VRSF 7":VRSF CHARGE pipe: Walbaro 255 inline: ACT 6 Puck: 100% e85
Appreciate 0
      08-18-2012, 09:35 PM   #20
fazman
Lieutenant Colonel
United_States
21
Rep
1,795
Posts

 
Drives: 335 e90
Join Date: Feb 2011
Location: LI, NY

iTrader: (0)

If you went with a catless Down pipe then you need to get the Permanent DP Fix (Simulates the cat for the car so it doesn't toss the readiness error code).

You will not be able to pass emissions test without the Permanent DP Fix. While you are at it, might as well get the JB4 at the same time to put the catless DP to good use (The install is in the same location)


JB4: http://www.burgertuning.com/jb4_pnp_...nce_tuner.html
JB4 Install Guide: http://www.burgertuning.com/instructions/JB4PnP.pdf

Permanent DP Fix: http://www.burgertuning.com/dpfix.html
DP Fix install guide: http://burgertuning.com/instructions/BMSdownpipefix.pdf
Appreciate 0
      08-19-2012, 06:52 AM   #21
Gunzaro
First Lieutenant
Cyprus
5
Rep
308
Posts

 
Drives: Speed Racer
Join Date: Jan 2011
Location: In transit

iTrader: (0)

These codes appear with no aftermarket hardware (ie downpipes). I noticed they happen only on certain brands of fuel. BP seems to be the best so far for not triggering the codes.

Again no loss of performance/idle/odd smells etc noticed.
Appreciate 0
      10-03-2012, 11:06 PM   #22
Alext
Colonel
No_Country
42
Rep
2,028
Posts

 
Drives: B M W
Join Date: Apr 2008
Location: Everest

iTrader: (2)

Anyone know the exact cause of these codes for cars without catless dp's or exhaust mods (ie stock)?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:45 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST