E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > BMW Canada Announces Limited E90 335xi xDrive Sedan Special Edition With Power Kit



Reply
 
Thread Tools Search this Thread
      04-11-2012, 02:36 PM   #925
SilverEmu
Private First Class
 
SilverEmu's Avatar
 
Drives: '11 335i xDrive SE
Join Date: Oct 2007
Location: ON

Posts: 124
iTrader: (0)

Quote:
Originally Posted by pyceasyas123 View Post
You can do kwv1 and kwv3 coilovers as well. I have kwv1. The car drives much better.
That's right! KW have xi specific v1 and v3 - missed them...
SilverEmu is offline   Canada
0
Reply With Quote
      04-12-2012, 07:52 AM   #926
Bobby_Sardells
First Lieutenant
 
Bobby_Sardells's Avatar
 
Drives: 2011 335i XDrive Special Ed.
Join Date: Aug 2011
Location: Toronto, Ontario, Canada

Posts: 323
iTrader: (0)

Garage List
Quote:
Originally Posted by SilverEmu View Post
That's right! KW have xi specific v1 and v3 - missed them...
Yeah theyre fairly reasonable too, but i really wish the bilstein PSS10 was available for xi. Also I am thinking about getting the m-tech, H&R, or UUC struts. I wanna stiffen this puppy up and I have heard good things
Bobby_Sardells is offline  
0
Reply With Quote
      04-12-2012, 09:23 AM   #927
williewonkerz
Second Lieutenant
 
williewonkerz's Avatar
 
Drives: 335xi Spec Edition
Join Date: Jun 2011
Location: Winnipeg

Posts: 289
iTrader: (0)

Garage List
I'll be curious as to what people go with. I'd like to lower mine a bit but not stiff the ride up too much
williewonkerz is offline   Canada
0
Reply With Quote
      04-13-2012, 04:41 PM   #928
Kernel Kurtz
First Lieutenant
 
Drives: '11 e90 335xi SE 6mt
Join Date: Sep 2007
Location: Winnipeg, Canada

Posts: 398
iTrader: (0)

Quote:
Originally Posted by williewonkerz View Post
I'll be curious as to what people go with. I'd like to lower mine a bit but not stiff the ride up too much
I find the ride on mine to be quite harsh with the 19s compared to the 17s I had on my previous 335. Also find the bottom drags on the ruts in my back lane during the winter, so I'd only be interested in a setup where ride height is easily adjustable.

See you are in the Peg as well. Are you a BMWCCM member? Also had a look at your garage pics and the window tint on your car looks good. Who applied it if you don't mind my asking....?
Kernel Kurtz is offline  
0
Reply With Quote
      04-15-2012, 09:55 PM   #929
Boco335iXdriveSE
Private
 
Drives: 335i Xdrive Special Edition
Join Date: Feb 2012
Location: Markham

Posts: 76
iTrader: (0)

My Engine Service light is on and stayed on again today! The car only has 2617km! I have the oil cap secured 100% for sure!
The first time the engine light came on was when the car had 750km on it, and 3 days after I filled up the gas. I bought my back to the dealer at that time and the service agent at the BMW Autohaus said that the oil cap was not tight, which caused that. He wanted to charge me $150 to cleared the Engine Light. He waived the charge after I argued with him, as I did not believe in that since I was very sure the oil cap was tightly closed.
Now at 2617km, the Engine Sevice light comes on again, 4 days after I filled up the gas. I checked the cap and it was tightly closed and there is no way one could close any tighter!!!
The car still drive the same and I do not notice anything problem!
It is becoming so annoying that I don't know I should do about this!
I have never had a car before that gives me any unexpected problem, even after 150,000km.
I don't mind the regular wear and tear maintenance, but not something like this! And the worse thing is that the service department of the BMW dealership is not willing to take ownership of the problem, and trying to blame the customer for the problem so they charge them to fix it!!!
Does anyone have any good suggestion as of what I should do with this problem?
I am really thankful to see that a lot of members of this forum are really supportive and are helping each other out when someone has a problem or a question.
Boco335iXdriveSE is offline  
0
Reply With Quote
      04-16-2012, 12:14 AM   #930
Kernel Kurtz
First Lieutenant
 
Drives: '11 e90 335xi SE 6mt
Join Date: Sep 2007
Location: Winnipeg, Canada

Posts: 398
iTrader: (0)

If the light stays on then at least they can hopefully pull a code from the car to find out what the real problem is.
Kernel Kurtz is offline  
0
Reply With Quote
      04-16-2012, 09:22 AM   #931
pyceasyas123
Captain
 
pyceasyas123's Avatar
 
Drives: 335i Sedan
Join Date: May 2009
Location: Toronto

Posts: 741
iTrader: (9)

Quote:
Originally Posted by Boco335iXdriveSE View Post
My Engine Service light is on and stayed on again today! The car only has 2617km! I have the oil cap secured 100% for sure!
The first time the engine light came on was when the car had 750km on it, and 3 days after I filled up the gas. I bought my back to the dealer at that time and the service agent at the BMW Autohaus said that the oil cap was not tight, which caused that. He wanted to charge me $150 to cleared the Engine Light. He waived the charge after I argued with him, as I did not believe in that since I was very sure the oil cap was tightly closed.
Now at 2617km, the Engine Sevice light comes on again, 4 days after I filled up the gas. I checked the cap and it was tightly closed and there is no way one could close any tighter!!!
The car still drive the same and I do not notice anything problem!
It is becoming so annoying that I don't know I should do about this!
I have never had a car before that gives me any unexpected problem, even after 150,000km.
I don't mind the regular wear and tear maintenance, but not something like this! And the worse thing is that the service department of the BMW dealership is not willing to take ownership of the problem, and trying to blame the customer for the problem so they charge them to fix it!!!
Does anyone have any good suggestion as of what I should do with this problem?
I am really thankful to see that a lot of members of this forum are really supportive and are helping each other out when someone has a problem or a question.
Check your oil level. on the computer in the dash display. I had to fill this up soon after I got my car...
pyceasyas123 is offline  
0
Reply With Quote
      04-16-2012, 09:27 AM   #932
williewonkerz
Second Lieutenant
 
williewonkerz's Avatar
 
Drives: 335xi Spec Edition
Join Date: Jun 2011
Location: Winnipeg

Posts: 289
iTrader: (0)

Garage List
Quote:
Originally Posted by Kernel Kurtz View Post
I find the ride on mine to be quite harsh with the 19s compared to the 17s I had on my previous 335. Also find the bottom drags on the ruts in my back lane during the winter, so I'd only be interested in a setup where ride height is easily adjustable.

See you are in the Peg as well. Are you a BMWCCM member? Also had a look at your garage pics and the window tint on your car looks good. Who applied it if you don't mind my asking....?
I'm not aware of "BMWCCM", but I'm sure I'd like to be.

I actually have changed the car a little. The dealership put a painted Spoiler on my car (because of the delay). I also put so spacers on, it makes the gap look less noticeable.

They also did the tint and just recently I had my first vertical scratch on the drivers window
williewonkerz is offline   Canada
0
Reply With Quote
      04-16-2012, 11:44 AM   #933
morphius909
Lieutenant
 
morphius909's Avatar
 
Drives: 2011 335 Xi Special Edition-JB
Join Date: Sep 2011
Location: Edmonton, Alberta

Posts: 546
iTrader: (0)

Quote:
Originally Posted by Boco335iXdriveSE View Post
My Engine Service light is on and stayed on again today! The car only has 2617km! I have the oil cap secured 100% for sure!
The first time the engine light came on was when the car had 750km on it, and 3 days after I filled up the gas. I bought my back to the dealer at that time and the service agent at the BMW Autohaus said that the oil cap was not tight, which caused that. He wanted to charge me $150 to cleared the Engine Light. He waived the charge after I argued with him, as I did not believe in that since I was very sure the oil cap was tightly closed.
Now at 2617km, the Engine Sevice light comes on again, 4 days after I filled up the gas. I checked the cap and it was tightly closed and there is no way one could close any tighter!!!
The car still drive the same and I do not notice anything problem!
It is becoming so annoying that I don't know I should do about this!
I have never had a car before that gives me any unexpected problem, even after 150,000km.
I don't mind the regular wear and tear maintenance, but not something like this! And the worse thing is that the service department of the BMW dealership is not willing to take ownership of the problem, and trying to blame the customer for the problem so they charge them to fix it!!!
Does anyone have any good suggestion as of what I should do with this problem?
I am really thankful to see that a lot of members of this forum are really supportive and are helping each other out when someone has a problem or a question.
what color is the engine light?
Red?
Yellow?
__________________


2011 335i X Drive Special Edition-Jerez Black
35% Tint All Around / 3M Rockguard / Weathertech/ PPK2 / 18&12mm Spacers/Lux H8 V3
morphius909 is offline  
0
Reply With Quote
      04-16-2012, 11:45 AM   #934
pyceasyas123
Captain
 
pyceasyas123's Avatar
 
Drives: 335i Sedan
Join Date: May 2009
Location: Toronto

Posts: 741
iTrader: (9)

Quote:
Originally Posted by williewonkerz View Post
I'm not aware of "BMWCCM", but I'm sure I'd like to be.

I actually have changed the car a little. The dealership put a painted Spoiler on my car (because of the delay). I also put so spacers on, it makes the gap look less noticeable.

They also did the tint and just recently I had my first vertical scratch on the drivers window
Which spoiler? perf or m3 or mtech?

Just curious, what spacers did you put in?

For the tint, I had my tint guy cut out the second rubber liner that the window rides on. Otherwise, you can get some felt installed on it but over time the glue will wear out and it may move...causing scratches. I've had my tint in for months now and no issues.
pyceasyas123 is offline  
0
Reply With Quote
      04-16-2012, 11:48 AM   #935
morphius909
Lieutenant
 
morphius909's Avatar
 
Drives: 2011 335 Xi Special Edition-JB
Join Date: Sep 2011
Location: Edmonton, Alberta

Posts: 546
iTrader: (0)

Quote:
Originally Posted by B Brownburry View Post
Getting my car back tonight! Took 24 days (including week-ends) to change the engine.
How is she?

Did they take are of you?
__________________


2011 335i X Drive Special Edition-Jerez Black
35% Tint All Around / 3M Rockguard / Weathertech/ PPK2 / 18&12mm Spacers/Lux H8 V3
morphius909 is offline  
0
Reply With Quote
      04-16-2012, 11:49 AM   #936
morphius909
Lieutenant
 
morphius909's Avatar
 
Drives: 2011 335 Xi Special Edition-JB
Join Date: Sep 2011
Location: Edmonton, Alberta

Posts: 546
iTrader: (0)

Quote:
Originally Posted by pyceasyas123 View Post
Which spoiler? perf or m3 or mtech?

Just curious, what spacers did you put in?

For the tint, I had my tint guy cut out the second rubber liner that the window rides on. Otherwise, you can get some felt installed on it but over time the glue will wear out and it may move...causing scratches. I've had my tint in for months now and no issues.
I've had tint since I bought the car and no issues, but I don't lower the windows much. Is this a time issue or a wear/tear issue?
__________________


2011 335i X Drive Special Edition-Jerez Black
35% Tint All Around / 3M Rockguard / Weathertech/ PPK2 / 18&12mm Spacers/Lux H8 V3
morphius909 is offline  
0
Reply With Quote
      04-16-2012, 11:53 AM   #937
achien
AC
 
Drives: E90 Post Members Crazy
Join Date: May 2007
Location: Toronto, Canada

Posts: 2,378
iTrader: (0)

looks like they sold you a lemon, which "stealership" is this in Toronto?

Quote:
Originally Posted by Boco335iXdriveSE View Post
My Engine Service light is on and stayed on again today! The car only has 2617km! I have the oil cap secured 100% for sure!
The first time the engine light came on was when the car had 750km on it, and 3 days after I filled up the gas. I bought my back to the dealer at that time and the service agent at the BMW Autohaus said that the oil cap was not tight, which caused that. He wanted to charge me $150 to cleared the Engine Light. He waived the charge after I argued with him, as I did not believe in that since I was very sure the oil cap was tightly closed.
Now at 2617km, the Engine Sevice light comes on again, 4 days after I filled up the gas. I checked the cap and it was tightly closed and there is no way one could close any tighter!!!
The car still drive the same and I do not notice anything problem!
It is becoming so annoying that I don't know I should do about this!
I have never had a car before that gives me any unexpected problem, even after 150,000km.
I don't mind the regular wear and tear maintenance, but not something like this! And the worse thing is that the service department of the BMW dealership is not willing to take ownership of the problem, and trying to blame the customer for the problem so they charge them to fix it!!!
Does anyone have any good suggestion as of what I should do with this problem?
I am really thankful to see that a lot of members of this forum are really supportive and are helping each other out when someone has a problem or a question.
__________________
Your Supreme Leader
achien is offline   Canada
0
Reply With Quote
      04-16-2012, 12:27 PM   #938
Kernel Kurtz
First Lieutenant
 
Drives: '11 e90 335xi SE 6mt
Join Date: Sep 2007
Location: Winnipeg, Canada

Posts: 398
iTrader: (0)

Quote:
Originally Posted by williewonkerz View Post
I'm not aware of "BMWCCM", but I'm sure I'd like to be.

I actually have changed the car a little. The dealership put a painted Spoiler on my car (because of the delay). I also put so spacers on, it makes the gap look less noticeable.

They also did the tint and just recently I had my first vertical scratch on the drivers window
BMW Car Club of Manitoba. http://www.bmwpower.ca

They have a "garage door opener" meet coming up in a couple of weeks, and put on a number of interesting events throughout the summer.

I've heard about tint scratching like that and it's one of the things that make me hesitant to do it.

Interesting idea about the spacers. Got a link?
Kernel Kurtz is offline  
0
Reply With Quote
      04-16-2012, 12:31 PM   #939
williewonkerz
Second Lieutenant
 
williewonkerz's Avatar
 
Drives: 335xi Spec Edition
Join Date: Jun 2011
Location: Winnipeg

Posts: 289
iTrader: (0)

Garage List
Quote:
Originally Posted by pyceasyas123 View Post
Which spoiler? perf or m3 or mtech?

Just curious, what spacers did you put in?

For the tint, I had my tint guy cut out the second rubber liner that the window rides on. Otherwise, you can get some felt installed on it but over time the glue will wear out and it may move...causing scratches. I've had my tint in for months now and no issues.
The spoiler is quite small, its not the performance. I prefer the subtly of it (I had the choice).

The spacers are EIBACH PRO-SPACER WHEEL SPACERS - 15MM.

I open my drivers window a lot (parkade) so I'm not surprised they scratched. Its quite minor at this point.
williewonkerz is offline   Canada
0
Reply With Quote
      04-16-2012, 12:33 PM   #940
pyceasyas123
Captain
 
pyceasyas123's Avatar
 
Drives: 335i Sedan
Join Date: May 2009
Location: Toronto

Posts: 741
iTrader: (9)

Quote:
Originally Posted by Kernel Kurtz View Post
BMW Car Club of Manitoba. http://www.bmwpower.ca

They have a "garage door opener" meet coming up in a couple of weeks, and put on a number of interesting events throughout the summer.

I've heard about tint scratching like that and it's one of the things that make me hesitant to do it.

Interesting idea about the spacers. Got a link?
Quote:
Originally Posted by morphius909 View Post
I've had tint since I bought the car and no issues, but I don't lower the windows much. Is this a time issue or a wear/tear issue?
The car has 2 rubber liners on the inside of the door that the window runs on as its being put up and down. If you cut out the second one you will never have an issue with tints. I did this on my last car and also with my new one. If you install a felt strip across the rubber, the glue may dry out or wear out overtime and the felt may move slightly. If this happens then there is a good chance that you will be scratching the tint. Hope that makes sense.
pyceasyas123 is offline  
0
Reply With Quote
      04-16-2012, 12:40 PM   #941
pyceasyas123
Captain
 
pyceasyas123's Avatar
 
Drives: 335i Sedan
Join Date: May 2009
Location: Toronto

Posts: 741
iTrader: (9)

Teaser for you guys...more pics coming soon. I'll post a link in here to the photo thread when they are ready.

pyceasyas123 is offline  
0
Reply With Quote
      04-16-2012, 01:32 PM   #942
Boco335iXdriveSE
Private
 
Drives: 335i Xdrive Special Edition
Join Date: Feb 2012
Location: Markham

Posts: 76
iTrader: (0)

Quote:
Originally Posted by pyceasyas123 View Post
Check your oil level. on the computer in the dash display. I had to fill this up soon after I got my car...
I checked on the computer in the dash display and it shows green and no problem reported
Boco335iXdriveSE is offline  
0
Reply With Quote
      04-16-2012, 01:33 PM   #943
Boco335iXdriveSE
Private
 
Drives: 335i Xdrive Special Edition
Join Date: Feb 2012
Location: Markham

Posts: 76
iTrader: (0)

Quote:
Originally Posted by morphius909 View Post
what color is the engine light?
Red?
Yellow?
It is yellow and it is a picture of the Engine
Boco335iXdriveSE is offline  
0
Reply With Quote
      04-16-2012, 01:47 PM   #944
morphius909
Lieutenant
 
morphius909's Avatar
 
Drives: 2011 335 Xi Special Edition-JB
Join Date: Sep 2011
Location: Edmonton, Alberta

Posts: 546
iTrader: (0)

Quote:
Originally Posted by Boco335iXdriveSE View Post
It is yellow and it is a picture of the Engine
Yellow can be the gas cap. Drive around for a while spirited. If it was RED it would be "STop car and get it put on a flat bed"

Yellow is warning, bring it in when you can or drive it to remove the , more then likely gas cap warning, but it could be anything.

Can you get the code read at a auto shop for free?
__________________


2011 335i X Drive Special Edition-Jerez Black
35% Tint All Around / 3M Rockguard / Weathertech/ PPK2 / 18&12mm Spacers/Lux H8 V3
morphius909 is offline  
0
Reply With Quote
      04-16-2012, 01:48 PM   #945
morphius909
Lieutenant
 
morphius909's Avatar
 
Drives: 2011 335 Xi Special Edition-JB
Join Date: Sep 2011
Location: Edmonton, Alberta

Posts: 546
iTrader: (0)

Quote:
Originally Posted by morphius909 View Post
what color is the engine light?
Red?
Yellow?
Some cars, from various manufactuers, are just prone to this.

NO idea about the science about it but I'd say it's the most common false alarm.
__________________


2011 335i X Drive Special Edition-Jerez Black
35% Tint All Around / 3M Rockguard / Weathertech/ PPK2 / 18&12mm Spacers/Lux H8 V3
morphius909 is offline  
0
Reply With Quote
      04-16-2012, 02:42 PM   #946
Boco335iXdriveSE
Private
 
Drives: 335i Xdrive Special Edition
Join Date: Feb 2012
Location: Markham

Posts: 76
iTrader: (0)

Quote:
Originally Posted by morphius909 View Post
Yellow can be the gas cap. Drive around for a while spirited. If it was RED it would be "STop car and get it put on a flat bed"

Yellow is warning, bring it in when you can or drive it to remove the , more then likely gas cap warning, but it could be anything.

Can you get the code read at a auto shop for free?
If it is caused by the oil cap, then there must be some problem with the oil cap, because I always turn to the point that there is no way to tighten it any further

When you said "Drive around for a while spirited", do you mean driving it fast, how fast should I go??

Last time BMW Autohaus dealer where I I bought it from said he was going to charge me about $150 if it was the oil cap, but like i said if it is the oil cap then there is a problem with the cap. He probably going to say it is the oil cap. BUt how am I able to verify that???
Boco335iXdriveSE is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:58 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST