E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Bluetooth problem ??



Reply
 
Thread Tools Search this Thread
      07-12-2011, 02:37 PM   #1
Butch
Second Lieutenant
 
Butch's Avatar
 
Drives: E90 330i SE Auto
Join Date: Oct 2009
Location: South Yorkshire, UK.

Posts: 282
iTrader: (1)

Garage List
2005 330i  [0.00]
Bluetooth problem ??

Hope someone can help me...

Bluetooth seems to have stopped working on the car, which it has done odd times in the past, but it normally comes up ok the next time I start the car up... this time it hasn't?

I've deleted the pairing in the phone, but I now can't even access the phone menu on the car - I'm getting the same problem as this guy in this video.



It's just like the bluetooth has disappeared from memory, no phone functions work ?

Anyone any ideas - ta muchly?
__________________


BMW E90 (2005) 330i SE Auto - E90Post Stickers, Exhaust Mod, Private Plates, Debadged, 19" Style 230 wheels, Toyo Non-RFT, MFD Scoops, K&N, Black Calipers/Hubs, 35% Rear Window Tints, Black/White Roundels, BMW Splitters, Blacklines, 12mm Rear Spacers, BMWP Knob... Future Mods - Drop?
Butch is offline   United Kingdom
0
Reply With Quote
      07-13-2011, 03:13 PM   #2
Butch
Second Lieutenant
 
Butch's Avatar
 
Drives: E90 330i SE Auto
Join Date: Oct 2009
Location: South Yorkshire, UK.

Posts: 282
iTrader: (1)

Garage List
2005 330i  [0.00]
Bluetooth still not working - so annoying, any ideas folks???
__________________


BMW E90 (2005) 330i SE Auto - E90Post Stickers, Exhaust Mod, Private Plates, Debadged, 19" Style 230 wheels, Toyo Non-RFT, MFD Scoops, K&N, Black Calipers/Hubs, 35% Rear Window Tints, Black/White Roundels, BMW Splitters, Blacklines, 12mm Rear Spacers, BMWP Knob... Future Mods - Drop?
Butch is offline   United Kingdom
0
Reply With Quote
      07-13-2011, 03:43 PM   #3
marcm
Second Lieutenant
 
marcm's Avatar
 
Drives: E90 325d
Join Date: Jan 2007
Location: UK

Posts: 286
iTrader: (1)

Have you tried to reset the bluetooth unit... If on your car its located under the floor in the boot disconnect the power to it (pull out the plugs) wait a couple of minutes for discharge then plug back in and wait a few more minutes and switch on.

Worth a shot.
marcm is offline   United Kingdom
0
Reply With Quote
      07-13-2011, 04:49 PM   #4
m1bjr
LSD - No, you're not seeing things
 
m1bjr's Avatar
 
Drives: RS250 CUP
Join Date: Mar 2010
Location: Somerset UK

Posts: 3,313
iTrader: (4)

Send a message via MSN to m1bjr
Pull the battery terminal for 30min.

It's possible the module has lost sync/comms.

If so it's a dealer recode jobbie, unless you know of a BMW 'coder' guy in your vacinity.
__________________
m1bjr is offline   United Kingdom
0
Reply With Quote
      07-13-2011, 05:22 PM   #5
Butch
Second Lieutenant
 
Butch's Avatar
 
Drives: E90 330i SE Auto
Join Date: Oct 2009
Location: South Yorkshire, UK.

Posts: 282
iTrader: (1)

Garage List
2005 330i  [0.00]
Thanks for that, will try and find the bluetooth unit first and disconnect the power.

If that doesn't work I will disconnect the battery for 30 mins, but will I get the car up and running ok again without issues?

Have got a friendly BMW guy nearby if worst comes to worst !!

Cheers.
__________________


BMW E90 (2005) 330i SE Auto - E90Post Stickers, Exhaust Mod, Private Plates, Debadged, 19" Style 230 wheels, Toyo Non-RFT, MFD Scoops, K&N, Black Calipers/Hubs, 35% Rear Window Tints, Black/White Roundels, BMW Splitters, Blacklines, 12mm Rear Spacers, BMWP Knob... Future Mods - Drop?
Butch is offline   United Kingdom
0
Reply With Quote
      07-14-2011, 05:39 AM   #6
Butch
Second Lieutenant
 
Butch's Avatar
 
Drives: E90 330i SE Auto
Join Date: Oct 2009
Location: South Yorkshire, UK.

Posts: 282
iTrader: (1)

Garage List
2005 330i  [0.00]
Well I've taken the bluetooth module out, unplugged it for an hour and plugged back in... still nothing !!!

Will disconnecting the battery (I presume its the one in the boot) actually reset anything else associated with bluetooth?

Also, will I get all the stereo settings and car running ok again if I actually disconnect the battery for a while ???

I really don't want to be stranded or can't start the car once I've drained the power?
__________________


BMW E90 (2005) 330i SE Auto - E90Post Stickers, Exhaust Mod, Private Plates, Debadged, 19" Style 230 wheels, Toyo Non-RFT, MFD Scoops, K&N, Black Calipers/Hubs, 35% Rear Window Tints, Black/White Roundels, BMW Splitters, Blacklines, 12mm Rear Spacers, BMWP Knob... Future Mods - Drop?
Butch is offline   United Kingdom
0
Reply With Quote
      07-21-2011, 09:24 AM   #7
Butch
Second Lieutenant
 
Butch's Avatar
 
Drives: E90 330i SE Auto
Join Date: Oct 2009
Location: South Yorkshire, UK.

Posts: 282
iTrader: (1)

Garage List
2005 330i  [0.00]
Really need some help on this one guys !!!

Garage can't get the diagnostics to read anything from the bluetooth, so they think the unit needs replacing, but cost to do this is just ridiculous... 556 !!!

There are a few second hand units on ebay for much cheaper, but need to know if I need to match the part number ???

The part number on my failed unit is 84 21 6-965406-01

There are a few on ebay that say suitable for E90 but the part numbers don't match - does anybody know if I have to get the exact same part number or will any BMW bluetooth unit work ?
__________________


BMW E90 (2005) 330i SE Auto - E90Post Stickers, Exhaust Mod, Private Plates, Debadged, 19" Style 230 wheels, Toyo Non-RFT, MFD Scoops, K&N, Black Calipers/Hubs, 35% Rear Window Tints, Black/White Roundels, BMW Splitters, Blacklines, 12mm Rear Spacers, BMWP Knob... Future Mods - Drop?
Butch is offline   United Kingdom
0
Reply With Quote
      07-21-2011, 02:16 PM   #8
markymark34
Second Lieutenant
 
Drives: 2007 325d M Sport
Join Date: Jul 2009
Location: NI

Posts: 245
iTrader: (0)

Quote:
Originally Posted by Butch View Post
Really need some help on this one guys !!!

Garage can't get the diagnostics to read anything from the bluetooth, so they think the unit needs replacing, but cost to do this is just ridiculous... 556 !!!

There are a few second hand units on ebay for much cheaper, but need to know if I need to match the part number ???

The part number on my failed unit is 84 21 6-965406-01

There are a few on ebay that say suitable for E90 but the part numbers don't match - does anybody know if I have to get the exact same part number or will any BMW bluetooth unit work ?
I have the same problem as u. BMW will give me a new control unit at 420. Totally stupid money. There is no other way round it. My local indy bmw guy told me he has seen several control units go in e90s and there are 2 types. 1 is 250 and the other is 420.

So thats that then. What im looking at now is having an aftermarket blutooth fitted that will sync in with the cars controls and look invisible. Im not prepared to pay 420.

My guy said dont even think of buying one of ebay as it could go in the next week/month.

Sucks. there must be a cheaper work around.

Mark
markymark34 is offline  
0
Reply With Quote
      07-21-2011, 02:18 PM   #9
markymark34
Second Lieutenant
 
Drives: 2007 325d M Sport
Join Date: Jul 2009
Location: NI

Posts: 245
iTrader: (0)

ps removing the battery didnt work for me, all it did was give me a seatbelt error on the dash which now wont go away. ;-(
markymark34 is offline  
0
Reply With Quote
      07-23-2011, 01:09 PM   #10
Butch
Second Lieutenant
 
Butch's Avatar
 
Drives: E90 330i SE Auto
Join Date: Oct 2009
Location: South Yorkshire, UK.

Posts: 282
iTrader: (1)

Garage List
2005 330i  [0.00]
Yeah, its alot for a bluetooth unit. Also read this on RealOEM:

A TCU (Telematics Control Unit) can
only be ordered with specification of
the Vehicle Identification Number. When
shipping the exchange TCU, the
Vehicle Identification Number is coded.
Recoding is not possible. The TCU only
functions properly with suitable coding.
Therefore, exchange TCUs cannot be
ordered for stock! Retrofitting and
conversions to SA633 are
not possible!

I don't want to risk 100 on ebay and have it not work, fail again in a few weeks or have problems recoding it - so for now I'm gonna do without !!!
__________________


BMW E90 (2005) 330i SE Auto - E90Post Stickers, Exhaust Mod, Private Plates, Debadged, 19" Style 230 wheels, Toyo Non-RFT, MFD Scoops, K&N, Black Calipers/Hubs, 35% Rear Window Tints, Black/White Roundels, BMW Splitters, Blacklines, 12mm Rear Spacers, BMWP Knob... Future Mods - Drop?
Butch is offline   United Kingdom
0
Reply With Quote
      07-24-2011, 06:53 AM   #11
m1bjr
LSD - No, you're not seeing things
 
m1bjr's Avatar
 
Drives: RS250 CUP
Join Date: Mar 2010
Location: Somerset UK

Posts: 3,313
iTrader: (4)

Send a message via MSN to m1bjr
Ask this question over on ********* dot com mate.
__________________
m1bjr is offline   United Kingdom
0
Reply With Quote
      07-30-2011, 03:33 AM   #12
markymark34
Second Lieutenant
 
Drives: 2007 325d M Sport
Join Date: Jul 2009
Location: NI

Posts: 245
iTrader: (0)

update on my story. I had seatbelt/airbag lights on as well. Local indy found a loose connection on the positive battery terminal which was causing the lights. Fixed, and to my surprise the bluetooth is back and working!
There are quite a few connections on the +ve terminal. Might be worth a try although im guessing u would have lights on the dash.
Needless to say im very happy!
markymark34 is offline  
0
Reply With Quote
      10-19-2011, 02:10 PM   #13
PeTo_H
Private
 
Drives: '99 528iA, X6 35i on the way
Join Date: May 2008
Location: Slovakia

Posts: 66
iTrader: (0)

I have the same problem... Anyone else knows how to make it work again?
PeTo_H is offline   Slovakia
0
Reply With Quote
      11-27-2012, 11:53 AM   #14
hlbrrr
New Member
 
Drives: bmw 325i '05
Join Date: Nov 2012
Location: Mgn

Posts: 10
iTrader: (0)

Same issue with my 325i '05 non-iDrive. Any advice?
hlbrrr is offline  
0
Reply With Quote
      11-27-2012, 12:04 PM   #15
markymark34
Second Lieutenant
 
Drives: 2007 325d M Sport
Join Date: Jul 2009
Location: NI

Posts: 245
iTrader: (0)

have a look at my post 3 above. was really irritating but turned out to be very simple. certainly worth a try anyway.
markymark34 is offline  
0
Reply With Quote
      11-27-2012, 12:35 PM   #16
hlbrrr
New Member
 
Drives: bmw 325i '05
Join Date: Nov 2012
Location: Mgn

Posts: 10
iTrader: (0)

Thanks, but already tried - no success. Fuse #17 replacement didn't solve the issue too.
hlbrrr is offline  
0
Reply With Quote
      11-27-2012, 12:41 PM   #17
hlbrrr
New Member
 
Drives: bmw 325i '05
Join Date: Nov 2012
Location: Mgn

Posts: 10
iTrader: (0)

Also checked bluetooth antenna in driver's footwell - connected. But the TEL menu still displays '- -' and some times (usually on cold start after night) shows the telephone symbol briefly before disappearing while the radio cuts out for a fraction of a second.
hlbrrr is offline  
0
Reply With Quote
      11-27-2012, 01:13 PM   #18
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,197
iTrader: (0)

Garage List
2006 330i  [2.83]
Have u tried a different phone? Make sure your blutooth connection on your phone its ON. I would try it if I were you.
GoRomeo is offline  
0
Reply With Quote
      11-27-2012, 01:29 PM   #19
hlbrrr
New Member
 
Drives: bmw 325i '05
Join Date: Nov 2012
Location: Mgn

Posts: 10
iTrader: (0)

I think it's some kind of software problem with car. Sometimes, when I press telephone button (on the wheel or dashboard nomatter), radio displays message "Switch on BT to make a call" and there is a title on the bottom of display "BT-ON", but nothing happens when I press button under this title. Sometimes pressing telephone button have no effect at all.
hlbrrr is offline  
0
Reply With Quote
      11-28-2012, 07:12 AM   #20
hlbrrr
New Member
 
Drives: bmw 325i '05
Join Date: Nov 2012
Location: Mgn

Posts: 10
iTrader: (0)

Today, local bmw guy said that ULF module is present, but not responding. He will try to code it tommorow.
hlbrrr is offline  
0
Reply With Quote
      11-29-2012, 04:28 AM   #21
hlbrrr
New Member
 
Drives: bmw 325i '05
Join Date: Nov 2012
Location: Mgn

Posts: 10
iTrader: (0)

Fixed. New MULF2 was intalled and coded.
hlbrrr is offline  
0
Reply With Quote
      11-29-2012, 08:38 AM   #22
hlbrrr
New Member
 
Drives: bmw 325i '05
Join Date: Nov 2012
Location: Mgn

Posts: 10
iTrader: (0)

Another question - where can I find manual for phone and voice commands functionality?
hlbrrr is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:52 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST