E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Help! rubber piece came off - rear windshield



Reply
 
Thread Tools Search this Thread
      05-06-2006, 10:34 AM   #1
ska///235i
***** noob
ska///235i's Avatar
United_States
196
Rep
9,239
Posts

 
Drives: M235i
Join Date: Sep 2005
Location: Boston

iTrader: (32)

Garage List
2006 325xi  [0.00]
Help! rubber piece came off - rear windshield

The lower rubber piece came half-way off on the rear glass
I just pushed it back in.....Do I need to bring it in to a dealer or as long as it stays on I should be fine?

I dont want my trunk to get flooded in the rain

Thx!
Attached Images
  
Appreciate 0
      05-06-2006, 10:46 AM   #2
E90Fleet
Major General
South Africa
157
Rep
8,099
Posts

 
Drives: BMW
Join Date: Apr 2005
Location: South Africa

iTrader: (0)

Should be fine, but if it comes loose again have the dealer replace it.

The trunk is sealed by the inner rubber seal seen at the bottom of your 2nd pic
__________________
Nominated: Member of the Year, Most Contributing Member


BMW if you are reading, I need a job
Appreciate 0
      05-06-2006, 10:49 AM   #3
ska///235i
***** noob
ska///235i's Avatar
United_States
196
Rep
9,239
Posts

 
Drives: M235i
Join Date: Sep 2005
Location: Boston

iTrader: (32)

Garage List
2006 325xi  [0.00]
Fleet

You the MAN!

Thanks!
Appreciate 0
      05-06-2006, 10:50 AM   #4
willpooted
Private
0
Rep
83
Posts

 
Drives: 2006 325i
Join Date: Jul 2005
Location: Encino, CA

iTrader: (0)

I would bring it in, just in case. Some rain somehow got into my trunk and shorted my audio system. The smell of burning plastic wasn't too pleasant. Result? Replaced the amp, wiring, and a few speakers.
__________________
5/06/05 | 2006 Alpine White 325i | Premium | Sport | Xenon | Beige Dakota w/ Poplar
Appreciate 0
      05-06-2006, 10:51 AM   #5
ska///235i
***** noob
ska///235i's Avatar
United_States
196
Rep
9,239
Posts

 
Drives: M235i
Join Date: Sep 2005
Location: Boston

iTrader: (32)

Garage List
2006 325xi  [0.00]
Quote:
Originally Posted by willpooted
I would bring it in, just in case. Some rain somehow got into my trunk and shorted my audio system. The smell of burning plastic wasn't too pleasant. Result? Replaced the amp, wiring, and a few speakers.
Was it the same rubber piece that came loose?????
Appreciate 0
      05-06-2006, 10:53 AM   #6
willpooted
Private
0
Rep
83
Posts

 
Drives: 2006 325i
Join Date: Jul 2005
Location: Encino, CA

iTrader: (0)

Quote:
Originally Posted by ska
Was it the same rubber piece that came loose?????
No, nothing came loose. But I figured erring on the side of caution couldn't hurt. You should be fine if the trunk is indeed sealed well. I guess mine just wasn't.
__________________
5/06/05 | 2006 Alpine White 325i | Premium | Sport | Xenon | Beige Dakota w/ Poplar
Appreciate 0
      05-06-2006, 10:53 AM   #7
E90Fleet
Major General
South Africa
157
Rep
8,099
Posts

 
Drives: BMW
Join Date: Apr 2005
Location: South Africa

iTrader: (0)

Quote:
Originally Posted by willpooted
I would bring it in, just in case. Some rain somehow got into my trunk and shorted my audio system. The smell of burning plastic wasn't too pleasant. Result? Replaced the amp, wiring, and a few speakers.
Did you have your rear window tinted ?

Most people dont realize the amount of water taht gets into the amp area when you tint your windows
__________________
Nominated: Member of the Year, Most Contributing Member


BMW if you are reading, I need a job
Appreciate 0
      05-06-2006, 10:57 AM   #8
tonyobrien
Second Lieutenant
tonyobrien's Avatar
Ireland
6
Rep
267
Posts

 
Drives: 320d SE
Join Date: Jul 2005
Location: Cork, Ireland

iTrader: (0)

Garage List
This is a manufacturing fault on the E90. I noticed mine was like that a few weeks after getting the car. I believe a few other people on this forum have reported the same and I bet there are others who have it but haven't noticed yet.

Rather than the mess of bringing it back to the dealer I bought some silcone sealant for windscreen rubbers in a auto repair shop and stuck it back on myself.
__________________
320d | 6sp Man | Sapphire Black | Beige/Dakota Leather/Burl Walnut | Sunroof | Comfort Access | PDC Front & Rear | Cruise | Adaptive Xenons | Sports Seats | Heated Seats | Hi-Fi Sound | Bluetooth | Style 158 Alloys | Chrome Grill | Chrome Window Trim | Split Folding Armrest | Dual Zone Climate Control | LEDs on Door Handles | Through Loading System | Power Folding Mirrors | Rain Sensor | Auto-dimming centre and side mirrors | Sports Steering Wheel | Rear Side Blinds | Smokers Package DELETED | Belkin iPod Charger (Black) & Sound Professionals 8" Aux Cable | Sony Ericsson K750i | iPod Nano
Appreciate 0
      05-06-2006, 11:06 AM   #9
E90Fleet
Major General
South Africa
157
Rep
8,099
Posts

 
Drives: BMW
Join Date: Apr 2005
Location: South Africa

iTrader: (0)

Quote:
Originally Posted by tonyobrien
This is a manufacturing fault on the E90. I noticed mine was like that a few weeks after getting the car. I believe a few other people on this forum have reported the same and I bet there are others who have it but haven't noticed yet.

Rather than the mess of bringing it back to the dealer I bought some silcone sealant for windscreen rubbers in a auto repair shop and stuck it back on myself.
Its not a seal but just a cover
Its only held on by a small amount of low strength adhesive.
Its made to be pulled off by hand should your rear windshield need replacement.


If there is a problem with a few comming loose, then it would be a problem with the small adhesive strip in the rubber, and it should be fixed under warranty by the dealer
__________________
Nominated: Member of the Year, Most Contributing Member


BMW if you are reading, I need a job
Appreciate 0
      05-06-2006, 11:59 AM   #10
mds82
Major General
mds82's Avatar
128
Rep
5,858
Posts

 
Drives: 2006 325xi
Join Date: Aug 2005
Location: South Central Connecticut

iTrader: (40)

Garage List
Send a message via AIM to mds82 Send a message via Yahoo to mds82
I had the same happen to my car a while back. I told the dealership about it and they were more then happy to replace it
Appreciate 0
      05-06-2006, 12:01 PM   #11
espo
Captain
espo's Avatar
United_States
7
Rep
718
Posts

 
Drives: 2014 M235i
Join Date: Sep 2005
Location: Sugar Land TX

iTrader: (0)

Just noticed the same thing on my car when I washed it last weekend.. Pushed it back on and it rained during the week... No water in the trunk..
__________________
E46 325xi Oxford Green/Sand Leatherette/Myrtle Wood Auto ZCW - Retired
E90 330xi Mystic Blue/Black Leather/Aluminum 6sp Manual ZSP/ZPP/ZCW/CA - Retired
F22 M235i Mineral Gray/Red Leather/Aluminum 6sp Manual ZPP/ZTP
Appreciate 0
      05-06-2006, 01:01 PM   #12
E90330iS
Major General
Germany
74
Rep
6,327
Posts

 
Drives: E90 330i
Join Date: Jan 2006
Location: Arcadia, California

iTrader: (56)

Garage List
2006 330i  [0.00]
Send a message via AIM to E90330iS Send a message via MSN to E90330iS Send a message via Skype™ to E90330iS
replace replace!
__________________
1. E90 325i/328i/330i Eisenmann Race Exhaust 2 x 76mm (Used for 30000 miles) $680 OBO
2. E90 M3 Jet Black Front Bumper $120 OBO
3. E90 M3 Style CF Trunk Spoiler $80 OBO
Appreciate 0
      05-06-2006, 01:48 PM   #13
Asiann
Got Seoul?
United_States
35
Rep
2,861
Posts

 
Drives: 2012 535i MSport
Join Date: Dec 2005
Location: Honolulu

iTrader: (0)

Garage List
2012 BMW 535i  [0.00]
2008 750Li  [0.00]
2006 BMW  [0.00]
Quote:
Originally Posted by ska
The lower rubber piece came half-way off on the rear glass
I just pushed it back in.....Do I need to bring it in to a dealer or as long as it stays on I should be fine?

I dont want my trunk to get flooded in the rain

Thx!
I checked mine and it is fastened really good. I would at least put some type of sealant to keep the water out.
__________________
Can you say Alooooha?
[SIGPIC][/SIGPIC]
Appreciate 0
      05-06-2006, 02:04 PM   #14
willpooted
Private
0
Rep
83
Posts

 
Drives: 2006 325i
Join Date: Jul 2005
Location: Encino, CA

iTrader: (0)

Quote:
Originally Posted by E90Fleet
Did you have your rear window tinted ?

Most people dont realize the amount of water taht gets into the amp area when you tint your windows
My rear window is tinted, but isn't the tint applied in the inside of the vehicle? I don't see how water could get in through there.
__________________
5/06/05 | 2006 Alpine White 325i | Premium | Sport | Xenon | Beige Dakota w/ Poplar
Appreciate 0
      05-06-2006, 02:21 PM   #15
E90Fleet
Major General
South Africa
157
Rep
8,099
Posts

 
Drives: BMW
Join Date: Apr 2005
Location: South Africa

iTrader: (0)

Quote:
Originally Posted by willpooted
My rear window is tinted, but isn't the tint applied in the inside of the vehicle? I don't see how water could get in through there.
Yes, tint is on the inside

Notice on the inside at the very bottom there are airvent holes on the rear deck

When they put on the tint the water they spray goes into these vents and they lead straight to that compartment with the amp or the other side with the battery.

Same happened in E46 , and a few of those also blew their amps if they didnt allow the water to dry before usuing the car
__________________
Nominated: Member of the Year, Most Contributing Member


BMW if you are reading, I need a job
Appreciate 0
      05-06-2006, 02:31 PM   #16
just4kickz
boku no namae ha...
United_States
134
Rep
11,038
Posts

 
Drives: 2006 BS 330i
Join Date: Feb 2006
Location: S. Bay Area, CA + Newark, NJ + ChiCity + True Blue

iTrader: (11)

Garage List
2006 E90 330i  [0.00]
haha... this happens to me alot... i ended up using cement to seal it... no time to go to dealer

Last edited by just4kickz; 05-06-2006 at 03:43 PM.
Appreciate 0
      05-06-2006, 10:02 PM   #17
StevoSEA
Second Lieutenant
StevoSEA's Avatar
United_States
2
Rep
227
Posts

 
Drives: E90 325i(SA) TiAg/Blk ZSP 6mt
Join Date: Dec 2005
Location: Long Beach, Ca

iTrader: (0)

Quote:
Originally Posted by E90330iS
replace replace!
Noticed mine was loose the same day that took delivery of my E90. The dealer replaced the complete rubber strip (and gave me a 325ci to drive around for 48hrs while waiting for the part). I walked around the dealership the next morning, before they opened for business and noticed that about 75% of the e90's on the lot (October 2005) had the same loose rear widow rubber strip as mine.
Appreciate 0
      06-19-2009, 07:54 PM   #18
MrDummy
→сяuisiиg iи му вмш←
MrDummy's Avatar
United_States
27
Rep
1,643
Posts

 
Drives: 2010 Space Gray 328i
Join Date: May 2009
Location: The Unemployment Capitol of America

iTrader: (1)

Garage List
2010 BMW 328i  [0.00]
Just had this happen today, they were buffing the deck lid and ripped it off, so they put a new one on, told me to NOT get it wet for 24 hrs to let it dry. But I dont have a garage and its raining right now, so it had about 3 hours or so to settle b4 the rain started. So I hope it stays on there and doesnt leak.
__________________
SuPerMoD @ MassMonsterz.com
A "Happy" Owner of a Metallic Space Gray 2010 BMW 328i
ProGaMeR on the XboX 360
Appreciate 0
      06-19-2009, 08:07 PM   #19
nhhiep
Captain
17
Rep
739
Posts

 
Drives: bmw
Join Date: Jan 2006
Location: Arizona

iTrader: (0)

at 47k miles, I noticed this last weekend while washing the car. this will be one of the things that I will ask them to fix it before 50k.

I will also push them to replace the head because of the ticking. Worth a try right? Even they already bleed the system, didn't fix it. maybe this time, will ask them to open a PUMA case.

so, anything else should i ask for before 50k?
Appreciate 0
      06-19-2009, 08:40 PM   #20
MrDummy
→сяuisiиg iи му вмш←
MrDummy's Avatar
United_States
27
Rep
1,643
Posts

 
Drives: 2010 Space Gray 328i
Join Date: May 2009
Location: The Unemployment Capitol of America

iTrader: (1)

Garage List
2010 BMW 328i  [0.00]
^^ I havent noticed any ticking yet, you referring to the engine? I heard it only does it in cold weather is that true?

is your car new or a cpo?
__________________
SuPerMoD @ MassMonsterz.com
A "Happy" Owner of a Metallic Space Gray 2010 BMW 328i
ProGaMeR on the XboX 360
Appreciate 0
      06-19-2009, 09:00 PM   #21
ejazbmw
blahhh
ejazbmw's Avatar
94
Rep
6,350
Posts

 
Drives: 2011 E92 335i
Join Date: Apr 2007
Location: NJ/NY

iTrader: (7)

wow talk about thread from the past
Appreciate 0
      06-20-2009, 06:59 PM   #22
nhhiep
Captain
17
Rep
739
Posts

 
Drives: bmw
Join Date: Jan 2006
Location: Arizona

iTrader: (0)

Quote:
Originally Posted by MrDummy View Post
^^ I havent noticed any ticking yet, you referring to the engine? I heard it only does it in cold weather is that true?

is your car new or a cpo?

yes, only in cold weather or when the engine is cold. are you sure your car doesn't tick? most of them tick, just how bad.

mine is new. if it is a CPO, i wouldn't worry at around 50k
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:44 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST