E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Turbo and Boost Issues



Reply
 
Thread Tools Search this Thread
      08-02-2011, 04:37 PM   #1
tegoblue335i
Enlisted Member
 
tegoblue335i's Avatar
 
Drives: AW 135i
Join Date: Nov 2010
Location: Orlando, FL

Posts: 45
iTrader: (0)

Turbo and Boost Issues

So about a week ago I was on a little road trip and on the way to my destination I loose basically all my boost. I initially thought that it was just a boost leak, but then my turbos started making a very slight supercharger type of noise upon trying to make boost. I had no choice but to keep driving but keeping the car out of boost. Anytime i would slightly give it gas i would get a half engine light.

Anyways, i bring the car to the dealer when I return and left it there for a few days. I pick it up and they tell me they replaced both the turbos! (For free under CPO warrenty) I was happy to say the least but not for long...

So i drive the car perfectly for just a day, then I notice that my boost was slowly but surely decreasing after every pull. It eventually got down to about 1 psi max lol. So I take it back to the dealer and they look at it for a whole day. The next day they tell me they find my procede (shit) and that my trunk vacuum plug was unplugged and said that these things might be causing the problem. I knew they weren't but I agreed to take out the procede and they agreed to look at it again after that.

So that's where I am now. Its currently at the dealer with no procede. Hopefully they can figure it out this time. My concern is that what if it is the turbos again? is it possible to destroy brand new turbos in less than a day?

If you guys have any idea what it could be please let me know. Thanks! Sorry for the long story lol.
__________________
R.I.P. E92 335i :PROcede v4: :Vishnu DCI: BT FMIC :Catless Downpipes:
Current:AW 135i
tegoblue335i is offline   United_States
0
Reply With Quote
      08-02-2011, 04:40 PM   #2
shiv@vishnu
Tuner
 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

Posts: 17,616
iTrader: (0)

It's probably going to be a leak in the vacuum lines that actuate the wastegates. Pretty common on car with 40k+ miles Hopefully the dealership checked this before replacing turbos. But by the sound of it, they didn't.
shiv@vishnu is offline   United_States
0
Reply With Quote
      08-02-2011, 05:01 PM   #3
tegoblue335i
Enlisted Member
 
tegoblue335i's Avatar
 
Drives: AW 135i
Join Date: Nov 2010
Location: Orlando, FL

Posts: 45
iTrader: (0)

Yup, that's initially what I thought it would be, but since they replaced the turbos I assumed they would have already checked preliminary stuff like that. But I guess the techs weren't smart enough to check for leaks first and decided to waste $4,000 of their dollars to replace the turbos lol.
__________________
R.I.P. E92 335i :PROcede v4: :Vishnu DCI: BT FMIC :Catless Downpipes:
Current:AW 135i
tegoblue335i is offline   United_States
0
Reply With Quote
      08-02-2011, 05:03 PM   #4
shiv@vishnu
Tuner
 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

Posts: 17,616
iTrader: (0)

Quote:
Originally Posted by tegoblue335i View Post
Yup, that's initially what I thought it would be, but since they replaced the turbos I assumed they would have already checked preliminary stuff like that. But I guess the techs weren't smart enough to check for leaks first and decided to waste $4,000 of their dollars to replace the turbos lol.
Hey, their laziness is your gain
shiv@vishnu is offline   United_States
0
Reply With Quote
      08-02-2011, 05:10 PM   #5
tegoblue335i
Enlisted Member
 
tegoblue335i's Avatar
 
Drives: AW 135i
Join Date: Nov 2010
Location: Orlando, FL

Posts: 45
iTrader: (0)

haha yes! free turbos FTW
__________________
R.I.P. E92 335i :PROcede v4: :Vishnu DCI: BT FMIC :Catless Downpipes:
Current:AW 135i
tegoblue335i is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:35 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST