E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Anyone please help...horror story



Reply
 
Thread Tools Search this Thread
      08-08-2011, 01:23 PM   #45
eduardomi
Private First Class
United_States
7
Rep
192
Posts

 
Drives: 335i
Join Date: Jul 2011
Location: SocaL

iTrader: (2)

Quote:
Originally Posted by eduardomi View Post
Exactly that.

I think they put either a faulty pump or a 328i pump. Once they removed the "new" pump, I found it was burnt at the plug, as if it shorted while connected. Now, that is a reason to freak out!!! Imagine a short like that burning you computer!

I drove 700 miles today...and the oil temp stayed at 235-245.

However, I know for sure (because I saw it) that the procedure to fill the the cooling system was not done properly. They never ran the electrical pump to bleed the air or anything.

You know what? With the pump change I also asked them to do the change of the transmission sleeve...damn I am afraid they either didn't use the right fluids or just didn't know how to do the job because I feel my car to be "heavier" if you know what I mean...if feel kinda powerless...in between gears it shifts smoothly but there is a fraction of second between changing gears, it is not a fast change I don't know how to explain it. Also, after them fixing the sleeve the car's response was damn fast (you'd push the pedal and it'd go), now I find it hard for it to downshift when in "d" mode....oh....it won't go to D/S mode anymore, don't know why.

Any suggestions? :S

Thanks!

Correction BEFORE
Appreciate 0
      08-08-2011, 01:26 PM   #46
eduardomi
Private First Class
United_States
7
Rep
192
Posts

 
Drives: 335i
Join Date: Jul 2011
Location: SocaL

iTrader: (2)

Quote:
Originally Posted by 3me View Post
Well, I am going to say what you have already heard. Don't go back to that indy shop or the dealership. personally, as soon as my car was out of warranty I went straight to shops I knew about or shops where I am friends with the people working on the cars. Not all dealerships are bad but...Ill save it for another thread haha point is take it to a better shop

As for your transmission, I have a stick and can't speak for yours. I would imagine if there were a problem with it, though, an error code would have been thrown. Exactly when did the car stop entering d/s mode? was it right after they messed with the transmission? did they also do a reprogramming?
I didn't know you needed to reprogram the car after a sleeve change...I doubt they did anything, they only have a obdII tool to read codes, I don't think they know how to program anything, so I doubt it.

The transmission stopped entering D/S mode after the whole ordeal, I don't know if it was after the dealer or after the shop. I didn't notice the issue until the water pump was fixed so I wouldn't know.
Appreciate 0
      08-08-2011, 06:15 PM   #47
dmorga1
Private
United_States
0
Rep
56
Posts

 
Drives: 2006 330i
Join Date: Jul 2009
Location: Cheverly, Maryland

iTrader: (0)

I now live in Maryland, but having lived in LA for 3 years, Glendale is one sketchy place. As others have said, this was a simple problem--you needed a water pump. Yeah, I admit, owning a 335i out of warranty scares the hell out of ME, but I can't blame the car here. It needed a water pump and he screwed the pooch on the job. I wouldn't trust the tranny work either, if I were you. It's a little bit of a hike, but there is a network of independent BMW dealers and they tend to be BMWCCA endorsed and great guys. The closest one to you (I have used him and he is excellent--gruff, but excellent) is Bavarian Workshop (www.bavarianworkshop.com) in West Hills. Go there for any future work--he is a true BMW lover, although he confessed to me he thinks the E90 series is trouble waiting to happen. Nonetheless, I would still trust him over any other indy in the area. He is meticulous.
Appreciate 0
      08-08-2011, 06:24 PM   #48
eduardomi
Private First Class
United_States
7
Rep
192
Posts

 
Drives: 335i
Join Date: Jul 2011
Location: SocaL

iTrader: (2)

Quote:
Originally Posted by dmorga1 View Post
I now live in Maryland, but having lived in LA for 3 years, Glendale is one sketchy place. As others have said, this was a simple problem--you needed a water pump. Yeah, I admit, owning a 335i out of warranty scares the hell out of ME, but I can't blame the car here. It needed a water pump and he screwed the pooch on the job. I wouldn't trust the tranny work either, if I were you. It's a little bit of a hike, but there is a network of independent BMW dealers and they tend to be BMWCCA endorsed and great guys. The closest one to you (I have used him and he is excellent--gruff, but excellent) is Bavarian Workshop (www.bavarianworkshop.com) in West Hills. Go there for any future work--he is a true BMW lover, although he confessed to me he thinks the E90 series is trouble waiting to happen. Nonetheless, I would still trust him over any other indy in the area. He is meticulous.
I truly appreciate your post. I think I went with a "part swapper" rather than with a BMW specialist independent shop. The transmission job is done, there is nothing I can do about it now. I don't know what fluid they used, or what procedure they followed. As you said, Glendale is sketchy and this shop specially I am 100% sure that if I ask the questions, they will lie, so itīd be just a waste of time.

Again, thanks for the referral. I will be visiting them next time.


k.
Appreciate 0
      08-09-2011, 09:03 AM   #49
iflyjetzzz
First Lieutenant
11
Rep
320
Posts

 
Drives: 2008 328i
Join Date: Sep 2010
Location: Tucson, AZ

iTrader: (0)

Quote:
Originally Posted by ENINTY View Post
I think your Indy doesn't know what he is doing.
Entity, you're being nice. You KNOW that Indy doesn't know what he's doing.

OP, I think your car is fine. If the water pump had been replaced properly, you wouldn't have any issues with the car. It looks like all of your problems can be traced to that indy shop. You just need to go to the indy shop that dmorga1 recommended.

When I picked out an indy here in Tucson, I did a lot of reading as to which one had the best reputation. He's probably more expensive than most other indies here in Tucson - I didn't check prices - but his reputation is pristine (Dearing Automotive for anyone in Tucson). I feel more comfortable going to Dearing than I do going to the local dealer.
Most things I do myself, but there are things that I absolutely will not do because I don't want to take the chance of screwing it up.
Appreciate 0
      08-09-2011, 12:53 PM   #50
bchuong58
Enlisted Member
United_States
0
Rep
40
Posts

 
Drives: Black E90
Join Date: May 2011
Location: San Jose, ca

iTrader: (0)

Quote:
Originally Posted by eduardomi View Post
Thanks again for your replies

The shop I took it to only works on BMW,and I just confirmed with them that they don't have to reprogram anything after a water pump change...is this true?

They hooked up their computer and it showed a few faults including the one I mentioned about the oil level sensor display in the dash. Let me try to post from my phone the picture I took of their screen.

Ok I can't but the faults say:

Stored faults

2E84: electric coolant pump communication
2E8B: intelligent battery sensor signal
2ACB: DME master relay activation
2E83: electric coolant pump, power reduced operation
2E85: electric coolant pump, communication
2EA1: oil condition sensor, communication (this is the one I initially noted)
2E98: alternator, communication

Active faults:
2E7C: bit serial-data interface, signal


What do you guys think?

The shop says the dealer messed up the computer programming.

Help, thanks.

k.
"Active faults: 2E7C: bit serial-data interface, signal".
The diagnostic message shows you that this is bit serial-data interface has bad connection, the cable connector is bad or not connected properly, this is not programming issue. It can't communicate to electric coolant pump, intelligent battery sensor signal,
DME master relay, oil condition sensor, alternator etc, because it can't read the data from this serial data interface. The dealer pulled this connector out and did not reconnect it for you.

Last edited by bchuong58; 08-09-2011 at 12:58 PM.
Appreciate 0
      08-13-2011, 02:54 PM   #51
eduardomi
Private First Class
United_States
7
Rep
192
Posts

 
Drives: 335i
Join Date: Jul 2011
Location: SocaL

iTrader: (2)

Quote:
Originally Posted by Potty_Pants View Post
warranty direct
Is it any good? How much do you pay for it? Is it worth it?

By the way, nice avatar haha.

Last edited by eduardomi; 08-13-2011 at 02:55 PM. Reason: Avatar comment
Appreciate 0
      08-13-2011, 02:56 PM   #52
eduardomi
Private First Class
United_States
7
Rep
192
Posts

 
Drives: 335i
Join Date: Jul 2011
Location: SocaL

iTrader: (2)

Quote:
Originally Posted by bchuong58 View Post
"Active faults: 2E7C: bit serial-data interface, signal".
The diagnostic message shows you that this is bit serial-data interface has bad connection, the cable connector is bad or not connected properly, this is not programming issue. It can't communicate to electric coolant pump, intelligent battery sensor signal,
DME master relay, oil condition sensor, alternator etc, because it can't read the data from this serial data interface. The dealer pulled this connector out and did not reconnect it for you.

By installing a "good" water pump, all the faults cleared. Weird... according to the BMW technician, the communication works in a loop, if there is a faulty component in that loop the car go nuts and triggers a bunch of other faults.

Does that sound right?

thanks


k.
Appreciate 0
      08-14-2011, 05:32 PM   #53
bchuong58
Enlisted Member
United_States
0
Rep
40
Posts

 
Drives: Black E90
Join Date: May 2011
Location: San Jose, ca

iTrader: (0)

Quote:
Originally Posted by eduardomi View Post
By installing a "good" water pump, all the faults cleared. Weird... according to the BMW technician, the communication works in a loop, if there is a faulty component in that loop the car go nuts and triggers a bunch of other faults.

Does that sound right?

thanks


k.
My 2 cents..
According to DME connector pinout, Pin 32 is Electric Pump, Pin 33 Intelligent Sensor, Pin 34 is Alternator, Pin 35 Oil Condition sensor. I can believe the Serial bit data line is daisy chained from pins 32, 33, 34 and 35 as a single wire.
The first water pump the Indy shop installed somehow screwed up these pins in this group, thus it triggered a series of faults. The second water pump installed & fixed this communication wiring. Something was not performed properly with this Indy shop in the first water pump fix, can't blame the *ealer for this error.
Going back to your story, the *ealer agent told you that the water was sipping and the water pressure was abnormal and need a water pump replacement, why don't they fix/replace/tighten the hoses first to stop the leakage thus the water pump pressure "may" be not the problem. Life is tough...
Appreciate 0
      08-15-2011, 01:40 AM   #54
eduardomi
Private First Class
United_States
7
Rep
192
Posts

 
Drives: 335i
Join Date: Jul 2011
Location: SocaL

iTrader: (2)

Quote:
Originally Posted by bchuong58 View Post
My 2 cents..
According to DME connector pinout, Pin 32 is Electric Pump, Pin 33 Intelligent Sensor, Pin 34 is Alternator, Pin 35 Oil Condition sensor. I can believe the Serial bit data line is daisy chained from pins 32, 33, 34 and 35 as a single wire.
The first water pump the Indy shop installed somehow screwed up these pins in this group, thus it triggered a series of faults. The second water pump installed & fixed this communication wiring. Something was not performed properly with this Indy shop in the first water pump fix, can't blame the *ealer for this error.
Going back to your story, the *ealer agent told you that the water was sipping and the water pressure was abnormal and need a water pump replacement, why don't they fix/replace/tighten the hoses first to stop the leakage thus the water pump pressure "may" be not the problem. Life is tough...

That makes sense, the pump was screwing up the rest of the loop.

I am impressed with the knowledge in these forums...seriously, BMW should include the reading of these forums as part of their technician training!

Thanks!

k.
Appreciate 0
      08-15-2011, 02:36 AM   #55
ctuna
Brigadier General
45
Rep
4,335
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Since e90's are just coming out of warranty

The experience level even at a good Indy shop isn't that high yet.
Mine changed my radiator fluid but they took the time to read the new
procedures . Sounds like this one got a bad part and it failed if there hadn't been a programming update at the same time the issue wouldn't have been as confusing. Its good to know about the serial bus causing multiple errors.
Thanks for the report.
Appreciate 0
      10-15-2011, 04:05 PM   #56
moon335
New Member
0
Rep
17
Posts

 
Drives: 2008 335i
Join Date: Apr 2010
Location: California

iTrader: (0)

Quote:
Originally Posted by Potty_Pants View Post
warranty direct
Any claims experience?
Appreciate 0
      10-15-2011, 09:42 PM   #57
335BBS
Brigadier General
Canada
42
Rep
3,607
Posts

 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

iTrader: (0)

Quote:
Originally Posted by tibra1 View Post
maybe shoud have got it fixed at BMW..sure it was 700 more..but look at the aggrevation..

I dont usually let the dealer work on my car as Im outta warranty..but in this case I would have bit the bullet..
Exactly. No way the dealer will/should accept any fault as the car was worked on by an Indy. THIS is exactly why you should stick with ONE place for service.
Appreciate 0
      10-15-2011, 09:44 PM   #58
335BBS
Brigadier General
Canada
42
Rep
3,607
Posts

 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

iTrader: (0)

Quote:
Originally Posted by eduardomi View Post
That makes sense, the pump was screwing up the rest of the loop.

I am impressed with the knowledge in these forums...seriously, BMW should include the reading of these forums as part of their technician training!

Thanks!

k.
assume this is a joke?
Appreciate 0
      10-15-2011, 09:55 PM   #59
mike3000fl
Colonel
mike3000fl's Avatar
United_States
49
Rep
2,434
Posts

 
Drives: 06 330i
Join Date: Feb 2010
Location: Tampa

iTrader: (0)

Quote:
Originally Posted by Leaker View Post
assume this is a joke?
why do you continue to shit in threads? if it is that bad here there are other sites on the internet that may interest you.
__________________
2006 330i - Jet Black - 19" E46 M3 wheels - HR Sport - 206,000 Miles...

Appreciate 0
      10-15-2011, 09:58 PM   #60
335BBS
Brigadier General
Canada
42
Rep
3,607
Posts

 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

iTrader: (0)

Quote:
Originally Posted by mike3000fl View Post
why do you continue to shit in threads? if it is that bad here there are other sites on the internet that may interest you.
Sorry. I thought that was funny.
Appreciate 0
      10-22-2011, 09:43 AM   #61
MGM2
Enlisted Member
MGM2's Avatar
0
Rep
32
Posts

 
Drives: 2006 330i e90 , 2008 328i e92
Join Date: May 2010
Location: Pasadena, California

iTrader: (1)

Whats so funny? he is right! the so called techs should do some reading here they would learn something.

I have a bad water pump now on a 2006 330i E90 92k miles on it and I got great info from this forum. i have had the overheated lights come on twice.

I went to two indy shops here in Pasadena Ca. to see if they could read the codes for me, they both told me if there was no check engine light that there wouldn't be any stored. Not to mention the jackass tech told me that my car didn't have electric water pump stupid ass!

Now i have been driving the car around with an obd2 reader just to watch the water temp and it has not got hotter than 215f i drove for hours yesterday. I'm gonna replace the pump and stat next week myself. NO SHOPS! they can all kma!
Appreciate 0
      10-24-2011, 04:26 PM   #62
silver4dracs
New Member
0
Rep
15
Posts

 
Drives: ASA 99 328i E46
Join Date: Feb 2006
Location: Glendale

iTrader: (0)

Was the Indy shop Avus Autosport in Glendale? Sounds like them.
Appreciate 0
      10-24-2011, 05:04 PM   #63
ScaredOnce
Very Important
ScaredOnce's Avatar
United_States
6
Rep
450
Posts

 
Drives: 335xi (e92)
Join Date: Sep 2010
Location: PIT

iTrader: (0)

Garage List
Quote:
Originally Posted by MGM2 View Post
Whats so funny? he is right! the so called techs should do some reading here they would learn something.

I have a bad water pump now on a 2006 330i E90 92k miles on it and I got great info from this forum. i have had the overheated lights come on twice.

I went to two indy shops here in Pasadena Ca. to see if they could read the codes for me, they both told me if there was no check engine light that there wouldn't be any stored. Not to mention the jackass tech told me that my car didn't have electric water pump stupid ass!

Now i have been driving the car around with an obd2 reader just to watch the water temp and it has not got hotter than 215f i drove for hours yesterday. I'm gonna replace the pump and stat next week myself. NO SHOPS! they can all kma!

While we all love the brand, and no offense to some of the "techs"/mechanics here on the forums... there's a reason they're not gainfully employed as rocket scientists/brain surgeons/etc. In my experience, it's been worth double checking their work.
Appreciate 0
      10-24-2011, 08:56 PM   #64
335BBS
Brigadier General
Canada
42
Rep
3,607
Posts

 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

iTrader: (0)

Quote:
Originally Posted by MGM2 View Post
Whats so funny? he is right! the so called techs should do some reading here they would learn something.

I have a bad water pump now on a 2006 330i E90 92k miles on it and I got great info from this forum. i have had the overheated lights come on twice.

I went to two indy shops here in Pasadena Ca. to see if they could read the codes for me, they both told me if there was no check engine light that there wouldn't be any stored. Not to mention the jackass tech told me that my car didn't have electric water pump stupid ass!

Now i have been driving the car around with an obd2 reader just to watch the water temp and it has not got hotter than 215f i drove for hours yesterday. I'm gonna replace the pump and stat next week myself. NO SHOPS! they can all kma!
Are you serious? While there are a few people here who seem to be quite knowledgeable the majority (including me) are just guessing but speak with authority. There are lots of great posts regarding past experiences etc but I've yet to read anything that might help a technician.....maybe an Indy but not a true BMW technician.

Last edited by 335BBS; 10-24-2011 at 08:59 PM. Reason: correction
Appreciate 0
      10-24-2011, 09:29 PM   #65
shazzy04
Lieutenant Colonel
shazzy04's Avatar
South Korea
19
Rep
1,838
Posts

 
Drives: '15 F22 M235i
Join Date: Jul 2010
Location: South Jersey

iTrader: (6)

Send a message via AIM to shazzy04 Send a message via MSN to shazzy04
__________________
2015 M235i - Mineral Gray/Coral Red - Cold Weather/ Technology/Premium Packages

Mods coming soon
Appreciate 0
      10-24-2011, 09:35 PM   #66
tibra1
Banned
No_Country
75
Rep
6,775
Posts

 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

iTrader: (4)

IDK know what you guys are talking about but there is a wealth of mis-information on these forums..there are handful of people who are straight-shooters and know what they r talking about..but the overwhelming majority are just simply talking out of their
Appreciate 0
Reply

Bookmarks

Tags
oil, overheating, pump, sensor, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:34 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST