E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > check engine light.



Reply
 
Thread Tools Search this Thread
      07-18-2014, 02:41 AM   #1
lemonpark
Second Lieutenant
 
lemonpark's Avatar
 
Drives: '08 335i E92
Join Date: May 2014
Location: Melbourne

Posts: 220
iTrader: (0)

check engine light.

hey guys,
picked up my at and it's been great but getting a check engine light when I take it to 7k rpm and I read on the main forum that it could be spark plugs, VANOS solenoids, carbon build up or coils.
anyone here know how to clean the solenoids? and which spark plugs would you recommend and where did you get them?

thanks!
__________________
JB4 G5 | BMS Backend Flash | Alpina B3 TCU Flash | AR Design DP | BMS DCI | Muffler Delete | M3 Steering Wheel | M3 DCT Paddles | 19" GTC-CX | BSM Lip Spoiler | Black Grill | Custom RGB Angel Eyes | 8000K HID's
lemonpark is offline   Australia
0
Reply With Quote
      07-18-2014, 02:53 AM   #2
bosnia88
New Member
 
Drives: 2011 335i e92 DCT
Join Date: Jun 2012
Location: Brisbane

Posts: 21
iTrader: (0)

If it helps, I had the same issue on mine. turned out to be the wastegate actuator valve. ever since it's been replaced I've had no issues at all.
bosnia88 is offline   Australia
0
Reply With Quote
      07-18-2014, 03:53 AM   #3
ady9
Private
 
Drives: 335i E92
Join Date: Feb 2014
Location: Melbourne

Posts: 58
iTrader: (0)

Didn't u buy it from kaitan? You have that premium shit get bmw to fix it. If you have a jb4 read the codes and it will tell you exactly what's wrong. Unless the jb4 is set to "auto delete codes"

Vanos is easy enough to do on your own. Try ecstuning.com
ady9 is offline   Australia
0
Reply With Quote
      07-18-2014, 04:06 AM   #4
Digitalism
Private First Class
 
Drives: BMW 335i
Join Date: Jul 2013
Location: Perth, Australia

Posts: 124
iTrader: (0)

Could be anything. Best to read the codes and diagnose from there.
No point going to 7000rpm as power tapers off at around 6000rpm. Best to shift at that point.
As for cleaning the VANOS , there is a DIY to remove and replace. Cleaning is just using compressed air and brake cleaner.
Stick with Bosch spark plugs or Ngk 5992 gapped correctly. EBay is your friend or BMR.
Digitalism is offline  
0
Reply With Quote
      07-18-2014, 04:41 AM   #5
DR-JEKL
Lieutenant Colonel
 
Drives: Space Grey 335i 6MT
Join Date: Jul 2012
Location: Newcastle Ozstraylia

Posts: 1,856
iTrader: (1)

vanos solenoids are easy to access and remove.

They're quite expensive, but for a car with 100k+ kays i would change them imo Having said that it gets expensive when you start adding new parts to diagnose an issue, maybe swing by activeautowerke and get them to diagnose the ca by reading the codes for you?

If you need spark plugs i have a set of bosch plugs (they are the oem supplier) for $105 shipped (most places are $120+ without p&h)
DR-JEKL is offline  
0
Reply With Quote
      07-18-2014, 06:35 AM   #6
lemonpark
Second Lieutenant
 
lemonpark's Avatar
 
Drives: '08 335i E92
Join Date: May 2014
Location: Melbourne

Posts: 220
iTrader: (0)

thanks for the replies, I got the guys at BMS to read the codes but just from the OBD or whatever and it said O2 sensor but he rekons it could be sparks. I'll read the codes off the JB4 and see what it says, those spark plugs are tempting, I'll PM you

thinking it might be the CP too cos it's still the stock one. hopefully all good soon
__________________
JB4 G5 | BMS Backend Flash | Alpina B3 TCU Flash | AR Design DP | BMS DCI | Muffler Delete | M3 Steering Wheel | M3 DCT Paddles | 19" GTC-CX | BSM Lip Spoiler | Black Grill | Custom RGB Angel Eyes | 8000K HID's
lemonpark is offline   Australia
0
Reply With Quote
      07-21-2014, 04:37 AM   #7
lemonpark
Second Lieutenant
 
lemonpark's Avatar
 
Drives: '08 335i E92
Join Date: May 2014
Location: Melbourne

Posts: 220
iTrader: (0)

hey guys, checked the code from the JB4, and it goes from 20,120,90,120.
don't know how to read that can anyone shed some light? noticed a bit of a rough idle from cold start, which is what the guys at BMR said would be the symptoms of bad plugs, thanks
__________________
JB4 G5 | BMS Backend Flash | Alpina B3 TCU Flash | AR Design DP | BMS DCI | Muffler Delete | M3 Steering Wheel | M3 DCT Paddles | 19" GTC-CX | BSM Lip Spoiler | Black Grill | Custom RGB Angel Eyes | 8000K HID's
lemonpark is offline   Australia
0
Reply With Quote
      07-21-2014, 05:54 AM   #8
Brule
Brendan
 
Drives: 2007 335i e92 6sp man
Join Date: Jul 2013
Location: Darwin

Posts: 240
iTrader: (0)

check out n54tech.com they have all the codes for JB4
__________________
2007 335i 6 spd man PTF RB's
Brule is offline   Australia
0
Reply With Quote
      07-21-2014, 10:33 AM   #9
JinAM
Private
 
Drives: 335i
Join Date: Nov 2013
Location: Melbourne

Posts: 60
iTrader: (0)

2C9C - i believe it's the oxy sensor fault.
It's best to have a proper test done on a factory diagnostic machine.
If you have time drop by our workshop, we can run a test on your car free of charge.
JinAM is offline  
0
Reply With Quote
      07-21-2014, 09:52 PM   #10
lemonpark
Second Lieutenant
 
lemonpark's Avatar
 
Drives: '08 335i E92
Join Date: May 2014
Location: Melbourne

Posts: 220
iTrader: (0)

sweet, thanks man! that's what the guys at BMR said was the code on their machine too :/ hope it's not expensive to fix, full time student with a part time job sucks
lemonpark is offline   Australia
0
Reply With Quote
      07-22-2014, 04:51 AM   #11
DR-JEKL
Lieutenant Colonel
 
Drives: Space Grey 335i 6MT
Join Date: Jul 2012
Location: Newcastle Ozstraylia

Posts: 1,856
iTrader: (1)

I have heard of O2 sensors playing up after the DP's have been swapped out. I believe troy had ar dp's installed then had them removed so maybe your o2 sensors are buggered...

Luckily they're cheap to purchase, buy two bosch o2 sensors (17098 is the part # by memory) that I can get for around $230 a pair and have Jin @ activemotorwerke install them
DR-JEKL is offline  
0
Reply With Quote
      07-22-2014, 05:26 AM   #12
lemonpark
Second Lieutenant
 
lemonpark's Avatar
 
Drives: '08 335i E92
Join Date: May 2014
Location: Melbourne

Posts: 220
iTrader: (0)

my car still has the AR Catless DP's tho :/

Will take it to Jin ASAP to have it looked at, although today when I floored it, it didn't come up with any lights :/ hopefully get this fixed soon, thanks everyone
__________________
JB4 G5 | BMS Backend Flash | Alpina B3 TCU Flash | AR Design DP | BMS DCI | Muffler Delete | M3 Steering Wheel | M3 DCT Paddles | 19" GTC-CX | BSM Lip Spoiler | Black Grill | Custom RGB Angel Eyes | 8000K HID's
lemonpark is offline   Australia
0
Reply With Quote
      07-22-2014, 12:30 PM   #13
YA-91
Private
 
YA-91's Avatar
 
Drives: 335i E93 Convertible
Join Date: Apr 2014
Location: Melbourne, Australia

Posts: 80
iTrader: (0)

Could be the charge pipe leaking and causing the fault. But all that code means is that your o2 sensor is playing up as you have ar catless downpipes I have the same codes for both sensors no biggy.

But yea go past active and see Jin he will sort it out for you.
YA-91 is offline  
0
Reply With Quote
      07-22-2014, 06:31 PM   #14
lemonpark
Second Lieutenant
 
lemonpark's Avatar
 
Drives: '08 335i E92
Join Date: May 2014
Location: Melbourne

Posts: 220
iTrader: (0)

I feel as though the CP could be leaking as it's still the stock one and when I had the JB4 set to hijack the temp for boost, on map5 it was goin up to nearly 20psi but it would drop around 5k rpm to under 5 then I back up, anyway( gonna book in soon with Jin
lemonpark is offline   Australia
0
Reply With Quote
      07-23-2014, 08:48 AM   #15
kaitan
Major
 
kaitan's Avatar
 
Drives: Bus 11 AKA walking
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,349
iTrader: (1)

Quote:
Originally Posted by DR-JEKL View Post
I have heard of O2 sensors playing up after the DP's have been swapped out. I believe troy had ar dp's installed then had them removed so maybe your o2 sensors are buggered...

Luckily they're cheap to purchase, buy two bosch o2 sensors (17098 is the part # by memory) that I can get for around $230 a pair and have Jin @ activemotorwerke install them
Nah i didnt take the dp outs just change exhaust...back to stock. I did a diagnos before and it turns out to be just a cel error i had bmw check the code they said its 02sensor but when i change the do i change the sensor too but it kept coming up but the car still drives fine so i didnt do anything as they always say if it drive fine dont change...
__________________
Sold:08 BSM E92 335i JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip (Missing it badly )

Check out Facebook: TLCC @ Pymble.
kaitan is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:03 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST