E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Help! E90 LCI Halogen to Xenon



Reply
 
Thread Tools Search this Thread
      04-06-2013, 11:45 AM   #155
Jaff
New Member
 
Jaff's Avatar
 
Drives: BMW's, SLR Mclaren, Lexus
Join Date: Feb 2011
Location: Jordan

Posts: 15
iTrader: (0)

Send a message via Skype™ to Jaff
Hello.. I changed my LCI E90 halogens to xenons all oem.
Everything is working great just have 2 issues.
Front DRL's AE's are not working, rear taillights are working fine.
And Parking AE's are not working also when parked moving the stalk left and right, also taillights are also working fine.

Angel Eyes are working in all other situations other that the above.

Is there any code I've missed?

Thanks
JAFF
__________________
Jaff is offline   Jordan
0
Reply With Quote
      06-02-2013, 11:29 AM   #156
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,501
iTrader: (46)

I am not sure but this thread is confusing people a lot.

I have installed LCI xenon (without AHL) to pre-LCI e90 without any issues.

I have added new wires to car side harness. Even if I revert back to halogen lights, new wires will not interfere as Xenon and halogen lights have difference.

Everything works on my car, exception is;
- High beam works with the shutter. If the low beam is not on and you flash, shutter works, but as there is no light---> no high beam.

I guess the solution is to buy OEM harness and try.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      06-02-2013, 12:29 PM   #157
pweber
Banned
 
pweber's Avatar
 
Drives: M57 330D
Join Date: May 2013
Location: Heilbronn

Posts: 258
iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
- High beam works with the shutter. If the low beam is not on and you flash, shutter works, but as there is no light---> no high beam.

I guess the solution is to buy OEM harness and try.
I have factory xenon.
Now I got it, you can't flash with high beam when healdight are off, right?

Send me your trace file from NFRM and I will compare with mine.
pweber is offline   Germany
0
Reply With Quote
      06-02-2013, 01:03 PM   #158
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,501
iTrader: (46)

Quote:
Originally Posted by ****** View Post
I have factory xenon.
Now I got it, you can't flash with high beam when healdight are off, right?

Send me your trace file from NFRM and I will compare with mine.
Yes, now you got the idea.
What FRM do you have?

I have tried FRM2 and FRM3. For me, FRM2 is way more flexible as it allows you to code certain things with minimum modification to wirings.

With FRM3, it does not even allow high beam (as all LCI xenons are without H7 high beam) power feed. Having said that, with FRM3, xenon works but not the high beam.


I know that the solution to it is proper hard wiring like LCI xenon car (installing two level sensors, running them to FRM and then to headlights) and coding it just for xenon (without the modification shown in this thread).

I can upload both FRMs, but based on your FRM its not going to help as you car has more wirings / level sensors compared to those cars which retrofitted these.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      06-02-2013, 01:17 PM   #159
pweber
Banned
 
pweber's Avatar
 
Drives: M57 330D
Join Date: May 2013
Location: Heilbronn

Posts: 258
iTrader: (0)

I have FRM2 2008 pre-LCI xenon, but it doesn't matter, this all is similar.
You can upload your trace file and I will take a look at this.
pweber is offline   Germany
0
Reply With Quote
      06-02-2013, 01:22 PM   #160
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,501
iTrader: (46)

Quote:
Originally Posted by ****** View Post
I have FRM2 2008 pre-LCI xenon, but it doesn't matter, this all is similar.
You can upload your trace file and I will take a look at this.
Brilliant, here you go then.

Thanks.
Attached Files
File Type: txt FSW_PSW.txt (34.9 KB, 98 views)
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      06-02-2013, 01:48 PM   #161
pweber
Banned
 
pweber's Avatar
 
Drives: M57 330D
Join Date: May 2013
Location: Heilbronn

Posts: 258
iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
Brilliant, here you go then.

Thanks.
Ok, I will take a look at this and let you know.

To keep things clear, you didn't do any wiring retrofit? You just use old cable from halogens to connect with your new LCI bi-xenons?
pweber is offline   Germany
0
Reply With Quote
      06-02-2013, 03:39 PM   #162
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,501
iTrader: (46)

Quote:
Originally Posted by ****** View Post

To keep things clear, you didn't do any wiring retrofit? You just use old cable from halogens to connect with your new LCI bi-xenons?
I had to do the wiring modification (not retrofit OEM cable for xenon).
So
- Add pin 2 (earth)
- Connect high beam (pin 6) to shutter pin 5 on Xenon headlights

And after that things work with coding modification.

However as I stated that on high beam, only shutter works (if the lights are not on) therefore no light.

If lights are on, then no issues.

I guess the only solution would be to install the OEM xenon retrofit cable.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      06-04-2013, 08:56 AM   #163
pweber
Banned
 
pweber's Avatar
 
Drives: M57 330D
Join Date: May 2013
Location: Heilbronn

Posts: 258
iTrader: (0)

Hey makkan00, I compared your trace file with mine and both look similar. I think you have to install OEM xenon retrofit as you said before, and it will resolve your issue.
pweber is offline   Germany
0
Reply With Quote
      06-04-2013, 11:11 AM   #164
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,501
iTrader: (46)

Quote:
Originally Posted by ******
Hey makkan00, I compared your trace file with mine and both look similar. I think you have to install OEM xenon retrofit as you said before, and it will resolve your issue.
Thanks buddy.
I'm working on a different method and hopeful that I'll crack it.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      02-16-2014, 09:01 PM   #165
skamkar
Registered
 
Drives: 2009 328i (e90)
Join Date: Feb 2014
Location: Culver City, CA

Posts: 2
iTrader: (0)

Perhaps I'm missing something obvious, but the LCI Halogen corner lights use a halogen bulb and the LCI Xenon uses LEDs. How is the physical (hardware) connection dealt with, or do they use the same interface?

Thanks!
skamkar is offline  
0
Reply With Quote
      03-04-2014, 03:23 AM   #166
Vee2k
Enlisted Member
 
Drives: 2011 E90 LCI
Join Date: Nov 2013
Location: Eastbay

Posts: 36
iTrader: (0)

can someone help me out with this conversion?? Im going from lci halogens to lci euro xenons. I understand I need to jump pins 5 and 6 for the high beam shutters but how do i get the low beams to turn on? Do i wire the negative from the high beams to low beam negative?
Vee2k is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:26 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST