E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > All lights lit up on dash?! HELP!



Reply
 
Thread Tools Search this Thread
      07-08-2011, 07:14 PM   #1
Edison.528
Enlisted Member
2
Rep
46
Posts

 
Drives: 2003 Mitsubishi Evolution
Join Date: May 2010
Location: Frederick, MD

iTrader: (0)

Exclamation All lights lit up on dash?! HELP!

Hey I'm not sure if this is in the right place, but I was just driving and all of a sudden all lights came on the dash (well most) i will list them since this is wing posted from my phone am can't add pictures:

"BRAKE" light
"ABS" light
"SERVICE ENGINE SOON" (scary)
"Seatlbelt"
"Air bag"
"Tire Pressure"
"ABS 4x4"
Therea also one below ABS that is a triangle with exclamation point in it and around the triangle there's a circle with an arrow at one tip?

WHAT THE EFFFF HAPPENED?! do I worry?! Do I need to go to BMW and get charged my left Gand for them to just look at it and remove it?" please let me know! Thank you! And sorry I don't have time to look through forums and look for answer, I'm in a parkinglot typing this up! Lol
Appreciate 0
      07-08-2011, 07:15 PM   #2
Edison.528
Enlisted Member
2
Rep
46
Posts

 
Drives: 2003 Mitsubishi Evolution
Join Date: May 2010
Location: Frederick, MD

iTrader: (0)

Ohhhhhh and my Speedomete does not move or my MPG needle stays put, BUT RPMs do work.
Appreciate 0
      07-08-2011, 07:30 PM   #3
mdosu
Banned
No_Country
117
Rep
8,517
Posts

 
Drives: Double Vanos'd Civic-M3
Join Date: Oct 2009
Location: San Francisco

iTrader: (6)

.
Appreciate 0
      08-30-2011, 06:36 AM   #4
Babbage
Private
0
Rep
74
Posts

 
Drives: X3 2011
Join Date: Mar 2011
Location: Canada

iTrader: (0)

Something almost identical happened to me.

My 2011 X3 35i has now been in the shop for 3 weeks.

I was at a stop light when most of the warning lights came on in the dash (parking brake on, ABS failure, 4x4 problem, tire pressure problem, other things related to braking/traction, ...).

The dealer said some module was defective, and was backordered. I had to wait two weeks. Then they got it, installed it, and said "No, the module was fine, it's the diagnostic controller that was faulty and falsely said the module was faulty." Now that one has been replaced, but they said that when they tried to program it, the computer crashed. They are apparently on the phone with BMW headquarters to figure it out.

Week four begins. And I've been given a Toyota Corolla as a replacement vehicle.

This is in Montreal, Canada.
Appreciate 0
      08-30-2011, 07:16 PM   #5
Babbage
Private
0
Rep
74
Posts

 
Drives: X3 2011
Join Date: Mar 2011
Location: Canada

iTrader: (0)

Update: The dealer says that the car doesn't start now, and the computer still isn't working. They have apparently turned the matter over to BMW headquarters by letting the programmers there remote access the car (I guess it's plugged into something at the shop).

Anyway, still no guess as to when (if?) it will ever be fixed. It apparently needs to be completely reprogrammed.

PS: Anyone know if any Bluetooth updates have come out since March 2011? My Bluetooth audio streaming (A2DP) was always a little flaky in that car.
Edit/Delete Message Reply With Quote Multi-Quote This Message Quick reply to this message
Appreciate 0
      08-30-2011, 07:33 PM   #6
John 070
Lieutenant General
157
Rep
11,512
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

That happened to me, and the dealership (who sold it to me new) had to nerve to ask me if the car was hit. Then they said they couldn't find anything for two more visits and it happening. If you're out of warranty you don't want to know the fix....
Appreciate 0
      08-30-2011, 07:34 PM   #7
John 070
Lieutenant General
157
Rep
11,512
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

Quote:
Originally Posted by Babbage View Post
Something almost identical happened to me.

My 2011 X3 35i has now been in the shop for 3 weeks.

I was at a stop light when most of the warning lights came on in the dash (parking brake on, ABS failure, 4x4 problem, tire pressure problem, other things related to braking/traction, ...).

The dealer said some module was defective, and was backordered. I had to wait two weeks. Then they got it, installed it, and said "No, the module was fine, it's the diagnostic controller that was faulty and falsely said the module was faulty." Now that one has been replaced, but they said that when they tried to program it, the computer crashed. They are apparently on the phone with BMW headquarters to figure it out.

Week four begins. And I've been given a Toyota Corolla as a replacement vehicle.

This is in Montreal, Canada.
Your story is not unusual to me. Only my car is a 2007 and yours a 2011. No progress was made in 4 model years?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:39 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST