E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Check engine light on 07 E92



Reply
 
Thread Tools Search this Thread
      08-31-2011, 03:34 PM   #1
iggyg52785
New Member
 
Drives: 2007 BMW 335i coupe
Join Date: Mar 2010
Location: Birmingham, AL

Posts: 10
iTrader: (0)

Check engine light on 07 E92

I hope someone can help me. Earlier a check engine light came on in my car and I got worried cause the transmission was shifting late and hard and my car had very little power. I took it to Auto Zone for a quick scan and this is what came up "poo12 Intake (A) Camshaft Position Timing Over-Retarderd (Bank 1). Kinda worried.. seems bad.

Anybody ever seen this before?

I have a chip and intake done to my car.. I dont know if that has anything to do with it?
iggyg52785 is offline  
0
Reply With Quote
      08-31-2011, 04:21 PM   #2
Glim
Captain
 
Drives: 2006 330i
Join Date: Jun 2011
Location: Victoria, BC

Posts: 772
iTrader: (0)

Sure, its a clogged/dirty/sticking VANOS solenoid:

http://www.e90post.com/forums/showthread.php?t=486201
Glim is offline   Canada
0
Reply With Quote
      08-31-2011, 04:26 PM   #3
Glim
Captain
 
Drives: 2006 330i
Join Date: Jun 2011
Location: Victoria, BC

Posts: 772
iTrader: (0)

And if you recently had an oil change done, check that you still have the stem attached to the oil filter cap:

http://www.e90post.com/forums/showthread.php?t=570608
Glim is offline   Canada
0
Reply With Quote
      08-31-2011, 05:18 PM   #4
iggyg52785
New Member
 
Drives: 2007 BMW 335i coupe
Join Date: Mar 2010
Location: Birmingham, AL

Posts: 10
iTrader: (0)

thanks guys.. I will look into it. I havent had a oil change recently so may not be that.
iggyg52785 is offline  
0
Reply With Quote
      08-31-2011, 05:47 PM   #5
J3NGOe90
Captain
 
Drives: e92 335i 6speed MT only!
Join Date: Jul 2011
Location: brooklyn

Posts: 696
iTrader: (1)

i have the same problem but i didnt chg the camshaft position sensor yet, my check engine light comes on only on the highway when i go with 6 gear and like 80-90mph car kinda becomes slow, i put the computer same code as urs, when turn ur car off and back on does it disappear and ur car becomes fast again? im driving in the city for 8 days and no check engine hope its not gonna come on again
J3NGOe90 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:38 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST