E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Help Troubleshooting Problem



Reply
 
Thread Tools Search this Thread
      09-08-2011, 06:42 AM   #1
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

Help Troubleshooting Problem

Summary:
-07 e90 335i
-No iDrive
-Swapped rear bumper for mtech
-40% into it, it started to rain
-took shirts and covered the holes where the tail lights go

-everything else works fine
-driving to work today (next morning) and audio shifts to back then front then cuts out
-SOS light goes off a few times
-No Audio
-Head Unit works
-Clicked the knob to turn radio off (shows only time). Heard light popping once every so often

Please help me diagnose this problem.

From searching, I did learn that the amp is near the left, back tail light.

Any ideas?
Appreciate 0
      09-08-2011, 06:57 AM   #2
dmatre
First Lieutenant
United_States
3
Rep
318
Posts

 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

iTrader: (0)

Open your trunk. Look at the left side, you probably have a hard plastic cover (CD case). Pry this up with your fingers (push toward side of car, lift near side, then pull cover off).

The silver finned box you see is your amp (if you have Logic7 or HiFi). Look for any water in this area. Hope it's just a fuse.
Appreciate 0
      09-08-2011, 07:00 AM   #3
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

Quote:
Originally Posted by dmatre View Post
Open your trunk. Look at the left side, you probably have a hard plastic cover (CD case). Pry this up with your fingers (push toward side of car, lift near side, then pull cover off).

The silver finned box you see is your amp (if you have Logic7 or HiFi). Look for any water in this area. Hope it's just a fuse.
thanks im gonna do that during my lunch break today. i dont think its a fuse tho because of the in-and-out effect I had briefly
Appreciate 0
      09-08-2011, 07:15 AM   #4
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

actually, just looked.
it was water in there. put some paper towels and a shirt in there to dry it out. made my day like this :/ instead of being for having my mtech on
Appreciate 0
      09-08-2011, 08:03 AM   #5
dmatre
First Lieutenant
United_States
3
Rep
318
Posts

 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

iTrader: (0)

Quote:
Originally Posted by bigj505 View Post
actually, just looked.
it was water in there. put some paper towels and a shirt in there to dry it out. made my day like this :/ instead of being for having my mtech on
If you've got HiFi, and your amp is dead, here's a possibility:
http://www.e90post.com/forums/showth...ight=amplifier
Appreciate 0
      09-08-2011, 08:28 AM   #6
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

Quote:
Originally Posted by dmatre View Post
If you've got HiFi, and your amp is dead, here's a possibility:
http://www.e90post.com/forums/showth...ight=amplifier
Thanks a ton man.
I send dude a PM a moment ago and talked to a tischer rep to get my part number. looks like i do have HIFI (65129181743)
Appreciate 0
      09-08-2011, 09:07 AM   #7
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

... sold :/

dude is cool tho. he's trying to help also. problem is bmw likes to change part numbers.
65129181743 is the new number. i gotta pull my amp to get the old number since it probably gonna b cheaper.
Appreciate 0
      09-08-2011, 10:11 AM   #8
dmatre
First Lieutenant
United_States
3
Rep
318
Posts

 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

iTrader: (0)

Are you sure that the amp is dead? I don't recall exactly, but when I took mine out, it appeared to be pretty well sealed. I would check the fuse first, maybe you got lucky...
Appreciate 0
      09-08-2011, 10:19 AM   #9
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

^^^ thanks dude.
ill have to pull it to verify. i do plan on unplugging it for the next few days so that no current goes through.
its supposed to rain until monday so i cant let it air out naturally.

i might also contact bmw next week to see if water damage is covered under CPO. might have to go to a different dealership since they might know i swapped bumpers lol
Appreciate 0
      09-08-2011, 01:06 PM   #10
ctuna
Brigadier General
45
Rep
4,342
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

You could probably replace it with something better

For a lot cheaper
What are they charging you for an amp.
Appreciate 0
      09-08-2011, 01:53 PM   #11
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

well, if its under warranty, then its just 50 bucks, which i doubt.
otherwise, ill probably upgrade the system with some aftermarket crap.

i thought i retired from the aftermarket audio scene when i left polk audio but obviously, i may be pulled back.
my main opponent will be the fiberoptics bmw runs.

and to answer your question, tischer said 1200 or so for the amp. yea, um ok.
Appreciate 0
      09-08-2011, 02:22 PM   #12
ctuna
Brigadier General
45
Rep
4,342
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

FYI

http://www.musicarnw.com/page-2/
Appreciate 0
      09-08-2011, 02:46 PM   #13
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

thanks dude. imma probably wait about a week to see if my amp is really toasted. cant pull it out of my car until saturday. then im gonna let it dry in my house for a few days.
Appreciate 0
      09-08-2011, 03:40 PM   #14
sunpole
Private
1
Rep
71
Posts

 
Drives: X5, 335i
Join Date: Jul 2010
Location: Houston

iTrader: (0)

got a spare hifi amp

I just did an after market installation 3 days ago, although not very successful, I do have a new HiFI OEM amp freed up for sale. My car is 4 month old, if you are interested send me a PM.
Appreciate 0
      09-08-2011, 10:54 PM   #15
ctuna
Brigadier General
45
Rep
4,342
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

BIGJ5050 may have logic 7

As I think those were standard in the 07
Appreciate 0
      09-09-2011, 06:50 AM   #16
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

thanks sunpole but ctuna nailed it.... i have a top-hifi aka logic 7 amp.

i pulled the smaller tab from the amp on my way home last night so that it would not be energized anymore.
i was driving and could hear very light popping from the rear speakers so i knew the amp was still doing something.
it should be pulled out tomorrow so that i can further evaluate it/dry it out.
Appreciate 0
      09-09-2011, 12:09 PM   #17
ctuna
Brigadier General
45
Rep
4,342
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

There is somebody that repairs those

In Florida. The problem you have is they are Fiber Optic connected and just
about nothing else does so you have to have a working one to do anything .
There are articles that say the earlier head units can be reprogrammed for
analog output the other choice is to get most bus fiber optic to analog translator.

Last edited by ctuna; 09-16-2011 at 11:44 AM.
Appreciate 0
      09-09-2011, 01:04 PM   #18
dmatre
First Lieutenant
United_States
3
Rep
318
Posts

 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

iTrader: (0)

There are also still a couple of Logic7 amps showing for sale in Classifieds.... (Hope you don't need it)
Appreciate 0
      09-09-2011, 01:06 PM   #19
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

well thats good news that there is someone that repairs amps. hopefully, it doesnt come to that and my amp is happy once i get to work on it.

i definitely do not wish to code it to handle analog.
Appreciate 0
      09-09-2011, 01:07 PM   #20
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

dmatre - ive contacted those members but no one has replied. no one except the hifi dude and he already sold anyways + i realized i was logic 7
Appreciate 0
      09-09-2011, 01:17 PM   #21
dmatre
First Lieutenant
United_States
3
Rep
318
Posts

 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

iTrader: (0)

Quote:
Originally Posted by bigj505 View Post
dmatre - ive contacted those members but no one has replied. no one except the hifi dude and he already sold anyways + i realized i was logic 7
Time to upgrade! Woo-Hoo!
Appreciate 0
      09-09-2011, 01:27 PM   #22
bigj505
Second Lieutenant
2
Rep
262
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2011
Location: Baltimore,MD

iTrader: (2)

lol i need to weigh all of my options first. im not really in the mood for a custom install. there is hope that the amp is still alive also.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:40 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST