E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Cosmetic and Lighting Modifications (exterior/interior) > Replacing HID Headlight/Bulb



Reply
 
Thread Tools Search this Thread
      09-11-2011, 05:33 PM   #1
Bimmer Barney
First Lieutenant
 
Bimmer Barney's Avatar
 
Drives: 2007 335i Sedan
Join Date: Jan 2011
Location: Santa Barbara, CA

Posts: 382
iTrader: (4)

Replacing HID Headlight/Bulb

Help!

Ok, here's where I'm at:

Passenger side headlight turned purple, then started flickering, and finally out. Headlight warning light. I bought a pair of D1S Phillips bulbs online. I swapped the passenger side bulb, turned on the car to test it an nothing - drivers side only (original bulb) turned on.

I left the passenger side alone and moved to the drivers side. I first took out the original bulb and installed the "other" original bulb (the one from the passenger side that I thought had burned out). Turned on the car and the drivers side lit up! Ok - So both of the original bulbs work and drivers side ignitor works.

Now I took a new Phillips bulb and installed it in the drivers side; I was curious if maybe the new bulbs weren't compatible for some reason. Turned on the car to test it, and nothing! Maybe new bulbs aren't compatible for some reason, I thought. Installed the original drivers side bulb back in the drivers side, turned on the car to test and nothing!

So I confirmed that both original bulbs work, but not not sure if either ignitor works.

Any advice? is there a headlight fuse somewhere that I can check?
Bimmer Barney is offline  
0
Reply With Quote
      09-11-2011, 06:59 PM   #2
Bimmer Barney
First Lieutenant
 
Bimmer Barney's Avatar
 
Drives: 2007 335i Sedan
Join Date: Jan 2011
Location: Santa Barbara, CA

Posts: 382
iTrader: (4)

Update: I checked the headlight fuses and they are fine.

Any ideas?
Bimmer Barney is offline  
0
Reply With Quote
      09-12-2011, 12:15 AM   #3
Bimmer Barney
First Lieutenant
 
Bimmer Barney's Avatar
 
Drives: 2007 335i Sedan
Join Date: Jan 2011
Location: Santa Barbara, CA

Posts: 382
iTrader: (4)

Anyone? Surely someone has replaced a bulb...
Bimmer Barney is offline  
0
Reply With Quote
      09-12-2011, 12:50 AM   #4
335iFab
Black Guy
 
Drives: 335i
Join Date: Sep 2008
Location: SF

Posts: 166
iTrader: (0)

check your passenger side ballast to see if its out. As for the bulbs, maybe you didn't plug them in enough, that or you bought some super bad bulbs
__________________
Mods: Enabled Rear Fogs | Matte Black Kidney Grills | Color Matched Side Markers | Full LED Interior | LED Side Blinkers | CREE LED Reverse Turn Signals | CREE LED REVERSE LAMPS
335iFab is offline  
0
Reply With Quote
      09-12-2011, 11:54 AM   #5
Bimmer Barney
First Lieutenant
 
Bimmer Barney's Avatar
 
Drives: 2007 335i Sedan
Join Date: Jan 2011
Location: Santa Barbara, CA

Posts: 382
iTrader: (4)

I purchased Phillips Xenstart D1S bulbs, which are OEM replacements.

I've tried plugging in the original bulbs and the new bulbs on the passenger side and driver side, but no light comes on. Is there another way to check the ballast?

Where can I buy replacement ballasts?
Bimmer Barney is offline  
0
Reply With Quote
      09-12-2011, 06:26 PM   #6
335iFab
Black Guy
 
Drives: 335i
Join Date: Sep 2008
Location: SF

Posts: 166
iTrader: (0)

Not sure where to buy an OEM ballast and i'm not sure if any after market ballast will work either so hopefully other members on the forum can help you there.

If the D1S bulbs you got did work I don't understand why they don't work in your driver side. If you know anyone else who uses a D1S bulb i suggest swapping it with their car just to see if they turn on, otherwise get a refund.

sorry i'm not much help
__________________
Mods: Enabled Rear Fogs | Matte Black Kidney Grills | Color Matched Side Markers | Full LED Interior | LED Side Blinkers | CREE LED Reverse Turn Signals | CREE LED REVERSE LAMPS
335iFab is offline  
0
Reply With Quote
      09-13-2011, 01:01 PM   #7
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 17,107
iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
If its not the bulbs then its the ballast more then likely.
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
      09-13-2011, 02:42 PM   #8
Bimmer Barney
First Lieutenant
 
Bimmer Barney's Avatar
 
Drives: 2007 335i Sedan
Join Date: Jan 2011
Location: Santa Barbara, CA

Posts: 382
iTrader: (4)

Are there any other components to the lighting system?

I can buy a pair of OEM ballasts for $800 shipped from Tischer, but they don't accept returns on electronics, so if that doesn't fix it, I'm in the hole $800.

I could drop it off at the dealer, tell them the headlights don't work and just say fix it. Worst case there I'm out like $1600 (bulbs and ballasts and labor) + tax.


Are there any aftermarket options on ballasts?
Bimmer Barney is offline  
0
Reply With Quote
      09-14-2011, 02:33 PM   #9
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 17,107
iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
These may or may not work...

http://www.highperformancebulbs.com/bmw3seseeoem.html
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:21 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST