E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Error Code 2C9C



Reply
 
Thread Tools Search this Thread
      01-29-2014, 07:45 AM   #1
kaitan
Major
 
kaitan's Avatar
 
Drives: Black Man Wheels
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,253
iTrader: (0)

Error Code 2C9C

Hi Guys,

After I had my schedule service by the dealer as I have premium selection, 1 day later I lost boost and error Engine fault, Power reduced came up. I read the code and it turns out to be code 2C9C.

Anyone had this problem before ?? apparently it's 2C9C output heater O2-sensor before catalyst.
__________________
Done: JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip
kaitan is offline  
0
Reply With Quote
      01-29-2014, 08:31 AM   #2
Zen
Lieutenant
 
Drives: E92 335i
Join Date: Nov 2008
Location: Sydney Aus

Posts: 567
iTrader: (0)

Quote:
Originally Posted by kaitan View Post
Hi Guys,

After I had my schedule service by the dealer as I have premium selection, 1 day later I lost boost and error Engine fault, Power reduced came up. I read the code and it turns out to be code 2C9C.

Anyone had this problem before ?? apparently it's 2C9C output heater O2-sensor before catalyst.
Similar to Fossil's problem?
http://www.e90post.com/forums/showthread.php?t=936168
__________________
08' E92 335I
Black Sapphire Metallic | M-Sport | GT-CS 19" Matte Anthracite | BMW Perf. Exhaust | JB4 | AR Design Catless DP | R1 Concepts Cross-drilled & Slotted Rotors | aFe DCI | ER Chargepipe with Forge DV | ER FMIC
Zen is offline   Australia
0
Reply With Quote
      01-29-2014, 07:32 PM   #3
froop
Lieutenant Colonel
 
froop's Avatar
 
Drives: 08 AW 6MT E82
Join Date: Jul 2012
Location: Sydney, Australia

Posts: 1,906
iTrader: (2)

From fossil's post, doesn't look like he's limping.

To my knowledge, normally O2 sensor codes don't cause limp modes. I had maybe a 3-4 week period where I was throwing O2 sensor codes (almost every code known to man) on a daily basis and I still had full boost. It just ran a little rough. This was due to a fault in my Procede map which made the car run rich. It was my fault.

Your issue is not that though obviously as you have a JB4 but something else.

Sounds quite coincidental that it happened when you took it for a service. Could they maybe have flashed some new anti tuner software on the car?

Maybe try remove the JB4 and see if it still happens.
__________________
Procede Rev 3 | PWM Meth | Mr5 Intake | AFE Scoops | ER FMIC | ER CP | TiAl BOV | AR Catless DPs | CP-E Exhaust | Forgestar F14s | M3 Strut Tower Brace | M3 Front Arms | M3 F + R Sway Bars | M3 Rear End Conversion | Moton Clubsports with Swift Springs | Vorshlag Camber Plates | ECS 2-Piece Rotors | SS Lines | Cool Carbons | BR Half Cage | BMWP SSK | BMWP Interior/Exterior Goodies | Blacklines | P3 Gauge | 1M Interior |
froop is offline   Australia
0
Reply With Quote
      01-30-2014, 12:55 AM   #4
fo55il
Private First Class
 
Drives: 335i
Join Date: Jun 2013
Location: Melbourne Australia

Posts: 130
iTrader: (0)

Im def hitting limp mode here and there

Im going to change my pre cat 02 sensor and see how i go when i do my DP's soon.
fo55il is offline   Australia
0
Reply With Quote
      01-30-2014, 01:18 AM   #5
kaitan
Major
 
kaitan's Avatar
 
Drives: Black Man Wheels
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,253
iTrader: (0)

Quote:
Originally Posted by fo55il View Post
Im def hitting limp mode here and there

Im going to change my pre cat 02 sensor and see how i go when i do my DP's soon.
hey fossil when u say hitting limp mode here and there? meaning?? when you press the gas does your car have any boost whatsoever. my boost come in but it's probably like 2psi only or as if it got no boost at all??

Yea like what alex said i find it strange that it is so coincidental that it happens after servicing the car

Maybe they sabotage my car because they weren't making money off me as i had premium selection??
__________________
Done: JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip
kaitan is offline  
0
Reply With Quote
      01-30-2014, 01:20 AM   #6
fo55il
Private First Class
 
Drives: 335i
Join Date: Jun 2013
Location: Melbourne Australia

Posts: 130
iTrader: (0)

I def have boost, can feel it. but sometimes it is jerky. Sometimes goes into limp mode sometimes not.

what did they do in the service?
fo55il is offline   Australia
0
Reply With Quote
      01-30-2014, 08:19 AM   #7
kaitan
Major
 
kaitan's Avatar
 
Drives: Black Man Wheels
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,253
iTrader: (0)

Quote:
Originally Posted by fo55il View Post
I def have boost, can feel it. but sometimes it is jerky. Sometimes goes into limp mode sometimes not.

what did they do in the service?
they did engine oil service and filter plus brake fluid change thats all. I'm getting the all not all the time but even without the error msg of engine power reduced i still don't have power as and when i want. It's running like a N/A car!!

just found out there is something rattling as you drive slowly in the car park. the rattling sounds tinny and it sounds like it's coming from the DP Center or at least sound where there.
__________________
Done: JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip
kaitan is offline  
0
Reply With Quote
      01-30-2014, 10:43 PM   #8
keungleung
Private
 
Drives: 08 335i msport
Join Date: Nov 2012
Location: Sydney

Posts: 53
iTrader: (0)

Exact same thing happened to mine, it started throwing codes after scheduled service:

-at service they changed oil, a few filters, spark plugs, one of my coils, all free under the warranty plus i did an end of warranty inspection which they found a few bulb holders needed replacing, as i was driving home it throw boost code just the once and not again for a whole week (jb4 turned off)

-they took the car back to check, changed some vacuum lines and both pressure valves under warranty, I got it back and it throw codes again three times in a week

-finally they took the car for a few days looking for problems which they couldn't find with all the smoke test etc, even getting their mechanic to drive it home to test at night trying to get the codes to come up, anyways they then decided to update all the software in the car... I haven't had an issue since!!! the car actually drives way smoother too with the updated software

They did this even when the car was just out of warranty, on the invoice I see that they just changed the date on their system as it was mainly labour costs. Pretty damn good service considering I actually got it from a completely different BMW dealership.
keungleung is offline  
0
Reply With Quote
      01-30-2014, 10:47 PM   #9
keungleung
Private
 
Drives: 08 335i msport
Join Date: Nov 2012
Location: Sydney

Posts: 53
iTrader: (0)

btw i was told that half engine light i got (the orange one) doesn't put the car in limp mode, you still get full boost, it disappeared every time i restarted the car and wouldn't come up again for a few days when i did have the problem

just the red engine light puts the car in limp mode
keungleung is offline  
0
Reply With Quote
      01-30-2014, 10:53 PM   #10
fo55il
Private First Class
 
Drives: 335i
Join Date: Jun 2013
Location: Melbourne Australia

Posts: 130
iTrader: (0)

u were told wrong. the half orange engine light in the dash display is limp mode.

the small engine light in the dash is not limp mode.
fo55il is offline   Australia
0
Reply With Quote
      01-31-2014, 08:53 AM   #11
kaitan
Major
 
kaitan's Avatar
 
Drives: Black Man Wheels
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,253
iTrader: (0)

Quote:
Originally Posted by fo55il View Post
u were told wrong. the half orange engine light in the dash display is limp mode.

the small engine light in the dash is not limp mode.
so i've got the half engine lights and it also throw an error of power reduced!!1 arrghhh !!! I only can booked in for BMW on the 19 feb.
__________________
Done: JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip
kaitan is offline  
0
Reply With Quote
      02-02-2014, 06:24 AM   #12
fo55il
Private First Class
 
Drives: 335i
Join Date: Jun 2013
Location: Melbourne Australia

Posts: 130
iTrader: (0)

sounds like a similar issue to mine.
fo55il is offline   Australia
0
Reply With Quote
      02-02-2014, 06:51 AM   #13
drjekl
Captain
 
Drives: E92 335i
Join Date: Jan 2013
Location: Oz

Posts: 711
iTrader: (0)

just take her to advan and get it sorted, bmw will see you have aftermarket dp's see a cat related code and most likely deny warranty and charge you $300 for checking the fault code/diagnosis, whereas if you're lucky advan might repair it for $300...
drjekl is online now  
0
Reply With Quote
      02-02-2014, 07:16 AM   #14
Zen
Lieutenant
 
Drives: E92 335i
Join Date: Nov 2008
Location: Sydney Aus

Posts: 567
iTrader: (0)

Quote:
Originally Posted by drjekl View Post
just take her to advan and get it sorted, bmw will see you have aftermarket dp's see a cat related code and most likely deny warranty and charge you $300 for checking the fault code/diagnosis, whereas if you're lucky advan might repair it for $300...
+1. Most likely that warranty will be denied as you have a dp.
__________________
08' E92 335I
Black Sapphire Metallic | M-Sport | GT-CS 19" Matte Anthracite | BMW Perf. Exhaust | JB4 | AR Design Catless DP | R1 Concepts Cross-drilled & Slotted Rotors | aFe DCI | ER Chargepipe with Forge DV | ER FMIC
Zen is offline   Australia
0
Reply With Quote
      02-02-2014, 08:30 AM   #15
fo55il
Private First Class
 
Drives: 335i
Join Date: Jun 2013
Location: Melbourne Australia

Posts: 130
iTrader: (0)

heads up that 02 sensors are not cheap. installation for the pre cat / top ones are not either.
fo55il is offline   Australia
0
Reply With Quote
      02-02-2014, 08:35 AM   #16
kaitan
Major
 
kaitan's Avatar
 
Drives: Black Man Wheels
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,253
iTrader: (0)

Quote:
Originally Posted by fo55il View Post
heads up that 02 sensors are not cheap. installation for the pre cat / top ones are not either.
thx boys...yea i understand what you are saying. Yes BMW already knows that I have a aftermarket DP. Even when I had my water pump warranty claims. But It's just funny that before BMW service everything was fine. Then immediately after sending it in, it had the fault! and no boost and limp.

How much did it cost you to fix yours fossil?
__________________
Done: JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip
kaitan is offline  
0
Reply With Quote
      02-02-2014, 09:05 AM   #17
fo55il
Private First Class
 
Drives: 335i
Join Date: Jun 2013
Location: Melbourne Australia

Posts: 130
iTrader: (0)

I haven't dont mine yet mang. DP should be delivered this week and picking up some 02 sensors for $100 each for the fronts. Rears im going to let slide for now. easier to change than the front.

Im a bit handy so it helps with these things.
fo55il is offline   Australia
0
Reply With Quote
      02-03-2014, 12:45 AM   #18
kaitan
Major
 
kaitan's Avatar
 
Drives: Black Man Wheels
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,253
iTrader: (0)

Quote:
Originally Posted by fo55il View Post
I haven't dont mine yet mang. DP should be delivered this week and picking up some 02 sensors for $100 each for the fronts. Rears im going to let slide for now. easier to change than the front.

Im a bit handy so it helps with these things.
I have drop my car in for emergency and initially said might sounds like HPFP but then they discovered that it's a vacuum actuator hose leak and it needs replacing.
__________________
Done: JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip
kaitan is offline  
0
Reply With Quote
      02-03-2014, 01:09 AM   #19
fo55il
Private First Class
 
Drives: 335i
Join Date: Jun 2013
Location: Melbourne Australia

Posts: 130
iTrader: (0)

woohoo! lucky!
fo55il is offline   Australia
0
Reply With Quote
      02-03-2014, 02:39 AM   #20
kaitan
Major
 
kaitan's Avatar
 
Drives: Black Man Wheels
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,253
iTrader: (0)

Quote:
Originally Posted by fo55il View Post
woohoo! lucky!
picked it up and it's all good !!! 2 Vacuum hose replaced and it's all good After $330 which i expected more as initially thought it was HPFP.
__________________
Done: JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip
kaitan is offline  
0
Reply With Quote
      02-03-2014, 03:16 AM   #21
Zen
Lieutenant
 
Drives: E92 335i
Join Date: Nov 2008
Location: Sydney Aus

Posts: 567
iTrader: (0)

Quote:
Originally Posted by kaitan View Post
picked it up and it's all good !!! 2 Vacuum hose replaced and it's all good After $330 which i expected more as initially thought it was HPFP.
Good stuff..
__________________
08' E92 335I
Black Sapphire Metallic | M-Sport | GT-CS 19" Matte Anthracite | BMW Perf. Exhaust | JB4 | AR Design Catless DP | R1 Concepts Cross-drilled & Slotted Rotors | aFe DCI | ER Chargepipe with Forge DV | ER FMIC
Zen is offline   Australia
0
Reply With Quote
      02-03-2014, 03:28 AM   #22
drjekl
Captain
 
Drives: E92 335i
Join Date: Jan 2013
Location: Oz

Posts: 711
iTrader: (0)

Did you notice it boosting quicker now?

$330 is kinda rich for $30 worth of hoses! ($100 in labour, $30 for the hoses and $200 you're a sucker tax?)
drjekl is online now  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:07 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST