BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > ST Coilovers on E90

Thread Tools Search this Thread
      10-03-2011, 02:42 PM   #1
Second Lieutenant

Drives: 335i
Join Date: Nov 2010
Location: Los Angeles

iTrader: (3)

ST Coilovers on E90

I installed the ST Coilovers earlier this year, some time between March and April. The ride has been running smoothly until recently (few weeks ago), I've noticed, when I start my car in the morning and backing it out of the garage, the front would make this squeeking noise, when it rolls down the driveway, it'd then make the similar noise. somtimes when I turn the wheels, it'd make that kind of noise also. it does not happen when I am driving regular speed, only in very slow speed (like less than 5 mph) - going up/down driveway/curb, etc.

the squeeking noise is nothing HORRIBlE, kind of like an old door making that squeeking noise (but not as high pitched)...almost like it needs WD40?

Can someone help?

I will eventually take it to the shop and get it checked out, but just in the meantime if someone can explain to me why this is happening
Appreciate 0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:22 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST