E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Eibach Multi-Pro R1 clunking all of a sudden...



Reply
 
Thread Tools Search this Thread
      10-18-2011, 07:27 PM   #1
nekky
Collector of Z4Ms
 
nekky's Avatar
 
Drives: 07 Z4MC MB, 06 Z4MR IR VT2-500
Join Date: May 2011
Location: Winnipeg, MB

Posts: 890
iTrader: (1)

Eibach Multi-Pro R1 clunking all of a sudden...

Installed Eibach Multi-Pro R1 coils onto my E92 335i pre-lci about 3 months ago. Only been driving on them for maybe a month and a half total, if that. Don't ask lol. Bought them used but in PERFECT shape and the seller was amazing. Great packaging, product exactly as designed, killer price and was totally communicative and even sent a nice email to help with install. Overall, *very* pleased.

I also absolutely loved the ride when I first had them on. Everything changed about 2 weeks ago, though.

I put my car on the hoist, and disconnected the strut plate at the bottom (inside the control arm), so I could get the spring/top adjustment collar out and clean/adjust it. We raised the car up and absolutely nailed the height perfectly. Put em back on the car, and a few days later, the rear starts clunking and sounds as if there's something in the trunk flying up and then falling back down. Also can feel it hitting both "top" and "bottom" over harsher areas where there are several bumps in a row. The noise seems to be less severe when there's someone in the passenger seat too, for whatever reason. Passenger rear seems to be worse, but both sides definitely clunk.

Everything is tight (confirmed by taking another look the other day) and the car still rides nice, except for the damn clunking. I put the stock wheels back on (yes, with RFTs.. only til winter tires go on soon) and I know the stock 18's w/ RFTs are heavier than the 19" Works I had on before. The car was absolutely 100% quiet a few weeks ago, with the coilovers on and the rear dumped (tucking a 275/35/19). Rode PERFECT and now this....

So confused. Please help! Any suggestions?

Thanks,
nekky
nekky is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:24 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST