E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Angel eye hids different color and flickers



Reply
 
Thread Tools Search this Thread
      10-09-2011, 11:01 AM   #1
Groganrocket
Second Lieutenant
2
Rep
225
Posts

 
Drives: 2010 e90 335i
Join Date: Jun 2010
Location: Area 57

iTrader: (0)

Angel eye hids different color and flickers

Hello guys I just noticed that one of my angel eyes has a different color and they have a flicker once in a while,Ive had them over a year they are alpine hids and Im thinking something is wrong with the ballast because of the occasional flicker and that's what causing the discoloration any input appreciated.
Appreciate 0
      10-09-2011, 09:04 PM   #2
rbtamms
Major
rbtamms's Avatar
Philippines
20
Rep
1,410
Posts

 
Drives: 2011 E90 and 2013 F25
Join Date: May 2011
Location: San Francisco

iTrader: (4)

Garage List
2011 328i  [0.00]
It's the ballast. If you will replace it, get the same exact brand & type or replace both if you cannot get the same one. Otherwise, you will have different color.
__________________

Last edited by rbtamms; 10-09-2011 at 09:09 PM.
Appreciate 0
      10-09-2011, 09:45 PM   #3
fdriller9
Banned
United_States
103
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
I don't think it's your ballast.

Xenon bulbs will change color (usually to a pinkish or purplish color for 4300k) when they are going out.

As for the flickering, check your connections. Maybe try swapping ballasts to either side and see if the problem follows.
Appreciate 0
      10-09-2011, 11:02 PM   #4
nomis_nehc
Banned
United_States
2
Rep
256
Posts

 
Drives: BMW E60
Join Date: May 2011
Location: W. San Jose

iTrader: (0)

Nah, actually, ballast is more likely than the bulb in this case. A faulty ballast may fire up the bulb but cannot power it up entirely to reach its true color. I had this issue in my fog earlier this year. My 6000k that was suppose to look white looked like it was blue-ish green. Replacing the ballast fixed it.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:46 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST