E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > 2010 328xi - No heat



Reply
 
Thread Tools Search this Thread
      10-18-2011, 09:34 AM   #1
rtgirard
1-5-3-6-2-4
United_States
2
Rep
60
Posts

 
Drives: Awaiting 2013 335xi -
Join Date: Sep 2011
Location: Upstate, New York

iTrader: (0)

2010 328xi - No heat

My wife's 328xi doesn't seem to want to blow hot air in the cabin. Someone suggested to check all the temp settings in iDrive, but there's no iDrive on this car.

After a "spirited" drive of 30 or so miles last night, it still didn't want to blow hot air. That's with both temp knobs turned up to 84 degrees and the dial on the dash turned to red.

I don't think the thermostat is stuck... we've not had any issues with overheating.

I get a bit of warm air out of the passenger side vents both top and in the footwell, but only cool air out of the driver's side. I'm guessing a blend door is stuck or maybe a stepper motor is shot?

Anyone have any ideas before I take a 120mi drive back to the dealer?
Appreciate 0
      10-18-2011, 09:47 AM   #2
ceb
NHTSA Nazi
21
Rep
1,979
Posts

 
Drives: 335ix
Join Date: Aug 2009
Location: MD

iTrader: (1)

Quote:
Originally Posted by rtgirard View Post
My wife's 328xi doesn't seem to want to blow hot air in the cabin. Someone suggested to check all the temp settings in iDrive, but there's no iDrive on this car.

After a "spirited" drive of 30 or so miles last night, it still didn't want to blow hot air. That's with both temp knobs turned up to 84 degrees and the dial on the dash turned to red.

I don't think the thermostat is stuck... we've not had any issues with overheating.

I get a bit of warm air out of the passenger side vents both top and in the footwell, but only cool air out of the driver's side. I'm guessing a blend door is stuck or maybe a stepper motor is shot?

Anyone have any ideas before I take a 120mi drive back to the dealer?
Move to Florida?

I think you'll need a trip to the dealer. Anything you try yourself may leave you with warranty problems.
Appreciate 0
      10-18-2011, 09:51 AM   #3
rtgirard
1-5-3-6-2-4
United_States
2
Rep
60
Posts

 
Drives: Awaiting 2013 335xi -
Join Date: Sep 2011
Location: Upstate, New York

iTrader: (0)

Quote:
Originally Posted by ceb View Post
Move to Florida?
Anything but that!

I think you're right about the warranty part, for sure.
Appreciate 0
      10-18-2011, 11:35 AM   #4
Admir328xiCT
Private First Class
4
Rep
104
Posts

 
Drives: 2007 BMW 328xi
Join Date: Sep 2011
Location: Central Area of CT

iTrader: (0)

Quote:
Originally Posted by rtgirard View Post
Quote:
Originally Posted by ceb View Post
Move to Florida?
Anything but that!

I think you're right about the warranty part, for sure.
It's a 2010 take it in get a loaner and enjoy your day...
Appreciate 0
      10-18-2011, 09:33 PM   #5
rollinstone157
Brotographer
rollinstone157's Avatar
United_States
26
Rep
1,701
Posts

 
Drives: 2010 328i xDrive Sedan
Join Date: Mar 2011
Location: NJ, USA

iTrader: (0)

Garage List
Quote:
Originally Posted by rtgirard View Post
My wife's 328xi doesn't seem to want to blow hot air in the cabin. Someone suggested to check all the temp settings in iDrive, but there's no iDrive on this car.

After a "spirited" drive of 30 or so miles last night, it still didn't want to blow hot air. That's with both temp knobs turned up to 84 degrees and the dial on the dash turned to red.

I don't think the thermostat is stuck... we've not had any issues with overheating.

I get a bit of warm air out of the passenger side vents both top and in the footwell, but only cool air out of the driver's side. I'm guessing a blend door is stuck or maybe a stepper motor is shot?

Anyone have any ideas before I take a 120mi drive back to the dealer?
I thought I had the same problem too, but let's run through some solutions.
1. there's a knob on both the rear of the center console, and on the center of the dash. It's a wheel with a line on it. Turn that all the way to red. That will direct slightly warmer air to come out of the main vents.

2. Make sure the AC is turned off (green frost icon). I know it sound obvious...but I've driven cars where if it's in the auto mode and you turn the AC off, the car reverts to just an air circulation program...

3. Turn off auto climate control, jack up the temperatures, and direct all the hot air to blow out right at your face.

4. Try the defroster and feel for hot air being pushed towards the windshield.

See if any of that works. if none of them work, then a trip to the dealer wouldn't be a bad idea.
__________________
Reviews -|- HPB "Ultimate" LED Interior Kit -|- Noyka Cornering Bulbs -|- HPB 20W AE [OLD] -|- LUX H8 V4 -|- New Reviews Pending Vendor Approval
Appreciate 0
      10-19-2011, 04:28 PM   #6
rtgirard
1-5-3-6-2-4
United_States
2
Rep
60
Posts

 
Drives: Awaiting 2013 335xi -
Join Date: Sep 2011
Location: Upstate, New York

iTrader: (0)

Quote:
Originally Posted by rollinstone157 View Post
I thought I had the same problem too, but let's run through some solutions.
1. there's a knob on both the rear of the center console, and on the center of the dash. It's a wheel with a line on it. Turn that all the way to red. That will direct slightly warmer air to come out of the main vents.

2. Make sure the AC is turned off (green frost icon). I know it sound obvious...but I've driven cars where if it's in the auto mode and you turn the AC off, the car reverts to just an air circulation program...

3. Turn off auto climate control, jack up the temperatures, and direct all the hot air to blow out right at your face.

4. Try the defroster and feel for hot air being pushed towards the windshield.

See if any of that works. if none of them work, then a trip to the dealer wouldn't be a bad idea.
Yep... did all this. Same result. Heading to dealer next week when schedule permits.

Thanks for the replies!
Appreciate 0
      10-19-2011, 09:13 PM   #7
Brian_TII
Second Lieutenant
United_States
3
Rep
213
Posts

 
Drives: 06 e90 330i 6spd
Join Date: Aug 2010
Location: Atlanta, GA

iTrader: (0)

Probably the air mix motor or something like that. Not a huge deal and should be under warranty
Appreciate 0
      11-04-2011, 09:38 AM   #8
rtgirard
1-5-3-6-2-4
United_States
2
Rep
60
Posts

 
Drives: Awaiting 2013 335xi -
Join Date: Sep 2011
Location: Upstate, New York

iTrader: (0)

Update: Heater core is clogged... dealer is replacing now. I'm glad this is a lease as I don't know what the implications are for the entire cooling system if crud is getting trapped in the core.
Appreciate 0
      11-04-2011, 10:19 AM   #9
Tom K.
Major General
Tom K.'s Avatar
United_States
55
Rep
5,416
Posts

 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by rtgirard View Post
Update: Heater core is clogged... dealer is replacing now. I'm glad this is a lease as I don't know what the implications are for the entire cooling system if crud is getting trapped in the core.
I suspect this is not a common issue. Did the dealer indicate any possible cause?

Tom
Appreciate 0
      11-04-2011, 01:29 PM   #10
rtgirard
1-5-3-6-2-4
United_States
2
Rep
60
Posts

 
Drives: Awaiting 2013 335xi -
Join Date: Sep 2011
Location: Upstate, New York

iTrader: (0)

Quote:
Originally Posted by Tom K. View Post
I suspect this is not a common issue. Did the dealer indicate any possible cause?

Tom
Not yet... awaiting full postmortem. The new core won't be in until Monday, so they won't pull it apart until then. I have no idea if this is a common issue or not, but, like you, I suspect this is a rare problem. They did not indicate how they came to this conclusion (and I haven't asked yet).
Appreciate 0
      11-11-2011, 02:30 AM   #11
335i101
Lieutenant
335i101's Avatar
13
Rep
532
Posts

 
Drives: 2007 335i Coupe-sold
Join Date: Dec 2010
Location: ND

iTrader: (2)

Quote:
Originally Posted by Tom K. View Post
Quote:
Originally Posted by rtgirard View Post
Update: Heater core is clogged... dealer is replacing now. I'm glad this is a lease as I don't know what the implications are for the entire cooling system if crud is getting trapped in the core.
I suspect this is not a common issue. Did the dealer indicate any possible cause?

Tom
Common enough for me to also have this problem. Dealer said 7hrs of labor or something like that...so passengers get no heat, my feet are 200 degrees, and my heat is poor.....
__________________
M3 Ashtray, M3 Windshield Wash Fluid, M3 Seatbelt buckle...have I impressed you yet.....and all these modds are from the 2017 model M3....
Appreciate 0
      11-11-2011, 09:59 PM   #12
335i101
Lieutenant
335i101's Avatar
13
Rep
532
Posts

 
Drives: 2007 335i Coupe-sold
Join Date: Dec 2010
Location: ND

iTrader: (2)

Any news?? Is it fixed??
__________________
M3 Ashtray, M3 Windshield Wash Fluid, M3 Seatbelt buckle...have I impressed you yet.....and all these modds are from the 2017 model M3....
Appreciate 0
      11-13-2011, 04:50 PM   #13
stevepoz
New Member
United_States
0
Rep
29
Posts

 
Drives: 2006 330i w/sport package
Join Date: Jan 2009
Location: St. Louis, MO

iTrader: (0)

Quote:
Originally Posted by 335i101 View Post
Common enough for me to also have this problem. Dealer said 7hrs of labor or something like that...so passengers get no heat, my feet are 200 degrees, and my heat is poor.....

If you don't mind my asking, what was the cost?
Appreciate 0
      11-13-2011, 06:09 PM   #14
volkswackin
Lieutenant Colonel
United_States
19
Rep
1,917
Posts

 
Drives: too broke for a BMW
Join Date: Jan 2008
Location: i get around..

iTrader: (1)

Quote:
Originally Posted by 335i101 View Post
Common enough for me to also have this problem. Dealer said 7hrs of labor or something like that...so passengers get no heat, my feet are 200 degrees, and my heat is poor.....
thats likely NOT a heatercore..a clogged/defective heatercore would cause little to no heat...not heat on your feet and not on top..possibly side to side though due to a split heatercore but i forget if e9x have that or not without one in front of me. The most common issue ive had in e9x with a lack of heat is actually a radiator issue which causes coolant to move too slow through it thus it cools down too much=lack of heat.
Appreciate 0
      11-14-2011, 12:42 AM   #15
335i101
Lieutenant
335i101's Avatar
13
Rep
532
Posts

 
Drives: 2007 335i Coupe-sold
Join Date: Dec 2010
Location: ND

iTrader: (2)

Quote:
Originally Posted by stevepoz View Post
Quote:
Originally Posted by 335i101 View Post
Common enough for me to also have this problem. Dealer said 7hrs of labor or something like that...so passengers get no heat, my feet are 200 degrees, and my heat is poor.....

If you don't mind my asking, what was the cost?
1500 or so....don't really remember it was last year.
__________________
M3 Ashtray, M3 Windshield Wash Fluid, M3 Seatbelt buckle...have I impressed you yet.....and all these modds are from the 2017 model M3....
Appreciate 0
      11-14-2011, 07:20 AM   #16
rtgirard
1-5-3-6-2-4
United_States
2
Rep
60
Posts

 
Drives: Awaiting 2013 335xi -
Join Date: Sep 2011
Location: Upstate, New York

iTrader: (0)

Update: mine is fixed. The replacement heater core did the trick. Obviously covered under warranty, so $0 out of pocket. I will say I'm pleased that there are no squeaks or rattles after they put the dash back in. Everything works as expected now.
Appreciate 0
      11-14-2011, 10:34 PM   #17
335i101
Lieutenant
335i101's Avatar
13
Rep
532
Posts

 
Drives: 2007 335i Coupe-sold
Join Date: Dec 2010
Location: ND

iTrader: (2)

Quote:
Originally Posted by volkswackin View Post
Quote:
Originally Posted by 335i101 View Post
Common enough for me to also have this problem. Dealer said 7hrs of labor or something like that...so passengers get no heat, my feet are 200 degrees, and my heat is poor.....
thats likely NOT a heatercore..a clogged/defective heatercore would cause little to no heat...not heat on your feet and not on top..possibly side to side though due to a split heatercore but i forget if e9x have that or not without one in front of me. The most common issue ive had in e9x with a lack of heat is actually a radiator issue which causes coolant to move too slow through it thus it cools down too much=lack of heat.
I have no heat on passenger side....extreme heat at my feet (heater core location). I think a clogged core makes sense but I am not an expert...

(remember there is dual climate control)
__________________
M3 Ashtray, M3 Windshield Wash Fluid, M3 Seatbelt buckle...have I impressed you yet.....and all these modds are from the 2017 model M3....
Appreciate 0
      11-16-2011, 01:01 PM   #18
rtgirard
1-5-3-6-2-4
United_States
2
Rep
60
Posts

 
Drives: Awaiting 2013 335xi -
Join Date: Sep 2011
Location: Upstate, New York

iTrader: (0)

Quote:
Originally Posted by 335i101 View Post
I think a clogged core
I vote for the core... The parts aren't too bad ordering from Tischer, but labor has got to be a killer on this one. I'm very happy that mine acted up under warranty.
Appreciate 0
      11-19-2011, 06:46 PM   #19
volkswackin
Lieutenant Colonel
United_States
19
Rep
1,917
Posts

 
Drives: too broke for a BMW
Join Date: Jan 2008
Location: i get around..

iTrader: (1)

Quote:
Originally Posted by 335i101 View Post
I have no heat on passenger side....extreme heat at my feet (heater core location). I think a clogged core makes sense but I am not an expert...

(remember there is dual climate control)
it would make sense as long as you also have decent heat on every other setting on the drivers side...
Appreciate 0
      11-27-2011, 04:25 AM   #20
335i101
Lieutenant
335i101's Avatar
13
Rep
532
Posts

 
Drives: 2007 335i Coupe-sold
Join Date: Dec 2010
Location: ND

iTrader: (2)

Quote:
Originally Posted by volkswackin View Post
Quote:
Originally Posted by 335i101 View Post
I have no heat on passenger side....extreme heat at my feet (heater core location). I think a clogged core makes sense but I am not an expert...

(remember there is dual climate control)
it would make sense as long as you also have decent heat on every other setting on the drivers side...
Ya I do....OP is yur new core still working well for u?!
__________________
M3 Ashtray, M3 Windshield Wash Fluid, M3 Seatbelt buckle...have I impressed you yet.....and all these modds are from the 2017 model M3....
Appreciate 0
      11-28-2011, 11:48 AM   #21
rtgirard
1-5-3-6-2-4
United_States
2
Rep
60
Posts

 
Drives: Awaiting 2013 335xi -
Join Date: Sep 2011
Location: Upstate, New York

iTrader: (0)

Quote:
Originally Posted by 335i101 View Post
Ya I do....OP is yur new core still working well for u?!
No issues since replacement of the core... all is well.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:51 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST