E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > iDrive MP3 CD and Nav audio no longer functions



Reply
 
Thread Tools Search this Thread
      05-10-2007, 08:46 PM   #1
zenmaster
Lieutenant Colonel
United_States
20
Rep
1,628
Posts

Drives: '13 AH3
Join Date: Mar 2007
Location: Atlanta

iTrader: (1)

iDrive MP3 CD and Nav audio no longer functions

I can get audio from radio and regular audio CD, but suddenly the Nav voice and MP3 audio can't be heard. Nav will still auto-lower the radio volume, but I can't hear the BMW nav girl anymore. MP3 CDs are still being read, but no audio. It happened during highway driving. Thinking the problem was a software glitch, I tried to "reset" the software by pulling over and turning off/on the car. Didn't help. Anyone know what happened?
Appreciate 0
      05-10-2007, 10:07 PM   #2
zenmaster
Lieutenant Colonel
United_States
20
Rep
1,628
Posts

Drives: '13 AH3
Join Date: Mar 2007
Location: Atlanta

iTrader: (1)

Leaving the car off for a longer period and then restarting it resolved the problem. But I'm wondering what caused it?
Appreciate 0
      05-11-2007, 12:14 AM   #3
GTx08
RAMPAGE!
United_States
5
Rep
224
Posts

Drives: 07 335i Sedan
Join Date: Aug 2005
Location: Irvine, Ca

iTrader: (9)

Quote:
Originally Posted by zenmaster View Post
Leaving the car off for a longer period and then restarting it resolved the problem. But I'm wondering what caused it?

I had the same issue, except everything associated with my iDrive stopped working. No radio, no navi, no telephone and my iDrive knob stopped functioning. This all resulted from a SOS malfunction... It happened at night and I repeatedly tried to no avail. The next morning it magically worked...
__________________
Retired - 07 BMW 335i Sedan (Alpine White/Black Interior)
ZPP, ZSP. ZCW, 205, 2XA, 322, 417, 4AD, 609 and mods

Retired - 03 Mercedes-Benz c320 Sports Sedan (Alabaster White/Black Interior)
Bi-Xenons, Euro Comand Navigation, Rear Sunshades and mods
Appreciate 0
      05-11-2007, 08:24 AM   #4
zenmaster
Lieutenant Colonel
United_States
20
Rep
1,628
Posts

Drives: '13 AH3
Join Date: Mar 2007
Location: Atlanta

iTrader: (1)

I noticed that those particular audio sources (iDrive voice and MP3 audio) stopped working right after WOT. Could acceleration change the alternator voltage enough to affect iDrive RAM?
Appreciate 0
      05-11-2007, 10:19 AM   #5
007e92
First Lieutenant
007e92's Avatar
United_States
6
Rep
372
Posts

Drives: 645Ci
Join Date: Dec 2006
Location: San Jose, CA

iTrader: (3)

Garage List
2004 BMW 645  [0.00]
ran into the same issue too - just gotta turn it off, wait awhile and turn it back on
__________________
Current Ride: 04' 645Ci

Retired Rides:
07' e92
04' e46
Appreciate 0
      05-11-2007, 08:11 PM   #6
zenmaster
Lieutenant Colonel
United_States
20
Rep
1,628
Posts

Drives: '13 AH3
Join Date: Mar 2007
Location: Atlanta

iTrader: (1)

Quote:
Originally Posted by 007e92 View Post
ran into the same issue too - just gotta turn it off, wait awhile and turn it back on
Any idea what the minimum wait time is?
Appreciate 0
      05-11-2007, 08:46 PM   #7
BK
Smiling politely
United_States
98
Rep
7,919
Posts

Drives: 330i
Join Date: Feb 2006
Location: Washington DC

iTrader: (0)

Garage List
2006 330i  [4.50]
Supposedly everything shuts down after about 20 minutes, but give it an hour. Where is E90Fleet when you need him?
__________________


330i | Black Sapphire | Beige + Burl | Sport | Premium | Cold | Nav | CA | Sat prep
Appreciate 0
      05-11-2007, 09:48 PM   #8
chbrules
MSVConrad++
United_States
16
Rep
777
Posts

Drives: E90 2006 325i | E92 2007 335i
Join Date: Dec 2006
Location: Peaches

iTrader: (0)

I think I'm happy for not having chosen iDrive in my car.

Yes there could be a big possibility that if the alternator all of a sudden is pumping out more amperage that it could screw with sensative electronic components, especially microelectronics like the iDrive. Hopefully it's not enough to damange them. I would ask BMW about this issue and see if there's a resolution. You shouldn't have to shut off the car for a period of time just to get your iDrive working again, that's pretty silly.
Appreciate 0
      05-11-2007, 10:00 PM   #9
Ninjaneer
Shadow Warrior
Ninjaneer's Avatar
United_States
30
Rep
2,097
Posts

Drives: '07 335i Sedan
Join Date: Aug 2006
Location: Florida

iTrader: (0)

What about trying the iDrive reset? Press the 2 eject buttons (CD + DVD) AND the volume knob in... hold it for a few secs.

Dunno if this would do more of a complete reset than turning the car off for awhile, but once my iDrive froze up, was playing my mp3 cd but could no longer access any menus and attempting to +/- the volume did nothing either. Reset it and all was well. Never happened again.
__________________
335i E90 / Arctic / Gray / Burl Walnut / Steptronic / ZPP / ZSP / Paddles / CA / Nav / PDC / OEM Spoiler
Mods:
PIAA Angel Eyes, Rear Fog Switch, Escort X50 Blue hardwire, 30% Charcoal Llumar
Installing soon: Rear Power Outlets (Happy Robot mod!)
Appreciate 0
      05-11-2007, 10:58 PM   #10
zenmaster
Lieutenant Colonel
United_States
20
Rep
1,628
Posts

Drives: '13 AH3
Join Date: Mar 2007
Location: Atlanta

iTrader: (1)

Quote:
Originally Posted by Ninjaneer View Post
What about trying the iDrive reset? Press the 2 eject buttons (CD + DVD) AND the volume knob in... hold it for a few secs.

Dunno if this would do more of a complete reset than turning the car off for awhile, but once my iDrive froze up, was playing my mp3 cd but could no longer access any menus and attempting to +/- the volume did nothing either. Reset it and all was well. Never happened again.
Thanks for the tip. Where did you get that info? I'm guessing BMW needs to add more tolerance to the iDrive's power supply.
Appreciate 0
      05-12-2007, 11:13 AM   #11
Ninjaneer
Shadow Warrior
Ninjaneer's Avatar
United_States
30
Rep
2,097
Posts

Drives: '07 335i Sedan
Join Date: Aug 2006
Location: Florida

iTrader: (0)

Quote:
Originally Posted by zenmaster View Post
Thanks for the tip. Where did you get that info? I'm guessing BMW needs to add more tolerance to the iDrive's power supply.
Learnt about it from the forum actually Not sure if it's in the manual.
__________________
335i E90 / Arctic / Gray / Burl Walnut / Steptronic / ZPP / ZSP / Paddles / CA / Nav / PDC / OEM Spoiler
Mods:
PIAA Angel Eyes, Rear Fog Switch, Escort X50 Blue hardwire, 30% Charcoal Llumar
Installing soon: Rear Power Outlets (Happy Robot mod!)
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:13 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST