E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > car wont start after battery replacement



Reply
 
Thread Tools Search this Thread
      11-10-2011, 11:47 AM   #1
jaydee23116
Registered
0
Rep
1
Posts

 
Drives: 2007 bmw 328i
Join Date: Nov 2011
Location: florida

iTrader: (0)

car wont start after battery replacement

I just replaced my battery in my 2007 328i and it wont start.Any help would be appreciated
Appreciate 0
      11-10-2011, 12:09 PM   #2
fdriller9
Banned
United_States
103
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
Did it start before battery replacement? Why did you replace it?

Did you reconnect all the connection? Obviously + and - terminals but did you reconnect the small 2 pin connector?
Appreciate 0
      11-11-2011, 07:11 PM   #3
azeemtn
Second Lieutenant
5
Rep
210
Posts

 
Drives: '14 m5, Space Gray
Join Date: Sep 2007
Location: San Jose

iTrader: (0)

Garage List
2015 m5  [0.00]
Do you have power to accessories or Hazards? If so, there is probably something loose on the red cut-off box that sits on top of your battery. Power comes from the battery on two circuits (as far as I know). One circuit runs your lights, flashers, etc, and it is the wire on the battery itself. Another circuit runs the motor and some other high-draw devices, and it is routed through the red device on the battery that supposedly cuts the power in an overturn accident for safety. There are some wires on there, that may have come loose. Hope this helps.
__________________
------------
Everything is just for fun, and may or may not constitue real characters in actual life...
------------
Appreciate 0
      11-11-2011, 07:23 PM   #4
tibra1
Banned
No_Country
75
Rep
6,775
Posts

 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

iTrader: (4)

Is the new battery fully charged?..did you connect everything correctly?
Appreciate 0
      11-19-2011, 05:46 AM   #5
DCwell3er
Private First Class
DCwell3er's Avatar
United_States
1
Rep
104
Posts

 
Drives: 2011 E90 LCI
Join Date: Nov 2011
Location: Warrensburg, Missouri

iTrader: (0)

I wonder what happened with this. Was there something not connected or an issue w/ the new battery?
__________________
Enjoying life! Missing the warmth of the 305.
Appreciate 0
      11-19-2011, 06:07 AM   #6
tibra1
Banned
No_Country
75
Rep
6,775
Posts

 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

iTrader: (4)

Typical...noobs create a thread and then never report back what happen
Appreciate 0
      11-23-2011, 02:03 PM   #7
bionet
Private First Class
2
Rep
116
Posts

 
Drives: e46 330i -> e92 335i
Join Date: Oct 2011
Location: NoVA

iTrader: (0)

Send a message via AIM to bionet
Not cool
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:06 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST