E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > INPA problem? (both black dots are on)



Reply
 
Thread Tools Search this Thread
      11-29-2011, 05:50 PM   #1
milly
Captain
 
milly's Avatar
 
Drives: 328i
Join Date: Dec 2010
Location: Charleston, SC

Posts: 785
iTrader: (3)

Garage List
2008 328i (e90)  [4.50]
INPA problem? (both black dots are on)

Ok so when i open inpa, it connects and both black dots show....unfortunately i don't have the option to choose my car (f9)

look at the pic... what shoild i do?


__________________
Black 2008 328i e90-BMW Performance CF Strut Bar/Muffler delete/8000k Fogs Fogs/Trunk Spoiler/5% Tint/BlueTooth/JVC HU/AG M359 Wheels/Matte Black kidney grills/H&R Race Springs/Koni Yellows/Orion V2 Angel Eyes/EuroCharged Tune/
milly is offline   United_States
0
Reply With Quote
      11-29-2011, 06:05 PM   #2
milly
Captain
 
milly's Avatar
 
Drives: 328i
Join Date: Dec 2010
Location: Charleston, SC

Posts: 785
iTrader: (3)

Garage List
2008 328i (e90)  [4.50]
Okay I downloaded new version of inpa and it seems to work but now when I try to check the air bags an error comes up saying not found or file not found or something... What do I need to do?

Thanks
__________________
Black 2008 328i e90-BMW Performance CF Strut Bar/Muffler delete/8000k Fogs Fogs/Trunk Spoiler/5% Tint/BlueTooth/JVC HU/AG M359 Wheels/Matte Black kidney grills/H&R Race Springs/Koni Yellows/Orion V2 Angel Eyes/EuroCharged Tune/
milly is offline   United_States
0
Reply With Quote
      11-30-2011, 02:48 AM   #3
1QuikWS6
No 55mph
 
1QuikWS6's Avatar
 
Drives: 09 E92 328iX N51 3-Stage
Join Date: Jul 2009
Location: Blitzburgh, PA

Posts: 4,349
iTrader: (80)

Garage List
Disregard the airbag error - that airbag check listed in the post doesn't work for most people...

Never has worked on my car & I have been coding since the day that BMW Coding thread was started.
__________________
2009 328ix E92//SGM//ACS Roof Spoiler//MTech Aero Lip+Trunk Spoiler//M3 Side Skirts//CF Roundels+Grilles//M3 Novillo Interior//Perf Shift Lever+Boot//MPerf DCT Wheel//M3 GT3 eBrake Handle+Boot//ACS Pedals//M3 Mirrors//LCI Tails w/LUX Rev//DTEC V7 AE+MTec 6000K D1S+HPB HID 6000K Fogs//HPB LED Interior//RPI Scoops//CF Euro Airbox+Underhood Hsgs//K&N//BMW PE//MTech Rear Bumper-iS Sport Diffuser//CF Strut Brace//Vishnu OFT//BMW 193M's+Kumho 4X
1QuikWS6 is offline   United_States
0
Reply With Quote
      11-30-2011, 06:40 AM   #4
milly
Captain
 
milly's Avatar
 
Drives: 328i
Join Date: Dec 2010
Location: Charleston, SC

Posts: 785
iTrader: (3)

Garage List
2008 328i (e90)  [4.50]
[quote=1QuikWS6;10893011]Disregard the airbag error - that airbag check listed in the post doesn't work for most people...

Never has worked on my car
__________________
Black 2008 328i e90-BMW Performance CF Strut Bar/Muffler delete/8000k Fogs Fogs/Trunk Spoiler/5% Tint/BlueTooth/JVC HU/AG M359 Wheels/Matte Black kidney grills/H&R Race Springs/Koni Yellows/Orion V2 Angel Eyes/EuroCharged Tune/
milly is offline   United_States
0
Reply With Quote
      11-30-2011, 06:45 AM   #5
milly
Captain
 
milly's Avatar
 
Drives: 328i
Join Date: Dec 2010
Location: Charleston, SC

Posts: 785
iTrader: (3)

Garage List
2008 328i (e90)  [4.50]
That's good to know, thank you!
__________________
Black 2008 328i e90-BMW Performance CF Strut Bar/Muffler delete/8000k Fogs Fogs/Trunk Spoiler/5% Tint/BlueTooth/JVC HU/AG M359 Wheels/Matte Black kidney grills/H&R Race Springs/Koni Yellows/Orion V2 Angel Eyes/EuroCharged Tune/
milly is offline   United_States
0
Reply With Quote
      04-05-2012, 09:19 PM   #6
mot
Banned
 
Drives: e92 AW M3 6MT
Join Date: Oct 2010
Location: Bay Area, California

Posts: 941
iTrader: (8)

I get an error when I check my airbags also. It says my version is out of date/ does not match. Anyone have this issue and how do I clear it?
mot is offline   United_States
0
Reply With Quote
      04-05-2012, 10:51 PM   #7
Alpineweiss e90
Banned
 
Drives: AW 330xi
Join Date: Feb 2012
Location: .

Posts: 220
iTrader: (0)

What version of INPA did you get? The one you show in your first post is bare and looks like it was installed from an original release of BMW Standard Tools. Did Toolset 32 and WinKPF (or something like that) install as well?

The original release of BMW Standard tools does not include scripts or any daten files, etc. You need to load them after your install INPA, in the proper C:\ directory.
Alpineweiss e90 is offline  
0
Reply With Quote
      04-06-2012, 09:27 PM   #8
mot
Banned
 
Drives: e92 AW M3 6MT
Join Date: Oct 2010
Location: Bay Area, California

Posts: 941
iTrader: (8)

Anyone?
mot is offline   United_States
0
Reply With Quote
      04-06-2012, 09:36 PM   #9
Alpineweiss e90
Banned
 
Drives: AW 330xi
Join Date: Feb 2012
Location: .

Posts: 220
iTrader: (0)

I told you.....you need to load the scripts and daten files into the correct folders in your C:\ directories. Check out bmw coding . com

EDIT: Wait you're not the OP, sorry.

But regardless, I believe you may need newer daten files.
Alpineweiss e90 is offline  
0
Reply With Quote
      04-06-2012, 10:37 PM   #10
mot
Banned
 
Drives: e92 AW M3 6MT
Join Date: Oct 2010
Location: Bay Area, California

Posts: 941
iTrader: (8)

I was using v45
mot is offline   United_States
0
Reply With Quote
      04-06-2012, 11:58 PM   #11
e90sexion
E 9 0 S E X I O N
 
e90sexion's Avatar
 
Drives: like old times
Join Date: Sep 2006
Location: Vancouver/WA

Posts: 6,217
iTrader: (16)

Quote:
Originally Posted by mot View Post
I get an error when I check my airbags also. It says my version is out of date/ does not match. Anyone have this issue and how do I clear it?
when I check the airbags, some error box came up on the screen but I ignored it, and now looks like many others do too. Coding worked for me tho.
e90sexion is offline   Canada
0
Reply With Quote
      04-07-2012, 08:22 AM   #12
mot
Banned
 
Drives: e92 AW M3 6MT
Join Date: Oct 2010
Location: Bay Area, California

Posts: 941
iTrader: (8)

I would like to diagnose the car using INPA though.
mot is offline   United_States
0
Reply With Quote
      04-07-2012, 09:48 AM   #13
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
It's weird. When I first installed INpa my lights would work fine with my Old IBM laptop. When connected battery light would just light up and when ignition was turned on the ignition would then also log black which is normal. Installed on a new laptop and now when I am just connected with no ignition the battery light does not come on, but when I turn ignition on both circles turn black. Connection is perfect but it just doesn't light up the connection circles like before. Weird
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      04-07-2012, 03:36 PM   #14
VTECaddict
Where'd my VTEC go?
 
VTECaddict's Avatar
 
Drives: 06 330i 6MT
Join Date: Mar 2009
Location: Las Vegas, NV

Posts: 4,617
iTrader: (4)

Quote:
Originally Posted by Alpineweiss e90 View Post
What version of INPA did you get? The one you show in your first post is bare and looks like it was installed from an original release of BMW Standard Tools. Did Toolset 32 and WinKPF (or something like that) install as well?

The original release of BMW Standard tools does not include scripts or any daten files, etc. You need to load them after your install INPA, in the proper C:\ directory.
I have the same problem. Can you tell me what exactly I need to move where? I tried searching and I cant find anything.

I have v45 daten files and BMW Standard Tools 2.11
__________________
AW/Terra | ZSP | ZPP | ZCW | iDrive | CA
Mods: BC BR | OEM Blacklines | M-tech rear | custom dual exhaust | M3 steering wheel | BMW SSK | ZHP shift knob | BMW Performance rep spoiler
Varrstoen ES1 19x9.5+20 Front, 19x11+25 rear
VTECaddict is offline  
0
Reply With Quote
      05-23-2012, 12:11 AM   #15
melloww22
Lieutenant
 
melloww22's Avatar
 
Drives: 2011 335i E90
Join Date: Apr 2011
Location: San Diego

Posts: 572
iTrader: (1)

Question Errors INPA

I received two errors when trying to read the airbag function...

Error1: "versions do not match"
Error2 Pops right after error 1: "language variants do not match "

I am using INPA v5.02 , EDIABAS v6.4.7 , with Daten SP-V45-E89

I have a 2011 April build 335 e90, last year i had the dealer perform the Power Perfromance Kit.

Is it telling me that my car was tuned using a newer/older version of INPA? What is the next step?

Thank you in advance for your help in this matter...

Last edited by melloww22; 05-23-2012 at 12:27 AM.
melloww22 is offline  
0
Reply With Quote
      05-23-2012, 07:22 AM   #16
GenePoole
Lieutenant
 
Drives: '06 E90 330i
Join Date: Apr 2010
Location: Brighton, IL

Posts: 537
iTrader: (0)

Quote:
Originally Posted by melloww22 View Post
I received two errors when trying to read the airbag function...

Error1: "versions do not match"
Error2 Pops right after error 1: "language variants do not match "

I am using INPA v5.02 , EDIABAS v6.4.7 , with Daten SP-V45-E89

I have a 2011 April build 335 e90, last year i had the dealer perform the Power Perfromance Kit.

Is it telling me that my car was tuned using a newer/older version of INPA? What is the next step?

Thank you in advance for your help in this matter...
Those are warnings, not errors. I don't think they are any cause for alarm. I think it just means that you have a mix of German and English INPA scripts and/or some scripts compiled for a different version or language variant of INPA. Unfortunately, we don't have (that I know of) the source code for the common scripts that are part of most of the INPA distributions floating around or we could recompile them for the proper version/language variant.
GenePoole is offline  
0
Reply With Quote
      05-23-2012, 11:48 AM   #17
melloww22
Lieutenant
 
melloww22's Avatar
 
Drives: 2011 335i E90
Join Date: Apr 2011
Location: San Diego

Posts: 572
iTrader: (1)

Mixed Success!!

I was able to do the following:

CAS: BC_DIGITAL_V
CAS: DIGITAL_KVA
CAS: BC_DIGITAL_V_KORREKTUR
KOMBI: KOMFORTSCHLIESSUNG_FB
KOMBI: LEGAL_DISCLAIMER_TIME
KOMBI: NAVI_FUELSTOP_PROPOSAL


however

I wanted to code:
FRM (NFRM) LH_UND_NSW_NICHT_GLEICHZ
FRM (NFRM) FL_UND_NSW_NICHT_GLEICHZ

I was unable to read the NFRM. I received the following errors:

COAPI-2000: EDIABAS or SGBD error
BIP-0009: BEST VERSION ERROR

Here is the error log:

ERROR! Modul: LFCDHDIA.CPP (A_PL2FRX.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
COAPI-2000: EDIABAS or SGBD error
BIP-0009: BEST VERSION ERROR

Any guideance is greatly appreciated...

____

EDIT: I think it has to do with having newer daten files and 6.4.7 wont read them correctly, I am going to try using EDIABAS 7.2.0.

Last edited by melloww22; 05-23-2012 at 12:05 PM.
melloww22 is offline  
0
Reply With Quote
      05-23-2012, 12:15 PM   #18
Elliott@DetailAddict
Brigadier General
 
Drives: E90
Join Date: May 2011
Location: Santa Clara, CA

Posts: 4,448
iTrader: (0)

^update your daten and ediabas
Elliott@DetailAddict is offline   United_States
0
Reply With Quote
      05-23-2012, 10:40 PM   #19
melloww22
Lieutenant
 
melloww22's Avatar
 
Drives: 2011 335i E90
Join Date: Apr 2011
Location: San Diego

Posts: 572
iTrader: (1)

installing smart tools 2.11 resolved my problem...
melloww22 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:53 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST