E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > For Help with NCSExpert Errors



Reply
 
Thread Tools Search this Thread
      07-14-2012, 06:23 PM   #45
rollinstone157
Brotographer
 
rollinstone157's Avatar
 
Drives: 2010 328i xDrive Sedan
Join Date: Mar 2011
Location: NJ, USA

Posts: 1,701
iTrader: (0)

Garage List
Quote:
Originally Posted by Grant@DetailAddict View Post
Without personally seeing your files, it seems to me youre having the same issue that people do and end up switching between their old files and new files to access the NFRM.

I'm not quite sure what they do incorrectly and my recommendation would be to start fresh and re-update the new installation following directions in the forum to the "T".
Hello Grant,

First off, the nitty-gritty--my car is a 2010 E90 LCI with a late 2009 build date

I fixed my original problems with the FRM and KOMBI access through a reinstallation of the suite, and using the "LADEN" files to update the DATEN files. Yay.

I've been a member here for a while now, and I've just started coding. I have updated my Daten files to 46.3 (from the BMW Coding forums). I am having a few issues though...

first off, I am currently unable to see the LMA module from the given list...any ideas? This is very strange to me, is it supposed to be seen under CAS-->LMA, or should it be expected either under FRM-->LMA or NFRM-->LMA?

Thanks!

- Rob
__________________
Reviews -|- HPB "Ultimate" LED Interior Kit -|- Noyka Cornering Bulbs -|- HPB 20W AE [OLD] -|- LUX H8 V4 -|- New Reviews Pending Vendor Approval

Last edited by rollinstone157; 07-14-2012 at 10:40 PM. Reason: Image Crop
rollinstone157 is offline   United_States
0
Reply With Quote
      07-21-2012, 01:15 PM   #46
michbmw
Second Lieutenant
 
Drives: 2010 328XI
Join Date: Jul 2012
Location: Michigan

Posts: 225
iTrader: (0)

Hello, trying to connect to my 2010 328XI with ncs expert, having some issues. First tried inpa, it connect to that, both circles were black. i tried the air bag test but it didn't work, i noticed that people said it doesn't work for everyone so i proceeded to try ncs expert. i'm following ncs_diy.pdf step by step when i get to step38 i get the error. I have my profile loaded, hit F1 then F3, selected E89 then CAS. after it thinks for a bit i get the error

below is the error.log


ERROR! Modul: LFCDHDIA.CPP (A_E65CAS.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
COAPI-2000: EDIABAS or SGBD error
IFH-0003: DATATRANSMISSION TO INTERFACE DISTURBED

>> ERROR! Modul: COAPI2.CPP, Proc: coapiRunCabd, LineNr: 06, ErrorNr: 2000
FGNR_LESEN

>> ERROR! Modul: COAPI.CPP, Proc: coapiReadFgNr, LineNr: 04, ErrorNr: 2000
FGNR_LESEN: A_E65CAS

i tried updating my daten files to 46.1 no luck. is there anything specifc besides overwriting the old files i'm supposed to do? i tried running the laden.bat file as well, still no luck....

any help would be appreciated.

Thanks,
michbmw is offline  
0
Reply With Quote
      07-21-2012, 06:50 PM   #47
michbmw
Second Lieutenant
 
Drives: 2010 328XI
Join Date: Jul 2012
Location: Michigan

Posts: 225
iTrader: (0)

unless someone has any better ideas i think the problem is with my cable. i read on another forum that if the cable you get has the blue circuit board you are guaranteed it won't work, if you get one with a green or white circuit board you'll be good to go. i guess it is based on the circuit board manufacturer of the cable. i unfortunately got one with a blue circuit, i'm requsting a replacement from tmart. if i get another dud i'll get refunded and go with one from the recommended site (the $100 one). please note i originally went with the tmart one because it was recommended that their cables work as well and since the other site was sold out i went with the tmart cable....oh well
michbmw is offline  
0
Reply With Quote
      07-21-2012, 07:51 PM   #48
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
T-Mart use to sell the ones that worked as I was the one that originally recommended it. This was about a year ago and since then they have shipped nothing but GARBAGE, and I took that link off my thread...Go get a refund and do yourself a favor and get the one from Onestopelectronics. If you have the blue circuit board cable, kindly either get a refund or throw it out the trash..
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      07-22-2012, 01:59 PM   #49
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 239
iTrader: (3)

retrofit CCC and others

*UPDATE2* I went ahead and updated the files to E89 v46.3, but now I'm getting a coapi-2000: ediabas or sgbd error
bip-0009 best version error, any one knows what's going on?

*UPDATE* seems like I need more recent daten files. Also not sure why it's complaining about E60 stuff when my car is a E90...

Need help, experts! I'm retrofitting CCC and many other components that come with the same donor car. Mine is a E90, MY07, 2008 328xi. Donor car is E90 M3 MY08, 2008 M3. I get these errors after changing VO to CAS and NFRM, when trying to process car/code car:



I followed the change vo instructions to:

1. remove :
$693 Xm prep
$640 phone prep
$663 radio pro

and added

$609 NAV
$620 voice control
$655 XM
$6AA bmw teleservices
$6AB control for "
$6FL USB
$6UH traffic update

to the CAS and NFRM.

Then I read the FA/VO again, and F6 back, F3 process car, F1 code car, which results in the error above when coding KOMBI.

BTW... I'm using the Tmart cable, white board. Bought it before reading the updated comment that it might be junk...

thanks,
D

Last edited by dylim; 07-22-2012 at 02:52 PM.
dylim is offline  
0
Reply With Quote
      07-22-2012, 02:27 PM   #50
Im8Up
Private
 
Im8Up's Avatar
 
Drives: 2007 335i
Join Date: Feb 2011
Location: Cincinnati

Posts: 78
iTrader: (1)

Started last night with my first coding attempt for my '07 e90 coding the kombi for the digital spedo.
Did so and all went fine until I got the spedo malfunction. Searched and updated the daten files with v46.
Flashed the kombi back and all was fine.
Went to try to code the nfrm module and get...
error in cabd
coapi-2000: ediabas or sgbd error
bip-0009 best version error

Went and updated Ediabas to version 7 and in doing so now i get no black dots in inpa and messages that inpa versions do not match and language variants do not match. I also do not see any ecu folder in this new version.

My question is would I be better off reinstaling everything and trying the v41 daten files using ebiadas v6.4.7? As I read that ediabas v7 or daten v46 has issues reading the nfrm? Sorry just been researching a lot and everything is starting to jumble in my head.

Fyi when I switch back to ediabas v6.4.7 inpa reads the airbag info just fine. And I can also see the CAS module just fine. Just seem to have an issue with the nfrm. Thanks in advance.
Im8Up is offline   United_States
0
Reply With Quote
      07-22-2012, 05:11 PM   #51
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by dylim View Post
*UPDATE2* I went ahead and updated the files to E89 v46.3, but now I'm getting a coapi-2000: ediabas or sgbd error
bip-0009 best version error, any one knows what's going on?

*UPDATE* seems like I need more recent daten files. Also not sure why it's complaining about E60 stuff when my car is a E90...

Need help, experts! I'm retrofitting CCC and many other components that come with the same donor car. Mine is a E90, MY07, 2008 328xi. Donor car is E90 M3 MY08, 2008 M3. I get these errors after changing VO to CAS and NFRM, when trying to process car/code car:



I followed the change vo instructions to:

1. remove :
$693 Xm prep
$640 phone prep
$663 radio pro

and added

$609 NAV
$620 voice control
$655 XM
$6AA bmw teleservices
$6AB control for "
$6FL USB
$6UH traffic update

to the CAS and NFRM.

Then I read the FA/VO again, and F6 back, F3 process car, F1 code car, which results in the error above when coding KOMBI.

BTW... I'm using the Tmart cable, white board. Bought it before reading the updated comment that it might be junk...

thanks,
D
If you have the white circuit board then your cable is not the issue.
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      07-22-2012, 08:45 PM   #52
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 239
iTrader: (3)

Quote:
Originally Posted by cn555ic View Post
If you have the white circuit board then your cable is not the issue.
Thanks cn555ic, I was about to RMA it

Still getting best version error when trying to code car. I downloaded the E89 v46.3 datens and overwrote the E89 subfolder under NCSEXPER\daten, and replaced the entire NCSEXPER\SGDAT\ as well as EDIABAS\ecu.

While overwriting the E89 subfolder, I noticed that many files are newer, but of the same size. Some files are larger and newer. Should I have overwritten only the larger and newer ones?

Thanks,
D

*UPDATE, found that this probably means my EDIABAS version is too old, need 7.x for the newer daten files. Proceeding to update EDIABAS...

*UPDATE 2, used the version with EDIABAS 7 and v41 datens, was able to code pass KOMBI, but now stuck at TCU with IFH 0009:



stuck now...

Last edited by dylim; 07-22-2012 at 10:55 PM.
dylim is offline  
0
Reply With Quote
      07-22-2012, 11:33 PM   #53
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 239
iTrader: (3)

Quote:
Originally Posted by Im8UprU View Post
Started last night with my first coding attempt for my '07 e90 coding the kombi for the digital spedo.
Did so and all went fine until I got the spedo malfunction. Searched and updated the daten files with v46.
Flashed the kombi back and all was fine.
Went to try to code the nfrm module and get...
error in cabd
coapi-2000: ediabas or sgbd error
bip-0009 best version error

Went and updated Ediabas to version 7 and in doing so now i get no black dots in inpa and messages that inpa versions do not match and language variants do not match. I also do not see any ecu folder in this new version.

My question is would I be better off reinstaling everything and trying the v41 daten files using ebiadas v6.4.7? As I read that ediabas v7 or daten v46 has issues reading the nfrm? Sorry just been researching a lot and everything is starting to jumble in my head.

Fyi when I switch back to ediabas v6.4.7 inpa reads the airbag info just fine. And I can also see the CAS module just fine. Just seem to have an issue with the nfrm. Thanks in advance.
Obviously I'm no expert, but I don't think the old EDIABAS would work with v41 daten - you'll get the best version error too. You can try the one with EDIABAS 7 and v41 datens in one package here:
http://www.e90post.com/forums/showthread.php?t=588311.
dylim is offline  
0
Reply With Quote
      07-23-2012, 10:50 AM   #54
michbmw
Second Lieutenant
 
Drives: 2010 328XI
Join Date: Jul 2012
Location: Michigan

Posts: 225
iTrader: (0)

Quote:
Originally Posted by cn555ic View Post
T-Mart use to sell the ones that worked as I was the one that originally recommended it. This was about a year ago and since then they have shipped nothing but GARBAGE, and I took that link off my thread...Go get a refund and do yourself a favor and get the one from Onestopelectronics. If you have the blue circuit board cable, kindly either get a refund or throw it out the trash..
I just requested a refund instead from Tmart and shipped them back the bad cable. I then ordered one from onestopelectronics, i see that they are coming from hong kong, does anyone know how long it takes approximately to get a cable to the US?

Thanks
michbmw is offline  
0
Reply With Quote
      07-23-2012, 11:13 AM   #55
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by michbmw View Post
I just requested a refund instead from Tmart and shipped them back the bad cable. I then ordered one from onestopelectronics, i see that they are coming from hong kong, does anyone know how long it takes approximately to get a cable to the US?

Thanks
about 2 weeks
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      07-23-2012, 02:31 PM   #56
michbmw
Second Lieutenant
 
Drives: 2010 328XI
Join Date: Jul 2012
Location: Michigan

Posts: 225
iTrader: (0)

Quote:
Originally Posted by cn555ic View Post
about 2 weeks
thanks for all your help
michbmw is offline  
0
Reply With Quote
      07-23-2012, 05:46 PM   #57
Im8Up
Private
 
Im8Up's Avatar
 
Drives: 2007 335i
Join Date: Feb 2011
Location: Cincinnati

Posts: 78
iTrader: (1)

Quote:
Originally Posted by michbmw View Post
I just requested a refund instead from Tmart and shipped them back the bad cable. I then ordered one from onestopelectronics, i see that they are coming from hong kong, does anyone know how long it takes approximately to get a cable to the US?

Thanks
Got mine in 8 days about a month ago. Hopefully you'll get yours just as fast!
Im8Up is offline   United_States
0
Reply With Quote
      07-24-2012, 11:38 PM   #58
Im8Up
Private
 
Im8Up's Avatar
 
Drives: 2007 335i
Join Date: Feb 2011
Location: Cincinnati

Posts: 78
iTrader: (1)

Quote:
Originally Posted by dylim View Post
Obviously I'm no expert, but I don't think the old EDIABAS would work with v41 daten - you'll get the best version error too. You can try the one with EDIABAS 7 and v41 datens in one package here:
http://www.e90post.com/forums/showthread.php?t=588311.
Thanks for the link dylim it worked like a charm and I finally have my Corner Delete and AE's as DRL's coded! And thanks to Phil for putting that all together for everyone!
Im8Up is offline   United_States
0
Reply With Quote
      07-25-2012, 12:25 AM   #59
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 239
iTrader: (3)

Quote:
Originally Posted by Im8UprU View Post
Thanks for the link dylim it worked like a charm and I finally have my Corner Delete and AE's as DRL's coded! And thanks to Phil for putting that all together for everyone!
Good for you man!! I'm still struggling with "process car -> code car" after retrofitting CCC, 6FL, BT, XM. Some how I can't communicate with TCUM or 2MULF. So far I was able to code the CCC (CAAPL), CAS, and NFRM, but not sure what to change in order for the components to work together. Right now, Navigation works, but nothing else - not even the radio
dylim is offline  
0
Reply With Quote
      08-06-2012, 10:04 AM   #60
michbmw
Second Lieutenant
 
Drives: 2010 328XI
Join Date: Jul 2012
Location: Michigan

Posts: 225
iTrader: (0)

Quote:
Originally Posted by cn555ic View Post
about 2 weeks
FYI the cable came and works great, digital speedo done, along with increasing brightness of angle eyes and angel eye DRL's on e90 lci

Thanks for all your help
michbmw is offline  
0
Reply With Quote
      10-26-2012, 10:38 AM   #61
HellFire335
Enlisted Member
 
Drives: 335I
Join Date: Jan 2011
Location: Charleston, SC

Posts: 38
iTrader: (1)

when trying to start NSCExpert after selecting my chassie( e90) and i select CAS, I keep getting the following error

ERROR! MODUL: LFCDHDIA.CPP (A_E65CAS.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
COAPI-2000: EDIABAS OR SGBD error
IFH-0003: DATATRANSMISSION TO INTERFACE DISTURBED

>> ERROR! Modul: COAPI2.CPP, Proc: coapiRunCabd, LineNr: 06, ErrorNr: 2000
FA_READ

>> ERROR! Modul: COAPI4.CPP, Proc: coapiReadAuftrag, LineNr: 04, ErrorNr: 2000
FA_REAS: A_E65CAS
HellFire335 is offline  
0
Reply With Quote
      10-26-2012, 11:52 AM   #62
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Something is not set up right in your configurations.
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      10-26-2012, 05:21 PM   #63
Elliott@DetailAddict
Brigadier General
 
Drives: E90
Join Date: May 2011
Location: Santa Clara, CA

Posts: 4,448
iTrader: (0)

Yes, it's looking for files that aren't there.
Reinstall.
Elliott@DetailAddict is offline   United_States
0
Reply With Quote
      10-27-2012, 04:07 PM   #64
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,753
iTrader: (46)

Hi
I wonder if someone can help me with this.
I was trying to retrofit heating seats on 2007 E92 with electric and memory seats.

When I tried to read CFAS module, following errors showed:

ERROR! Modul: LFCDHDIA.CPP (A_E65.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
COAPI-2000: EDIABAS or SGBD error
BIP-0009: BEST VERSION ERROR

>> ERROR! Modul: COAPI2.CPP, Proc: coapiRunCabd, LineNr: 06, ErrorNr: 2000
CODIERINDEX_LESEN

>> ERROR! Modul: COAPI.CPP, Proc: coapiReadCodierIndexFromSg, LineNr: 05, ErrorNr: 2000
CODIERINDEX_LESEN: A_E65

>> ERROR! Modul: LFCDHDIA.CPP (A_E65.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
BIP-0009: BEST VERSION ERROR

>> ERROR! Modul: COAPI2.CPP, Proc: coapiRunCabd, LineNr: 06, ErrorNr: 2000
CODIERDATEN_LESEN



And same goes for BFAS module and error was:


ERROR! Modul: LFCDHDIA.CPP (A_E65.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
COAPI-2000: EDIABAS or SGBD error
BIP-0009: BEST VERSION ERROR

>> ERROR! Modul: COAPI2.CPP, Proc: coapiRunCabd, LineNr: 06, ErrorNr: 2000
CODIERINDEX_LESEN

>> ERROR! Modul: COAPI.CPP, Proc: coapiReadCodierIndexFromSg, LineNr: 05, ErrorNr: 2000
CODIERINDEX_LESEN: A_E65

>> ERROR! Modul: LFCDHDIA.CPP (A_E65.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
BIP-0009: BEST VERSION ERROR

>> ERROR! Modul: COAPI2.CPP, Proc: coapiRunCabd, LineNr: 06, ErrorNr: 2000
CODIERDATEN_LESEN

ERROR! Modul: LFCDHDIA.CPP (A_E65.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
COAPI-2000: EDIABAS or SGBD error
BIP-0009: BEST VERSION ERROR

>> ERROR! Modul: COAPI2.CPP, Proc: coapiRunCabd, LineNr: 06, ErrorNr: 2000
CODIERINDEX_LESEN

>> ERROR! Modul: COAPI.CPP, Proc: coapiReadCodierIndexFromSg, LineNr: 05, ErrorNr: 2000
CODIERINDEX_LESEN: A_E65

>> ERROR! Modul: LFCDHDIA.CPP (A_E65.IPS/IPO), Proc: CDHapiResultText, LineNr: 01, ErrorNr: 2000
BIP-0009: BEST VERSION ERROR

>> ERROR! Modul: COAPI2.CPP, Proc: coapiRunCabd, LineNr: 06, ErrorNr: 2000
CODIERDATEN_LESEN




Can somebody explained what these errors means?

I am using V46 daten files. Also tried V41 but no luck.

Thanks.
__________________
makkan00 is online now   United Kingdom
0
Reply With Quote
      10-27-2012, 04:07 PM   #65
HellFire335
Enlisted Member
 
Drives: 335I
Join Date: Jan 2011
Location: Charleston, SC

Posts: 38
iTrader: (1)

awesome got everything working now, thanks
HellFire335 is offline  
0
Reply With Quote
      10-31-2012, 11:53 AM   #66
michbmw
Second Lieutenant
 
Drives: 2010 328XI
Join Date: Jul 2012
Location: Michigan

Posts: 225
iTrader: (0)

any word how cn555ic is doing after Sandy hit?
michbmw is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:17 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST