E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > 06 330i throwing lots of codes



Reply
 
Thread Tools Search this Thread
      12-13-2011, 01:01 PM   #1
Speedracer350
New Member
 
Drives: 06 330i
Join Date: Nov 2011
Location: South Florida

Posts: 16
iTrader: (0)

06 330i throwing lots of codes

Well I just changed the oil separator and all its hoses that I broke when installing my starter. That all went smooth until I went to fire her up. She is throwing the following codes:

P0700 - P0700 Transmission Control System Malfunction
P0123 -Throttle Position Sensor/Switch A Circuit High Input
P0222 - Throttle/Petal Position Sensor/Switch B Circuit Low Input
P1417 - Port Air Relief Circuit Malfunction
P0335 - Ignition Coil E Primary/Secondary Circuit Malfunction
P111F - Unsure
P0102 - Mass or Volume Air Flow Circuit Low Input

I am certain that the MAF is plugged in correctly, both sensors on the sides of the intake manifold are in. I changed the plugs while I had the covers off, so I will check the coil. Is Coil E the second from the front of the motor, or the back? The car takes several seconds to fire every time I start it, yet the fuel rail has plenty of pressure, I tested the bleeder valve. You guys have been great helping me so far, much apprecited!!

Joseph
Speedracer350 is offline  
0
Reply With Quote
      12-13-2011, 01:24 PM   #2
Speedracer350
New Member
 
Drives: 06 330i
Join Date: Nov 2011
Location: South Florida

Posts: 16
iTrader: (0)

So I checked all the coils, by pulling each one at a time while it was running, and the idle fell for each one. When in neutral, it will rev all the way out, no hesitation, no issue. When I rescanned the codes after checking the coils, it only through 2:

P1727 - Coast Clutch Solenoid Inductive Signature Malfunction (say what)
P0355

Like before, when in D, it is sluggish and wont go over 20 or so, and rpms stay below 2500.
Speedracer350 is offline  
0
Reply With Quote
      12-13-2011, 04:50 PM   #3
Speedracer350
New Member
 
Drives: 06 330i
Join Date: Nov 2011
Location: South Florida

Posts: 16
iTrader: (0)

Also, just to add more information, the car prior to installing the new oil separator and hoses would fire immediately, none of this 4-5 seconds of cranking.
Speedracer350 is offline  
0
Reply With Quote
      03-30-2013, 12:24 PM   #4
mrjoe
joseph
 
mrjoe's Avatar
 
Drives: 2006 330i E90 N52
Join Date: Aug 2011
Location: San Diego, California

Posts: 61
iTrader: (0)

Garage List
2006 330i  [0.00]
Send a message via Skype™ to mrjoe
any luck? I am in the exact same situation now.
__________________
2006 330i E90 N52 - Coded
Production 10/2005
mrjoe is offline   United_States
0
Reply With Quote
      05-17-2013, 09:38 AM   #5
markrambo
Registered
 
Drives: 06 330i
Join Date: May 2013
Location: pleasanton calif

Posts: 1
iTrader: (0)

o6 330i mass air sensor wires

i pulled the plug on my mass air sensor when changing airfilter,when pulling plug,all colored wires came out of plug and dont know the color sequencing or the order wires go,can anyone help??its un plugged now and car runs great except for check engine light
markrambo is offline  
0
Reply With Quote
      05-17-2013, 02:17 PM   #6
nate5ks
Captain
 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

Posts: 604
iTrader: (0)

Quote:
Originally Posted by markrambo
i pulled the plug on my mass air sensor when changing airfilter,when pulling plug,all colored wires came out of plug and dont know the color sequencing or the order wires go,can anyone help??its un plugged now and car runs great except for check engine light
I also have a 330i, ill check for you and send a pic
nate5ks is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:55 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST