E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Possible steering rack issue



Reply
 
Thread Tools Search this Thread
      10-23-2012, 01:19 PM   #23
KyLu II
FREE DREAMK
 
KyLu II's Avatar
 
Drives: the shiiit!
Join Date: Aug 2009
Location: Vineland, NJ

Posts: 9,315
iTrader: (6)

Garage List
2011 Lexus LFA  [1.88]
Quote:
Originally Posted by nmswenson View Post
I fugred out what the problem was with mine. I unbolted the track bar and sway bar links and tested the steering that way to see if I could isolate the rack as the problem. I didn't make any difference in the sound. I then went to remove the steering rack and found the two mounting bolts loose! About 30K miles ago I installed aftermarket downpipes and had to unbolt the steering rack to install them. They must of just worked themselves loose. I put some blue locktite on them and retightened. Everything is great now. Steering is much smoother, no noise, and the ride is much quieter. Sure glad it was an easy fix!
thanks for your input!
same here! the noise is completely gone now
__________________
KyLu II is offline   Dominican Republic
0
Reply With Quote
      04-29-2013, 01:45 PM   #24
phubar
Enlisted Member
 
Drives: 335 Coupe
Join Date: Apr 2013
Location: Fort Campbell KY

Posts: 45
iTrader: (2)

This thread should be made a sticky. I was ready to buy a new steering rack and kept reading and reading the forums because I had never heard a steering rack make that kinda noise when bad. I finally found this thread, tried to the bolts as a last resort and what do you know it freaking WORKED!!

Thank you all.
phubar is offline  
0
Reply With Quote
      03-16-2014, 02:58 PM   #25
AYF80
Captain
 
Drives: 2015 AY F80
Join Date: Sep 2009
Location: Nashville, TN

Posts: 943
iTrader: (0)

Yup, just wanted to report that as of 15 min ago i was also suffering from the exact same issue…

My driver side rack mounting bolt was very loose… tightened it back down and now its perfect!!!

Im going to order a new set of bolts and nuts and replace the current set to be safe that it does not happen again and ensure that i use lock tight.

Eric.
AYF80 is offline  
0
Reply With Quote
      03-16-2014, 05:47 PM   #26
Gen_E92
Brigadier General
 
Drives: slow
Join Date: Oct 2006
Location: Vancouver

Posts: 3,386
iTrader: (17)

Garage List
2007 335i  [3.90]
I wish someone made a thread before I had this issue so I might not have to replace my rack lol...oh well, at least it helped you guys out :d
Gen_E92 is offline   Japan
0
Reply With Quote
      06-30-2014, 09:40 PM   #27
prepster
Private First Class
 
Drives: bmw 335i
Join Date: Apr 2011
Location: ventura ca

Posts: 102
iTrader: (0)

I am currently having the same issue, thanks for the posts, I will recheck all the bolts and engine mounts this coming up weekend, hope its a simple fix and not the actual steering rack going out. I occasionally get the steering wheel yellow light with the double sided arrows popping up when i remove the key so i hope there isn't any other issues…
prepster is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:15 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST