E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Adaptive headlamp failure



Reply
 
Thread Tools Search this Thread
      12-30-2011, 11:37 AM   #1
AddictedToBavarian
My other ride is a Bianchi Infinito
AddictedToBavarian's Avatar
Portugal
38
Rep
2,762
Posts

 
Drives: Miss my E92 but love my E46 M3
Join Date: Apr 2011
Location: North Jersey

iTrader: (2)

Adaptive headlamp failure

So last night as I was driving I got the dreaded adaptive headlamp failure. When it popped up I hadn't hit a pothole or anything of that sort so it was peculiar because most threads I've researched for this error stemmed from someone hitting a pothole. I drove another 5 miles or so and it never went away. I got home turned off my car and turned it back on, error appeared again as soon as I tried turning the steering wheel. I got in my car this morning and the error is no longer there, even after another 5-6 mile drive.

However, my understanding is that the adaptive lights only work when the light dial is switched to "auto". Since it's daytime, my headlights or adaptive headlights wouldn't come on anyway. I tried the regular position all the way to the right, drove like that too and also nothing. Would this error be stored in the "control messages" section even though it isn't night time? I guess the real test will be tonight, but I wanted to know if anyone on here had this come up on their cars and go away casually not returning.

Here's the pic:


Thanks guys
Appreciate 0
      12-30-2011, 12:07 PM   #2
BKV122
Major
BKV122's Avatar
United_States
14
Rep
1,096
Posts

 
Drives: E90
Join Date: Feb 2009
Location: NY

iTrader: (1)

Garage List
2006 330xi  [4.75]
I say tn have your car off and facing a wall or garage door. Turn tje lights to auto and start the car up and see if the headlights go through the normal procedure of up down or w.e they do. Then turn the wheel left and right amd make sure both turn.
__________________

Monaco Blue 330xi - Terra Interior/6-MT/Sport/Premium/Cold/CSL's/M3 Spoiler Lip/Black Kidney's
Appreciate 0
      12-30-2011, 04:52 PM   #3
nOshi
bad man nuh fren fish
nOshi's Avatar
Jamaica
1
Rep
198
Posts

 
Drives: TiAg E90 335i
Join Date: Apr 2011
Location: Central FL

iTrader: (4)

If it was still malfunctioning, even when the lights are off it will still bring up that adaptive headlight malfunction message. Since after start up it checks to see if they are functioning. Best thing to do is get it checked out at a dealer or indie shop, the error should be stored and they can review it.
__________________
TiAG E90 N54 335i | COBB | RB | FBO

Appreciate 0
      12-30-2011, 05:06 PM   #4
AddictedToBavarian
My other ride is a Bianchi Infinito
AddictedToBavarian's Avatar
Portugal
38
Rep
2,762
Posts

 
Drives: Miss my E92 but love my E46 M3
Join Date: Apr 2011
Location: North Jersey

iTrader: (2)

Quote:
Originally Posted by nOshi View Post
If it was still malfunctioning, even when the lights are off it will still bring up that adaptive headlight malfunction message. Since after start up it checks to see if they are functioning. Best thing to do is get it checked out at a dealer or indie shop, the error should be stored and they can review it.
Another thing to add to the list of things to get checked out Monday at the dealer. I swear I live in fear of turning on my car. I always think a new electrical glitch is going to pop up.
Appreciate 0
      12-30-2011, 05:50 PM   #5
JAN_CAMINERO
New Member
Puerto Rico
0
Rep
10
Posts

 
Drives: E92 335I WITH M PACKAGES
Join Date: Sep 2011
Location: Puerto Rico

iTrader: (0)

My Car Broke The Headlamp Bracket And Dis The Same Thing !!
Appreciate 0
      12-30-2011, 05:54 PM   #6
AddictedToBavarian
My other ride is a Bianchi Infinito
AddictedToBavarian's Avatar
Portugal
38
Rep
2,762
Posts

 
Drives: Miss my E92 but love my E46 M3
Join Date: Apr 2011
Location: North Jersey

iTrader: (2)

I actually just went out, drove it around tested it repeatedly while in motion and stationery and everything works fine. Glitch? I don't know. I hope. I really don't feel like taking out my LUX AEs if I tell them about this problem.

Just hope it doesn't return. Honestly I'm going to avoid using this feature so much.
Appreciate 0
      02-23-2012, 07:50 AM   #7
banky
First Lieutenant
9
Rep
348
Posts

 
Drives: 2007 335i e92
Join Date: Jul 2011
Location: Houston

iTrader: (1)

this is kinda happening to me too. this morning, in the middle of my drive to work, my adaptive error came on (non-idrive) and stayed on until i parked at work. a few months ago, they came on and went off within 5 minutes.

did yours ever come back on again?
Appreciate 0
      02-23-2012, 08:00 AM   #8
wrickem
doesn't really care
wrickem's Avatar
25
Rep
2,302
Posts

 
Drives: what he wants to
Join Date: Mar 2006
Location: lambertville nj

iTrader: (0)

I needed to chek something recently on mine and found that in daylight, with your lights in "auto", you can make them come on by throwing a towel over the sensor in the windshield to block out the light. See if the message is there.
__________________
______________________________________________
'14 528-xdrive - daily driver/winter beater, '06 Boxster - for fun, '07 M6- for even more fun.
Appreciate 0
      02-23-2012, 01:19 PM   #9
AddictedToBavarian
My other ride is a Bianchi Infinito
AddictedToBavarian's Avatar
Portugal
38
Rep
2,762
Posts

 
Drives: Miss my E92 but love my E46 M3
Join Date: Apr 2011
Location: North Jersey

iTrader: (2)

Quote:
Originally Posted by banky View Post
this is kinda happening to me too. this morning, in the middle of my drive to work, my adaptive error came on (non-idrive) and stayed on until i parked at work. a few months ago, they came on and went off within 5 minutes.

did yours ever come back on again?
No, it never has again. I don't even set my lights to auto anymore because these adaptive headlamps are so finicky.
Appreciate 0
      02-23-2012, 01:35 PM   #10
triger716
Second Lieutenant
3
Rep
295
Posts

 
Drives: '09 335i E90
Join Date: Nov 2011
Location: United States

iTrader: (0)

My car is at the dealer to fix this issue right now. In my case they said it was a bad stepper motor controller and had to be ordered from Germany which took a month to get here.

When I first took the car in, the error would show up maybe 50 - 60% of the time. I'm not sure what they did to determine the issue, but after I got it back (not fixed because of the part being ordered) it showed up 100% of the time.
Appreciate 0
      02-23-2012, 02:04 PM   #11
rbocc13
Second Lieutenant
rbocc13's Avatar
United_States
7
Rep
231
Posts

 
Drives: 08 Black 328xi coupe
Join Date: Jan 2011
Location: Central NJ

iTrader: (0)

Garage List
2008 BMW 328 xi  [0.00]
Send a message via AIM to rbocc13
same thing here... it came on then went off the next day and everything seemed fine. Brought it to BMW told them it was on then went off said i needed a whole new headlight or something... cost me $53 covered under CPO or what not. It worked fine but i figured i'm covered let them fix it.
Appreciate 0
      02-23-2012, 04:05 PM   #12
triger716
Second Lieutenant
3
Rep
295
Posts

 
Drives: '09 335i E90
Join Date: Nov 2011
Location: United States

iTrader: (0)

The dealer just called and told me the new stepper motor controller was installed, however it takes 14 hours to program it.

Do they use a Commodore 64 at the dealerships?
Appreciate 0
      02-23-2012, 10:00 PM   #13
banky
First Lieutenant
9
Rep
348
Posts

 
Drives: 2007 335i e92
Join Date: Jul 2011
Location: Houston

iTrader: (1)

well after parking the car at work when i saw the error, i went out about an hour later to get breakfast and the error didnt come on... these things are so crazy. if it pops up again for whatever reason im just gonna take it in. only thing that sucks is removing my LUX and putting in oem bulbs. installing LUX bulbs suck with my big hands ;(

just to be clear, im gonna remove the LUX to remove any possible issue of them giving me shit because of aftermarket stuff.
Appreciate 0
      01-05-2013, 06:30 PM   #14
Electric
Private
United_States
0
Rep
54
Posts

 
Drives: 2007 E92 335i
Join Date: Oct 2007
Location: NJ

iTrader: (0)

I just bought my car last week and I just received this error code. My car has some sort of modified halos for sure, not sure what kind though. My car is CPO. Should I just tell dealer I bought it like this? I don't even have plates yet! Thanks
Appreciate 0
      01-05-2013, 08:09 PM   #15
mcpcolas
First Lieutenant
mcpcolas's Avatar
United_States
5
Rep
370
Posts

 
Drives: 2009 montego blue 335i xdrive
Join Date: Apr 2012
Location: new jersey

iTrader: (0)

Those headlight are so freaking fragile. I'm on my fourth set,thank god I had warranty then cause they cost about 1800 plus labor.
Appreciate 0
      01-05-2013, 09:57 PM   #16
AddictedToBavarian
My other ride is a Bianchi Infinito
AddictedToBavarian's Avatar
Portugal
38
Rep
2,762
Posts

 
Drives: Miss my E92 but love my E46 M3
Join Date: Apr 2011
Location: North Jersey

iTrader: (2)

I never got it again since that night. Then again, because of that night I never really use them. They are a fragile disaster waiting to happen.
Appreciate 0
      01-05-2013, 10:15 PM   #17
Electric
Private
United_States
0
Rep
54
Posts

 
Drives: 2007 E92 335i
Join Date: Oct 2007
Location: NJ

iTrader: (0)

Quote:
Originally Posted by AddictedToBavarian View Post
I never got it again since that night. Then again, because of that night I never really use them. They are a fragile disaster waiting to happen.
Funny you said that, I just got in my car to drive home and the light is off. How can I turn it off. Excuse my ignorance I've literally just got the car last week still figuring things out!
Appreciate 0
      01-05-2013, 10:38 PM   #18
rorkor
Second Lieutenant
rorkor's Avatar
United_States
3
Rep
278
Posts

 
Drives: '11 E90 N52 6MT
Join Date: Feb 2012
Location: here

iTrader: (0)

Garage List
2010 E70 X5 35d  [5.00]
2011 E90 328i  [5.00]
Quote:
Originally Posted by triger716 View Post
The dealer just called and told me the new stepper motor controller was installed, however it takes 14 hours to program it.

Do they use a Commodore 64 at the dealerships?
They use a TI-86 Graphing Calculator. That way they can calculate how much to charge you at the same time.
__________________
Appreciate 0
      01-05-2013, 11:11 PM   #19
AddictedToBavarian
My other ride is a Bianchi Infinito
AddictedToBavarian's Avatar
Portugal
38
Rep
2,762
Posts

 
Drives: Miss my E92 but love my E46 M3
Join Date: Apr 2011
Location: North Jersey

iTrader: (2)

Quote:
Originally Posted by Electric View Post
Funny you said that, I just got in my car to drive home and the light is off. How can I turn it off. Excuse my ignorance I've literally just got the car last week still figuring things out!
You don't turn them off per say. You just don't put your lights on the left "automatic" mode.
Appreciate 0
      01-06-2013, 04:21 PM   #20
Electric
Private
United_States
0
Rep
54
Posts

 
Drives: 2007 E92 335i
Join Date: Oct 2007
Location: NJ

iTrader: (0)

Quote:
Originally Posted by AddictedToBavarian View Post
You don't turn them off per say. You just don't put your lights on the left "automatic" mode.
Easy enough thanks!

Tom
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:53 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST